/[smecontribs]/rpms/hylafax/contribs8/hylafax.spec
ViewVC logotype

Annotation of /rpms/hylafax/contribs8/hylafax.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.1 - (hide annotations) (download)
Fri May 24 20:40:04 2013 UTC (10 years, 11 months ago) by unnilennium
Branch: MAIN
CVS Tags: hylafax-4_4_4-1_el5_sme, HEAD
Initial import

1 unnilennium 1.1 # $Id: hylafax.spec,v 1.5 2008/11/25 16:20:12 slords Exp $
2     # Authority: dungog
3     # Name: Stephen Noble
4    
5     %define name hylafax
6     %define version 4.4.4
7    
8     %define release 1
9     %define serial %(echo `date +%Y%m%d`)
10    
11     %define initdir /etc/rc.d/init.d
12     %define faxspool %{_var}/spool/hylafax
13    
14     Summary: HylaFAX(tm) is a sophisticated enterprise strength fax package
15     Name: %{name}
16     Version: %{version}
17     Release: %{release}%{?dist}
18     Epoch: %{serial}
19     License: better than LGPL
20     Group: Applications/Communications
21     URL: http://www.ifax.com/
22    
23     Source: ftp://ftp.hylafax.org/source/%{name}-%{version}.tar.gz
24     Source1: hylafax_init
25     Source2: hylafax_config
26     Source3: hylafax_config.modem
27     Source4: hylafax_setup.cache
28     Source5: hylafax_setup.modem
29     Source6: hylafax_daily.cron
30     Source7: hylafax_hourly.cron
31     Source8: hylafax_logrotate
32     Source9: hylafax_README.rpm
33     Source10: hylafax_hyla.conf
34     Source11: hylafax_FaxDispatch
35     Source12: hylafax_jobcontrol.sh
36     Source13: hylafax_sysconfig
37    
38     BuildPrereq: libjpeg-devel, libtiff-devel, zlib-devel
39     Requires: ghostscript >= 5.5
40     Requires: libtiff >= 3.5.5
41     Requires: gawk
42     Requires: rpm >= 3.0.5
43     Requires: sharutils
44     Conflicts: mgetty-sendfax
45    
46     BuildRoot: %{_tmppath}/%{name}-root
47    
48     %description
49     HylaFAX(tm) is a sophisticated enterprise-strength fax package for
50     class 1 and 2 fax modems on unix systems. It provides spooling
51     services and numerous supporting fax management tools.
52     The fax clients may reside on machines different from the server
53     and client implementations exist for a number of platforms including
54     windows.
55    
56     %prep
57     %setup -q
58    
59     %build
60     # - Can't use the configure macro because HylaFAX configure script does
61     # not understand the config options used by that macro
62     ./configure \
63     --with-DIR_BIN=%{_bindir} \
64     --with-DIR_SBIN=%{_sbindir} \
65     --with-DIR_LIB=%{_libdir} \
66     --with-DIR_LIBEXEC=%{_sbindir} \
67     --with-DIR_LIBDATA=%{_sysconfdir}/hylafax \
68     --with-DIR_LOCKS=%{_var}/lock \
69     --with-LIBDIR=%{_libdir} \
70     --with-TIFFBIN=%{_bindir} \
71     --with-DIR_MAN=%{_mandir} \
72     --with-PATH_GSRIP=%{_bindir}/gs \
73     --with-DBLIBINC=%{_includedir} \
74     --with-LIBTIFF="-ltiff -ljpeg -lz" \
75     --with-DIR_SPOOL=%{faxspool} \
76     --with-AFM=no \
77     --with-AWK=/usr/bin/gawk \
78     --with-PATH_VGETTY=/sbin/vgetty \
79     --with-PATH_GETTY=/sbin/mgetty \
80     --with-HTML=no \
81     --with-PAGESIZE=A4 \
82     --with-PATH_DPSRIP=%{faxspool}/bin/ps2fax \
83     --with-PATH_IMPRIP="" \
84     --with-SYSVINIT=%{initdir}/hylafax \
85     --with-INTERACTIVE=no
86    
87     # CFLAGS is set up by the HylaFAX configure script; setting it up here the
88     # standard way would break things. Since OPTIMIZER is included in CFLAGS
89     # by the HylaFAX configure system, it's used here in place of CFLAGS
90     #make CFLAGS="$RPM_OPT_FLAGS"
91     make OPTIMIZER="$RPM_OPT_FLAGS"
92    
93     %install
94     [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
95    
96     # install: make some dirs...
97     mkdir -p -m 755 $RPM_BUILD_ROOT%{_sysconfdir}/{cron.daily,cron.hourly,logrotate.d}
98     mkdir -p -m 755 $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
99     mkdir -p -m 755 $RPM_BUILD_ROOT%{_sysconfdir}/hylafax
100     mkdir -p -m 755 $RPM_BUILD_ROOT%{initdir}
101     mkdir -p -m 755 $RPM_BUILD_ROOT%{_bindir}
102     mkdir -p -m 755 $RPM_BUILD_ROOT%{_sbindir}
103     mkdir -p -m 755 $RPM_BUILD_ROOT%{_libdir}
104     mkdir -p -m 755 $RPM_BUILD_ROOT%{_mandir}
105     mkdir -p -m 755 $RPM_BUILD_ROOT%{faxspool}/config/defaults
106    
107     # install: binaries and man pages
108     # FAXUSER, FAXGROUP, SYSUSER and SYSGROUP are set to the current user to
109     # avoid warnings about chown/chgrp if the user building the SRPM is not root;
110     # they are set to the correct values with the RPM attr macro
111     %makeinstall -e \
112     FAXUSER=`id -u` \
113     FAXGROUP=`id -g` \
114     SYSUSER=`id -u` \
115     SYSGROUP=`id -g` \
116     BIN=$RPM_BUILD_ROOT%{_bindir} \
117     SBIN=$RPM_BUILD_ROOT%{_sbindir} \
118     LIBDIR=$RPM_BUILD_ROOT%{_libdir} \
119     LIBDATA=$RPM_BUILD_ROOT%{_sysconfdir}/hylafax \
120     LIBEXEC=$RPM_BUILD_ROOT%{_sbindir} \
121     SPOOL=$RPM_BUILD_ROOT%{faxspool} \
122     MAN=$RPM_BUILD_ROOT%{_mandir} \
123     INSTALL_ROOT=$RPM_BUILD_ROOT
124    
125     # Starting from 4.1.6, port/install.sh won't chown/chmod anymore if the current
126     # user is not root; instead a file root.sh is created with chown/chmod inside.
127     #
128     # If you build the rpm as normal user (not root) you get an rpm with all the
129     # permissions messed up and hylafax will give various weird errors.
130     #
131     # The following line fixes that.
132     #
133     [ -f root.sh ] && sh root.sh
134    
135     # install: remaining files
136     install -m 755 %{SOURCE1} $RPM_BUILD_ROOT%{initdir}/hylafax
137     install -m 644 %{SOURCE2} $RPM_BUILD_ROOT%{faxspool}/config/defaults/config
138     install -m 644 %{SOURCE3} $RPM_BUILD_ROOT%{faxspool}/config/defaults/config.modem
139     install -m 644 %{SOURCE4} $RPM_BUILD_ROOT%{faxspool}/config/defaults/setup.cache
140     install -m 644 %{SOURCE5} $RPM_BUILD_ROOT%{faxspool}/config/defaults/setup.modem
141     install -m 755 %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/cron.daily/hylafax
142     install -m 755 %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/cron.hourly/hylafax
143     install -m 644 %{SOURCE8} $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/hylafax
144     install -m 644 %{SOURCE9} ./README.rpm
145     install -m 644 %{SOURCE10} $RPM_BUILD_ROOT%{_sysconfdir}/hylafax/hyla.conf
146     install -m 644 %{SOURCE11} $RPM_BUILD_ROOT%{faxspool}/etc/FaxDispatch
147     install -m 644 %{SOURCE12} $RPM_BUILD_ROOT%{faxspool}/bin/jobcontrol.sh
148     install -m 644 %{SOURCE13} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/hylafax
149    
150    
151     # some symlinks
152     ln -s ../..%{faxspool}/etc $RPM_BUILD_ROOT%{_sysconfdir}/hylafax/etc
153     ln -s ../..%{faxspool}/log $RPM_BUILD_ROOT%{_sysconfdir}/hylafax/log
154     ln -s ps2fax.gs $RPM_BUILD_ROOT%{faxspool}/bin/ps2fax
155     ln -s pdf2fax.gs $RPM_BUILD_ROOT%{faxspool}/bin/pdf2fax
156    
157     # Remove files that are not needed on Linux
158     rm -f $RPM_BUILD_ROOT%{_sbindir}/{faxsetup.irix,faxsetup.bsdi}
159     rm -f $RPM_BUILD_ROOT%{faxspool}/bin/{ps2fax.imp,ps2fax.dps}
160     # avoid rpm 4.x errors about files in buildroot but not in file list
161     rm -f $RPM_BUILD_ROOT%{faxspool}/etc/xferfaxlog
162     rm -f $RPM_BUILD_ROOT%{faxspool}/COPYRIGHT
163    
164     %clean
165     [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
166    
167     %pre
168     # if necessary (upgrading from < 4.1rc1) move spool dir to the new location
169     # and live with rpm errors :)
170     if [ -f /var/spool/fax/etc/setup.cache -a ! -d %{faxspool} ]; then
171     if [ -f /var/lock/subsys/hylafax ]; then
172     /sbin/service hylafax stop 1>/dev/null 2>&1 || :
173     fi
174     mv /var/spool/fax /var/spool/hylafax
175     fi
176    
177     %post
178     if [ -x /usr/lib/lsb/install_initd ]; then
179     /usr/lib/lsb/install_initd %{initdir}/hylafax
180     elif [ -x /sbin/chkconfig ]; then
181     /sbin/chkconfig --add hylafax
182     else
183     for i in 3 4 5; do
184     ln -sf %{initdir}/hylafax /etc/rc.d/rc${i}.d/S95hylafax
185     done
186     for i in 0 1 2 6; do
187     ln -sf %{initdir}/hylafax /etc/rc.d/rc${i}.d/K05hylafax
188     done
189     fi
190     /sbin/ldconfig
191    
192     echo "#########################################################"
193     echo "# HylaFAX installation complete! #"
194     echo "# #"
195     echo "# You should now run /usr/sbin/faxsetup to #"
196     echo "# create or update HylaFAX configuration #"
197     echo "# before you can begin using the software. #"
198     echo "# #"
199     echo "#########################################################"
200    
201     %preun
202     if [ $1 = 0 ] ; then
203     if [ -x /usr/lib/lsb/remove_initd ]; then
204     /usr/lib/lsb/install_initd %{initdir}/hylafax
205     elif [ -x /sbin/chkconfig ]; then
206     /sbin/chkconfig --del hylafax
207     else
208     rm -f /etc/rc.d/rc?.d/???hylafax
209     fi
210     /sbin/service hylafax stop >/dev/null 2>&1 || :
211     fi
212    
213     %postun
214     /sbin/ldconfig
215     if [ "$1" -ge "1" ]; then
216     /sbin/service hylafax condrestart >/dev/null 2>&1 || :
217     fi
218    
219    
220     %files
221     %defattr(-,root,root)
222     %doc CONTRIBUTORS COPYRIGHT INSTALL README TODO VERSION README.rpm doc/*.txt
223     %attr(755,root,root) %config(noreplace) %{initdir}/hylafax
224     %attr(644,root,root) %config(noreplace) %{_sysconfdir}/sysconfig/hylafax
225     %attr(644,root,root) %config(noreplace) %{_sysconfdir}/logrotate.d/hylafax
226     %attr(755,root,root) %config(noreplace) %{_sysconfdir}/cron.daily/hylafax
227     %attr(755,root,root) %config(noreplace) %{_sysconfdir}/cron.hourly/hylafax
228     %{_bindir}/*
229     %{_sbindir}/*
230     %{_libdir}/*
231     %attr(644,root,root) %{_mandir}/*/*
232     %attr(755,root,root) %dir %{_sysconfdir}/hylafax
233     %attr(644,root,root) %{_sysconfdir}/hylafax/faxcover_example_sgi.ps
234     %attr(644,root,root) %config(noreplace) %{_sysconfdir}/hylafax/faxcover.ps
235     %attr(644,root,root) %config(noreplace) %{_sysconfdir}/hylafax/faxmail.ps
236     %attr(644,root,root) %config(noreplace) %{_sysconfdir}/hylafax/hfaxd.conf
237     %attr(644,root,root) %config(noreplace) %{_sysconfdir}/hylafax/hyla.conf
238     %attr(644,root,root) %config(noreplace) %{_sysconfdir}/hylafax/pagesizes
239     %attr(644,root,root) %config(noreplace) %{_sysconfdir}/hylafax/typerules
240     %attr(-,root,root) %{_sysconfdir}/hylafax/etc
241     %attr(-,root,root) %{_sysconfdir}/hylafax/log
242     %attr(-,uucp,uucp) %dir %{faxspool}
243     %attr(-,uucp,uucp) %dir %{faxspool}/archive
244     %attr(-,uucp,uucp) %dir %{faxspool}/bin
245     %attr(-,uucp,uucp) %dir %{faxspool}/client
246     %attr(-,uucp,uucp) %dir %{faxspool}/config
247     #%attr(-,uucp,uucp) %dir %{faxspool}/config/defaults
248     %attr(-,uucp,uucp) %dir %{faxspool}/dev
249     %attr(-,uucp,uucp) %dir %{faxspool}/docq
250     %attr(-,uucp,uucp) %dir %{faxspool}/doneq
251     %attr(-,uucp,uucp) %dir %{faxspool}/etc
252     %attr(-,uucp,uucp) %dir %{faxspool}/etc/templates
253     %attr(644,root,root) %{faxspool}/etc/templates/README
254     %attr(-,uucp,uucp) %dir %{faxspool}/etc/templates/en
255     %attr(-,uucp,uucp) %dir %{faxspool}/etc/templates/es
256     %attr(-,uucp,uucp) %dir %{faxspool}/etc/templates/de
257     %attr(-,uucp,uucp) %dir %{faxspool}/etc/templates/pt_BR
258     %attr(-,uucp,uucp) %dir %{faxspool}/etc/templates/pl
259     %attr(-,uucp,uucp) %dir %{faxspool}/etc/templates/pt
260     %attr(-,uucp,uucp) %dir %{faxspool}/etc/templates/it
261     %attr(-,uucp,uucp) %dir %{faxspool}/etc/templates/ro
262     %attr(-,uucp,uucp) %dir %{faxspool}/etc/templates/fr
263     %attr(-,uucp,uucp) %dir %{faxspool}/etc/templates/html-sample1
264     %attr(644,root,root) %config %{faxspool}/etc/templates/*/*
265     %attr(-,uucp,uucp) %dir %{faxspool}/info
266     %attr(-,uucp,uucp) %dir %{faxspool}/log
267     %attr(-,uucp,uucp) %dir %{faxspool}/pollq
268     %attr(-,uucp,uucp) %dir %{faxspool}/recvq
269     %attr(-,uucp,uucp) %dir %{faxspool}/sendq
270     %attr(-,uucp,uucp) %dir %{faxspool}/status
271     %attr(-,uucp,uucp) %dir %{faxspool}/tmp
272     %attr(-,root,root) %{faxspool}/bin/*
273     %attr(-,root,root) %{faxspool}/config/*
274     %attr(-,root,root) %{faxspool}/etc/dpsprinter.ps
275     %attr(-,root,root) %{faxspool}/etc/cover.templ
276     %attr(-,root,root) %config(noreplace) %{faxspool}/etc/dialrules*
277     %attr(-,uucp,uucp) %{faxspool}/etc/lutRS18.pcf
278     %attr(-,uucp,uucp) %config(noreplace) %{faxspool}/etc/hosts.hfaxd
279     %attr(-,uucp,uucp) %config(noreplace) %{faxspool}/etc/FaxDispatch
280     %attr(-,uucp,uucp) %{faxspool}/FIFO
281    
282    
283     %changelog
284     * Tue Jan 08 2008 Darren Nickerson <darren.nickerson@ifax.com> 4.4.4-1
285     - update to official 4.4.4 release
286    
287     * Sun Nov 25 2007 Darren Nickerson <darren.nickerson@ifax.com> 4.4.3-1
288     - update to official 4.4.3 release
289    
290     * Wed Oct 03 2007 Darren Nickerson <darren.nickerson@ifax.com> 4.4.2-1
291     - update to official 4.4.2 release
292    
293     * Wed Aug 22 2007 Darren Nickerson <darren.nickerson@ifax.com> 4.4.1-1
294     - update to official 4.4.1 release
295    
296     * Fri Jul 27 2007 Patrice Fournier <patrice.fournier@ifax.com> 4.4.0-1
297     - update to official 4.4.0 release
298    
299     * Fri Jul 06 2007 Patrice Fournier <patrice.fournier@ifax.com> 4.4.0rc2-1
300     - update to second release candidate of 4.4.0
301    
302     * Fri Jun 29 2007 Patrice Fournier <patrice.fournier@ifax.com> 4.4.0rc1-1
303     - update to first release candidate of 4.4.0
304    
305     * Fri May 18 2007 Patrice Fournier <patrice.fournier@ifax.com> 4.3.4-1
306     - update to official 4.3.4 release
307     - distributed templates are now always replaced
308    
309     * Fri Mar 02 2007 Patrice Fournier <patrice.fournier@ifax.com> 4.3.3-1
310     - update to official 4.3.3 release
311    
312     * Fri Feb 23 2007 Patrice Fournier <patrice.fournier@ifax.com> 4.3.2-3
313     - Add requirement for tiff package under SuSE
314    
315     * Fri Feb 23 2007 Patrice Fournier <patrice.fournier@ifax.com> 4.3.2-2
316     - [bug 849] notify "rejected" templates are wrongly called notify-reject.txt
317     - [bug 850] adds jobtag to notification mails
318    
319     * Fri Feb 16 2007 Patrice Fournier <patrice.fournier@ifax.com> 4.3.2-1
320     - update to official 4.3.2 release
321    
322     * Mon Jan 29 2007 Darren Nickerson <darren.nickerson@ifax.com> 4.3.2rc1-1
323     - update to first release candidate of 4.3.2
324    
325     * Mon Jan 29 2007 Darren Nickerson <darren.nickerson@ifax.com> 4.3.2beta2-1
326     - update to second beta of 4.3.2
327    
328     * Mon Jan 29 2007 Darren Nickerson <darren.nickerson@ifax.com> 4.3.2beta1-1
329     - update to first beta of 4.3.2
330    
331     * Mon Dec 04 2006 Darren Nickerson <darren.nickerson@ifax.com> 4.3.1-1
332     - update to offical 4.3.1 release
333    
334     * Wed Nov 22 2006 Darren Nickerson <darren.nickerson@ifax.com> 4.3.1rc3-1
335     - update to third release candidate of 4.3.1
336    
337     * Tue Nov 14 2006 Darren Nickerson <darren.nickerson@ifax.com> 4.3.1rc2-1
338     - update to second release candidate of 4.3.1
339    
340     * Fri Oct 27 2006 Patrice Fournier <patrice.fournier@ifax.com> 4.3.1rc1-1
341     - update to first release candidate of 4.3.1
342    
343     * Tue Oct 12 2006 Darren Nickerson <darren.nickerson@ifax.com> 4.3.1beta4-1
344     - update to 4.3.1beta4
345    
346     * Fri May 26 2006 Patrice Fournier <patrice.fournier@ifax.com> 4.3.0-2
347     - [Bug 775] Don't try to start two instances of hfaxd (Simon Matter)
348     - [Bug 776] sysconfig file doesn't need exec permissions (Simon Matter)
349    
350     * Mon May 22 2006 Darren Nickerson <darren.nickerson@ifax.com> 4.3.0-1
351     - update to official 4.3.0 release
352    
353     * Fri May 12 2006 Patrice Fournier <patrice.fournier@ifax.com> 4.3.0rc3-1
354     - update to third release candidate of 4.3.0
355    
356     * Fri Apr 28 2006 Patrice Fournier <patrice.fournier@ifax.com> 4.3.0rc2-1
357     - update to second release candidate of 4.3.0
358    
359     * Fri Apr 21 2006 Patrice Fournier <patrice.fournier@ifax.com> 4.3.0rc1-1
360     - update to first release candidate of 4.3.0
361     - Added Sample jobcontrol script
362     - Stop logrotate from returning an error when ran before HylaFAX first
363     start (Simon Matter)
364     - [Bug 766] Replaced obsolete Serial tag with Epoch (Dimitris)
365     - HylaFAX init script can now be configured in /etc/sysconfig/hylafax
366     (fixes bug 652)
367    
368     * Thu Jan 12 2006 Darren Nickerson <darren.nickerson@ifax.com> 4.2.5-1
369     - update to official 4.2.5 release
370     - updated urls in README.rpm
371    
372     * Fri Jan 6 2006 Patrice Fournier <patrice.fournier@ifax.com> 4.2.4-1
373     - update to official 4.2.4 release
374    
375     * Tue Nov 15 2005 Darren Nickerson <darren.nickerson@ifax.com> 4.2.3-1
376     - update to official 4.2.3 release
377    
378     * Fri Nov 11 2005 Patrice Fournier <patrice.fournier@ifax.com> 4.2.3rc1-2
379     - only run faxcron when HylaFAX has been setup (Simon Matter)
380     - fixed RPM file naming on RedHat 7 (broken since 4.2.2rc1-2)
381     - put hylafax init script in the right place on SuSE
382     - fixed init script for SuSE
383     - Correctly differentiate between SLES and regular SuSE
384    
385     * Fri Nov 9 2005 Darren Nickerson <darren.nickerson@ifax.com> 4.2.3rc1-1
386     - update to first release candidate of 4.2.3
387    
388     * Fri Sep 23 2005 Patrice Fournier <patrice.fournier@ifax.com> 4.2.2-1
389     - update to official 4.2.2 release
390    
391     * Fri Sep 16 2005 Patrice Fournier <patrice.fournier@ifax.com> 4.2.2rc1-2
392     - added SuSE support to SPECS file
393     - now distinguish between RH and RHEL versions (using version number)
394    
395     * Fri Sep 2 2005 Patrice Fournier <patrice.fournier@ifax.com> 4.2.2rc1-1
396     - update to first release candidate of 4.2.2
397     - updated installation complete message
398    
399     * Tue Jan 11 2005 Darren Nickerson <darren.nickerson@ifax.com> 4.2.1-1
400     - update to official 4.2.1 release
401     - [Bug 617] remove unnecessary debug logging (iFAX Solutions)
402     - [Bug 574] faxsetup cleanups (Lee Howard)
403     - [Bug 118] Improve EOM handling in batched faxes (Lee Howard)
404     - improve previously broken digi config (Lee Howard)
405     - improve redhat release detection and RPM file naming
406    
407     * Thu Jul 15 2004 Darren Nickerson <darren.nickerson@ifax.com> 4.2.0-1
408     - update to official 4.2.0 release
409    
410     * Thu Jul 15 2004 Darren Nickerson <darren.nickerson@ifax.com> 4.2.0rc2-1
411     - update to second release candidate of 4.2.0
412    
413     * Mon May 10 2004 Darren Nickerson <darren.nickerson@ifax.com> 4.2.0beta2-1
414     - update to second beta release of 4.2.0
415    
416     * Fri Apr 16 2004 Darren Nickerson <darren.nickerson@ifax.com> 4.2.0beta1-1
417     - update to first beta release of 4.2.0
418    
419     * Sun Dec 14 2003 Darren Nickerson <darren.nickerson@ifax.com> 4.1.8-2
420     - [Bug 435] tiffcheck does not properly implement "-3" option
421     (Kevin Fleming)
422     - [Bug 436] tiffcheck does not suppress libtiff warnings
423     (Kevin Fleming)
424    
425     * Fri Oct 10 2003 Darren Nickerson <darren.nickerson@ifax.com> 4.1.8-1
426     - update to official 4.1.8 release
427     - [Bug 468] Fix remotely executable format string vulnerability in hfaxd
428     (Sebastian Krahmer and the SuSE Security Team)
429    
430     * Fri Oct 10 2003 Darren Nickerson <darren.nickerson@ifax.com> 4.1.7-2
431     - [Bug 443] Expand & unify sequence namespace (iFAX Solutions)
432     - [Bug 445] Corrected a long-standing problem that would leave old image
433     files in docq/ causing them to be sent again many months later in
434     place of the new image file (iFAX Solutions)
435     - [Bug 454] Faxgetty could hear more than 1 ring at once, doubling
436     things like CIDNAME and CIDNUMBER, and breaking inbound fax
437     routing (iFAX Solutions)
438     - [Bug 424] Updated, slightly cleaner patch. Functionally identical.
439    
440     * Sun Jun 15 2003 Darren Nickerson <darren.nickerson@ifax.com> 4.1.7-1
441     - update to official 4.1.7 release
442     - add metamail dependency
443     - [Bug 420] Add SaveUnconfirmedPages config option
444     (Lee Howard)
445     - [Bug 427] Fix problem with port/install.sh on non-root builds
446     (Giulio Orsero)
447     - [Bug 424] Add support for tracking CIDName and CIDNumber in
448     xferfaxlog, tiff files, and client/server protocol via hfaxd
449     (iFAX Solutions)
450    
451     * Sun Jun 15 2003 Darren Nickerson <darren.nickerson@ifax.com> 4.1.6-1
452     - update to official 4.1.6 release
453     - [Bug 410] Added sharutils dependency, and default FaxDispatch
454     - [Bug 407] Remove COPYRIGHT (packaged in %doc) and empty xferfaxlog
455     files from source tree before packaging.
456    
457     * Mon Oct 21 2002 Darren Nickerson <darren@hylafax.org> 4.1.5-1
458     - update to official 4.1.5 release
459    
460     * Wed Oct 16 2002 Darren Nickerson <darren@hylafax.org> 4.1.4-1
461     - update to official 4.1.4 release
462    
463     * Sun Jul 28 2002 Darren Nickerson <darren@hylafax.org> 4.1.3-1
464     - update to official 4.1.3 release
465     - added --with-LIBDIR=%{_libdir} to configure invocation (Lee Howard)
466    
467     * Sun Mar 17 2002 Darren Nickerson <darren@dazza.org> 4.1.1-2
468     - [Bug 160] fix segfault in faxqclean under heavy load
469    
470     * Sun Feb 17 2002 Darren Nickerson <darren@dazza.org> 4.1.1-1
471     - update to official 4.1.1 release
472    
473     * Sun Feb 10 2002 Darren Nickerson <darren@dazza.org>
474     - [Bug 156] Faxquit may not work after an upgrade - init script
475     now uses killall. (Giulio Orsero)
476     - [Bug 188] Roll-up of various fixes (Giulio Orsero)
477     1. removed 'sed' from hylafax_logrotate and similar files, which
478     caused confusion and some missed /var/spool/fax ->
479     /var/spool/hylafax corrections.
480     2. removed 2 unnecessary files on linux: ps2fax.dps and ps2fax.imp
481     3. set IMPRIP to blank since it does not exist on linux
482     4. marked all %config as noreplace
483     5. Changed "Copyright:" to "License:"
484     6. Changed serial to date +%Y%m%d
485     7. Linux DSO support has been merged into CVS. Removed patch
486     and modified .spec accordingly
487     8. Restore CFLAGS to RPM default
488     - [Bug 189] FHS compliance - changed /usr/share/fax -> /etc/hylafax
489     (see http://www.pathname.com/fhs/2.0/fhs-4.8.html) (Giulio Orsero)
490     - [Bug 196] Updated stale source files, commented hylafax_hyla.conf
491     (Giulio Orsero - spotting a trend here?)
492     - [Bug 206] Init script activates SNPP support if pagermap file
493     exists (Matthew Rice)
494    
495    
496     * Sun Jul 01 2001 Darren Nickerson <darren@dazza.org>
497     - [Bug 132] Added Conflicts: to avoid confusion with mgetty-sendfax
498     - [Bug 145] Added BuildPrereq: zlib-devel, since it's necessary
499     - [Bug 156] Init script now restarts faxgetty also
500     - [Bug 133] Set symlink for pdf2fax, added new docs to the %doc macro,
501     add intelligence to set spooldir accordingly, clarify comment for
502     %build macro, migrate /var/spool/fax to /var/spool/hylafax if this
503     is an upgrade, and add serial number to make versioning know 4.1 is
504     newer than 4.1beta3 and 4.1rc2. Thanks Giulio!!
505     - added --with-DIR_LIB=%{_libdir} to configure invocation
506    
507     * Sun Apr 15 2001 Darren Nickerson <darren@dazza.org>
508     - [Bug 89] Modify OPTIMIZER to be less aggressive for binary compatibility
509     on older systems. Tweaked .spec file so that one file produces both the
510     rh6 and rh7 RPMs (requires rpm-3.0.5 or better), remove gawk version
511     requirement. Removed --with-TIFFINC and --with-libdb from configure
512     invocation (Giulio Orsero).
513    
514     * Thu Feb 22 2001 Darren Nickerson <darren@dazza.org>
515     - update to hylafax-4.1beta3
516    
517     * Sun Dec 03 2000 Darren Nickerson <darren@dazza.org>
518     - update to cvs-20001203
519     - break out VRes tweak into hyla.conf for clarity. Makes a nice
520     example of how to use hyla.conf as well.
521    
522     * Fri Sep 01 2000 Darren Nickerson <darren@dazza.org>
523     - remove SysVinit patch due to clash with Tim Rice's work
524     - hard-wire gawk dependency to prevent it defaulting to mawk, which
525     is not installed by default on some systems
526     - use system zlib rather than HylaFAX's bundled one
527     - remove typerules and ps2fax patches, after committing them to CVS
528     - Update README.RPM
529    
530     * Wed Aug 23 2000 Darren Nickerson <darren@dazza.org>
531     - remove libgr dependencies for greater RPM portability
532    
533     * Mon Aug 21 2000 Giulio Orsero <giulioo@pobox.com>
534     - new 'rh7/rpm4 features': uses FHS macros, binaries stripping and man
535     pages gzipping handled by rpm policies, uses /sbin/service.
536     - Red Hat 6.x/7.x style init script (colors, condrestart)
537     - does not use caldera's lisa because I cannot test it.
538     - xferfaxlog and lutRS18.pcf no more tagged as config files
539     - RPM does not own /etc, /usr, ... anymore, just the files in them
540     - no more AFM dir and links (textfmt does not need them since 4.1b1)
541     - page size set to A4
542     - does not use HTML/CGI configure directive, takes html directly from source
543     - configure patched to run 'unattended'
544     - no more in RPM: manpage, man2html, unquote, faxsetup.irix, faxsetup.bsdi
545     - uses the OPTIMIZER variable to pass RPM_OPT_FLAGS to 'make'
546    
547     * Sun May 14 2000 Darren Nickerson <darren@dazza.org>
548     - standardize on libtiff >= 3.5 to resolve run length (16->32 bits)
549     - fixed modes of .dso files in dso.patch to silence ldd warning
550    
551     * Sun Mar 18 2000 Darren Nickerson <darren@dazza.org>
552     - instead of beta2 + patches, begin using CVS snapshot
553     - changed LIBTIFF linker line to include -ljpeg -lz, suggested by Matthew
554     Rice <matt@starnix.com>, and Erik Ratcliffe <erik@calderasystems.com>
555    
556     * Fri Nov 5 1999 Matthew Rice <matt@starnix.com>
557     - hylafax-4.1beta2.tar.gz
558     - added lisa support
559     - fix for installing into a build root
560    
561     * Wed Jun 16 1999 Darren Nickerson <darren@info.tpc.int>
562     - hylafax-4.1beta1.tar.gz
563     - added chkconfig support
564     - removed libjpeg linking and dependency
565    
566     * Tue Sep 29 1998 Darren Nickerson <darren@info.tpc.int>
567     - added security fix proposed by Carsten Hoeger <choeger@suse.de> for
568     potential race condition reported by Tobias Richter
569     <tsr@cave.isdn.cs.tu-berlin.de>
570     * Wed Sep 9 1998 Darren Nickerson <darren@info.tpc.int>
571     - built the RPM on Redhat-5.0 to avoid dependency problems with libjpeg
572     and libstdc++.
573     * Tue May 26 1998 Darren Nickerson <darren@info.tpc.int>
574     - removed .orig files from patch - they were 90 percent of it
575     - removed oversimplified /dev/modem assumptions
576     - faxcron was invoking xferstats, instead of new xferfaxstats - fixed
577     - revised faxcron's manpage
578     - HylaFAX was still writing etc/xferlog. Changed to etc/xferfaxlog as
579     advertised by all supporting docs and scripts.
580     - added hourly faxqclean and daily faxcron cron jobs, and xferlog rotation
581     - hfaxd no longer hard-wired as running from inetd, faxsetup will handle this
582     - no longer assumes /dev/modem and blindly inserts inittab entry
583     - change naming scheme to differentiate rh4/rh5
584     - move documentation back into main rpm, instead of sub-packages
585     - added Robert Colquhoun's textfmt-mailer patch
586     - increased margin on LHS, was too close and getting clipped
587     - make faxsetup warn that modem class = modem pool, not Class1/2/2.0
588     - use HylaFAX's init script, startup with new protocol only and no snpp
589     - added -DFIXEDMEDIA to last command in ps2fax.gs, as posted
590     by "Alan Sparks" <asparks@nss.harris.com>
591     - added fixhtml patch, removed release from the doc dir, now just version
592     - added Nico's skel patch, for class1/2/2.0 modem prototype files
593     - added Robert Colquhoun's patch to hfaxd's tagline generation
594     - fixes to build on 5.1, contributed by Richard Sharpe <sharpe@ns.aus.com>
595     - faxrcvd now treated as a config file, preserved as .rpmsave
596     - fixed ghostscript dependency to require fonts-std, not fonts.
597     - remove requirement for mawk - use gawk instead.
598     - faxsetup now detects is hfaxd is not driven from inetd, and starts it
599     when restarting faxq using SysV init script (Robert Colquhoun)
600    
601    
602     * Wed Mar 04 1998 Markus Pilzecker <mp@rhein-neckar.netsurf.de>
603     - took ldconfig call out of install section
604     - minimized and compressed patch
605     - arch rpm buildable as ordinary user
606     - diverted subpackages for [un]compressed man pages
607     - diverted subpackage for html documentation
608    
609     * Thu Jan 22 1998 Bernd Johannes Wuebben <wuebben@kde.org>
610     - hylafax-4.0-8
611     - A previous version of this spec file was handed to me by
612     Ramana Juvvadi (juvvadi@lekha.org)
613     who unfortunately can no longer provide rpms of hylafax.
614     Thanks so much for you work Ramana!
615     Bernd
616    
617     * Fri Oct 24 1997 Ramana Juvvadi (juvvadi@lekha.org)
618     - hylafax-4.0-6
619    
620    

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed