1 |
slords |
1.1 |
%define apachedir /etc/httpd |
2 |
|
|
%define apacheuser www |
3 |
|
|
%define apachegroup www |
4 |
|
|
%define contentdir /home/httpd |
5 |
|
|
|
6 |
|
|
Summary: The web-based calendar system for Horde. |
7 |
|
|
Name: kronolith-h3 |
8 |
|
|
Version: 2.1.6 |
9 |
|
|
Release: 1%{?dist} |
10 |
|
|
License: LGPL |
11 |
|
|
Group: Applications/Horde |
12 |
|
|
Source: ftp://ftp.horde.org/pub/kronolith/tarballs/kronolith-h3-%{version}.tar.gz |
13 |
|
|
URL: http://www.horde.org/ |
14 |
|
|
BuildArchitectures: noarch |
15 |
|
|
BuildRoot: /tmp/horde-root |
16 |
|
|
AutoReq: no |
17 |
|
|
Requires: horde >= 3.1 |
18 |
|
|
Requires: php >= 4.3.0 |
19 |
|
|
Requires: httpd >= 2.0.46 |
20 |
|
|
Prereq: /usr/bin/perl |
21 |
|
|
|
22 |
|
|
%description |
23 |
|
|
Kronolith is a web-based calendar system written in PHP and utilizing the |
24 |
|
|
Horde Application Framework. |
25 |
|
|
|
26 |
|
|
The Horde Project writes web applications in PHP and releases them under |
27 |
|
|
Open Source licenses. For more information (including help with Horde |
28 |
|
|
and its modules) please visit http://www.horde.org/. |
29 |
|
|
|
30 |
|
|
This package contains customizations for SME Server |
31 |
|
|
and will probably not work properly on other Linux systems. |
32 |
|
|
|
33 |
|
|
%prep |
34 |
|
|
%setup -q -n %{name}-%{version} |
35 |
|
|
|
36 |
|
|
%build |
37 |
|
|
|
38 |
|
|
%install |
39 |
|
|
[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT |
40 |
|
|
mkdir -p $RPM_BUILD_ROOT%{apachedir}/conf |
41 |
|
|
mkdir -p $RPM_BUILD_ROOT%{contentdir}/html/horde/kronolith |
42 |
|
|
cp -pR * $RPM_BUILD_ROOT%{contentdir}/html/horde/kronolith |
43 |
|
|
cd $RPM_BUILD_ROOT%{contentdir}/html/horde/kronolith/config |
44 |
|
|
for d in *.dist; do |
45 |
|
|
d0=`basename $d .dist` |
46 |
|
|
if [ ! -f "$d0" ]; then |
47 |
|
|
cp -p $d $d0 |
48 |
|
|
fi |
49 |
|
|
done |
50 |
|
|
|
51 |
|
|
%clean |
52 |
|
|
[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT |
53 |
|
|
|
54 |
|
|
%post |
55 |
|
|
|
56 |
|
|
%postun |
57 |
|
|
|
58 |
|
|
%files |
59 |
|
|
%defattr(-,root,root) |
60 |
|
|
# Include top level with %dir so not all files are sucked in |
61 |
|
|
%dir %{contentdir}/html/horde/kronolith |
62 |
|
|
# Include top-level files by hand |
63 |
|
|
%{contentdir}/html/horde/kronolith/*.php |
64 |
|
|
# Include these dirs so that all files _will_ get sucked in |
65 |
|
|
%{contentdir}/html/horde/kronolith/js |
66 |
|
|
%{contentdir}/html/horde/kronolith/lib |
67 |
|
|
%{contentdir}/html/horde/kronolith/locale |
68 |
|
|
%{contentdir}/html/horde/kronolith/po |
69 |
|
|
%{contentdir}/html/horde/kronolith/scripts |
70 |
|
|
%{contentdir}/html/horde/kronolith/templates |
71 |
|
|
%{contentdir}/html/horde/kronolith/themes |
72 |
|
|
# Mark documentation files with %doc and %docdir |
73 |
|
|
%doc %{contentdir}/html/horde/kronolith/COPYING |
74 |
|
|
%doc %{contentdir}/html/horde/kronolith/README |
75 |
|
|
%docdir %{contentdir}/html/horde/kronolith/docs |
76 |
|
|
%{contentdir}/html/horde/kronolith/docs |
77 |
|
|
# Mark configuration files with %config and use secure permissions |
78 |
|
|
# (note that .dist files are considered software; don't mark %config) |
79 |
|
|
%attr(750,root,%{apachegroup}) %dir %{contentdir}/html/horde/kronolith/config |
80 |
|
|
%defattr(640,root,%{apachegroup}) |
81 |
|
|
%{contentdir}/html/horde/kronolith/config/.htaccess |
82 |
|
|
%{contentdir}/html/horde/kronolith/config/*.dist |
83 |
|
|
%config %{contentdir}/html/horde/kronolith/config/*.php |
84 |
|
|
%config %{contentdir}/html/horde/kronolith/config/*.xml |
85 |
|
|
|
86 |
|
|
%changelog |
87 |
|
|
* Mon Nov 11 2007 John H. Bennett III <bennettj@johnbennettservices.com> 2.1.6-1 |
88 |
|
|
- Updated to kronolith 2.1.6 |
89 |
|
|
|
90 |
|
|
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> |
91 |
|
|
- Clean up spec so package can be built by koji/plague |
92 |
|
|
|
93 |
|
|
* Fri Mar 23 2007 John H. Bennett III <bennettj@johnbennettservices.com> 2.1.5-1 |
94 |
|
|
- Updated to kronolith 2.1.5 |
95 |
|
|
|
96 |
|
|
* Mon Dec 4 2006 John H. Bennett III <bennettj@johnbennettservices.com> 2.1.4-00sme01 |
97 |
|
|
- Updated to kronolith 2.1.4 |
98 |
|
|
|
99 |
|
|
* Fri Nov 24 2006 John H. Bennett III <bennettj@johnbennettservices.com> 2.1.3-00sme01 |
100 |
|
|
- Updated to kronolith 2.1.3 |
101 |
|
|
|
102 |
|
|
* Sat Sep 9 2006 John H. Bennett III <bennettj@johnbennettservices.com> 2.1.2-00sme01 |
103 |
|
|
- Updated to kronolith 2.1.2 |
104 |
|
|
|
105 |
|
|
* Wed Mar 1 2006 John H. Bennett III <bennettj@johnbennettservices.com> 2.0.6-1sme02 |
106 |
|
|
- Removed post and postun events |
107 |
|
|
- Renamed to smeserver-kronolith to represent an addon product |
108 |
|
|
|
109 |
|
|
* Wed Feb 15 2006 John H. Bennett III <bennettj@johnbennettservices.com> 2.0.6-1sme01 |
110 |
|
|
- Initial Release of Kronolith 2.0.6 building on Greg's work |
111 |
|
|
|
112 |
|
|
* Thu Sep 01 2005 Greg Swallow |
113 |
|
|
- [1.0-1sme01] |
114 |
|
|
- Initial Release |
115 |
|
|
|
116 |
|
|
|