1 |
mrjhb3 |
1.11 |
# $Id: kronolith-h3.spec,v 1.10 2009/10/10 03:19:43 mrjhb3 Exp $ |
2 |
slords |
1.3 |
# Authority: mrjhb3 |
3 |
|
|
# Name: John H. Bennett III |
4 |
|
|
|
5 |
slords |
1.1 |
%define apachedir /etc/httpd |
6 |
|
|
%define apacheuser www |
7 |
|
|
%define apachegroup www |
8 |
|
|
%define contentdir /home/httpd |
9 |
|
|
|
10 |
|
|
Summary: The web-based calendar system for Horde. |
11 |
|
|
Name: kronolith-h3 |
12 |
mrjhb3 |
1.11 |
Version: 2.3.3 |
13 |
slords |
1.1 |
Release: 1%{?dist} |
14 |
|
|
License: LGPL |
15 |
|
|
Group: Applications/Horde |
16 |
|
|
Source: ftp://ftp.horde.org/pub/kronolith/tarballs/kronolith-h3-%{version}.tar.gz |
17 |
|
|
URL: http://www.horde.org/ |
18 |
|
|
BuildArchitectures: noarch |
19 |
|
|
BuildRoot: /tmp/horde-root |
20 |
|
|
AutoReq: no |
21 |
slords |
1.5 |
Requires: horde >= 3.2 |
22 |
slords |
1.1 |
Requires: php >= 4.3.0 |
23 |
|
|
Requires: httpd >= 2.0.46 |
24 |
|
|
Prereq: /usr/bin/perl |
25 |
|
|
|
26 |
|
|
%description |
27 |
|
|
Kronolith is a web-based calendar system written in PHP and utilizing the |
28 |
|
|
Horde Application Framework. |
29 |
|
|
|
30 |
|
|
The Horde Project writes web applications in PHP and releases them under |
31 |
|
|
Open Source licenses. For more information (including help with Horde |
32 |
|
|
and its modules) please visit http://www.horde.org/. |
33 |
|
|
|
34 |
|
|
This package contains customizations for SME Server |
35 |
|
|
and will probably not work properly on other Linux systems. |
36 |
|
|
|
37 |
|
|
%prep |
38 |
|
|
%setup -q -n %{name}-%{version} |
39 |
|
|
|
40 |
|
|
%build |
41 |
|
|
|
42 |
|
|
%install |
43 |
|
|
[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT |
44 |
|
|
mkdir -p $RPM_BUILD_ROOT%{apachedir}/conf |
45 |
|
|
mkdir -p $RPM_BUILD_ROOT%{contentdir}/html/horde/kronolith |
46 |
|
|
cp -pR * $RPM_BUILD_ROOT%{contentdir}/html/horde/kronolith |
47 |
|
|
cd $RPM_BUILD_ROOT%{contentdir}/html/horde/kronolith/config |
48 |
|
|
for d in *.dist; do |
49 |
|
|
d0=`basename $d .dist` |
50 |
|
|
if [ ! -f "$d0" ]; then |
51 |
|
|
cp -p $d $d0 |
52 |
|
|
fi |
53 |
|
|
done |
54 |
|
|
|
55 |
|
|
%clean |
56 |
|
|
[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT |
57 |
|
|
|
58 |
|
|
%post |
59 |
|
|
|
60 |
|
|
%postun |
61 |
|
|
|
62 |
|
|
%files |
63 |
|
|
%defattr(-,root,root) |
64 |
|
|
# Include top level with %dir so not all files are sucked in |
65 |
|
|
%dir %{contentdir}/html/horde/kronolith |
66 |
|
|
# Include top-level files by hand |
67 |
|
|
%{contentdir}/html/horde/kronolith/*.php |
68 |
|
|
# Include these dirs so that all files _will_ get sucked in |
69 |
|
|
%{contentdir}/html/horde/kronolith/js |
70 |
|
|
%{contentdir}/html/horde/kronolith/lib |
71 |
|
|
%{contentdir}/html/horde/kronolith/locale |
72 |
|
|
%{contentdir}/html/horde/kronolith/po |
73 |
|
|
%{contentdir}/html/horde/kronolith/scripts |
74 |
|
|
%{contentdir}/html/horde/kronolith/templates |
75 |
|
|
%{contentdir}/html/horde/kronolith/themes |
76 |
slords |
1.5 |
%{contentdir}/html/horde/kronolith/calendars |
77 |
mrjhb3 |
1.8 |
%{contentdir}/html/horde/kronolith/feed |
78 |
slords |
1.1 |
# Mark documentation files with %doc and %docdir |
79 |
|
|
%doc %{contentdir}/html/horde/kronolith/COPYING |
80 |
|
|
%doc %{contentdir}/html/horde/kronolith/README |
81 |
|
|
%docdir %{contentdir}/html/horde/kronolith/docs |
82 |
|
|
%{contentdir}/html/horde/kronolith/docs |
83 |
|
|
# Mark configuration files with %config and use secure permissions |
84 |
|
|
# (note that .dist files are considered software; don't mark %config) |
85 |
|
|
%attr(750,root,%{apachegroup}) %dir %{contentdir}/html/horde/kronolith/config |
86 |
|
|
%defattr(640,root,%{apachegroup}) |
87 |
|
|
%{contentdir}/html/horde/kronolith/config/.htaccess |
88 |
|
|
%{contentdir}/html/horde/kronolith/config/*.dist |
89 |
|
|
%config %{contentdir}/html/horde/kronolith/config/*.php |
90 |
|
|
%config %{contentdir}/html/horde/kronolith/config/*.xml |
91 |
|
|
|
92 |
|
|
%changelog |
93 |
mrjhb3 |
1.11 |
* Sun Dec 27 2009 John H. Bennett III <bennettj@johnbennettservices.com> 2.3.3-1 |
94 |
|
|
- Updated to Kronolith 2.3.3 |
95 |
|
|
|
96 |
mrjhb3 |
1.10 |
* Fri Oct 9 2009 John H. Bennett III <bennettj@johnbennettservices.com> 2.3.2-1 |
97 |
|
|
- Updated to Kronolith 2.3.2 |
98 |
|
|
|
99 |
mrjhb3 |
1.9 |
* Wed Apr 1 2009 John H. Bennett III <bennettj@johnbennettservices.com> 2.3.1-1 |
100 |
|
|
- Updated to Kronolith 2.3.1 |
101 |
|
|
|
102 |
mrjhb3 |
1.8 |
* Fri Dec 05 2008 John H. Bennett III <bennettj@johnbennettservices.com> 2.3-1 |
103 |
|
|
- Updated to Kronolith 2.3 |
104 |
|
|
|
105 |
slords |
1.5 |
* Mon Jun 2 2008 John H. Bennett III <bennettj@johnbennettservices.com> 2.2-1 |
106 |
|
|
- initial RPM roll for Kronolith 2.2 |