1 |
slords |
1.3 |
# $Id$ |
2 |
|
|
# Authority: mrjhb3 |
3 |
|
|
# Name: John H. Bennett III |
4 |
|
|
|
5 |
slords |
1.1 |
%define apachedir /etc/httpd |
6 |
|
|
%define apacheuser www |
7 |
|
|
%define apachegroup www |
8 |
|
|
%define contentdir /home/httpd |
9 |
|
|
|
10 |
|
|
Summary: The web-based calendar system for Horde. |
11 |
|
|
Name: kronolith-h3 |
12 |
slords |
1.2 |
Version: 2.1.7 |
13 |
slords |
1.1 |
Release: 1%{?dist} |
14 |
|
|
License: LGPL |
15 |
|
|
Group: Applications/Horde |
16 |
|
|
Source: ftp://ftp.horde.org/pub/kronolith/tarballs/kronolith-h3-%{version}.tar.gz |
17 |
|
|
URL: http://www.horde.org/ |
18 |
|
|
BuildArchitectures: noarch |
19 |
|
|
BuildRoot: /tmp/horde-root |
20 |
|
|
AutoReq: no |
21 |
|
|
Requires: horde >= 3.1 |
22 |
|
|
Requires: php >= 4.3.0 |
23 |
|
|
Requires: httpd >= 2.0.46 |
24 |
|
|
Prereq: /usr/bin/perl |
25 |
|
|
|
26 |
|
|
%description |
27 |
|
|
Kronolith is a web-based calendar system written in PHP and utilizing the |
28 |
|
|
Horde Application Framework. |
29 |
|
|
|
30 |
|
|
The Horde Project writes web applications in PHP and releases them under |
31 |
|
|
Open Source licenses. For more information (including help with Horde |
32 |
|
|
and its modules) please visit http://www.horde.org/. |
33 |
|
|
|
34 |
|
|
This package contains customizations for SME Server |
35 |
|
|
and will probably not work properly on other Linux systems. |
36 |
|
|
|
37 |
|
|
%prep |
38 |
|
|
%setup -q -n %{name}-%{version} |
39 |
|
|
|
40 |
|
|
%build |
41 |
|
|
|
42 |
|
|
%install |
43 |
|
|
[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT |
44 |
|
|
mkdir -p $RPM_BUILD_ROOT%{apachedir}/conf |
45 |
|
|
mkdir -p $RPM_BUILD_ROOT%{contentdir}/html/horde/kronolith |
46 |
|
|
cp -pR * $RPM_BUILD_ROOT%{contentdir}/html/horde/kronolith |
47 |
|
|
cd $RPM_BUILD_ROOT%{contentdir}/html/horde/kronolith/config |
48 |
|
|
for d in *.dist; do |
49 |
|
|
d0=`basename $d .dist` |
50 |
|
|
if [ ! -f "$d0" ]; then |
51 |
|
|
cp -p $d $d0 |
52 |
|
|
fi |
53 |
|
|
done |
54 |
|
|
|
55 |
|
|
%clean |
56 |
|
|
[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT |
57 |
|
|
|
58 |
|
|
%post |
59 |
|
|
|
60 |
|
|
%postun |
61 |
|
|
|
62 |
|
|
%files |
63 |
|
|
%defattr(-,root,root) |
64 |
|
|
# Include top level with %dir so not all files are sucked in |
65 |
|
|
%dir %{contentdir}/html/horde/kronolith |
66 |
|
|
# Include top-level files by hand |
67 |
|
|
%{contentdir}/html/horde/kronolith/*.php |
68 |
|
|
# Include these dirs so that all files _will_ get sucked in |
69 |
|
|
%{contentdir}/html/horde/kronolith/js |
70 |
|
|
%{contentdir}/html/horde/kronolith/lib |
71 |
|
|
%{contentdir}/html/horde/kronolith/locale |
72 |
|
|
%{contentdir}/html/horde/kronolith/po |
73 |
|
|
%{contentdir}/html/horde/kronolith/scripts |
74 |
|
|
%{contentdir}/html/horde/kronolith/templates |
75 |
|
|
%{contentdir}/html/horde/kronolith/themes |
76 |
|
|
# Mark documentation files with %doc and %docdir |
77 |
|
|
%doc %{contentdir}/html/horde/kronolith/COPYING |
78 |
|
|
%doc %{contentdir}/html/horde/kronolith/README |
79 |
|
|
%docdir %{contentdir}/html/horde/kronolith/docs |
80 |
|
|
%{contentdir}/html/horde/kronolith/docs |
81 |
|
|
# Mark configuration files with %config and use secure permissions |
82 |
|
|
# (note that .dist files are considered software; don't mark %config) |
83 |
|
|
%attr(750,root,%{apachegroup}) %dir %{contentdir}/html/horde/kronolith/config |
84 |
|
|
%defattr(640,root,%{apachegroup}) |
85 |
|
|
%{contentdir}/html/horde/kronolith/config/.htaccess |
86 |
|
|
%{contentdir}/html/horde/kronolith/config/*.dist |
87 |
|
|
%config %{contentdir}/html/horde/kronolith/config/*.php |
88 |
|
|
%config %{contentdir}/html/horde/kronolith/config/*.xml |
89 |
|
|
|
90 |
|
|
%changelog |
91 |
slords |
1.2 |
* Tue Mar 25 2008 Shad L. Lords <slords@mail.com> 2.1.7-1 |
92 |
|
|
- Updated to kronolith 2.1.7 |
93 |
|
|
|
94 |
slords |
1.1 |
* Mon Nov 11 2007 John H. Bennett III <bennettj@johnbennettservices.com> 2.1.6-1 |
95 |
|
|
- Updated to kronolith 2.1.6 |
96 |
|
|
|
97 |
|
|
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> |
98 |
|
|
- Clean up spec so package can be built by koji/plague |
99 |
|
|
|
100 |
|
|
* Fri Mar 23 2007 John H. Bennett III <bennettj@johnbennettservices.com> 2.1.5-1 |
101 |
|
|
- Updated to kronolith 2.1.5 |
102 |
|
|
|
103 |
|
|
* Mon Dec 4 2006 John H. Bennett III <bennettj@johnbennettservices.com> 2.1.4-00sme01 |
104 |
|
|
- Updated to kronolith 2.1.4 |
105 |
|
|
|
106 |
|
|
* Fri Nov 24 2006 John H. Bennett III <bennettj@johnbennettservices.com> 2.1.3-00sme01 |
107 |
|
|
- Updated to kronolith 2.1.3 |
108 |
|
|
|
109 |
|
|
* Sat Sep 9 2006 John H. Bennett III <bennettj@johnbennettservices.com> 2.1.2-00sme01 |
110 |
|
|
- Updated to kronolith 2.1.2 |
111 |
|
|
|
112 |
|
|
* Wed Mar 1 2006 John H. Bennett III <bennettj@johnbennettservices.com> 2.0.6-1sme02 |
113 |
|
|
- Removed post and postun events |
114 |
|
|
- Renamed to smeserver-kronolith to represent an addon product |
115 |
|
|
|
116 |
|
|
* Wed Feb 15 2006 John H. Bennett III <bennettj@johnbennettservices.com> 2.0.6-1sme01 |
117 |
|
|
- Initial Release of Kronolith 2.0.6 building on Greg's work |
118 |
|
|
|
119 |
|
|
* Thu Sep 01 2005 Greg Swallow |
120 |
|
|
- [1.0-1sme01] |
121 |
|
|
- Initial Release |
122 |
|
|
|
123 |
|
|
|