/[smecontribs]/rpms/lcdproc/contribs8/lcdproc.spec
ViewVC logotype

Annotation of /rpms/lcdproc/contribs8/lcdproc.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.5 - (hide annotations) (download)
Wed Feb 24 18:39:40 2010 UTC (14 years, 3 months ago) by slords
Branch: MAIN
CVS Tags: HEAD
Changes since 1.4: +1 -1 lines
FILE REMOVED
Maintained upstream

1 slords 1.5 # $Id: lcdproc.spec,v 1.4 2008/11/25 16:20:13 slords Exp $
2 slords 1.2 # Authority: slords
3     # Name: Shad L. Lords
4    
5 slords 1.1 Summary: LCDproc displays real-time system information on a backlit LCD
6     Name: lcdproc
7     Version: 0.5.2
8 slords 1.2 Release: 2%{?dist}
9 slords 1.1 License: GPL
10     Url: http://lcdproc.omnipotent.net
11     Group: System Environment/Libraries
12     Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
13     Patch0: lcdproc-0.5.2-scripts.patch
14 slords 1.2 Patch1: lcdproc-0.5.2-roamer.patch
15 slords 1.1 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
16    
17     BuildRequires: doxygen
18     BuildRequires: graphviz
19     BuildRequires: glibc-headers
20     BuildRequires: libusb-devel
21     BuildRequires: ncurses-devel
22     BuildRequires: nfs-utils-lib-devel
23     BuildRequires: openldap-devel
24     BuildRequires: pth-devel
25     BuildRequires: xmlto
26     BuildRequires: libX11-devel
27     BuildRequires: libXext-devel
28    
29     %ifarch %{ix86} x86_64
30     BuildRequires: svgalib-devel
31     %endif
32    
33     Requires(post): /sbin/chkconfig
34     Requires(postun): /sbin/chkconfig
35    
36    
37    
38     %description
39     LCDproc is a client/server suite inclduding drivers for all
40     kinds of nifty LCD displays. The server supports several
41     serial devices: Matrix Orbital, Crystal Fontz, Bayrad, LB216,
42     LCDM001 (kernelconcepts.de), Wirz-SLI and PIC-an-LCD; and some
43     devices connected to the LPT port: HD44780, STV5730, T6963,
44     SED1520 and SED1330. Various clients are available that display
45     things like CPU load, system load, memory usage, uptime, and a lot more.
46     See also http://lcdproc.omnipotent.net.
47    
48    
49     %prep
50     %setup -q
51     %patch0 -p1 -b .initscripts
52 slords 1.2 %patch1 -p1
53 slords 1.1 chmod 644 server/drivers/timing.h
54    
55    
56     %build
57     %configure --libdir=%{_libdir} \
58     --enable-libusb \
59     --enable-ldap \
60     --enable-drivers=all \
61     --enable-permissive-menu-goto \
62     --enable-lcdproc-menus \
63     --enable-stat-nfs \
64     --enable-stat-smbfs \
65     --with-lcdport=13666
66    
67     sed -i -e 's|-L/usr/lib|-L%{_libdir}|g' Makefile
68    
69     make CFLAGS="$RPM_OPT_FLAGS" %{?_smp_mflags}
70    
71    
72     %install
73     rm -rf $RPM_BUILD_ROOT __doc
74     make install DESTDIR=$RPM_BUILD_ROOT
75     make install-html-guides DESTDIR=$RPM_BUILD_ROOT
76    
77     # Fix docs
78     mkdir -p __doc/developer-guide
79     mkdir -p __doc/user-guide
80     install -m 0644 $RPM_BUILD_ROOT%{_datadir}/doc/lcdproc/user-guide/* __doc/user-guide
81     install -m 0644 $RPM_BUILD_ROOT%{_datadir}/doc/lcdproc/developer-guide/* __doc/developer-guide
82     rm -rf $RPM_BUILD_ROOT%{_datadir}/doc
83    
84     # init
85     install -d $RPM_BUILD_ROOT%{_initrddir}
86     install -pm 0755 scripts/init-LCDd.rpm $RPM_BUILD_ROOT%{_initrddir}/LCDd
87     install -pm 0755 scripts/init-lcdproc.rpm $RPM_BUILD_ROOT%{_initrddir}/lcdproc
88    
89    
90    
91     %post
92     if [ $1 -eq 1 ]; then
93     # Add init script and but don't start it
94     /sbin/chkconfig --add LCDd
95     /sbin/chkconfig --add lcdproc ||:
96     fi
97    
98    
99     %preun
100     if [ $1 -eq 0 ]; then
101     # Disable driver on final removal
102     %{_initrddir}/lcdproc stop &>/dev/null
103     %{_initrddir}/LCDd stop &>/dev/null
104     /sbin/chkconfig --del lcdproc
105     /sbin/chkconfig --del LCDd ||:
106     fi
107    
108    
109     %clean
110     rm -rf $RPM_BUILD_ROOT __doc
111    
112     %files
113     %defattr(-,root,root,-)
114     %doc README* INSTALL COPYING CREDITS TODO ChangeLog
115     %doc docs/*.txt docs/README.* __doc/*
116     %{_bindir}/*
117     %dir %{_libdir}/lcdproc
118     %{_libdir}/lcdproc/*
119     %{_sbindir}/*
120     %{_mandir}/man?/*
121     %config(noreplace) %{_sysconfdir}/*.conf
122     %{_initrddir}/LCDd
123     %{_initrddir}/lcdproc
124    
125    
126     %changelog
127 slords 1.2 * Sat Apr 12 2008 Shad L. Lords <slords@mail.com> 0.5.2-2
128     - Add support for roamer display on rackable systems
129    
130 slords 1.1 * Sat May 19 2007 kwizart < kwizart at gmail.com > 0.5.2-1
131     - Update to 0.5.2
132     - Add BR
133     - Install docs
134    
135     * Tue Apr 17 2007 kwizart < kwizart at gmail.com > 0.5.1-1
136     - Cleaned spec files for Fedora guidelines.
137    
138     * Fri Sep 26 2003 TC Wan <tcwan@cs.usm.my>
139     - Fixed spec file for RH 9, made metar dependency optional
140    
141     * Sun Oct 6 2002 Arnaud de Lorbeau <adelorbeau@mandrakesoft.com> 0.4.3-2mdk
142     - Add docs
143    
144     * Thu Sep 12 2002 Nicolas Chipaux <chipaux@mandrakesoft.com> 0.4.3-1mdk
145     - new release
146    
147     * Fri Oct 26 2001 Rex Dieter <rdieter@unl.edu> 0.4.1-1
148     - --enable-stat-smbfs
149     - TODO: make server/client init scripts
150    
151     * Mon Oct 22 2001 Rex Dieter <rdieter@unl.edu> -0
152     - first try, 0.4.1
153     - --enable-stat-nfs
154    

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed