/[smecontribs]/rpms/ldns/contribs9/ldns.spec
ViewVC logotype

Annotation of /rpms/ldns/contribs9/ldns.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.1 - (hide annotations) (download)
Wed Mar 9 12:19:19 2016 UTC (8 years, 2 months ago) by unnilennium
Branch: MAIN
CVS Tags: ldns-1_6_16-7_el6_1
Initial import

1 unnilennium 1.1 %{?!with_python: %global with_python 1}
2    
3     %if %{with_python}
4     %{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
5     %{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
6     %endif
7    
8     Summary: Low-level DNS(SEC) library with API
9     Name: ldns
10     Version: 1.6.16
11     Release: 7%{?dist}.1
12     License: BSD
13     Url: http://www.nlnetlabs.nl/%{name}/
14     Source: http://www.nlnetlabs.nl/downloads/%{name}/%{name}-%{version}.tar.gz
15    
16     Patch0: %{name}-1.6.16-uninitialized-value-compiler-warnings.patch
17     Patch1: %{name}-1.6.16-multilib.patch
18     Patch2: %{name}-1.6.16-manpage-fixes-bundle.patch
19     Patch3: %{name}-1.6.16-dsa-key-failures.patch
20    
21     Group: System Environment/Libraries
22     BuildRequires: perl, libpcap-devel, openssl-devel, gcc-c++, doxygen,
23     # for snapshots only
24     # BuildRequires: libtool, autoconf, automake
25     %if %{with_python}
26     BuildRequires: python-devel, swig
27     %endif
28     Requires: ca-certificates
29    
30     %description
31     ldns is a library with the aim to simplify DNS programming in C. All
32     low-level DNS/DNSSEC operations are supported. We also define a higher
33     level API which allows a programmer to (for instance) create or sign
34     packets.
35    
36     %package devel
37     Summary: Development package that includes the ldns header files
38     Group: Development/Libraries
39     Requires: %{name} = %{version}-%{release}
40    
41     %description devel
42     The devel package contains the ldns library and the include files
43    
44     %if %{with_python}
45     %package python
46     Summary: Python extensions for ldns
47     Group: Applications/System
48     Requires: %{name} = %{version}-%{release}
49    
50     %description python
51     Python extensions for ldns
52     %endif
53    
54     %package doc
55     Summary: Documentation for the ldns library
56     Group: Development/Libraries
57     Requires: %{name}-devel = %{version}-%{release}
58     BuildArch: noarch
59    
60     %description doc
61     This package contains documentation for the ldns library
62    
63     %prep
64     %setup -q
65     %patch0 -p2
66     %patch1 -p1
67     %patch2 -p1 -b .manpage
68     %patch3 -p1 -b .dsa_issue
69    
70     # To built svn snapshots
71     # rm config.guess config.sub ltmain.sh
72     # aclocal
73     # libtoolize -c --install
74     # autoreconf --install
75    
76     %build
77     # as long as ECC is banned we cannot enable GOST
78     %configure --disable-rpath --disable-static --disable-gost --enable-ecdsa \
79     --with-ca-file=/etc/pki/tls/certs/ca-bundle.trust.crt --with-ca-path=/etc/pki/tls/certs/ \
80     %if %{with_python}
81     --with-pyldns \
82     %endif
83     --with-trust-anchor=%{_sharedstatedir}/unbound/root.key
84    
85     (cd drill ; %configure --disable-rpath --disable-static --disable-gost \
86     --disable-ecdsa \
87     --with-ca-file=/etc/pki/tls/certs/ca-bundle.trust.crt --with-ca-path=/etc/pki/tls/certs/ \
88     --with-trust-anchor=%{_sharedstatedir}/unbound/root.key
89     )
90     (cd examples ; %configure --disable-rpath --disable-static --disable-gost \
91     --disable-ecdsa \
92     --with-ca-file=/etc/pki/tls/certs/ca-bundle.trust.crt --with-ca-path=/etc/pki/tls/certs/ \
93     --with-trust-anchor=%{_sharedstatedir}/unbound/root.key
94     )
95    
96     make %{?_smp_mflags}
97     ( cd drill ; make %{?_smp_mflags} )
98     ( cd examples ; make %{?_smp_mflags} )
99     make %{?_smp_mflags} doc
100    
101     %install
102     rm -rf %{buildroot}
103    
104     make DESTDIR=%{buildroot} INSTALL="%{__install} -p" install
105     make DESTDIR=%{buildroot} INSTALL="%{__install} -p" install-doc
106    
107     # don't package xml files
108     rm doc/*.xml
109     # don't package building script for install-doc in doc section
110     rm doc/doxyparse.pl
111     #remove double set of man pages
112     rm -rf doc/man
113     # remove .la files
114     rm -rf %{buildroot}%{_libdir}/*.la %{buildroot}%{python_sitearch}/*.la
115     (cd drill ; make DESTDIR=%{buildroot} install)
116     (cd examples; make DESTDIR=%{buildroot} install)
117    
118     %clean
119     rm -rf %{buildroot}
120    
121     %files
122     %defattr(-,root,root)
123     %{_libdir}/libldns*so.*
124     %{_bindir}/drill
125     %{_bindir}/ldnsd
126     %{_bindir}/ldns-chaos
127     %{_bindir}/ldns-compare-zones
128     %{_bindir}/ldns-[d-z]*
129     %doc README LICENSE
130     %{_mandir}/*/*
131    
132     %files devel
133     %defattr(-,root,root,-)
134     %{_libdir}/libldns*so
135     %{_bindir}/ldns-config
136     %dir %{_includedir}/ldns
137     %{_includedir}/ldns/*.h
138     %doc Changelog README
139    
140     %if %{with_python}
141     %files python
142     %defattr(-,root,root)
143     %{python_sitearch}/*
144     %endif
145    
146     %files doc
147     %doc doc
148    
149     %post -p /sbin/ldconfig
150    
151     %postun -p /sbin/ldconfig
152    
153     %changelog
154     * Fri Aug 14 2015 Tomas Hozza <thozza@redhat.com> - 1.6.16-7.1
155     - port the rhel-7 package version to rhel-6
156     - enabled ECDSA due to Unbound
157     - Fix issue in DSA algorithm (#1077799)
158    
159     * Fri Jan 24 2014 Daniel Mach <dmach@redhat.com> - 1.6.16-7
160     - Mass rebuild 2014-01-24
161    
162     * Fri Dec 27 2013 Daniel Mach <dmach@redhat.com> - 1.6.16-6
163     - Mass rebuild 2013-12-27
164    
165     * Tue Jul 23 2013 Tomas Hozza <thozza@redhat.com> - 1.6.16-5
166     - Fix compiler warnings and one uninitialized value
167     - make ldns-config multilib clean
168     - Fix man pages and usages errors
169    
170     * Mon Jun 03 2013 Paul Wouters <pwouters@redhat.com> - 1.6.16-4
171     - Use /var/lib/unbound/root.key for --with-trust-anchor
172    
173     * Fri Apr 19 2013 Adam Tkac <atkac redhat com> - 1.6.16-3
174     - make package multilib clean
175    
176     * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.16-2
177     - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
178    
179     * Tue Oct 30 2012 Paul Wouters <pwouters@redhat.com> - 1.6.16-1
180     - Updated to 1.6.16
181     - Addresses bug in 1.6.14 and 1.6.15 that affects opendnssec
182     (if you have empty non-terminals and use NSEC3)
183    
184     * Fri Oct 26 2012 Paul Wouters <pwouters@redhat.com> - 1.6.15-1
185     - Updated to 1.6.15, as 1.6.14 accidentally broke ABI
186     (We never released 1.6.14)
187    
188     * Tue Oct 23 2012 Paul Wouters <pwouters@redhat.com> - 1.6.14-1
189     - [pulled before release]
190     - Updated to 1.6.14
191     - Removed merged in patch
192     - Added new dependancy on ca-certificates for ldns-dane PKIX validation
193    
194     * Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.13-3
195     - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
196    
197     * Fri Jun 01 2012 Paul Wouters <pwouters@redhat.com> - 1.6.13-2
198     - Added reworked ldns-read-zone patch from trunk
199     (adds -p for SOA padding, and -o for zeroizing timestamps/sigs)
200    
201     * Mon May 21 2012 Paul Wouters <pwouters@redhat.com> - 1.6.13-1
202     - Upgraded to 1.6.13, bugfix release
203     - Added --disable-ecdsa as ECC is still banned
204     - Removed --with-sha2 - it is always enabled and option was removed
205    
206     * Wed Jan 11 2012 Paul Wouters <paul@nohats.ca> - 1.6.12-1
207     - Upgraded to 1.6.12, fixes important end of year handling date bug
208    
209     * Wed Oct 5 2011 Paul Wouters <paul@xelerance.com> - 1.6.11-2
210     - Updated to 1.6.11, fixes rhbz#741026 which is CVE-2011-3581
211     - Python goes into sitearch, not sitelib
212     - Fix source link and spelling errors in description
213    
214     * Mon Sep 19 2011 Paul Wouters <paul@xelerance.com> - 1.6.10-2
215     - Fix for losing nameserver when it drops UDP fragments in
216     ldns_resolver_send_pkt [Willem Toorop <willem@NLnetLabs.nl>]
217     - Added ldnsx module (to be merged into ldns soon)
218     http://git.xelerance.com/cgi-bin/gitweb.cgi?p=ldnsx.git;a=summary
219    
220     * Wed Jun 08 2011 Paul Wouters <paul@xelerance.com> - 1.6.10-1
221     - Upodated to 1.6.10
222     - Commented out dependancies that are only needed for snapshots
223    
224     * Sun Mar 27 2011 Paul Wouters <paul@xelerance.com> - 1.6.9-1
225     - Updated to 1.6.9
226    
227     * Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.8-2
228     - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
229    
230     * Mon Jan 24 2011 Paul Wouters <paul@xelerance.com> - 1.6.8-1
231     - Updated to 1.6.8
232    
233     * Thu Aug 26 2010 Paul Wouters <paul@xelerance.com> - 1.6.6-2
234     - Bump for EVR
235    
236     * Mon Aug 09 2010 Paul Wouters <paul@xelerance.com> - 1.6.6-1
237     - Upgraded to 1.6.6
238    
239     * Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 1.6.5-2
240     - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
241    
242     * Tue Jun 15 2010 Paul Wouters <paul@xelerance.com> - 1.6.5-1
243     - Updated to 1.6.5
244    
245     * Fri Jan 22 2010 Paul Wouters <paul@xelerance.com> - 1.6.4-2
246     - Fix missing _ldns.so causing ldns-python to not work
247     - Patch for installing ldns-python files
248     - Patch for rpath in ldns-python
249     - Don't install .a file for ldns-python
250    
251     * Wed Jan 20 2010 Paul Wouters <paul@xelerance.com> - 1.6.4-1
252     - Upgraded to 1.6.4.
253     - Added ldns-python sub package
254    
255     * Fri Dec 04 2009 Paul Wouters <paul@xelerance.com> - 1.6.3-1
256     - Upgraded to 1.6.3, which has minor bugfixes
257    
258     * Fri Nov 13 2009 Paul Wouters <paul@xelerance.com> - 1.6.2-1
259     - Upgraded to 1.6.2. This fixes various bugs.
260     (upstream released mostly to default with sha2 for the imminent
261     signed root, but we already enabled that in our builds)
262    
263     * Tue Aug 25 2009 Tomas Mraz <tmraz@redhat.com> - 1.6.1-3
264     - rebuilt with new openssl
265    
266     * Sun Aug 16 2009 Paul Wouters <paul@xelerance.com> - 1.6.1-2
267     - Added openssl dependancy back in, since we get more functionality
268     when using openssl. Especially in 'drill'.
269    
270     * Sun Aug 16 2009 Paul Wouters <paul@xelerance.com> - 1.6.1-1
271     - Updated to 1.6.1
272    
273     * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.0-5
274     - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
275    
276     * Mon Jul 13 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-4
277     - Fixed the ssl patch so it can now compile --without-ssl
278    
279     * Sat Jul 11 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-3
280     - Added patch to compile with --without-ssl
281     - Removed openssl dependancies
282     - Recompiled with --without-ssl
283    
284     * Sat Jul 11 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-2
285     - Updated to 1.6.0
286     - (did not yet compile with --without-ssl due to compile failures)
287    
288     * Fri Jul 10 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-1
289     - Updated to 1.6.0
290     - Compile without openssl
291    
292     * Thu Apr 16 2009 Paul Wouters <paul@xelerance.com> - 1.5.1-4
293     - Memory management bug when generating a sha256 key, see:
294     https://bugzilla.redhat.com/show_bug.cgi?id=493953
295    
296     * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.1-2
297     - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
298    
299     * Tue Feb 10 2009 Paul Wouters <paul@xelerance.com> - 1.5.1-1
300     - Updated to new version, 1.5.0 had a bug preventing
301     zone signing.
302    
303     * Mon Feb 9 2009 Paul Wouters <paul@xelerance.com> - 1.5.0-1
304     - Updated to new version
305    
306     * Thu Feb 05 2009 Adam Tkac <atkac redhat com> - 1.4.0-3
307     - fixed configure flags
308    
309     * Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 1.4.0-2
310     - rebuild with new openssl
311    
312     * Fri Nov 7 2008 Paul Wouters <paul@xelerance.com> - 1.4.0-1
313     - Updated to 1.4.0
314    
315     * Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-3
316     - enable SHA2 functionality
317    
318     * Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-2
319     - re-tag (don't do builds while renaming local repo dirs)
320    
321     * Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-1
322     - Updated to latest release
323    
324     * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.2.2-3
325     - Autorebuild for GCC 4.3
326    
327     * Wed Dec 5 2007 Paul Wouters <paul@xelerance.com> - 1.2.2-2
328     - Rebuild for new libcrypto
329    
330     * Thu Nov 29 2007 Paul Wouters <paul@xelerance.com> - 1.2.2-1
331     - Upgraded to 1.2.2. Removed no longer needed race workaround
332    
333     * Tue Nov 13 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-4
334     - Try to fix racing ln -s statements in parallel builds
335    
336     * Fri Nov 9 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-3
337     - Added patch for ldns-read-zone that does not put @. in RRDATA
338    
339     * Fri Oct 19 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-2
340     - Use install -p to work around multilib conflicts for .h files
341    
342     * Wed Oct 10 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-1
343     - Updated to 1.2.1
344     - Removed patches that got moved into upstream
345    
346     * Wed Aug 8 2007 Paul Wouters <paul@xelerance.com> 1.2.0-11
347     - Patch for ldns-key2ds to write to stdout
348     - Again remove extra set of man pages from doc
349     - own /usr/include/ldns (bug 233858)
350    
351     * Wed Aug 8 2007 Paul Wouters <paul@xelerance.com> 1.2.0-10
352     - Added sha256 DS record patch to ldns-key2ds
353     - Minor tweaks for proper doc/man page installation.
354     - Workaround for parallel builds
355    
356     * Mon Aug 6 2007 Paul Wouters <paul@xelerance.com> 1.2.0-2
357     - Own the /usr/include/ldns directory (bug #233858)
358     - Removed obsoleted patch
359     - Remove files form previous libtool run accidentally packages by upstream
360    
361     * Mon Sep 11 2006 Paul Wouters <paul@xelerance.com> 1.0.1-4
362     - Commented out 1.1.0 make targets, put make 1.0.1 targets.
363    
364     * Mon Sep 11 2006 Paul Wouters <paul@xelerance.com> 1.0.1-3
365     - Fixed changelog typo in date
366     - Rebuild requested for PT_GNU_HASH support from gcc
367     - Did not upgrade to 1.1.0 due to compile issues on x86_64
368    
369     * Fri Jan 6 2006 Paul Wouters <paul@xelerance.com> 1.0.1-1
370     - Upgraded to 1.0.1. Removed temporary clean hack from spec file.
371    
372     * Sun Dec 18 2005 Paul Wouters <paul@xelerance.com> 1.0.0-8
373     - Cannot use make clean because there are no Makefiles. Use hardcoded rm.
374    
375     * Sun Dec 18 2005 Paul Wouters <paul@xelerance.com> 1.0.0-7
376     - Patched 'make clean' target to get rid of object files shipped with 1.0.0
377    
378     * Tue Dec 13 2005 Paul Wouters <paul@xelerance.com> 1.0.0-6
379     - added a make clean for 2.3.3 since .o files were left behind upstream,
380     causing failure on ppc platform
381    
382     * Sun Dec 11 2005 Tom "spot" Callaway <tcallawa@redhat.com> 1.0.0-5
383     - minor cleanups
384    
385     * Wed Oct 5 2005 Paul Wouters <paul@xelerance.com> 0.70_1205
386     - reworked for svn version
387    
388     * Sun Sep 25 2005 Paul Wouters <paul@xelerance.com> - 0.70
389     - Initial version

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed