1 |
# $Id: libdlna.spec 7982 2009-11-03 03:41:01Z dag $ |
2 |
# Authority: dag |
3 |
# Upstream: Benjamin Zores <ben$geexbox,org> |
4 |
|
5 |
Summary: Implementation of Digital Living Network Alliance (DLNA) standards |
6 |
Name: libdlna |
7 |
Version: 0.2.3 |
8 |
Release: 4%{?dist} |
9 |
License: GPL |
10 |
Group: System Environment/Libraries |
11 |
URL: http://libdlna.geexbox.org/ |
12 |
|
13 |
Packager: Dag Wieers <dag@wieers.com> |
14 |
Vendor: Dag Apt Repository, http://dag.wieers.com/apt/ |
15 |
|
16 |
Source: http://libdlna.geexbox.org/releases/libdlna-%{version}.tar.bz2 |
17 |
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root |
18 |
|
19 |
BuildRequires: ffmpeg-devel |
20 |
BuildRequires: ffmpeg-compat-devel |
21 |
|
22 |
%description |
23 |
libdlna aims at being the reference open-source implementation of DLNA |
24 |
(Digital Living Network Alliance) standards. Its primary goal is to |
25 |
provide DLNA support to uShare, an embedded DLNA & UPnP A/V Media Server, |
26 |
but it will be used to build both DLNA servers and players in the long term. |
27 |
|
28 |
%package devel |
29 |
Summary: Header files, libraries and development documentation for %{name}. |
30 |
Group: Development/Libraries |
31 |
Requires: %{name} = %{version}-%{release} |
32 |
|
33 |
%description devel |
34 |
This package contains the header files, static libraries and development |
35 |
documentation for %{name}. If you like to develop programs using %{name}, |
36 |
you will need to install %{name}-devel. |
37 |
|
38 |
%prep |
39 |
%setup |
40 |
#remove test |
41 |
%{__perl} -pi.orig -e ' |
42 |
s|check_lib ffmpeg/avformat.h av_register_all -lavformat|echo "ok"|; |
43 |
s|check_lib ffmpeg/avcodec.h avcodec_register_all -lavcodec|echo "ok"|; |
44 |
' configure src/*.c src/*.h |
45 |
%{__perl} -pi.orig -e ' |
46 |
s|ffmpeg/avformat.h|ffmpeg-compat/libavformat/avformat.h|; |
47 |
s|ffmpeg/avcodec.h|ffmpeg-compat/libavcodec/avcodec.h|; |
48 |
' configure src/*.c src/*.h |
49 |
|
50 |
#check_lib ffmpeg/libavformat/avformat.h av_register_all -lavformat || die "Error, can't find libavformat !" |
51 |
#echolog "Checking for libavcodec ..." |
52 |
#check_lib ffmpeg/libavcodec/avcodec.h avcodec_register_all -lavcodec || die "Error, can't find libavcodec !" |
53 |
|
54 |
# %if %{!?_without_ffmpeg05:1}0 |
55 |
# %{__perl} -pi.orig -e ' |
56 |
# s|ffmpeg/avformat.h|libavformat/avformat.h|; |
57 |
# s|ffmpeg/avcodec.h|libavcodec/avcodec.h|; |
58 |
# ' configure src/*.c src/*.h |
59 |
# %endif |
60 |
|
61 |
|
62 |
%build |
63 |
export CFLAGS="%{optflags}" |
64 |
./configure \ |
65 |
--disable-static \ |
66 |
--libdir="%{_libdir}" \ |
67 |
--prefix="%{_prefix}" \ |
68 |
--log=/dev/stdout |
69 |
%{__make} %{?_smp_mflags} || : |
70 |
|
71 |
%install |
72 |
%{__rm} -rf %{buildroot} |
73 |
%{__make} install DESTDIR="%{buildroot}" |
74 |
|
75 |
%post -p /sbin/ldconfig |
76 |
%postun -p /sbin/ldconfig |
77 |
|
78 |
%clean |
79 |
%{__rm} -rf %{buildroot} |
80 |
|
81 |
%files |
82 |
%defattr(-, root, root, 0755) |
83 |
%doc AUTHORS ChangeLog COPYING README |
84 |
%{_libdir}/libdlna.so.* |
85 |
|
86 |
%files devel |
87 |
%{_includedir}/dlna.h |
88 |
%{_libdir}/libdlna.so |
89 |
%{_libdir}/pkgconfig/libdlna.pc |
90 |
|
91 |
%changelog |
92 |
* Sun Apr 30 2017 Jean-Philipe Pialasse <tests@pialasse.com> 0.2.3-4.sme |
93 |
- first import in SME buildsys |
94 |
|
95 |
* Sat Dec 04 2010 Dag Wieers <dag@wieers.com> - 0.2.3-3 |
96 |
- Rebuild against ffmpeg-0.6.1. |
97 |
|
98 |
* Mon Jul 13 2009 Dag Wieers <dag@wieers.com> - 0.2.3-2 |
99 |
- Rebuild against ffmpeg-0.5. |
100 |
|
101 |
* Tue Nov 27 2007 Dag Wieers <dag@wieers.com> - 0.2.3-1 |
102 |
- Updated to release 0.2.3. |
103 |
|
104 |
* Sun Nov 25 2007 Dag Wieers <dag@wieers.com> - 0.2.2-1 |
105 |
- Updated to release 0.2.2. |
106 |
|
107 |
* Fri Nov 23 2007 Dag Wieers <dag@wieers.com> - 0.2.1-1 |
108 |
- Initial package. (using DAR) |