1 |
jpp |
1.1 |
%define major 1 |
2 |
|
|
%define libname evhtp-lib |
3 |
|
|
%define develname evhtp-devel |
4 |
jpp |
1.2 |
%define release 4 |
5 |
jpp |
1.1 |
|
6 |
|
|
Name: libevhtp |
7 |
|
|
Version: 1.2.11n |
8 |
|
|
Release: %{release}%{dist} |
9 |
|
|
Summary: A more flexible replacement for libevent's http API |
10 |
|
|
License: BSD |
11 |
|
|
Group: System/Libraries |
12 |
|
|
Url: https://github.com/ellzey/libevhtp |
13 |
|
|
Source0: https://github.com/ellzey/libevhtp/archive/%{version}/%{name}-%{version}.tar.gz |
14 |
|
|
Patch0: libevhtp-1.2.11-soname-and-pkgconfig.patch |
15 |
|
|
Patch1: libevhtp-1.2.11-internal-header-files-path.patch |
16 |
|
|
BuildRequires: cmake |
17 |
|
|
BuildRequires: glibc-devel |
18 |
|
|
BuildRequires: pkgconfig(openssl) |
19 |
|
|
BuildRequires: pkgconfig(libevent) |
20 |
|
|
BuildRequires: gcc-c++ |
21 |
|
|
|
22 |
|
|
%description |
23 |
|
|
Libevhtp was created as a replacement API for Libevent's current |
24 |
|
|
HTTP API. The reality of libevent's http interface is that it |
25 |
|
|
was created as a JIT server, meaning the developer never thought |
26 |
|
|
of it being used for creating a full-fledged HTTP service. |
27 |
|
|
Infact I am under the impression that the libevent http API was |
28 |
|
|
designed almost as an example of what you can do with libevent. |
29 |
|
|
It's not Apache in a box, but more and more developers are |
30 |
|
|
attempting to use it as so. |
31 |
|
|
|
32 |
|
|
#---------------------------------------------------- |
33 |
|
|
|
34 |
|
|
%package -n %{libname} |
35 |
|
|
Summary: Library for %{name} |
36 |
|
|
Group: System/Libraries |
37 |
|
|
|
38 |
|
|
%description -n %{libname} |
39 |
|
|
Libevhtp was created as a replacement API for Libevent's current |
40 |
|
|
HTTP API. The reality of libevent's http interface is that it |
41 |
|
|
was created as a JIT server, meaning the developer never thought |
42 |
|
|
of it being used for creating a full-fledged HTTP service. |
43 |
|
|
Infact I am under the impression that the libevent http API was |
44 |
|
|
designed almost as an example of what you can do with libevent. |
45 |
|
|
It's not Apache in a box, but more and more developers are |
46 |
|
|
attempting to use it as so. |
47 |
|
|
This package contains library files for %{name}. |
48 |
|
|
|
49 |
|
|
#---------------------------------------------------- |
50 |
|
|
|
51 |
|
|
%package -n %{develname} |
52 |
|
|
Summary: Development files for %{name} |
53 |
|
|
Group: Development/C |
54 |
|
|
Requires: %{libname} = %{version}-%{release} |
55 |
|
|
Provides: evhtp-devel = %{version}-%{release} |
56 |
|
|
Provides: %{name}-devel = %{version}-%{release} |
57 |
|
|
|
58 |
|
|
%description -n %{develname} |
59 |
|
|
The %{develname} package contains libraries and header files for |
60 |
|
|
developing applications that use %{name}. |
61 |
|
|
|
62 |
|
|
#---------------------------------------------------- |
63 |
|
|
|
64 |
|
|
%prep |
65 |
|
|
%setup -q |
66 |
jpp |
1.2 |
%patch0 -p1 |
67 |
|
|
%patch1 -p1 |
68 |
jpp |
1.1 |
|
69 |
|
|
%build |
70 |
|
|
%cmake -DEVHTP_BUILD_SHARED:STRING=ON |
71 |
|
|
make |
72 |
|
|
|
73 |
|
|
%install |
74 |
|
|
%make_install |
75 |
|
|
|
76 |
|
|
%files |
77 |
|
|
%doc ChangeLog README.markdown |
78 |
|
|
%doc LICENSE |
79 |
|
|
%{_libdir}/libevhtp.so.%{major}.* |
80 |
jpp |
1.2 |
%{_libdir}/libevhtp.so* |
81 |
jpp |
1.1 |
|
82 |
|
|
%files -n %{libname} |
83 |
|
|
%{_libdir}/libevhtp.so.%{major}.* |
84 |
jpp |
1.2 |
%{_libdir}/libevhtp.so* |
85 |
jpp |
1.1 |
|
86 |
|
|
%files -n %{develname} |
87 |
|
|
%doc ChangeLog README.markdown |
88 |
|
|
%doc LICENSE |
89 |
|
|
%{_includedir}/evhtp/ |
90 |
|
|
%{_libdir}/libevhtp.so |
91 |
jpp |
1.2 |
%{_libdir}/pkgconfig/evhtp.pc |
92 |
jpp |
1.1 |
|
93 |
|
|
|
94 |
|
|
%changelog |
95 |
jpp |
1.2 |
* Wed Feb 28 2018 Jean-Philipe Pialasse <tests@pialasse.com> Version: 1.2.11n-4.sme |
96 |
|
|
- improve patch for internal-header-files-path |
97 |
|
|
|
98 |
jpp |
1.1 |
* Mon Feb 19 2018 Jean-Philippe Pialasse <tests@pialasse.com> - 1.2.11n-3 |
99 |
|
|
- first import for SME Server |
100 |
|
|
- tidy the spec file to get it build with mock |
101 |
|
|
|
102 |
|
|
* Wed Feb 15 2017 mrambo3501 <mrambo3501> 1.2.11n-2.mga6 |
103 |
|
|
+ Revision: 1086231 |
104 |
|
|
- rebuild for new libevent |
105 |
|
|
|
106 |
|
|
* Thu May 12 2016 daviddavid <daviddavid> 1.2.11n-1.mga6 |
107 |
|
|
+ Revision: 1014272 |
108 |
|
|
- initial package libevhtp |
109 |
|
|
|