/[smecontribs]/rpms/libextractor/contribs9/libextractor.spec
ViewVC logotype

Annotation of /rpms/libextractor/contribs9/libextractor.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.1 - (hide annotations) (download)
Sun Apr 30 21:37:24 2017 UTC (7 years ago) by unnilennium
Branch: MAIN
CVS Tags: libextractor-0_6_2-1_rf
Initial import

1 unnilennium 1.1 # $Id: libextractor.spec 8921 2010-06-24 12:39:00Z dag $
2     # Authority: dag
3     # Upstream: Christian Grothoff <libextractor$cs,purdue,edu>
4    
5     %{?el4:%define _without_libtoolltdl 1}
6     %{?el3:%define _without_libtoolltdl 1}
7    
8     %define python_sitearch %(%{__python} -c 'from distutils import sysconfig; print sysconfig.get_python_lib(1)')
9    
10     Summary: Meta-data extraction library
11     Name: libextractor
12     Version: 0.6.2
13     Release: 1%{?dist}
14     License: GPL
15     Group: System Environment/Libraries
16     URL: http://www.gnu.org/software/libextractor/
17    
18     Packager: Dag Wieers <dag@wieers.com>
19     Vendor: Dag Apt Repository, http://dag.wieers.com/apt/
20    
21     Source: http://ftpmirror.gnu.org/libextractor/libextractor-%{version}.tar.gz
22     BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
23    
24     BuildRequires: bzip2-devel
25     BuildRequires: exiv2-devel
26     BuildRequires: gcc-c++
27     BuildRequires: gettext
28     BuildRequires: glib2-devel
29     BuildRequires: gtk2-devel
30     BuildRequires: ImageMagick
31     BuildRequires: ImageMagick-c++-devel
32     BuildRequires: ImageMagick-devel
33     BuildRequires: intltool
34     BuildRequires: libogg-devel
35     BuildRequires: libvorbis-devel
36     BuildRequires: mpeg2dec-devel
37     BuildRequires: pkgconfig
38     BuildRequires: python-devel
39     %{!?_without_libtoolltdl:BuildRequires: libtool-ltdl-devel}
40     Requires: /sbin/install-info
41    
42     %description
43     libextractor is a simple library for meta-data extraction.
44     libextractor uses a plugin-mechanism that makes it easy to add support
45     for more file formats, allowing anybody to add new extractors quickly.
46    
47     libextractor currently features meta-data extractors for HTML, PDF, PS,
48     MP3, OGG, JPEG, GIF, PNG, TIFF, RPM, ZIP, REAL, RIFF (AVI), MPEG, QT
49     and ASF. It also detects many more MIME-types in a fashion similar to
50     the well-known "file" tool. Furthermore, a generic extractor that
51     extracts dictionary words from binaries is included. Supported
52     dictionaries are currently da, en, de, it and no.
53    
54     %package devel
55     Summary: Header files, libraries and development documentation for %{name}.
56     Group: Development/Libraries
57     Requires: %{name} = %{version}-%{release}
58    
59     %description devel
60     This package contains the header files, static libraries and development
61     documentation for %{name}. If you like to develop programs using %{name},
62     you will need to install %{name}-devel.
63    
64     %package -n python-extractor
65     Summary: Python bindings to libextractor
66     Group: Development/Libraries
67     Requires: %{name} = %{version}-%{release}
68    
69     %description -n python-extractor
70     Python bindings to libextractor.
71    
72     %prep
73     %setup
74    
75     %build
76     %configure \
77     --disable-static \
78     --with-pic \
79     CFLAGS="-I/usr/include/exiv2"
80     %{__make} %{?_smp_mflags} datadir="%{_datadir}" pkgconfigdatadir="%{_libdir}/pkgconfig"
81    
82     %install
83     %{__rm} -rf %{buildroot}
84     %{__make} install DESTDIR="%{buildroot}" datadir="%{_datadir}" pkgconfigdatadir="%{_libdir}/pkgconfig"
85     %find_lang %{name}
86    
87     ### Clean up buildroot
88     %{__rm} -rf %{buildroot}%{_infodir}/dir
89    
90     %post
91     /sbin/ldconfig
92     /sbin/install-info %{_infodir}/extract.info %{_infodir}/dir || :
93    
94    
95     %preun
96     if [ $1 -eq 0 ]; then
97     /sbin/install-info --delete %{_infodir}/extract.info %{_infodir}/dir || :
98     fi
99    
100     %postun -p /sbin/ldconfig
101    
102     %clean
103     %{__rm} -rf %{buildroot}
104    
105     %files -f %{name}.lang
106     %defattr(-, root, root, 0755)
107     %doc %{_infodir}/extractor.info*
108     %doc %{_mandir}/man1/extract.1*
109     %{_bindir}/extract
110     %{_libdir}/libextractor.so.*
111     %{_libdir}/libextractor_common.so.*
112     %{_libdir}/libextractor/
113     #%exclude %{_libdir}/libextractor/libextractor_*.a
114     %exclude %{_libdir}/libextractor/libextractor_*.la
115    
116     %files devel
117     %defattr(-, root, root, 0755)
118     %doc %{_mandir}/man3/libextractor.3*
119     %{_includedir}/extractor.h
120     #%{_libdir}/libextractor.a
121     %{_libdir}/libextractor.so
122     %{_libdir}/libextractor_common.so
123     %{_libdir}/pkgconfig/libextractor.pc
124     %exclude %{_libdir}/libextractor.la
125     %exclude %{_libdir}/libextractor_common.la
126    
127     #%files -n python-extractor
128     #%defattr(-, root, root, 0755)
129     #%{python_sitearch}/extractor.so
130    
131     %changelog
132     * Mon Jun 14 2010 Dag Wieers <dag@wieers.com> - 0.6.2-1 - 8921+/dag
133     - Updated to release 0.6.2.
134    
135     * Thu Jun 03 2010 Dag Wieers <dag@wieers.com> - 0.6.0-2
136     - Rebuild against exiv2-0.20.
137    
138     * Wed Jan 20 2010 Dag Wieers <dag@wieers.com> - 0.6.0-1
139     - Updated to release 0.6.0.
140    
141     * Sun Feb 22 2009 Dag Wieers <dag@wieers.com> - 0.5.22-1
142     - Updated to release 0.5.22.
143    
144     * Mon Nov 03 2008 Dag Wieers <dag@wieers.com> - 0.5.21-1
145     - Updated to release 0.5.21.
146    
147     * Mon Jul 14 2008 Dag Wieers <dag@wieers.com> - 0.5.20c-1
148     - Updated to release 0.5.20c.
149    
150     * Sun Apr 27 2008 Dag Wieers <dag@wieers.com> - 0.5.20b-1
151     - Updated to release 0.5.20b.
152    
153     * Sun Jan 13 2008 Dag Wieers <dag@wieers.com> - 0.5.19a-1
154     - Updated to release 0.5.19a.
155    
156     * Mon Jan 07 2008 Dag Wieers <dag@wieers.com> - 0.5.19-1
157     - Updated to release 0.5.19.
158    
159     * Thu Dec 06 2007 Dag Wieers <dag@wieers.com> - 0.5.18a-1
160     - Updated to release 0.5.18a.
161    
162     * Sun Mar 18 2007 Dag Wieers <dag@wieers.com> - 0.5.18-1
163     - Updated to release 0.5.18.
164    
165     * Wed Jan 10 2007 Dag Wieers <dag@wieers.com> - 0.5.17a-1
166     - Updated to release 0.5.17a.
167    
168     * Mon Jan 08 2007 Dries Verachtert <dries@ulyssis.org> - 0.5.17-1
169     - Updated to release 0.5.17.
170    
171     * Sun Nov 12 2006 Dag Wieers <dag@wieers.com> - 0.5.16-1
172     - Updated to release 0.5.16.
173    
174     * Tue Sep 12 2006 Dag Wieers <dag@wieers.com> - 0.5.15-1
175     - Updated to release 0.5.15.
176    
177     * Fri May 19 2006 Dries Verachtert <dries@ulyssis.org> - 0.5.14-1
178     - Updated to release 0.5.14.
179    
180     * Sun Apr 30 2006 Dag Wieers <dag@wieers.com> - 0.5.13-1
181     - Updated to release 0.5.13.
182    
183     * Sat Apr 22 2006 Dries Verachtert <dries@ulyssis.org> - 0.5.12-1
184     - Updated to release 0.5.12.
185    
186     * Sun Mar 12 2006 Dag Wieers <dag@wieers.com> - 0.5.11-1
187     - Updated to release 0.5.11.
188    
189     * Sun Dec 25 2005 Dries Verachtert <dries@ulyssis.org> - 0.5.9-1
190     - Updated to release 0.5.9.
191    
192     * Thu Dec 08 2005 Dries Verachtert <dries@ulyssis.org> - 0.5.8-1
193     - Updated to release 0.5.8.
194    
195     * Thu Sep 08 2005 Dries Verachtert <dries@ulyssis.org> - 0.5.5-1
196     - Updated to release 0.5.5.
197    
198     * Mon Aug 15 2005 Dries Verachtert <dries@ulyssis.org> - 0.5.3-1
199     - Updated to release 0.5.3.
200    
201     * Thu Jul 21 2005 Dries Verachtert <dries@ulyssis.org> - 0.5.2-1
202     - Updated to release 0.5.2.
203    
204     * Wed Jul 06 2005 Dries Verachtert <dries@ulyssis.org> - 0.5.1-1
205     - Updated to release 0.5.1.
206    
207     * Sun May 22 2005 Dag Wieers <dag@wieers.com> - 0.5.0-1
208     - Updated to release 0.5.0.
209    
210     * Fri Feb 25 2005 Dag Wieers <dag@wieers.com> - 0.4.2-1
211     - Updated to release 0.4.2.
212    
213     * Fri Jan 28 2005 Dag Wieers <dag@wieers.com> - 0.4.1-1
214     - Updated to release 0.4.1.
215    
216     * Tue Jan 04 2005 Dag Wieers <dag@wieers.com> - 0.4-1
217     - Updated to release 0.4.
218    
219     * Sun Nov 14 2004 Dag Wieers <dag@wieers.com> - 0.3.11-1
220     - Updated to release 0.3.11.
221    
222     * Sun Oct 03 2004 Dag Wieers <dag@wieers.com> - 0.3.8-1
223     - Updated to release 0.3.8.
224    
225     * Fri Sep 24 2004 Dag Wieers <dag@wieers.com> - 0.3.7-1
226     - Updated to release 0.3.7.
227    
228     * Wed Sep 22 2004 Dag Wieers <dag@wieers.com> - 0.3.6-1
229     - Updated to release 0.3.6.
230    
231     * Sat Jul 24 2004 Dag Wieers <dag@wieers.com> - 0.3.3-1
232     - Initial package. (using DAR)

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed