1 |
unnilennium |
1.1 |
# $Id: libextractor.spec 8921 2010-06-24 12:39:00Z dag $ |
2 |
|
|
# Authority: dag |
3 |
|
|
# Upstream: Christian Grothoff <libextractor$cs,purdue,edu> |
4 |
|
|
|
5 |
|
|
%{?el4:%define _without_libtoolltdl 1} |
6 |
|
|
%{?el3:%define _without_libtoolltdl 1} |
7 |
|
|
|
8 |
|
|
%define python_sitearch %(%{__python} -c 'from distutils import sysconfig; print sysconfig.get_python_lib(1)') |
9 |
|
|
|
10 |
|
|
Summary: Meta-data extraction library |
11 |
|
|
Name: libextractor |
12 |
|
|
Version: 0.6.2 |
13 |
unnilennium |
1.2 |
Release: 2%{?dist} |
14 |
unnilennium |
1.1 |
License: GPL |
15 |
|
|
Group: System Environment/Libraries |
16 |
|
|
URL: http://www.gnu.org/software/libextractor/ |
17 |
|
|
|
18 |
|
|
Packager: Dag Wieers <dag@wieers.com> |
19 |
|
|
Vendor: Dag Apt Repository, http://dag.wieers.com/apt/ |
20 |
|
|
|
21 |
|
|
Source: http://ftpmirror.gnu.org/libextractor/libextractor-%{version}.tar.gz |
22 |
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root |
23 |
|
|
|
24 |
|
|
BuildRequires: bzip2-devel |
25 |
|
|
BuildRequires: exiv2-devel |
26 |
|
|
BuildRequires: gcc-c++ |
27 |
|
|
BuildRequires: gettext |
28 |
|
|
BuildRequires: glib2-devel |
29 |
|
|
BuildRequires: gtk2-devel |
30 |
|
|
BuildRequires: ImageMagick |
31 |
|
|
BuildRequires: ImageMagick-c++-devel |
32 |
|
|
BuildRequires: ImageMagick-devel |
33 |
|
|
BuildRequires: intltool |
34 |
|
|
BuildRequires: libogg-devel |
35 |
|
|
BuildRequires: libvorbis-devel |
36 |
jpp |
1.3 |
BuildRequires: libtool |
37 |
|
|
#BuildRequires: mpeg2dec-devel |
38 |
|
|
BuildRequires: libmpeg2-devel |
39 |
|
|
BuildRequires: mpeg2dec |
40 |
unnilennium |
1.1 |
BuildRequires: pkgconfig |
41 |
|
|
BuildRequires: python-devel |
42 |
|
|
%{!?_without_libtoolltdl:BuildRequires: libtool-ltdl-devel} |
43 |
|
|
Requires: /sbin/install-info |
44 |
|
|
|
45 |
|
|
%description |
46 |
|
|
libextractor is a simple library for meta-data extraction. |
47 |
|
|
libextractor uses a plugin-mechanism that makes it easy to add support |
48 |
|
|
for more file formats, allowing anybody to add new extractors quickly. |
49 |
|
|
|
50 |
|
|
libextractor currently features meta-data extractors for HTML, PDF, PS, |
51 |
|
|
MP3, OGG, JPEG, GIF, PNG, TIFF, RPM, ZIP, REAL, RIFF (AVI), MPEG, QT |
52 |
|
|
and ASF. It also detects many more MIME-types in a fashion similar to |
53 |
|
|
the well-known "file" tool. Furthermore, a generic extractor that |
54 |
|
|
extracts dictionary words from binaries is included. Supported |
55 |
|
|
dictionaries are currently da, en, de, it and no. |
56 |
|
|
|
57 |
|
|
%package devel |
58 |
|
|
Summary: Header files, libraries and development documentation for %{name}. |
59 |
|
|
Group: Development/Libraries |
60 |
|
|
Requires: %{name} = %{version}-%{release} |
61 |
|
|
|
62 |
|
|
%description devel |
63 |
|
|
This package contains the header files, static libraries and development |
64 |
|
|
documentation for %{name}. If you like to develop programs using %{name}, |
65 |
|
|
you will need to install %{name}-devel. |
66 |
|
|
|
67 |
|
|
%package -n python-extractor |
68 |
|
|
Summary: Python bindings to libextractor |
69 |
|
|
Group: Development/Libraries |
70 |
|
|
Requires: %{name} = %{version}-%{release} |
71 |
|
|
|
72 |
|
|
%description -n python-extractor |
73 |
|
|
Python bindings to libextractor. |
74 |
|
|
|
75 |
|
|
%prep |
76 |
|
|
%setup |
77 |
|
|
|
78 |
|
|
%build |
79 |
|
|
%configure \ |
80 |
|
|
--disable-static \ |
81 |
|
|
--with-pic \ |
82 |
|
|
CFLAGS="-I/usr/include/exiv2" |
83 |
|
|
%{__make} %{?_smp_mflags} datadir="%{_datadir}" pkgconfigdatadir="%{_libdir}/pkgconfig" |
84 |
|
|
|
85 |
|
|
%install |
86 |
|
|
%{__rm} -rf %{buildroot} |
87 |
|
|
%{__make} install DESTDIR="%{buildroot}" datadir="%{_datadir}" pkgconfigdatadir="%{_libdir}/pkgconfig" |
88 |
|
|
%find_lang %{name} |
89 |
|
|
|
90 |
|
|
### Clean up buildroot |
91 |
|
|
%{__rm} -rf %{buildroot}%{_infodir}/dir |
92 |
|
|
|
93 |
|
|
%post |
94 |
|
|
/sbin/ldconfig |
95 |
|
|
/sbin/install-info %{_infodir}/extract.info %{_infodir}/dir || : |
96 |
|
|
|
97 |
|
|
|
98 |
|
|
%preun |
99 |
|
|
if [ $1 -eq 0 ]; then |
100 |
|
|
/sbin/install-info --delete %{_infodir}/extract.info %{_infodir}/dir || : |
101 |
|
|
fi |
102 |
|
|
|
103 |
|
|
%postun -p /sbin/ldconfig |
104 |
|
|
|
105 |
|
|
%clean |
106 |
|
|
%{__rm} -rf %{buildroot} |
107 |
|
|
|
108 |
|
|
%files -f %{name}.lang |
109 |
|
|
%defattr(-, root, root, 0755) |
110 |
|
|
%doc %{_infodir}/extractor.info* |
111 |
|
|
%doc %{_mandir}/man1/extract.1* |
112 |
|
|
%{_bindir}/extract |
113 |
|
|
%{_libdir}/libextractor.so.* |
114 |
|
|
%{_libdir}/libextractor_common.so.* |
115 |
|
|
%{_libdir}/libextractor/ |
116 |
|
|
#%exclude %{_libdir}/libextractor/libextractor_*.a |
117 |
|
|
%exclude %{_libdir}/libextractor/libextractor_*.la |
118 |
|
|
|
119 |
|
|
%files devel |
120 |
|
|
%defattr(-, root, root, 0755) |
121 |
|
|
%doc %{_mandir}/man3/libextractor.3* |
122 |
|
|
%{_includedir}/extractor.h |
123 |
|
|
#%{_libdir}/libextractor.a |
124 |
|
|
%{_libdir}/libextractor.so |
125 |
|
|
%{_libdir}/libextractor_common.so |
126 |
|
|
%{_libdir}/pkgconfig/libextractor.pc |
127 |
|
|
%exclude %{_libdir}/libextractor.la |
128 |
|
|
%exclude %{_libdir}/libextractor_common.la |
129 |
|
|
|
130 |
|
|
#%files -n python-extractor |
131 |
|
|
#%defattr(-, root, root, 0755) |
132 |
|
|
#%{python_sitearch}/extractor.so |
133 |
|
|
|
134 |
|
|
%changelog |
135 |
unnilennium |
1.2 |
* Sun Apr 30 2017 Jean-Philipe Pialasse <tests@pialasse.com> 0.6.2-2.sme |
136 |
|
|
- first import in SMe buildsys |
137 |
|
|
|
138 |
unnilennium |
1.1 |
* Mon Jun 14 2010 Dag Wieers <dag@wieers.com> - 0.6.2-1 - 8921+/dag |
139 |
|
|
- Updated to release 0.6.2. |
140 |
|
|
|
141 |
|
|
* Thu Jun 03 2010 Dag Wieers <dag@wieers.com> - 0.6.0-2 |
142 |
|
|
- Rebuild against exiv2-0.20. |
143 |
|
|
|
144 |
|
|
* Wed Jan 20 2010 Dag Wieers <dag@wieers.com> - 0.6.0-1 |
145 |
|
|
- Updated to release 0.6.0. |
146 |
|
|
|
147 |
|
|
* Sun Feb 22 2009 Dag Wieers <dag@wieers.com> - 0.5.22-1 |
148 |
|
|
- Updated to release 0.5.22. |
149 |
|
|
|
150 |
|
|
* Mon Nov 03 2008 Dag Wieers <dag@wieers.com> - 0.5.21-1 |
151 |
|
|
- Updated to release 0.5.21. |
152 |
|
|
|
153 |
|
|
* Mon Jul 14 2008 Dag Wieers <dag@wieers.com> - 0.5.20c-1 |
154 |
|
|
- Updated to release 0.5.20c. |
155 |
|
|
|
156 |
|
|
* Sun Apr 27 2008 Dag Wieers <dag@wieers.com> - 0.5.20b-1 |
157 |
|
|
- Updated to release 0.5.20b. |
158 |
|
|
|
159 |
|
|
* Sun Jan 13 2008 Dag Wieers <dag@wieers.com> - 0.5.19a-1 |
160 |
|
|
- Updated to release 0.5.19a. |
161 |
|
|
|
162 |
|
|
* Mon Jan 07 2008 Dag Wieers <dag@wieers.com> - 0.5.19-1 |
163 |
|
|
- Updated to release 0.5.19. |
164 |
|
|
|
165 |
|
|
* Thu Dec 06 2007 Dag Wieers <dag@wieers.com> - 0.5.18a-1 |
166 |
|
|
- Updated to release 0.5.18a. |
167 |
|
|
|
168 |
|
|
* Sun Mar 18 2007 Dag Wieers <dag@wieers.com> - 0.5.18-1 |
169 |
|
|
- Updated to release 0.5.18. |
170 |
|
|
|
171 |
|
|
* Wed Jan 10 2007 Dag Wieers <dag@wieers.com> - 0.5.17a-1 |
172 |
|
|
- Updated to release 0.5.17a. |
173 |
|
|
|
174 |
|
|
* Mon Jan 08 2007 Dries Verachtert <dries@ulyssis.org> - 0.5.17-1 |
175 |
|
|
- Updated to release 0.5.17. |
176 |
|
|
|
177 |
|
|
* Sun Nov 12 2006 Dag Wieers <dag@wieers.com> - 0.5.16-1 |
178 |
|
|
- Updated to release 0.5.16. |
179 |
|
|
|
180 |
|
|
* Tue Sep 12 2006 Dag Wieers <dag@wieers.com> - 0.5.15-1 |
181 |
|
|
- Updated to release 0.5.15. |
182 |
|
|
|
183 |
|
|
* Fri May 19 2006 Dries Verachtert <dries@ulyssis.org> - 0.5.14-1 |
184 |
|
|
- Updated to release 0.5.14. |
185 |
|
|
|
186 |
|
|
* Sun Apr 30 2006 Dag Wieers <dag@wieers.com> - 0.5.13-1 |
187 |
|
|
- Updated to release 0.5.13. |
188 |
|
|
|
189 |
|
|
* Sat Apr 22 2006 Dries Verachtert <dries@ulyssis.org> - 0.5.12-1 |
190 |
|
|
- Updated to release 0.5.12. |
191 |
|
|
|
192 |
|
|
* Sun Mar 12 2006 Dag Wieers <dag@wieers.com> - 0.5.11-1 |
193 |
|
|
- Updated to release 0.5.11. |
194 |
|
|
|
195 |
|
|
* Sun Dec 25 2005 Dries Verachtert <dries@ulyssis.org> - 0.5.9-1 |
196 |
|
|
- Updated to release 0.5.9. |
197 |
|
|
|
198 |
|
|
* Thu Dec 08 2005 Dries Verachtert <dries@ulyssis.org> - 0.5.8-1 |
199 |
|
|
- Updated to release 0.5.8. |
200 |
|
|
|
201 |
|
|
* Thu Sep 08 2005 Dries Verachtert <dries@ulyssis.org> - 0.5.5-1 |
202 |
|
|
- Updated to release 0.5.5. |
203 |
|
|
|
204 |
|
|
* Mon Aug 15 2005 Dries Verachtert <dries@ulyssis.org> - 0.5.3-1 |
205 |
|
|
- Updated to release 0.5.3. |
206 |
|
|
|
207 |
|
|
* Thu Jul 21 2005 Dries Verachtert <dries@ulyssis.org> - 0.5.2-1 |
208 |
|
|
- Updated to release 0.5.2. |
209 |
|
|
|
210 |
|
|
* Wed Jul 06 2005 Dries Verachtert <dries@ulyssis.org> - 0.5.1-1 |
211 |
|
|
- Updated to release 0.5.1. |
212 |
|
|
|
213 |
|
|
* Sun May 22 2005 Dag Wieers <dag@wieers.com> - 0.5.0-1 |
214 |
|
|
- Updated to release 0.5.0. |
215 |
|
|
|
216 |
|
|
* Fri Feb 25 2005 Dag Wieers <dag@wieers.com> - 0.4.2-1 |
217 |
|
|
- Updated to release 0.4.2. |
218 |
|
|
|
219 |
|
|
* Fri Jan 28 2005 Dag Wieers <dag@wieers.com> - 0.4.1-1 |
220 |
|
|
- Updated to release 0.4.1. |
221 |
|
|
|
222 |
|
|
* Tue Jan 04 2005 Dag Wieers <dag@wieers.com> - 0.4-1 |
223 |
|
|
- Updated to release 0.4. |
224 |
|
|
|
225 |
|
|
* Sun Nov 14 2004 Dag Wieers <dag@wieers.com> - 0.3.11-1 |
226 |
|
|
- Updated to release 0.3.11. |
227 |
|
|
|
228 |
|
|
* Sun Oct 03 2004 Dag Wieers <dag@wieers.com> - 0.3.8-1 |
229 |
|
|
- Updated to release 0.3.8. |
230 |
|
|
|
231 |
|
|
* Fri Sep 24 2004 Dag Wieers <dag@wieers.com> - 0.3.7-1 |
232 |
|
|
- Updated to release 0.3.7. |
233 |
|
|
|
234 |
|
|
* Wed Sep 22 2004 Dag Wieers <dag@wieers.com> - 0.3.6-1 |
235 |
|
|
- Updated to release 0.3.6. |
236 |
|
|
|
237 |
|
|
* Sat Jul 24 2004 Dag Wieers <dag@wieers.com> - 0.3.3-1 |
238 |
|
|
- Initial package. (using DAR) |