1 |
jpp |
1.1 |
%global _hardened_build 1 |
2 |
|
|
%define release 3 |
3 |
|
|
|
4 |
|
|
Name: libsearpc |
5 |
|
|
Version: 3.0.7 |
6 |
|
|
Release: %{release}%{?dist} |
7 |
|
|
Summary: A simple and easy-to-use C language RPC framework |
8 |
|
|
|
9 |
|
|
License: LGPLv3 |
10 |
|
|
URL: https://github.com/haiwen/%{name} |
11 |
|
|
Source0: https://github.com/haiwen/%{name}/archive/v%{version}.tar.gz |
12 |
|
|
|
13 |
|
|
BuildRequires: autoconf |
14 |
|
|
BuildRequires: automake |
15 |
|
|
BuildRequires: libtool |
16 |
|
|
BuildRequires: glib2-devel |
17 |
|
|
BuildRequires: jansson-devel |
18 |
|
|
BuildRequires: pygobject2 |
19 |
|
|
BuildRequires: python-simplejson |
20 |
|
|
|
21 |
|
|
|
22 |
|
|
%description |
23 |
|
|
Searpc is a simple C language RPC framework based on GObject system. Searpc |
24 |
|
|
handles the serialization/deserialization part of RPC, the transport part is |
25 |
|
|
left to users. |
26 |
|
|
|
27 |
|
|
|
28 |
|
|
%package devel |
29 |
|
|
Summary: Development files for %{name} |
30 |
|
|
Requires: %{name}%{?_isa} = %{version}-%{release} |
31 |
|
|
Requires: glib2-devel |
32 |
|
|
Requires: jansson-devel >= 2.2.1 |
33 |
|
|
|
34 |
|
|
|
35 |
|
|
%description devel |
36 |
|
|
The %{name}-devel package contains libraries and header files for developing |
37 |
|
|
applications that use %{name}. |
38 |
|
|
|
39 |
|
|
|
40 |
|
|
%prep |
41 |
|
|
%setup -qn %{name}-%{version} |
42 |
|
|
sed -i -e /\(DESTDIR\)/d %{name}.pc.in |
43 |
|
|
|
44 |
|
|
|
45 |
|
|
%build |
46 |
|
|
./autogen.sh |
47 |
|
|
%configure --disable-static --disable-compile-demo |
48 |
|
|
%{__make} %{?_smp_mflags} CFLAGS="%{optflags}" |
49 |
|
|
|
50 |
|
|
|
51 |
|
|
%install |
52 |
|
|
%{__make} install DESTDIR=%{buildroot} |
53 |
|
|
find %{buildroot} -name '*.la' -exec rm -f {} ';' |
54 |
|
|
|
55 |
|
|
|
56 |
|
|
%check |
57 |
|
|
%{__make} check |
58 |
|
|
|
59 |
|
|
|
60 |
|
|
%post -p /sbin/ldconfig |
61 |
|
|
|
62 |
|
|
%postun -p /sbin/ldconfig |
63 |
|
|
|
64 |
|
|
|
65 |
|
|
%files |
66 |
|
|
%doc AUTHORS README.markdown |
67 |
|
|
%doc COPYING |
68 |
|
|
%{_libdir}/%{name}.so.* |
69 |
|
|
%{_bindir}/searpc-codegen.py |
70 |
|
|
%{python_sitearch}/pysearpc/ |
71 |
|
|
|
72 |
|
|
%files devel |
73 |
|
|
%doc COPYING |
74 |
|
|
%{_includedir}/searpc* |
75 |
|
|
%{_libdir}/%{name}.so |
76 |
|
|
%{_libdir}/pkgconfig/%{name}.pc |
77 |
|
|
|
78 |
|
|
|
79 |
|
|
%changelog |
80 |
|
|
* Mon Feb 19 2018 Jean-Philippe Pialasse <tests@pialasse.com> - 3.0.7-3 |
81 |
|
|
- first import for SME Server |
82 |
|
|
|
83 |
|
|
* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.7-2 |
84 |
|
|
- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages |
85 |
|
|
|
86 |
|
|
* Tue Feb 02 2016 Nikos Roussos <comzeradd@fedoraproject.org> - 3.0.7-1 |
87 |
|
|
- Update to 3.0.7 |
88 |
|
|
|
89 |
|
|
* Fri Dec 04 2015 Nikos Roussos <comzeradd@fedoraproject.org> - 3.0-6 |
90 |
|
|
- Add optflags |
91 |
|
|
|
92 |
|
|
* Fri Sep 11 2015 Nikos Roussos <comzeradd@fedoraproject.org> - 3.0-5 |
93 |
|
|
- Fix license |
94 |
|
|
|
95 |
|
|
* Fri Sep 11 2015 Nikos Roussos <comzeradd@fedoraproject.org> - 3.0-4 |
96 |
|
|
- Fix license |
97 |
|
|
- Fix build requiremets |
98 |
|
|
- Add check |
99 |
|
|
|
100 |
|
|
* Sat Apr 11 2015 Nikos Roussos <comzeradd@fedoraproject.org> - 3.0-3 |
101 |
|
|
- Use release tag instead of commit |
102 |
|
|
|
103 |
|
|
* Wed Nov 05 2014 Nikos Roussos <comzeradd@fedoraproject.org> - 3.0-2 |
104 |
|
|
- Update to latest tag |
105 |
|
|
- Remove merged patch |
106 |
|
|
|
107 |
|
|
* Tue Aug 12 2014 Nikos Roussos <comzeradd@fedoraproject.org> - 3.0-1 |
108 |
|
|
- Initial version of the package |