1 |
jpp |
1.2 |
# define name of the scl |
2 |
|
|
%global scl python27 |
3 |
|
|
%scl_package %scl |
4 |
|
|
|
5 |
|
|
# Defaults for the values for the python27/rh-python35 Software Collection. These |
6 |
|
|
# will be used when python27-scldevel (or rh-python35-scldevel) is not in the |
7 |
|
|
# build root |
8 |
|
|
%{!?scl_python:%global scl_python python27} |
9 |
|
|
%{!?scl_no_vendor:%global scl_no_vendor python27} |
10 |
|
|
%{!?scl_prefix_python:%global scl_prefix_python %{scl_python}-} |
11 |
|
|
|
12 |
|
|
# Only for this build, you need to override default __os_install_post, |
13 |
|
|
# because the default one would find /opt/.../lib/python2.7/ and try |
14 |
|
|
# to bytecompile with the system /usr/bin/python2.7 |
15 |
|
|
%global __os_install_post %{%{scl_no_vendor}_os_install_post} |
16 |
|
|
# Similarly, override __python_requires for automatic dependency generator |
17 |
|
|
%global __python_requires %{%{scl_no_vendor}_python_requires} |
18 |
|
|
|
19 |
|
|
# The directory for site packages for this Software Collection |
20 |
|
|
%global seafile_sitelib %(echo %{python27python_sitelib} | sed 's|%{scl_python}|%{scl}|') |
21 |
|
|
|
22 |
|
|
|
23 |
|
|
|
24 |
jpp |
1.1 |
%global _hardened_build 1 |
25 |
jpp |
1.2 |
%define release 4 |
26 |
jpp |
1.1 |
|
27 |
|
|
Name: libsearpc |
28 |
|
|
Version: 3.0.7 |
29 |
jpp |
1.2 |
Release: %{release}%{?dist} |
30 |
jpp |
1.1 |
Summary: A simple and easy-to-use C language RPC framework |
31 |
|
|
|
32 |
|
|
License: LGPLv3 |
33 |
|
|
URL: https://github.com/haiwen/%{name} |
34 |
|
|
Source0: https://github.com/haiwen/%{name}/archive/v%{version}.tar.gz |
35 |
|
|
|
36 |
|
|
BuildRequires: autoconf |
37 |
|
|
BuildRequires: automake |
38 |
|
|
BuildRequires: libtool |
39 |
|
|
BuildRequires: glib2-devel |
40 |
|
|
BuildRequires: jansson-devel |
41 |
|
|
BuildRequires: pygobject2 |
42 |
jpp |
1.2 |
#might need pygobject227 instead |
43 |
|
|
BuildRequires: %{scl_prefix_python}python-simplejson |
44 |
|
|
#SCL |
45 |
|
|
BuildRequires: scl-utils-build |
46 |
|
|
# Always make sure that there is the python27-sclbuild (or rh-python35-sclbuild) |
47 |
|
|
# package in the build root |
48 |
|
|
BuildRequires: %{scl_prefix_python}scldevel |
49 |
|
|
# Require python27-python-devel, you will need macros from that package |
50 |
|
|
BuildRequires: %{scl_prefix_python}python-devel |
51 |
|
|
BuildRequires: %{scl_prefix_python}build |
52 |
|
|
Requires: %{scl_prefix}python-versiontools |
53 |
jpp |
1.3 |
BuildArch: x86_64 |
54 |
jpp |
1.1 |
|
55 |
|
|
|
56 |
|
|
%description |
57 |
|
|
Searpc is a simple C language RPC framework based on GObject system. Searpc |
58 |
|
|
handles the serialization/deserialization part of RPC, the transport part is |
59 |
|
|
left to users. |
60 |
|
|
|
61 |
|
|
|
62 |
jpp |
1.2 |
%package -n %{scl_python}-%{name}-devel |
63 |
jpp |
1.1 |
Summary: Development files for %{name} |
64 |
|
|
Requires: %{name}%{?_isa} = %{version}-%{release} |
65 |
|
|
Requires: glib2-devel |
66 |
|
|
Requires: jansson-devel >= 2.2.1 |
67 |
|
|
|
68 |
|
|
|
69 |
jpp |
1.2 |
%description -n %{scl_python}-%{name}-devel |
70 |
jpp |
1.1 |
The %{name}-devel package contains libraries and header files for developing |
71 |
|
|
applications that use %{name}. |
72 |
|
|
|
73 |
|
|
|
74 |
jpp |
1.2 |
#---------------------------------------------------- |
75 |
|
|
%package -n %{scl_python}-%{name} |
76 |
|
|
Summary: A simple and easy-to-use C language RPC framework |
77 |
|
|
Requires: %{scl_prefix}python-versiontools |
78 |
|
|
|
79 |
|
|
%description -n %{scl_python}-%{name} |
80 |
|
|
Searpc is a simple C language RPC framework based on GObject system. Searpc |
81 |
|
|
handles the serialization/deserialization part of RPC, the transport part is |
82 |
|
|
left to users. |
83 |
|
|
|
84 |
|
|
#---------------------------------------------------- |
85 |
|
|
%package -n %{scl_python}-%{name}-debug |
86 |
|
|
Summary: debug package for %{scl_python}-%{name} |
87 |
|
|
|
88 |
|
|
%description -n %{scl_python}-%{name}-debug |
89 |
|
|
Searpc is a simple C language RPC framework based on GObject system. Searpc |
90 |
|
|
handles the serialization/deserialization part of RPC, the transport part is |
91 |
|
|
left to users. |
92 |
|
|
|
93 |
|
|
|
94 |
jpp |
1.1 |
%prep |
95 |
|
|
%setup -qn %{name}-%{version} |
96 |
|
|
sed -i -e /\(DESTDIR\)/d %{name}.pc.in |
97 |
|
|
|
98 |
|
|
|
99 |
|
|
%build |
100 |
jpp |
1.2 |
%{?scl:scl enable %{scl_python} - << \EOF} |
101 |
|
|
export PYTHON='/opt/rh/python27/root/usr/bin/python' |
102 |
|
|
|
103 |
jpp |
1.1 |
./autogen.sh |
104 |
|
|
%configure --disable-static --disable-compile-demo |
105 |
|
|
%{__make} %{?_smp_mflags} CFLAGS="%{optflags}" |
106 |
jpp |
1.2 |
%{?scl:EOF} |
107 |
jpp |
1.1 |
|
108 |
|
|
%install |
109 |
jpp |
1.2 |
%scl_install |
110 |
|
|
%{?scl:scl enable %{scl_python} - << \EOF} |
111 |
|
|
export PYTHON='/opt/rh/python27/root/usr/bin/python' |
112 |
jpp |
1.1 |
%{__make} install DESTDIR=%{buildroot} |
113 |
jpp |
1.2 |
%{?scl:EOF} |
114 |
|
|
|
115 |
|
|
|
116 |
jpp |
1.1 |
find %{buildroot} -name '*.la' -exec rm -f {} ';' |
117 |
jpp |
1.2 |
rm -rf %{buildroot}/etc/rpm/macros.python27-config |
118 |
|
|
rm -rf %{buildroot}/etc/scl/prefixes/python27 |
119 |
|
|
rm -rf %{buildroot}/opt/rh/python27/root/usr/tmp |
120 |
|
|
rm -rf %{buildroot}/opt/rh/python27/root/var/mail |
121 |
jpp |
1.1 |
|
122 |
|
|
|
123 |
|
|
%check |
124 |
jpp |
1.2 |
%{?scl:scl enable %{scl_python} - << \EOF} |
125 |
|
|
export PYTHON='/opt/rh/python27/root/usr/bin/python' |
126 |
jpp |
1.1 |
%{__make} check |
127 |
jpp |
1.2 |
%{?scl:EOF} |
128 |
jpp |
1.1 |
|
129 |
|
|
|
130 |
|
|
%post -p /sbin/ldconfig |
131 |
|
|
|
132 |
|
|
%postun -p /sbin/ldconfig |
133 |
|
|
|
134 |
|
|
|
135 |
jpp |
1.2 |
%files -n %{scl_python}-%{name} |
136 |
jpp |
1.1 |
%doc AUTHORS README.markdown |
137 |
|
|
%doc COPYING |
138 |
|
|
%{_libdir}/%{name}.so.* |
139 |
|
|
%{_bindir}/searpc-codegen.py |
140 |
|
|
%{python_sitearch}/pysearpc/ |
141 |
|
|
|
142 |
jpp |
1.2 |
%files -n %{scl_python}-%{name}-devel |
143 |
jpp |
1.1 |
%doc COPYING |
144 |
|
|
%{_includedir}/searpc* |
145 |
|
|
%{_libdir}/%{name}.so |
146 |
|
|
%{_libdir}/pkgconfig/%{name}.pc |
147 |
|
|
|
148 |
jpp |
1.2 |
%files -n %{scl_python}-%{name}-debug |
149 |
|
|
/usr/src/debug/* |
150 |
|
|
/usr/lib/debug/.build-id/* |
151 |
|
|
/usr/lib/debug/opt/rh/python27/root/usr/lib64/* |
152 |
|
|
|
153 |
jpp |
1.1 |
|
154 |
|
|
%changelog |
155 |
jpp |
1.2 |
* Wed Mar 07 2018 Jean-Philipe Pialasse <tests@pialasse.com> - 3.0.7-4.sme |
156 |
jpp |
1.3 |
- ibuild against python27 scl and x86_64 only |
157 |
jpp |
1.2 |
|
158 |
jpp |
1.1 |
* Mon Feb 19 2018 Jean-Philippe Pialasse <tests@pialasse.com> - 3.0.7-3 |
159 |
|
|
- first import for SME Server |
160 |
|
|
|
161 |
|
|
* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.7-2 |
162 |
|
|
- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages |
163 |
|
|
|
164 |
|
|
* Tue Feb 02 2016 Nikos Roussos <comzeradd@fedoraproject.org> - 3.0.7-1 |
165 |
|
|
- Update to 3.0.7 |
166 |
|
|
|
167 |
|
|
* Fri Dec 04 2015 Nikos Roussos <comzeradd@fedoraproject.org> - 3.0-6 |
168 |
|
|
- Add optflags |
169 |
|
|
|
170 |
|
|
* Fri Sep 11 2015 Nikos Roussos <comzeradd@fedoraproject.org> - 3.0-5 |
171 |
|
|
- Fix license |
172 |
|
|
|
173 |
|
|
* Fri Sep 11 2015 Nikos Roussos <comzeradd@fedoraproject.org> - 3.0-4 |
174 |
|
|
- Fix license |
175 |
|
|
- Fix build requiremets |
176 |
|
|
- Add check |
177 |
|
|
|
178 |
|
|
* Sat Apr 11 2015 Nikos Roussos <comzeradd@fedoraproject.org> - 3.0-3 |
179 |
|
|
- Use release tag instead of commit |
180 |
|
|
|
181 |
|
|
* Wed Nov 05 2014 Nikos Roussos <comzeradd@fedoraproject.org> - 3.0-2 |
182 |
|
|
- Update to latest tag |
183 |
|
|
- Remove merged patch |
184 |
|
|
|
185 |
|
|
* Tue Aug 12 2014 Nikos Roussos <comzeradd@fedoraproject.org> - 3.0-1 |
186 |
|
|
- Initial version of the package |