/[smecontribs]/rpms/libzdb/contribs9/libzdb.spec
ViewVC logotype

Annotation of /rpms/libzdb/contribs9/libzdb.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.5 - (hide annotations) (download)
Thu Mar 22 22:11:35 2018 UTC (6 years, 2 months ago) by jpp
Branch: MAIN
CVS Tags: libzdb-3_1-5_el6_sme
Changes since 1.4: +52 -2 lines
* Thu Mar 22 2018 Jean-Philipe Pialasse <tests@pialasse.com> 3.1-5.sme
- build with python27 scl

1 jpp 1.5 # define name of the scl
2     %global scl python27
3     %scl_package %scl
4    
5     # Defaults for the values for the python27/rh-python35 Software Collection. These
6     # will be used when python27-scldevel (or rh-python35-scldevel) is not in the
7     # build root
8     %{!?scl_python:%global scl_python python27}
9     %{!?scl_no_vendor:%global scl_no_vendor python27}
10     %{!?scl_prefix_python:%global scl_prefix_python %{scl_python}-}
11    
12     # Only for this build, you need to override default __os_install_post,
13     # because the default one would find /opt/.../lib/python2.7/ and try
14     # to bytecompile with the system /usr/bin/python2.7
15     %global __os_install_post %{%{scl_no_vendor}_os_install_post}
16     # Similarly, override __python_requires for automatic dependency generator
17     %global __python_requires %{%{scl_no_vendor}_python_requires}
18    
19     # The directory for site packages for this Software Collection
20     %global seafile_sitelib %(echo %{python27python_sitelib} | sed 's|%{scl_python}|%{scl}|')
21    
22     %define release 5
23 jpp 1.2 %define version 3.1
24 jpp 1.1 Name: libzdb
25 jpp 1.2 Version: %{version}
26     Release: %{release}%{?dist}
27 jpp 1.1 Summary: Small, easy to use Database Connection Pool Library
28     License: GPLv3+ and MIT
29     URL: http://www.tildeslash.com/libzdb/
30     Source0: http://www.tildeslash.com/%{name}/dist/%{name}-%{version}.tar.gz
31     BuildRequires: flex
32     BuildRequires: mysql-devel
33     BuildRequires: pkgconfig
34     BuildRequires: postgresql-devel >= 8
35 jpp 1.5 #BuildRequires: sqlite-devel >= 3.7.17
36     BuildRequires: scl-utils-build
37     # Always make sure that there is the python27-sclbuild (or rh-python35-sclbuild)
38     # package in the build root
39     BuildRequires: %{scl_prefix_python}scldevel
40     # Require python27-python-devel, you will need macros from that package
41     BuildRequires: %{scl_prefix_python}python-devel
42     BuildRequires: %{scl_prefix_python}build
43     Requires: %{scl_prefix}python-versiontools
44    
45 jpp 1.1
46     %description
47     The Zild C Database Library implements a small, fast, and easy to use database
48     API with thread-safe connection pooling. The library can connect transparently
49     to multiple database systems, has zero configuration and connections are
50     specified via a standard URL scheme.
51    
52     %package devel
53     Summary: Development files for %{name}
54     Requires: %{name}%{?_isa} = %{version}-%{release}
55    
56     %description devel
57     This package contains libraries and header files for
58     developing applications that use %{name}.
59    
60     %prep
61     %setup -q
62    
63     # Errant file
64     rm -f doc/api-docs/._*
65    
66     %build
67 jpp 1.5 scl enable %{scl_python} "bash"
68     %{?scl:scl enable %{scl_python} - << \EOF}
69     export PYTHON='/opt/rh/python27/root/usr/bin/python'
70    
71 jpp 1.3 %configure --disable-static --enable-protected --with-sqlite --enable-sqliteunlock
72 jpp 1.2
73 jpp 1.1 make %{?_smp_mflags}
74 jpp 1.5 %{?scl:EOF}
75 jpp 1.1
76     %install
77 jpp 1.5 %scl_install
78     %{?scl:scl enable %{scl_python} - << \EOF}
79     export PYTHON='/opt/rh/python27/root/usr/bin/python'
80    
81 jpp 1.1 make install DESTDIR=%{buildroot}
82 jpp 1.5 %{?scl:EOF}
83     rm -rf %{buildroot}/etc/rpm/macros.python27-config
84     rm -rf %{buildroot}/etc/scl/prefixes/python27
85     rm -rf %{buildroot}/opt/rh/python27/root/usr/tmp
86     rm -rf %{buildroot}/opt/rh/python27/root/var/mail
87 jpp 1.1
88     %post -p /sbin/ldconfig
89    
90     %postun -p /sbin/ldconfig
91    
92     %files
93     %doc AUTHORS CHANGES COPYING README
94     %{_libdir}/%{name}.so.*
95    
96     %files devel
97 jpp 1.5 /usr/src/debug/*
98     /usr/lib/debug/.build-id/*
99 jpp 1.1 %{_includedir}/zdb/
100     %{_libdir}/%{name}.so
101 jpp 1.5 /usr/lib/debug/%{_libdir}/%{name}.so*.debug
102 jpp 1.1 %{_libdir}/pkgconfig/zdb.pc
103     %exclude %{_libdir}/%{name}.la
104     %doc doc/api-docs
105    
106     %changelog
107 jpp 1.5 * Thu Mar 22 2018 Jean-Philipe Pialasse <tests@pialasse.com> 3.1-5.sme
108     - build with python27 scl
109    
110 jpp 1.3 * Tue Feb 27 2018 Jean-Philipe Pialasse <tests@pialasse.com> 3.1-4.sme
111     - enable sqliteunlock [SME: 10527]
112 jpp 1.4 - require sqlite >=3.7.17
113 jpp 1.3
114 jpp 1.2 * Mon Feb 26 2018 Jean-Philipe Pialasse <tests@pialasse.com> - 3.1-3.sme
115     - disable unlock notify for sqlite (--enable-sqliteunlock), this is not supported by upstream packaged sqlite,
116     would need the following option at build time : -DSQLITE_ENABLE_UNLOCK_NOTIFY=1
117    
118 jpp 1.1 * Mon Feb 19 2018 Jean-Philippe Pialasse <tests@pialasse.com> - 3.1-2
119     - first import for SME Server
120    
121     * Sun Oct 23 2016 Julien Enselme <jujens@jujens.eu> - 3.1-1
122     - Update to 3.1
123     - Unretire package
124    
125     * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 3.0-5
126     - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
127    
128     * Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0-4
129     - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
130    
131     * Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0-3
132     - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
133    
134     * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0-2
135     - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
136    
137     * Thu Mar 20 2014 Christopher Meng <rpm@cicku.me> - 3.0-2
138     - Enable SQLite unlock notification API support.
139    
140     * Thu Mar 13 2014 Bernard Johnson <bjohnson@symetrix.com> - 3.0-1
141     - v 3.0 (bz #1049219)
142    
143     * Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.8.1-5
144     - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
145    
146     * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.8.1-4
147     - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
148    
149     * Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.8.1-3
150     - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
151    
152     * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.8.1-2
153     - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
154    
155     * Tue Jul 05 2011 Bernard Johnson <bjohnson@symetrix.com> - 2.8.1-1
156     - bump to 2.8.1 which fixes a Oracle driver transaction memory leak
157    
158     * Wed Mar 23 2011 Dan HorĂ¡k <dan@danny.cz> - 2.8-2
159     - rebuilt for mysql 5.5.10 (soname bump in libmysqlclient)
160    
161     * Tue Feb 22 2011 Bernard Johnson <bjohnson@symetrix.com> - 2.8-1
162     - v 2.8
163    
164     * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.7-2
165     - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
166    
167     * Wed Dec 08 2010 Bernard Johnson <bjohnson@symetrix.com> - 2.7-1
168     - v 2.7
169     - change BR from flex to flex-static for F15 (bz #660879)
170    
171     * Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 2.6-3
172     - rebuilt with new openssl
173    
174     * Thu Jul 30 2009 Jesse Keating <jkeating@redhat.com> - 2.6-2
175     - Bump for F12 mass rebuild
176    
177     * Sun Jul 05 2009 Bernard Johnson <bjohnson@symetrix.com> - 2.6-1
178     - v 2.6
179    
180     * Thu Jun 04 2009 Bernard Johnson <bjohnson@symetrix.com> - 2.5-1
181     - remove EXCEPTIONS notice
182     - v 2.5
183    
184     * Sat Mar 07 2009 Bernard Johnson <bjohnson@symetrix.com> - 2.4-3
185     - fix typo in requires
186     - bz #474044
187    
188     * Wed Feb 25 2009 Bernard Johnson <bjohnson@symetrix.com> - 2.4-2
189     - add a notice to EXCEPTIONS that dual licensing is not available in Fedora
190    
191     * Mon Feb 16 2009 Bernard Johnson <bjohnson@symetrix.com> - 2.4-1
192     - v 2.4
193     - remove patches required for 2.3
194     - drop EXCEPTIONS as noted in review ticket
195    
196     * Thu Feb 05 2009 Bernard Johnson <bjohnson@symetrix.com> - 2.3-1
197     - v 2.3
198    
199     * Thu Dec 04 2008 Bernard Johnson <bjohnson@symetrix.com> - 2.2.3-2
200     - disable static build by default
201     - remove release version from soname
202     - move headers to %%{_includedir}/libzdb/
203    
204     * Thu Nov 13 2008 Bernard Johnson <bjohnson@symetrix.com> - 2.2.3-1
205     - initial build

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed