/[smecontribs]/rpms/madsonic/contribs10/madsonic.spec
ViewVC logotype

Annotation of /rpms/madsonic/contribs10/madsonic.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.5 - (hide annotations) (download)
Sat Jul 23 07:06:28 2022 UTC (22 months, 1 week ago) by jpp
Branch: MAIN
Changes since 1.4: +20 -6 lines
* Fri Jul 22 2022 Jean-Philippe Pialasse <tests@pialasse.com> 6.2.9092-1.sme
- update with log4j fixes and more
- systemd capable
- enable mediasonic.test by default

1 jpp 1.1 %define name madsonic
2 jpp 1.4 %define version 6.2.9092
3     %define release 1
4 jpp 1.1 %define __os_install_post \
5     /usr/lib/rpm/brp-compress \
6     /usr/lib/rpm/brp-strip \
7     /usr/lib/rpm/brp-strip-static-archive \
8     echo "not /usr/lib/rpm/brp-strip-comment-note" \
9     %{nil}
10     Name: %{name}
11     Version: %{version}
12     Release: %{release}%{?dist}
13     Summary: A web-based music streamer, jukebox and Podcast receiver
14     Source: %{name}-%{version}.tar.gz
15 jpp 1.5 Patch0: madsonic-6.2.9084-test.patch
16 jpp 1.1 BuildRoot: /var/tmp/%{name}-%{version}-buildroot
17     BuildArch: noarch
18     BuildRequires: e-smith-devtools
19     AutoReqProv: no
20     Group: Applications/Multimedia
21     License: GPLv3
22     URL: http://madsonic.org
23    
24     %changelog
25 jpp 1.4 * Fri Jul 22 2022 Jean-Philippe Pialasse <tests@pialasse.com> 6.2.9092-1.sme
26     - update with log4j fixes and more
27 jpp 1.5 - systemd capable
28     - enable mediasonic.test by default
29 jpp 1.4
30 jpp 1.3 * Fri Jun 04 2021 Jean-Philippe Pialasse <tests@pialasse.com> 6.2.9084-2.sme
31     - fix permissions [SME: 10699]
32     - fix noise on start with initial install [SME: 8016]
33    
34 jpp 1.2 * Thu Jun 03 2021 Jean-Philippe Pialasse <tests@pialasse.com> 6.2.9084-1.sme
35     - update to 6.2.9084
36     - first build for SME10
37    
38 jpp 1.1 * Sun Nov 17 2013 JP Pialasse <tests@pialasse.com> 5.0.3760-1.sme
39     - first build for sme
40     - adding noarch
41     - adding e-smith-devtools
42    
43     %description
44     Madsonic is a web-based music streamer, fork of Subsonic, jukebox and Podcast receiver,
45     providing access to your music collection wherever you are. Use it
46     to share your music with friends, or to listen to your music while away
47     from home.
48    
49     Apps for Android, iPhone and Windows Phone are also available.
50    
51 jpp 1.5 Java 1.8 or higher is required to run Madsonic.>= 6.2
52 jpp 1.1
53     %prep
54     %setup
55 jpp 1.5 mkdir -p root/run/madsonic
56     mkdir -p root/usr/lib/tmpfiles.d/
57     echo "d /run/madsonic 0755 madsonic madsonic" > root/usr/lib/tmpfiles.d/madsonic.conf
58     rm root/etc/init.d/madsonic
59     ln -sf root/usr/share/madsonic/madsonic.sh root/usr/bin/madsonic
60     %patch0 -p1
61 jpp 1.1
62    
63     %install
64     rm -rf $RPM_BUILD_ROOT
65     (cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT)
66     rm -f %{name}-%{version}-filelist
67     /sbin/e-smith/genfilelist $RPM_BUILD_ROOT \
68 jpp 1.3 --dir /usr/share/madsonic 'attr(0750,madsonic,madsonic)' \
69     --dir /var/madsonic 'attr(0750,madsonic,madsonic)' \
70 jpp 1.5 --file /usr/lib/tmpfiles.d/madsonic.conf 'attr(0750,root,root)' \
71     --dir /run/madsonic 'attr(0755,madsonic,madsonic)' \
72     --ignoredir /run \
73     --ignoredir "/etc/sysconfig/madsonic" \
74     --ignoredir "/etc/init.d" \
75     --ignoredir "/etc/sysconfig"\
76 jpp 1.1 > %{name}-%{version}-filelist
77    
78     %clean
79     rm -rf $RPM_BUILD_ROOT
80    
81     %files -f %{name}-%{version}-filelist
82     %defattr(-,root,root)
83     %config(noreplace) /etc/sysconfig/madsonic
84    
85     %pre
86 jpp 1.3 grep '^madsonic:' /etc/passwd > /dev/null || \
87     /usr/sbin/useradd -c "madsonic" -M -d /usr/share/madsonic -s /bin/bash madsonic
88     /usr/sbin/usermod -aG audio madsonic
89    
90 jpp 1.1 # Stop Madsonic service.
91     if [ -e /etc/init.d/madsonic ]; then
92     service madsonic stop
93     fi
94 jpp 1.5 [ -e /usr/lib/systemd/system/madsonic.service ] && systemctl stop madsonic
95 jpp 1.1
96     # Backup database.
97     if [ -e /var/madsonic/db ]; then
98     rm -rf /var/madsonic/db.backup
99     cp -R /var/madsonic/db /var/madsonic/db.backup
100     fi
101    
102     exit 0
103    
104     %post
105 jpp 1.5 #ln -sf /usr/share/madsonic/madsonic.sh /usr/bin/madsonic
106     #chmod 750 /var/madsonic
107 jpp 1.1
108     # Clear jetty cache.
109     rm -rf /var/madsonic/jetty
110    
111     # For SELinux: Set security context
112     chcon -t java_exec_t /etc/init.d/madsonic 2>/dev/null
113    
114     # Configure and start Madsonic service.
115 jpp 1.3 #chkconfig --add madsonic
116     #service madsonic start
117 jpp 1.1
118     exit 0
119     %preun
120     # Only do it if uninstalling, not upgrading.
121     if [ $1 = 0 ] ; then
122    
123     # Stop the service.
124     [ -e /etc/init.d/madsonic ] && service madsonic stop
125 jpp 1.5 [ -e /usr/lib/systemd/system/madsonic.service ] && systemctl stop madsonic
126 jpp 1.1
127     # Remove symlink.
128     rm -f /usr/bin/madsonic
129    
130     # Remove startup scripts.
131     chkconfig --del madsonic
132    
133     fi
134    
135     exit 0
136    

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed