1 |
unnilennium |
1.1 |
# $Id$ |
2 |
|
|
# Authority: shuff |
3 |
|
|
# Upstream: Sergey Bostandzhyan <contact$mediatomb,cc> |
4 |
|
|
# ExcludeDist: el2 |
5 |
|
|
|
6 |
|
|
# el6 changed the package name to libcurl |
7 |
|
|
%{?el3:%define _without_libcurl 1} |
8 |
|
|
%{?el4:%define _without_libcurl 1} |
9 |
|
|
%{?el5:%define _without_libcurl 1} |
10 |
|
|
|
11 |
|
|
# el6 split out file and file-devel |
12 |
|
|
%{?el3:%define _without_file-devel 1} |
13 |
|
|
%{?el4:%define _without_file-devel 1} |
14 |
|
|
%{?el5:%define _without_file-devel 1} |
15 |
|
|
|
16 |
|
|
Summary: UPnP server with web interface |
17 |
|
|
Name: mediatomb |
18 |
|
|
Version: 0.12.1 |
19 |
jpp |
1.3 |
Release: 2%{?dist} |
20 |
unnilennium |
1.1 |
License: GPL |
21 |
|
|
Group: Applications/Multimedia |
22 |
|
|
URL: http://mediatomb.cc/ |
23 |
|
|
|
24 |
|
|
Packager: Steve Huff <shuff@vecna.org> |
25 |
|
|
Vendor: Dag Apt Repository, http://dag.wieers.com/apt/ |
26 |
|
|
|
27 |
|
|
Source: http://downloads.sourceforge.net/project/mediatomb/MediaTomb/%{version}/mediatomb-%{version}.tar.gz |
28 |
jpp |
1.3 |
Patch0: libav_0.7_support.patch |
29 |
unnilennium |
1.1 |
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root |
30 |
|
|
|
31 |
|
|
#Buildarch: noarch |
32 |
|
|
BuildRequires: binutils |
33 |
|
|
BuildRequires: expat-devel |
34 |
|
|
BuildRequires: file%{?_without_file-devel:-devel} |
35 |
|
|
BuildRequires: ffmpeg-devel |
36 |
jpp |
1.3 |
##jpp add |
37 |
|
|
BuildRequires: ffmpeg-compat-devel |
38 |
|
|
BuildRequires: file-libs |
39 |
|
|
BuildRequires: libmp4v2 libmp4v2-devel |
40 |
|
|
##jpp add end |
41 |
unnilennium |
1.1 |
BuildRequires: gcc-c++ |
42 |
|
|
BuildRequires: js-devel |
43 |
|
|
BuildRequires: %{!?_without_libcurl:lib}curl-devel >= 4 |
44 |
|
|
BuildRequires: libexif-devel |
45 |
|
|
# BuildRequires: libffmpegthumbnailer-devel |
46 |
|
|
BuildRequires: libssh2-devel |
47 |
|
|
BuildRequires: nspr-devel |
48 |
|
|
BuildRequires: make |
49 |
|
|
BuildRequires: mysql-devel >= 4 |
50 |
|
|
BuildRequires: sqlite-devel >= 3 |
51 |
|
|
BuildRequires: taglib-devel |
52 |
|
|
BuildRequires: zlib-devel |
53 |
|
|
|
54 |
|
|
%description |
55 |
|
|
MediaTomb is an open source (GPL) UPnP MediaServer with a nice web user |
56 |
|
|
interface, it allows you to stream your digital media through your home network |
57 |
|
|
and listen to/watch it on a variety of UPnP compatible devices. |
58 |
|
|
|
59 |
|
|
MediaTomb implements the UPnP MediaServer V 1.0 specification that can be found |
60 |
|
|
on http://www.upnp.org/. The current implementation focuses on parts that are |
61 |
|
|
required by the specification, however we look into extending the functionality |
62 |
|
|
to cover the optional parts of the spec as well. |
63 |
|
|
|
64 |
|
|
MediaTomb should work with any UPnP compliant MediaRenderer, please tell us if |
65 |
|
|
you experience difficulties with particular models, also take a look at the |
66 |
|
|
Supported Devices list for more information. |
67 |
|
|
|
68 |
|
|
|
69 |
|
|
%prep |
70 |
|
|
%setup |
71 |
jpp |
1.3 |
%patch0 -p1 |
72 |
unnilennium |
1.1 |
|
73 |
|
|
%build |
74 |
|
|
%configure \ |
75 |
|
|
--disable-dependency-tracking \ |
76 |
|
|
--enable-ffmpeg \ |
77 |
|
|
--with-search=%{_usr} |
78 |
|
|
%{__make} %{?_smp_mflags} |
79 |
|
|
|
80 |
|
|
# fix mediatomb init script |
81 |
|
|
%{__perl} -pi -e 's|/etc/mediatomb\.conf|/etc/sysconfig/mediatomb|;' scripts/mediatomb-service-fedora |
82 |
|
|
|
83 |
|
|
%install |
84 |
|
|
%{__rm} -rf %{buildroot} |
85 |
|
|
%{__make} install DESTDIR="%{buildroot}" |
86 |
|
|
|
87 |
|
|
# init script |
88 |
|
|
%{__install} -d -m755 %{buildroot}%{_initrddir} |
89 |
|
|
%{__install} -m755 scripts/mediatomb-service-fedora %{buildroot}%{_initrddir}/mediatomb |
90 |
|
|
|
91 |
|
|
# config file |
92 |
|
|
%{__install} -d -m755 %{buildroot}%{_sysconfdir}/sysconfig |
93 |
|
|
%{__install} -m755 config/mediatomb-conf-fedora %{buildroot}%{_sysconfdir}/sysconfig/mediatomb |
94 |
|
|
|
95 |
|
|
# fix for stupid strip issue |
96 |
|
|
#%{__chmod} -R u+w %{buildroot}/* |
97 |
|
|
|
98 |
|
|
%post |
99 |
|
|
if [ $1 -eq 1 ]; then |
100 |
|
|
/usr/sbin/groupadd -f -r mediatomb |
101 |
|
|
/usr/sbin/useradd -d %{_datadir}/mediatomb -g mediatomb -r -s /bin/false mediatomb |
102 |
|
|
/sbin/chkconfig --add mediatomb |
103 |
|
|
exit 0 |
104 |
|
|
fi |
105 |
|
|
|
106 |
|
|
%preun |
107 |
|
|
if [ $1 -eq 0 ]; then |
108 |
|
|
/sbin/chkconfig --del mediatomb |
109 |
|
|
/usr/sbin/userdel mediatomb |
110 |
|
|
/usr/sbin/groupdel mediatomb |
111 |
|
|
exit 0 |
112 |
|
|
fi |
113 |
|
|
|
114 |
|
|
%clean |
115 |
|
|
%{__rm} -rf %{buildroot} |
116 |
|
|
|
117 |
|
|
%files |
118 |
|
|
%defattr(-, root, root, 0755) |
119 |
|
|
%doc AUTHORS ChangeLog COPYING INSTALL NEWS README* TODO doc/ scripts/ |
120 |
|
|
%doc %{_mandir}/man?/* |
121 |
|
|
%{_bindir}/* |
122 |
|
|
%{_datadir}/mediatomb/ |
123 |
|
|
%{_initrddir}/mediatomb |
124 |
|
|
%config %{_sysconfdir}/sysconfig/mediatomb |
125 |
|
|
|
126 |
|
|
%changelog |
127 |
jpp |
1.3 |
* Tue Feb 27 2018 Jean-Philipe Pialasse <tests@pialasse.com> 0.12.1-2.sme |
128 |
|
|
- initial package for SME Server |
129 |
|
|
- tidt spec file to allow to build |
130 |
|
|
- disable libffmpegthumbnailer as package not available |
131 |
|
|
- disable lastfmlib support 0.4 is needed , not liblastfm 1 |
132 |
|
|
- patch for libav |
133 |
|
|
|
134 |
unnilennium |
1.1 |
* Sat Jun 25 2011 Steve Huff <shuff@vecna.org> - 0.12.1-1 |
135 |
|
|
- Initial package. |