/[smecontribs]/rpms/mediatomb/contribs9/mediatomb.spec
ViewVC logotype

Annotation of /rpms/mediatomb/contribs9/mediatomb.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.4 - (hide annotations) (download)
Tue Feb 27 19:39:22 2018 UTC (6 years, 3 months ago) by jpp
Branch: MAIN
CVS Tags: HEAD
Changes since 1.3: +6 -1 lines
Prep for sqlite import

1 unnilennium 1.1 # $Id$
2     # Authority: shuff
3     # Upstream: Sergey Bostandzhyan <contact$mediatomb,cc>
4     # ExcludeDist: el2
5    
6     # el6 changed the package name to libcurl
7     %{?el3:%define _without_libcurl 1}
8     %{?el4:%define _without_libcurl 1}
9     %{?el5:%define _without_libcurl 1}
10    
11     # el6 split out file and file-devel
12     %{?el3:%define _without_file-devel 1}
13     %{?el4:%define _without_file-devel 1}
14     %{?el5:%define _without_file-devel 1}
15    
16     Summary: UPnP server with web interface
17     Name: mediatomb
18     Version: 0.12.1
19 jpp 1.4 Release: 3%{?dist}
20 unnilennium 1.1 License: GPL
21     Group: Applications/Multimedia
22     URL: http://mediatomb.cc/
23    
24     Packager: Steve Huff <shuff@vecna.org>
25     Vendor: Dag Apt Repository, http://dag.wieers.com/apt/
26    
27     Source: http://downloads.sourceforge.net/project/mediatomb/MediaTomb/%{version}/mediatomb-%{version}.tar.gz
28 jpp 1.3 Patch0: libav_0.7_support.patch
29 unnilennium 1.1 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
30    
31     #Buildarch: noarch
32     BuildRequires: binutils
33     BuildRequires: expat-devel
34     BuildRequires: file%{?_without_file-devel:-devel}
35     BuildRequires: ffmpeg-devel
36 jpp 1.3 ##jpp add
37     BuildRequires: ffmpeg-compat-devel
38     BuildRequires: file-libs
39     BuildRequires: libmp4v2 libmp4v2-devel
40 jpp 1.4 BuildRequires: libupnp-devel
41     BuildRequires: libexif-devel, id3lib-devel, js-devel, flac-devel
42 jpp 1.3 ##jpp add end
43 unnilennium 1.1 BuildRequires: gcc-c++
44     BuildRequires: js-devel
45     BuildRequires: %{!?_without_libcurl:lib}curl-devel >= 4
46     BuildRequires: libexif-devel
47     # BuildRequires: libffmpegthumbnailer-devel
48     BuildRequires: libssh2-devel
49     BuildRequires: nspr-devel
50     BuildRequires: make
51     BuildRequires: mysql-devel >= 4
52     BuildRequires: sqlite-devel >= 3
53     BuildRequires: taglib-devel
54     BuildRequires: zlib-devel
55    
56     %description
57     MediaTomb is an open source (GPL) UPnP MediaServer with a nice web user
58     interface, it allows you to stream your digital media through your home network
59     and listen to/watch it on a variety of UPnP compatible devices.
60    
61     MediaTomb implements the UPnP MediaServer V 1.0 specification that can be found
62     on http://www.upnp.org/. The current implementation focuses on parts that are
63     required by the specification, however we look into extending the functionality
64     to cover the optional parts of the spec as well.
65    
66     MediaTomb should work with any UPnP compliant MediaRenderer, please tell us if
67     you experience difficulties with particular models, also take a look at the
68     Supported Devices list for more information.
69    
70    
71     %prep
72     %setup
73 jpp 1.3 %patch0 -p1
74 unnilennium 1.1
75     %build
76     %configure \
77     --disable-dependency-tracking \
78     --enable-ffmpeg \
79     --with-search=%{_usr}
80     %{__make} %{?_smp_mflags}
81    
82     # fix mediatomb init script
83     %{__perl} -pi -e 's|/etc/mediatomb\.conf|/etc/sysconfig/mediatomb|;' scripts/mediatomb-service-fedora
84    
85     %install
86     %{__rm} -rf %{buildroot}
87     %{__make} install DESTDIR="%{buildroot}"
88    
89     # init script
90     %{__install} -d -m755 %{buildroot}%{_initrddir}
91     %{__install} -m755 scripts/mediatomb-service-fedora %{buildroot}%{_initrddir}/mediatomb
92    
93     # config file
94     %{__install} -d -m755 %{buildroot}%{_sysconfdir}/sysconfig
95     %{__install} -m755 config/mediatomb-conf-fedora %{buildroot}%{_sysconfdir}/sysconfig/mediatomb
96    
97     # fix for stupid strip issue
98     #%{__chmod} -R u+w %{buildroot}/*
99    
100     %post
101     if [ $1 -eq 1 ]; then
102     /usr/sbin/groupadd -f -r mediatomb
103     /usr/sbin/useradd -d %{_datadir}/mediatomb -g mediatomb -r -s /bin/false mediatomb
104     /sbin/chkconfig --add mediatomb
105     exit 0
106     fi
107    
108     %preun
109     if [ $1 -eq 0 ]; then
110     /sbin/chkconfig --del mediatomb
111     /usr/sbin/userdel mediatomb
112     /usr/sbin/groupdel mediatomb
113     exit 0
114     fi
115    
116     %clean
117     %{__rm} -rf %{buildroot}
118    
119     %files
120     %defattr(-, root, root, 0755)
121     %doc AUTHORS ChangeLog COPYING INSTALL NEWS README* TODO doc/ scripts/
122     %doc %{_mandir}/man?/*
123     %{_bindir}/*
124     %{_datadir}/mediatomb/
125     %{_initrddir}/mediatomb
126     %config %{_sysconfdir}/sysconfig/mediatomb
127    
128     %changelog
129 jpp 1.4 * Tue Feb 27 2018 Jean-Philipe Pialasse <tests@pialasse.com> 0.12.1-3.sme
130     - added some build requires
131    
132 jpp 1.3 * Tue Feb 27 2018 Jean-Philipe Pialasse <tests@pialasse.com> 0.12.1-2.sme
133     - initial package for SME Server
134     - tidt spec file to allow to build
135     - disable libffmpegthumbnailer as package not available
136     - disable lastfmlib support 0.4 is needed , not liblastfm 1
137     - patch for libav
138    
139 unnilennium 1.1 * Sat Jun 25 2011 Steve Huff <shuff@vecna.org> - 0.12.1-1
140     - Initial package.

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed