1 |
slords |
1.1 |
%define apachedir /etc/httpd |
2 |
|
|
%define apacheuser www |
3 |
|
|
%define apachegroup www |
4 |
|
|
%define contentdir /home/httpd |
5 |
|
|
|
6 |
|
|
Summary: A version of IMP for mobile phones. |
7 |
|
|
Name: mimp-h3 |
8 |
|
|
Version: 1.0.2 |
9 |
|
|
Release: 1%{?dist} |
10 |
|
|
License: LGPL |
11 |
|
|
Group: Applications/Horde |
12 |
|
|
Source: ftp://ftp.horde.org/pub/mimp/tarballs/mimp-h3-%{version}.tar.gz |
13 |
|
|
URL: http://www.horde.org/ |
14 |
|
|
BuildArchitectures: noarch |
15 |
|
|
BuildRoot: /tmp/horde-root |
16 |
|
|
AutoReq: no |
17 |
|
|
Requires: horde >= 3.0 |
18 |
|
|
Requires: php >= 4.3.0 |
19 |
|
|
Requires: httpd >= 2.0.46 |
20 |
|
|
Prereq: /usr/bin/perl |
21 |
|
|
|
22 |
|
|
%description |
23 |
|
|
MIMP is a version of `IMP`_ intended for mobile phones/PDAs, written in PHP |
24 |
|
|
and utilizing the Horde Application Framework. |
25 |
|
|
|
26 |
|
|
The Horde Project writes web applications in PHP and releases them under |
27 |
|
|
Open Source licenses. For more information (including help with Horde |
28 |
|
|
and its modules) please visit http://www.horde.org/. |
29 |
|
|
|
30 |
|
|
This package contains customizations for SME Server |
31 |
|
|
and will probably not work properly on other Linux systems. |
32 |
|
|
|
33 |
|
|
%prep |
34 |
|
|
|
35 |
|
|
%setup -q -n %{name}-%{version} |
36 |
|
|
|
37 |
|
|
%build |
38 |
|
|
|
39 |
|
|
%install |
40 |
|
|
[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT |
41 |
|
|
mkdir -p $RPM_BUILD_ROOT%{apachedir}/conf |
42 |
|
|
mkdir -p $RPM_BUILD_ROOT%{contentdir}/html/horde/mimp |
43 |
|
|
cp -pR * $RPM_BUILD_ROOT%{contentdir}/html/horde/mimp |
44 |
|
|
cd $RPM_BUILD_ROOT%{contentdir}/html/horde/mimp/config |
45 |
|
|
|
46 |
|
|
|
47 |
|
|
for d in *.dist; do |
48 |
|
|
d0=`basename $d .dist` |
49 |
|
|
if [ ! -f "$d0" ]; then |
50 |
|
|
cp -p $d $d0 |
51 |
|
|
fi |
52 |
|
|
done |
53 |
|
|
|
54 |
|
|
%clean |
55 |
|
|
[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT |
56 |
|
|
|
57 |
|
|
%post |
58 |
|
|
|
59 |
|
|
%postun |
60 |
|
|
|
61 |
|
|
%files |
62 |
|
|
%defattr(-,root,root) |
63 |
|
|
# Include top level with %dir so not all files are sucked in |
64 |
|
|
%dir %{contentdir}/html/horde/mimp |
65 |
|
|
# Include top-level files by hand |
66 |
|
|
%{contentdir}/html/horde/mimp/*.php |
67 |
|
|
# Include these dirs so that all files _will_ get sucked in |
68 |
|
|
%{contentdir}/html/horde/mimp/lib |
69 |
|
|
%{contentdir}/html/horde/mimp/locale |
70 |
|
|
%{contentdir}/html/horde/mimp/po |
71 |
|
|
%{contentdir}/html/horde/mimp/templates |
72 |
|
|
%{contentdir}/html/horde/mimp/themes |
73 |
|
|
# Mark documentation files with %doc and %docdir |
74 |
|
|
%doc %{contentdir}/html/horde/mimp/COPYING |
75 |
|
|
%doc %{contentdir}/html/horde/mimp/README |
76 |
|
|
%docdir %{contentdir}/html/horde/mimp/docs |
77 |
|
|
%{contentdir}/html/horde/mimp/docs |
78 |
|
|
# Mark configuration files with %config and use secure permissions |
79 |
|
|
# (note that .dist files are considered software; don't mark %config) |
80 |
|
|
%attr(750,root,%{apachegroup}) %dir %{contentdir}/html/horde/mimp/config |
81 |
|
|
%defattr(640,root,%{apachegroup}) |
82 |
|
|
%{contentdir}/html/horde/mimp/config/.htaccess |
83 |
|
|
%{contentdir}/html/horde/mimp/config/*.dist |
84 |
|
|
%config %{contentdir}/html/horde/mimp/config/*.php |
85 |
|
|
%config %{contentdir}/html/horde/mimp/config/*.xml |
86 |
|
|
%config %{contentdir}/html/horde/mimp/config/*.txt |
87 |
|
|
|
88 |
|
|
%changelog |
89 |
|
|
* Mon Nov 12 2007 John H. Bennett III <bennettj@johnbennettservices.com> 1.0.2-1 |
90 |
|
|
- Updated to mimp 1.0.2 |
91 |
|
|
|
92 |
|
|
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> |
93 |
|
|
- Clean up spec so package can be built by koji/plague |
94 |
|
|
|
95 |
|
|
* Fri Mar 23 2007 John H. Bennett III <bennettj@johnbennettservices.com> 1.0.1-1 |
96 |
|
|
- Updated to mimp 1.0.1-1 |
97 |
|
|
|
98 |
|
|
* Sat Jun 10 2006 John H. Bennett III <bennettj@johnbennettservices.com> |
99 |
|
|
- Re-rolled using released version of mimp 1.0 |
100 |
|
|
|
101 |
|
|
* Sun May 28 2006 John H. Bennett III <bennettj@johnbennettservices.com> |
102 |
|
|
- Upgraded to mimp1.0.RC2 [1.0-0.1] |
103 |
|
|
|
104 |
|
|
* Fri Mar 7 2006 John H. Bennett III <bennettj@johnbennettservices.com> |
105 |
|
|
- Dropped rc1 from RPM name [1.0-0] |
106 |
|
|
|
107 |
|
|
* Fri Mar 2 2006 John H. Bennett III <bennettj@johnbennettservices.com> |
108 |
|
|
- Re-rolled using mimp-h3-1.0-rc1 [1.0-RC1] |
109 |
|
|
|
110 |
|
|
* Thu Sep 01 2005 Greg Swallow |
111 |
|
|
- [0.0.1-1sme01] |
112 |
|
|
- Initial Release from CVS 2005-09-03 |
113 |
|
|
|