1 |
slords |
1.4 |
# $Id: mimp-h3.spec,v 1.3 2008/06/26 18:03:25 slords Exp $ |
2 |
slords |
1.2 |
# Authority: mrjhb3 |
3 |
|
|
# Name: John H. Bennett III |
4 |
|
|
|
5 |
slords |
1.1 |
%define apachedir /etc/httpd |
6 |
|
|
%define apacheuser www |
7 |
|
|
%define apachegroup www |
8 |
|
|
%define contentdir /home/httpd |
9 |
|
|
|
10 |
|
|
Summary: A version of IMP for mobile phones. |
11 |
|
|
Name: mimp-h3 |
12 |
slords |
1.3 |
Version: 1.1 |
13 |
slords |
1.1 |
Release: 1%{?dist} |
14 |
|
|
License: LGPL |
15 |
|
|
Group: Applications/Horde |
16 |
|
|
Source: ftp://ftp.horde.org/pub/mimp/tarballs/mimp-h3-%{version}.tar.gz |
17 |
|
|
URL: http://www.horde.org/ |
18 |
|
|
BuildArchitectures: noarch |
19 |
|
|
BuildRoot: /tmp/horde-root |
20 |
|
|
AutoReq: no |
21 |
slords |
1.3 |
Requires: horde >= 3.2 |
22 |
slords |
1.1 |
Requires: php >= 4.3.0 |
23 |
|
|
Requires: httpd >= 2.0.46 |
24 |
|
|
Prereq: /usr/bin/perl |
25 |
|
|
|
26 |
|
|
%description |
27 |
|
|
MIMP is a version of `IMP`_ intended for mobile phones/PDAs, written in PHP |
28 |
|
|
and utilizing the Horde Application Framework. |
29 |
|
|
|
30 |
|
|
The Horde Project writes web applications in PHP and releases them under |
31 |
|
|
Open Source licenses. For more information (including help with Horde |
32 |
|
|
and its modules) please visit http://www.horde.org/. |
33 |
|
|
|
34 |
|
|
This package contains customizations for SME Server |
35 |
|
|
and will probably not work properly on other Linux systems. |
36 |
|
|
|
37 |
|
|
%prep |
38 |
|
|
|
39 |
|
|
%setup -q -n %{name}-%{version} |
40 |
|
|
|
41 |
|
|
%build |
42 |
|
|
|
43 |
|
|
%install |
44 |
|
|
[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT |
45 |
|
|
mkdir -p $RPM_BUILD_ROOT%{apachedir}/conf |
46 |
|
|
mkdir -p $RPM_BUILD_ROOT%{contentdir}/html/horde/mimp |
47 |
|
|
cp -pR * $RPM_BUILD_ROOT%{contentdir}/html/horde/mimp |
48 |
|
|
cd $RPM_BUILD_ROOT%{contentdir}/html/horde/mimp/config |
49 |
|
|
|
50 |
|
|
|
51 |
|
|
for d in *.dist; do |
52 |
|
|
d0=`basename $d .dist` |
53 |
|
|
if [ ! -f "$d0" ]; then |
54 |
|
|
cp -p $d $d0 |
55 |
|
|
fi |
56 |
|
|
done |
57 |
|
|
|
58 |
|
|
%clean |
59 |
|
|
[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT |
60 |
|
|
|
61 |
|
|
%post |
62 |
|
|
|
63 |
|
|
%postun |
64 |
|
|
|
65 |
|
|
%files |
66 |
|
|
%defattr(-,root,root) |
67 |
|
|
# Include top level with %dir so not all files are sucked in |
68 |
|
|
%dir %{contentdir}/html/horde/mimp |
69 |
|
|
# Include top-level files by hand |
70 |
|
|
%{contentdir}/html/horde/mimp/*.php |
71 |
|
|
# Include these dirs so that all files _will_ get sucked in |
72 |
|
|
%{contentdir}/html/horde/mimp/lib |
73 |
|
|
%{contentdir}/html/horde/mimp/locale |
74 |
|
|
%{contentdir}/html/horde/mimp/po |
75 |
|
|
%{contentdir}/html/horde/mimp/templates |
76 |
|
|
%{contentdir}/html/horde/mimp/themes |
77 |
|
|
# Mark documentation files with %doc and %docdir |
78 |
|
|
%doc %{contentdir}/html/horde/mimp/COPYING |
79 |
|
|
%doc %{contentdir}/html/horde/mimp/README |
80 |
|
|
%docdir %{contentdir}/html/horde/mimp/docs |
81 |
|
|
%{contentdir}/html/horde/mimp/docs |
82 |
|
|
# Mark configuration files with %config and use secure permissions |
83 |
|
|
# (note that .dist files are considered software; don't mark %config) |
84 |
|
|
%attr(750,root,%{apachegroup}) %dir %{contentdir}/html/horde/mimp/config |
85 |
|
|
%defattr(640,root,%{apachegroup}) |
86 |
|
|
%{contentdir}/html/horde/mimp/config/.htaccess |
87 |
|
|
%{contentdir}/html/horde/mimp/config/*.dist |
88 |
|
|
%config %{contentdir}/html/horde/mimp/config/*.php |
89 |
|
|
%config %{contentdir}/html/horde/mimp/config/*.xml |
90 |
|
|
|
91 |
|
|
%changelog |
92 |
slords |
1.3 |
* Mon Jun 2 2008 John H. Bennett III <bennettj@johnbennettservices.com> 1.1-1 |
93 |
|
|
- initial RPM roll for Mimp 1.1 |