1 |
slords |
1.1 |
%define apachedir /etc/httpd |
2 |
|
|
%define apacheuser www |
3 |
|
|
%define apachegroup www |
4 |
|
|
%define contentdir /home/httpd |
5 |
|
|
|
6 |
|
|
Summary: The notes and memos application for Horde. |
7 |
|
|
Name: mnemo-h3 |
8 |
slords |
1.2 |
Version: 2.1.2 |
9 |
slords |
1.1 |
Release: 1%{?dist} |
10 |
|
|
License: LGPL |
11 |
|
|
Group: Applications/Horde |
12 |
|
|
Source: ftp://ftp.horde.org/pub/mnemo/tarballs/mnemo-h3-%{version}.tar.gz |
13 |
|
|
URL: http://www.horde.org/ |
14 |
|
|
BuildArchitectures: noarch |
15 |
|
|
BuildRoot: /tmp/horde-root |
16 |
|
|
AutoReq: no |
17 |
|
|
Requires: horde >= 3.1 |
18 |
|
|
Requires: php >= 4.3.0 |
19 |
|
|
Requires: httpd >= 2.0.46 |
20 |
|
|
Prereq: /usr/bin/perl |
21 |
|
|
|
22 |
|
|
%description |
23 |
|
|
Mnemo is the Horde notes and memos application. It lets users keep free-text |
24 |
|
|
notes and other bits of information which doesn't fit as a contact, a todo |
25 |
|
|
item, an event, etc. It is very similar in functionality to the Palm Memo |
26 |
|
|
application. |
27 |
|
|
|
28 |
|
|
The Horde Project writes web applications in PHP and releases them under |
29 |
|
|
Open Source licenses. For more information (including help with Horde |
30 |
|
|
and its modules) please visit http://www.horde.org/. |
31 |
|
|
|
32 |
|
|
This package contains customizations for SME Server |
33 |
|
|
and will probably not work properly on other Linux systems. |
34 |
|
|
|
35 |
|
|
%prep |
36 |
|
|
%setup -q -n %{name}-%{version} |
37 |
|
|
|
38 |
|
|
%build |
39 |
|
|
|
40 |
|
|
%install |
41 |
|
|
[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT |
42 |
|
|
mkdir -p $RPM_BUILD_ROOT%{apachedir}/conf |
43 |
|
|
mkdir -p $RPM_BUILD_ROOT%{contentdir}/html/horde/mnemo |
44 |
|
|
cp -pR * $RPM_BUILD_ROOT%{contentdir}/html/horde/mnemo |
45 |
|
|
cd $RPM_BUILD_ROOT%{contentdir}/html/horde/mnemo/config |
46 |
|
|
for d in *.dist; do |
47 |
|
|
d0=`basename $d .dist` |
48 |
|
|
if [ ! -f "$d0" ]; then |
49 |
|
|
cp -p $d $d0 |
50 |
|
|
fi |
51 |
|
|
done |
52 |
|
|
|
53 |
|
|
%clean |
54 |
|
|
[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT |
55 |
|
|
|
56 |
|
|
%post |
57 |
|
|
|
58 |
|
|
%postun |
59 |
|
|
|
60 |
|
|
%files |
61 |
|
|
%defattr(-,root,root) |
62 |
|
|
# Include top level with %dir so not all files are sucked in |
63 |
|
|
%dir %{contentdir}/html/horde/mnemo |
64 |
|
|
# Include top-level files by hand |
65 |
|
|
%{contentdir}/html/horde/mnemo/*.php |
66 |
|
|
# Include these dirs so that all files _will_ get sucked in |
67 |
|
|
%{contentdir}/html/horde/mnemo/js |
68 |
|
|
%{contentdir}/html/horde/mnemo/lib |
69 |
|
|
%{contentdir}/html/horde/mnemo/locale |
70 |
|
|
%{contentdir}/html/horde/mnemo/po |
71 |
|
|
%{contentdir}/html/horde/mnemo/scripts |
72 |
|
|
%{contentdir}/html/horde/mnemo/templates |
73 |
|
|
%{contentdir}/html/horde/mnemo/themes |
74 |
|
|
# Mark documentation files with %doc and %docdir |
75 |
|
|
%doc %{contentdir}/html/horde/mnemo/LICENSE |
76 |
|
|
%doc %{contentdir}/html/horde/mnemo/README |
77 |
|
|
%docdir %{contentdir}/html/horde/mnemo/docs |
78 |
|
|
%{contentdir}/html/horde/mnemo/docs |
79 |
|
|
# Mark configuration files with %config and use secure permissions |
80 |
|
|
# (note that .dist files are considered software; don't mark %config) |
81 |
|
|
%attr(750,root,%{apachegroup}) %dir %{contentdir}/html/horde/mnemo/config |
82 |
|
|
%defattr(640,root,%{apachegroup}) |
83 |
|
|
%{contentdir}/html/horde/mnemo/config/.htaccess |
84 |
|
|
%{contentdir}/html/horde/mnemo/config/*.dist |
85 |
|
|
%config %{contentdir}/html/horde/mnemo/config/*.php |
86 |
|
|
%config %{contentdir}/html/horde/mnemo/config/*.xml |
87 |
|
|
|
88 |
|
|
%changelog |
89 |
slords |
1.2 |
* Tue Mar 25 2008 Shad L. Lords <slords@mail.com) 2.1.2-1 |
90 |
|
|
- Updated to mnemo 2.1.2 |
91 |
|
|
|
92 |
slords |
1.1 |
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> |
93 |
|
|
- Clean up spec so package can be built by koji/plague |
94 |
|
|
|
95 |
|
|
* Fri Nov 24 2006 John H. Bennett III 2.1.1-00sme01 |
96 |
|
|
- Updated to mnemo 2.1.1 |
97 |
|
|
|
98 |
|
|
* Sat Sep 9 2006 John H. Bennett III 2.1-00sme01 |
99 |
|
|
- Updated to mnemo 2.1 |
100 |
|
|
|
101 |
|
|
* Wed Feb 15 2006 John H. Bennett III 2.0.3-1sme01 |
102 |
|
|
- Initial Release of Mnemo 2.0.3 building on Greg's work |
103 |
|
|
|
104 |
|
|
* Thu Sep 01 2005 Greg Swallow |
105 |
|
|
- [1.0-1sme01] |
106 |
|
|
- Initial Release |