1 |
# $Id: mnemo-h3.spec,v 1.9 2009/10/10 21:43:09 mrjhb3 Exp $ |
2 |
# Authority: mrjhb3 |
3 |
# Name: John H. Bennett III |
4 |
|
5 |
%define apachedir /etc/httpd |
6 |
%define apacheuser www |
7 |
%define apachegroup www |
8 |
%define contentdir /home/httpd |
9 |
|
10 |
Summary: The notes and memos application for Horde. |
11 |
Name: mnemo-h3 |
12 |
Version: 2.2.3 |
13 |
Release: 1%{?dist} |
14 |
License: LGPL |
15 |
Group: Applications/Horde |
16 |
Source: ftp://ftp.horde.org/pub/mnemo/tarballs/mnemo-h3-%{version}.tar.gz |
17 |
URL: http://www.horde.org/ |
18 |
BuildArchitectures: noarch |
19 |
BuildRoot: /tmp/horde-root |
20 |
AutoReq: no |
21 |
Requires: horde >= 3.2 |
22 |
Requires: php >= 4.3.0 |
23 |
Requires: httpd >= 2.0.46 |
24 |
Prereq: /usr/bin/perl |
25 |
|
26 |
%description |
27 |
Mnemo is the Horde notes and memos application. It lets users keep free-text |
28 |
notes and other bits of information which doesn't fit as a contact, a todo |
29 |
item, an event, etc. It is very similar in functionality to the Palm Memo |
30 |
application. |
31 |
|
32 |
The Horde Project writes web applications in PHP and releases them under |
33 |
Open Source licenses. For more information (including help with Horde |
34 |
and its modules) please visit http://www.horde.org/. |
35 |
|
36 |
This package contains customizations for SME Server |
37 |
and will probably not work properly on other Linux systems. |
38 |
|
39 |
%prep |
40 |
%setup -q -n %{name}-%{version} |
41 |
|
42 |
%build |
43 |
|
44 |
%install |
45 |
[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT |
46 |
mkdir -p $RPM_BUILD_ROOT%{apachedir}/conf |
47 |
mkdir -p $RPM_BUILD_ROOT%{contentdir}/html/horde/mnemo |
48 |
cp -pR * $RPM_BUILD_ROOT%{contentdir}/html/horde/mnemo |
49 |
cd $RPM_BUILD_ROOT%{contentdir}/html/horde/mnemo/config |
50 |
for d in *.dist; do |
51 |
d0=`basename $d .dist` |
52 |
if [ ! -f "$d0" ]; then |
53 |
cp -p $d $d0 |
54 |
fi |
55 |
done |
56 |
|
57 |
%clean |
58 |
[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT |
59 |
|
60 |
%post |
61 |
|
62 |
%postun |
63 |
|
64 |
%files |
65 |
%defattr(-,root,root) |
66 |
# Include top level with %dir so not all files are sucked in |
67 |
%dir %{contentdir}/html/horde/mnemo |
68 |
# Include top-level files by hand |
69 |
%{contentdir}/html/horde/mnemo/*.php |
70 |
# Include these dirs so that all files _will_ get sucked in |
71 |
%{contentdir}/html/horde/mnemo/js |
72 |
%{contentdir}/html/horde/mnemo/lib |
73 |
%{contentdir}/html/horde/mnemo/locale |
74 |
%{contentdir}/html/horde/mnemo/po |
75 |
%{contentdir}/html/horde/mnemo/scripts |
76 |
%{contentdir}/html/horde/mnemo/templates |
77 |
%{contentdir}/html/horde/mnemo/themes |
78 |
%{contentdir}/html/horde/mnemo/note |
79 |
%{contentdir}/html/horde/mnemo/notepads |
80 |
%{contentdir}/html/horde/mnemo/notes |
81 |
# Mark documentation files with %doc and %docdir |
82 |
%doc %{contentdir}/html/horde/mnemo/LICENSE |
83 |
%doc %{contentdir}/html/horde/mnemo/README |
84 |
%docdir %{contentdir}/html/horde/mnemo/docs |
85 |
%{contentdir}/html/horde/mnemo/docs |
86 |
# Mark configuration files with %config and use secure permissions |
87 |
# (note that .dist files are considered software; don't mark %config) |
88 |
%attr(750,root,%{apachegroup}) %dir %{contentdir}/html/horde/mnemo/config |
89 |
%defattr(640,root,%{apachegroup}) |
90 |
%{contentdir}/html/horde/mnemo/config/.htaccess |
91 |
%{contentdir}/html/horde/mnemo/config/*.dist |
92 |
%config %{contentdir}/html/horde/mnemo/config/*.php |
93 |
%config %{contentdir}/html/horde/mnemo/config/*.xml |
94 |
|
95 |
%changelog |
96 |
* Sun Dec 27 2009 John H. Bennett III <bennettj@johnbennettservices.com> 2.2.3-1 |
97 |
- Update to Mnemo 2.2.3 |
98 |
|
99 |
* Sat Oct 10 2009 John H. Bennett III <bennettj@johnbennettservices.com> 2.2.2-1 |
100 |
- Update to Mnemo 2.2.2 |
101 |
|
102 |
* Tue Sep 16 2008 John H. Bennett III <bennettj@johnbennettservices.com> 2.2.1-1 |
103 |
- Update to Mnemo 2.2.1 |
104 |
|
105 |
* Mon Jun 2 2008 John H. Bennett III <bennettj@johnbennettservices.com> 2.2-1 |
106 |
- initial RPM roll for Mnemo 2.2 |