1 |
slords |
1.1 |
Summary: Builds packages inside chroots |
2 |
|
|
Name: mock |
3 |
|
|
Version: 0.7.2 |
4 |
|
|
Release: 1%{?dist}.1 |
5 |
|
|
License: GPL |
6 |
|
|
Group: Development/Tools |
7 |
|
|
Source: http://fedoraproject.org/projects/mock/releases/%{name}-%{version}.tar.gz |
8 |
|
|
URL: http://fedoraproject.org/wiki/Projects/Mock |
9 |
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) |
10 |
|
|
Requires: python, yum >= 3.0 |
11 |
|
|
Requires(pre): shadow-utils |
12 |
|
|
BuildRequires: libselinux-devel |
13 |
|
|
|
14 |
|
|
%description |
15 |
|
|
Mock takes a srpm and builds it in a chroot |
16 |
|
|
|
17 |
|
|
%prep |
18 |
|
|
%setup -q |
19 |
|
|
|
20 |
|
|
%build |
21 |
|
|
make CFLAGS="$RPM_OPT_FLAGS" |
22 |
|
|
|
23 |
|
|
%install |
24 |
|
|
rm -rf $RPM_BUILD_ROOT |
25 |
|
|
make DESTDIR=$RPM_BUILD_ROOT install |
26 |
|
|
# make the default.cfg link |
27 |
|
|
cd $RPM_BUILD_ROOT/%{_sysconfdir}/%{name} |
28 |
|
|
|
29 |
|
|
%if 0%{?fedora:1} |
30 |
|
|
if [ -f fedora-%{fedora}-%{_target_cpu}-core.cfg ]; then |
31 |
|
|
ln -s fedora-%{fedora}-%{_target_cpu}-core.cfg default.cfg |
32 |
|
|
elif [ -f fedora-%{fedora}-%{_target_cpu}.cfg ]; then |
33 |
|
|
ln -s fedora-%{fedora}-%{_target_cpu}.cfg default.cfg |
34 |
|
|
fi |
35 |
|
|
%endif |
36 |
|
|
|
37 |
|
|
# if we haven't created a default link yet, try to do so as devel |
38 |
|
|
if [ ! -f default.cfg ]; then |
39 |
|
|
if [ -f fedora-development-%{_target_cpu}.cfg ]; then |
40 |
|
|
ln -s fedora-development-%{_target_cpu}.cfg default.cfg |
41 |
|
|
elif [ -f fedora-devel-%{_target_cpu}.cfg ]; then |
42 |
|
|
ln -s fedora-devel-%{_target_cpu}.cfg default.cfg |
43 |
|
|
elif [ -f fedora-development-i386.cfg ]; then |
44 |
|
|
ln -s fedora-development-i386.cfg default.cfg |
45 |
|
|
elif [ -f fedora-devel-i386.cfg ]; then |
46 |
|
|
ln -s fedora-devel-i386.cfg default.cfg |
47 |
|
|
fi |
48 |
|
|
fi |
49 |
|
|
|
50 |
|
|
%clean |
51 |
|
|
rm -rf $RPM_BUILD_ROOT |
52 |
|
|
|
53 |
|
|
%pre |
54 |
|
|
if [ $1 -eq 1 ]; then |
55 |
|
|
groupadd -r mock >/dev/null 2>&1 || : |
56 |
|
|
fi |
57 |
|
|
|
58 |
|
|
%files |
59 |
|
|
%defattr(-, root, root) |
60 |
|
|
%doc README ChangeLog buildsys-build.spec |
61 |
|
|
%dir %{_sysconfdir}/%{name} |
62 |
|
|
%config(noreplace) %{_sysconfdir}/%{name}/*.cfg |
63 |
|
|
%{_bindir}/%{name} |
64 |
|
|
%{_libexecdir}/mock-yum |
65 |
|
|
%{_mandir}/man1/mock.1* |
66 |
|
|
%attr(04750, root, mock) %{_sbindir}/mock-helper |
67 |
|
|
%attr(02775, root, mock) %dir /var/lib/mock |
68 |
|
|
%{_libdir}/libselinux-mock.so |
69 |
|
|
|
70 |
|
|
%changelog |
71 |
|
|
* Wed Jun 13 2007 Michael Brown <mebrown@michaels-house.net> - 0.7.1-1 |
72 |
|
|
- Fix problem with autocache where different users couldnt share same cache |
73 |
|
|
- Fix problem creating resolv.conf in rootfs |
74 |
|
|
- cleanup perms on rootfs /etc/ |
75 |
|
|
|
76 |
|
|
* Tue Jun 12 2007 Michael Brown <mebrown@michaels-house.net> - 0.7.1-1 |
77 |
|
|
- add EPEL 5 config files |
78 |
|
|
|
79 |
|
|
* Mon Jun 11 2007 Clark Williams <williams@redhat.com> - 0.7-1 |
80 |
|
|
- fixed bind mount problems |
81 |
|
|
- added code to allow multiple users to use --no-clean |
82 |
|
|
- merged mock-0-6-branch to head and changed version |
83 |
|
|
|
84 |
|
|
* Thu Jun 7 2007 Clark Williams <williams@redhat.com> - 0.6.17-1 |
85 |
|
|
- added F-7 config files (BZ#242276) |
86 |
|
|
- modified epel configs for changed mirrorlist location (BZ#239981) |
87 |
|
|
- added bind mount of /dev (BZ#236428) |
88 |
|
|
- added copy of /etc/resolv.conf to chroot (BZ#237663 and BZ#238101) |
89 |
|
|
|
90 |
|
|
* Tue May 01 2007 Clark Williams <williams@redhat.com> - 0.6.16-1 |
91 |
|
|
- timeout code adds new cmdline option that will kill build process after |
92 |
|
|
specified timeout. Useful for automated builds of things that may hang during |
93 |
|
|
build and you just want it to fail. |
94 |
|
|
|
95 |
|
|
* Tue Apr 10 2007 Clark Williams <williams@redhat.com> - 0.6.15-1 |
96 |
|
|
- Fixed typo in FC4 -epel configs (BZ 235490) |
97 |
|
|
|
98 |
|
|
* Sat Feb 24 2007 Clark Williams <williams@redhat.com> - 0.6.14-1 |
99 |
|
|
- Ville Skyttä's fix for RPM_OPT_FLAGS (BZ 226673) |
100 |
|
|
|
101 |
|
|
* Tue Feb 20 2007 Clark Williams <williams@redhat.com> - 0.6.13-1 |
102 |
|
|
- Handle --no-clean option when doing yum.conf symlink (BZ 230824) |
103 |
|
|
|
104 |
|
|
* Fri Feb 16 2007 Clark Williams <williams@redhat.com> - 0.6.12-1 |
105 |
|
|
- added safety symlink for yum.conf |
106 |
|
|
|
107 |
|
|
* Wed Feb 7 2007 Clark Williams <williams@redhat.com> - 0.6.11-1 |
108 |
|
|
- added error() calls to print command output on failed commands |
109 |
|
|
|
110 |
|
|
* Tue Feb 6 2007 Clark Williams <williams@redhat.com> - 0.6.11-1 |
111 |
|
|
- added installdeps command for long-term chroot management |
112 |
|
|
|
113 |
|
|
* Mon Jan 8 2007 Clark Williams <williams@redhat.com> - 0.6.10-1 |
114 |
|
|
- Added Josh Boyer's EPEL config files |
115 |
|
|
|
116 |
|
|
* Tue Nov 21 2006 Clark Williams <williams@redhat.com> - 0.6.9-1 |
117 |
|
|
- applied Eric Work's patch to fix defaults vs. command line option problem |
118 |
|
|
(BZ 215168) |
119 |
|
|
- use /etc/mock/defaults.cfg if --configdir specified and no defaults found |
120 |
|
|
in the specified configdir |
121 |
|
|
(BZ 209407) |
122 |
|
|
- applied Jesse Keatings patch for arch specifi config files |
123 |
|
|
(BZ 213516) |
124 |
|
|
|
125 |
|
|
* Mon Oct 30 2006 Clark Williams <williams@redhat.com> - 0.6.8-1 |
126 |
|
|
- respun tarballs without buildsys rpms |
127 |
|
|
|
128 |
|
|
* Mon Oct 30 2006 Clark Williams <williams@redhat.com> - 0.6.7-1 |
129 |
|
|
- updated for FC6 release |
130 |
|
|
|
131 |
|
|
* Sat Oct 21 2006 Clark Williams <williams@redhat.com> - 0.6.6-1 |
132 |
|
|
- bumped version to 0.6.6 (fixed tarball problem) |
133 |
|
|
|
134 |
|
|
* Mon Sep 11 2006 Clark Williams <williams@redhat.com> - 0.6.5-1 |
135 |
|
|
- changed version number for patch from Karanbir Singh |
136 |
|
|
(rpm workaround on CentOS 4.4) |
137 |
|
|
|
138 |
|
|
* Tue Aug 29 2006 Clark Williams <williams@redhat.com> - 0.6.3-1 |
139 |
|
|
- changed version number to indicate fix for bz 204051 |
140 |
|
|
|
141 |
|
|
* Tue Aug 29 2006 Clark Williams <williams@redhat.com> - 0.6.2-2 |
142 |
|
|
- bumped revision for bz 204051 |
143 |
|
|
|
144 |
|
|
* Wed Aug 23 2006 Clark Williams <williams@redhat.com> - 0.6.2-1 |
145 |
|
|
- Updated README |
146 |
|
|
- Fixed link problem in etc/Makefile |
147 |
|
|
- Bumped version number |
148 |
|
|
|
149 |
|
|
* Wed Aug 16 2006 Clark Williams <williams@redhat.com> |
150 |
|
|
- Added buildsys-build specfile to docs |
151 |
|
|
- Added disttag |
152 |
|
|
- Bumped release number |
153 |
|
|
|
154 |
|
|
* Wed Jun 7 2006 Seth Vidal <skvidal at linux.duke.edu> |
155 |
|
|
- version update |
156 |
|
|
|
157 |
|
|
* Tue Apr 11 2006 Seth Vidal <skvidal at linux.duke.edu> |
158 |
|
|
- specfile version iterate |
159 |
|
|
|
160 |
|
|
* Tue Dec 27 2005 Seth Vidal <skvidal@phy.duke.edu> |
161 |
|
|
- add patch from Andreas Thienemann - adds man page |
162 |
|
|
|
163 |
|
|
* Sat Jun 11 2005 Seth Vidal <skvidal@phy.duke.edu> |
164 |
|
|
- security fix in mock-helper |
165 |
|
|
|
166 |
|
|
* Sun Jun 5 2005 Seth Vidal <skvidal@phy.duke.edu> |
167 |
|
|
- clean up packaging for fedora extras |
168 |
|
|
|
169 |
|
|
* Thu May 19 2005 Seth Vidal <skvidal@phy.duke.edu> |
170 |
|
|
- second packaging and backing down the yum ver req |
171 |
|
|
|
172 |
|
|
* Sun May 15 2005 Seth Vidal <skvidal@phy.duke.edu> |
173 |
|
|
- first version/packaging |