1 |
slords |
1.1 |
%define apachedir /etc/httpd |
2 |
|
|
%define apacheuser www |
3 |
|
|
%define apachegroup www |
4 |
|
|
%define contentdir /home/httpd |
5 |
|
|
|
6 |
|
|
Summary: The task list application for Horde. |
7 |
|
|
Name: nag-h3 |
8 |
slords |
1.2 |
Version: 2.1.4 |
9 |
slords |
1.1 |
Release: 1%{?dist} |
10 |
|
|
License: LGPL |
11 |
|
|
Group: Applications/Horde |
12 |
|
|
Source: ftp://ftp.horde.org/pub/nag/tarballs/nag-h3-%{version}.tar.gz |
13 |
|
|
URL: http://www.horde.org/ |
14 |
|
|
BuildArchitectures: noarch |
15 |
|
|
BuildRoot: /tmp/horde-root |
16 |
|
|
AutoReq: no |
17 |
|
|
Requires: horde >= 3.1 |
18 |
|
|
Requires: php >= 4.3.0 |
19 |
|
|
Requires: httpd >= 2.0.46 |
20 |
|
|
Prereq: /usr/bin/perl |
21 |
|
|
|
22 |
|
|
%description |
23 |
|
|
Nag is the Horde task list application. It stores todo items, things due |
24 |
|
|
later this week, etc. It is very similar in functionality to the Palm ToDo |
25 |
|
|
application. |
26 |
|
|
|
27 |
|
|
The Horde Project writes web applications in PHP and releases them under |
28 |
|
|
Open Source licenses. For more information (including help with Horde |
29 |
|
|
and its modules) please visit http://www.horde.org/. |
30 |
|
|
|
31 |
|
|
This package contains customizations for SME Server |
32 |
|
|
and will probably not work properly on other Linux systems. |
33 |
|
|
|
34 |
|
|
%prep |
35 |
|
|
%setup -q -n %{name}-%{version} |
36 |
|
|
|
37 |
|
|
%build |
38 |
|
|
|
39 |
|
|
%install |
40 |
|
|
[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT |
41 |
|
|
mkdir -p $RPM_BUILD_ROOT%{apachedir}/conf |
42 |
|
|
mkdir -p $RPM_BUILD_ROOT%{contentdir}/html/horde/nag |
43 |
|
|
cp -pR * $RPM_BUILD_ROOT%{contentdir}/html/horde/nag |
44 |
|
|
cd $RPM_BUILD_ROOT%{contentdir}/html/horde/nag/config |
45 |
|
|
for d in *.dist; do |
46 |
|
|
d0=`basename $d .dist` |
47 |
|
|
if [ ! -f "$d0" ]; then |
48 |
|
|
cp -p $d $d0 |
49 |
|
|
fi |
50 |
|
|
done |
51 |
|
|
|
52 |
|
|
%clean |
53 |
|
|
[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT |
54 |
|
|
|
55 |
|
|
%post |
56 |
|
|
|
57 |
|
|
%postun |
58 |
|
|
|
59 |
|
|
%files |
60 |
|
|
%defattr(-,root,root) |
61 |
|
|
# Include top level with %dir so not all files are sucked in |
62 |
|
|
%dir %{contentdir}/html/horde/nag |
63 |
|
|
# Include top-level files by hand |
64 |
|
|
%{contentdir}/html/horde/nag/*.php |
65 |
|
|
# Include these dirs so that all files _will_ get sucked in |
66 |
|
|
%{contentdir}/html/horde/nag/js |
67 |
|
|
%{contentdir}/html/horde/nag/lib |
68 |
|
|
%{contentdir}/html/horde/nag/locale |
69 |
|
|
%{contentdir}/html/horde/nag/po |
70 |
|
|
%{contentdir}/html/horde/nag/scripts |
71 |
|
|
%{contentdir}/html/horde/nag/templates |
72 |
|
|
%{contentdir}/html/horde/nag/themes |
73 |
|
|
# Mark documentation files with %doc and %docdir |
74 |
|
|
%doc %{contentdir}/html/horde/nag/COPYING |
75 |
|
|
%doc %{contentdir}/html/horde/nag/README |
76 |
|
|
%docdir %{contentdir}/html/horde/nag/docs |
77 |
|
|
%{contentdir}/html/horde/nag/docs |
78 |
|
|
# Mark configuration files with %config and use secure permissions |
79 |
|
|
# (note that .dist files are considered software; don't mark %config) |
80 |
|
|
%attr(750,root,%{apachegroup}) %dir %{contentdir}/html/horde/nag/config |
81 |
|
|
%defattr(640,root,%{apachegroup}) |
82 |
|
|
%{contentdir}/html/horde/nag/config/.htaccess |
83 |
|
|
%{contentdir}/html/horde/nag/config/*.dist |
84 |
|
|
%config %{contentdir}/html/horde/nag/config/*.php |
85 |
|
|
%config %{contentdir}/html/horde/nag/config/*.xml |
86 |
|
|
|
87 |
|
|
%changelog |
88 |
slords |
1.2 |
* Tue Mar 25 2008 Shad L. Lords <slords@mail.com> 2.1.4-1 |
89 |
|
|
- Updated to nag 2.1.4 |
90 |
|
|
|
91 |
slords |
1.1 |
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> |
92 |
|
|
- Clean up spec so package can be built by koji/plague |
93 |
|
|
|
94 |
|
|
* Fri Mar 23 2007 John H. Bennett III 2.1.3-1 |
95 |
|
|
- Updated to nag 2.1.3 |
96 |
|
|
|
97 |
|
|
* Fri Nov 24 2006 John H. Bennett III 2.1.2-00sme01 |
98 |
|
|
- Updated to nag 2.1.2 |
99 |
|
|
|
100 |
|
|
* Wed Feb 15 2006 John H. Bennett III 2.1.1-00sme01 |
101 |
|
|
- Updated to nag 2.1.1 |
102 |
|
|
|
103 |
|
|
* Wed Feb 15 2006 John H. Bennett III 2.0.4-1sme01 |
104 |
|
|
- Initial Release of Nag 2.0.4 building on Greg's work |
105 |
|
|
|
106 |
|
|
* Thu Sep 01 2005 Greg Swallow |
107 |
|
|
- [1.0-1sme01] |
108 |
|
|
- Initial Release |