1 |
slords |
1.1 |
# $Id: nag-h3.spec,v 1.11 2010/05/11 03:11:45 mrjhb3 Exp $ |
2 |
|
|
# Authority: mrjhb3 |
3 |
|
|
# Name: John H. Bennett III |
4 |
|
|
|
5 |
|
|
%define apachedir /etc/httpd |
6 |
|
|
%define apacheuser www |
7 |
|
|
%define apachegroup www |
8 |
|
|
%define contentdir /home/httpd |
9 |
|
|
|
10 |
|
|
Summary: The task list application for Horde. |
11 |
|
|
Name: nag-h3 |
12 |
|
|
Version: 2.3.5 |
13 |
|
|
Release: 1%{?dist} |
14 |
|
|
License: LGPL |
15 |
|
|
Group: Applications/Horde |
16 |
|
|
Source: ftp://ftp.horde.org/pub/nag/tarballs/nag-h3-%{version}.tar.gz |
17 |
|
|
URL: http://www.horde.org/ |
18 |
|
|
BuildArchitectures: noarch |
19 |
|
|
BuildRoot: /tmp/horde-root |
20 |
|
|
AutoReq: no |
21 |
|
|
Requires: horde >= 3.2 |
22 |
|
|
Requires: php >= 4.3.0 |
23 |
|
|
Requires: httpd >= 2.0.46 |
24 |
|
|
Prereq: /usr/bin/perl |
25 |
|
|
|
26 |
|
|
%description |
27 |
|
|
Nag is the Horde task list application. It stores todo items, things due |
28 |
|
|
later this week, etc. It is very similar in functionality to the Palm ToDo |
29 |
|
|
application. |
30 |
|
|
|
31 |
|
|
The Horde Project writes web applications in PHP and releases them under |
32 |
|
|
Open Source licenses. For more information (including help with Horde |
33 |
|
|
and its modules) please visit http://www.horde.org/. |
34 |
|
|
|
35 |
|
|
This package contains customizations for SME Server |
36 |
|
|
and will probably not work properly on other Linux systems. |
37 |
|
|
|
38 |
|
|
%prep |
39 |
|
|
%setup -q -n %{name}-%{version} |
40 |
|
|
|
41 |
|
|
%build |
42 |
|
|
|
43 |
|
|
%install |
44 |
|
|
[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT |
45 |
|
|
mkdir -p $RPM_BUILD_ROOT%{apachedir}/conf |
46 |
|
|
mkdir -p $RPM_BUILD_ROOT%{contentdir}/html/horde/nag |
47 |
|
|
cp -pR * $RPM_BUILD_ROOT%{contentdir}/html/horde/nag |
48 |
|
|
cd $RPM_BUILD_ROOT%{contentdir}/html/horde/nag/config |
49 |
|
|
for d in *.dist; do |
50 |
|
|
d0=`basename $d .dist` |
51 |
|
|
if [ ! -f "$d0" ]; then |
52 |
|
|
cp -p $d $d0 |
53 |
|
|
fi |
54 |
|
|
done |
55 |
|
|
|
56 |
|
|
%clean |
57 |
|
|
[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT |
58 |
|
|
|
59 |
|
|
%post |
60 |
|
|
|
61 |
|
|
%postun |
62 |
|
|
|
63 |
|
|
%files |
64 |
|
|
%defattr(-,root,root) |
65 |
|
|
# Include top level with %dir so not all files are sucked in |
66 |
|
|
%dir %{contentdir}/html/horde/nag |
67 |
|
|
# Include top-level files by hand |
68 |
|
|
%{contentdir}/html/horde/nag/*.php |
69 |
|
|
# Include these dirs so that all files _will_ get sucked in |
70 |
|
|
%{contentdir}/html/horde/nag/js |
71 |
|
|
%{contentdir}/html/horde/nag/lib |
72 |
|
|
%{contentdir}/html/horde/nag/locale |
73 |
|
|
%{contentdir}/html/horde/nag/po |
74 |
|
|
%{contentdir}/html/horde/nag/scripts |
75 |
|
|
%{contentdir}/html/horde/nag/templates |
76 |
|
|
%{contentdir}/html/horde/nag/themes |
77 |
|
|
%{contentdir}/html/horde/nag/tasklists/ |
78 |
|
|
%{contentdir}/html/horde/nag/tasks/ |
79 |
|
|
# Mark documentation files with %doc and %docdir |
80 |
|
|
%doc %{contentdir}/html/horde/nag/COPYING |
81 |
|
|
%doc %{contentdir}/html/horde/nag/README |
82 |
|
|
%docdir %{contentdir}/html/horde/nag/docs |
83 |
|
|
%{contentdir}/html/horde/nag/docs |
84 |
|
|
# Mark configuration files with %config and use secure permissions |
85 |
|
|
# (note that .dist files are considered software; don't mark %config) |
86 |
|
|
%attr(750,root,%{apachegroup}) %dir %{contentdir}/html/horde/nag/config |
87 |
|
|
%defattr(640,root,%{apachegroup}) |
88 |
|
|
%{contentdir}/html/horde/nag/config/.htaccess |
89 |
|
|
%{contentdir}/html/horde/nag/config/*.dist |
90 |
|
|
%config %{contentdir}/html/horde/nag/config/*.php |
91 |
|
|
%config %{contentdir}/html/horde/nag/config/*.xml |
92 |
|
|
|
93 |
|
|
%changelog |
94 |
|
|
* Mon May 10 2010 John H. Bennett III <bennettj@johnbennettservices.com> 2.3.5-1 |
95 |
|
|
- Updated to Nag 2.3.5 |
96 |
|
|
|
97 |
|
|
* Sun Dec 27 2009 John H. Bennett III <bennettj@johnbennettservices.com> 2.3.4-1 |
98 |
|
|
- Updated to Nag 2.3.4 |
99 |
|
|
|
100 |
|
|
* Sat Oct 10 2009 John H. Bennett III <bennettj@johnbennettservices.com> 2.3.3-1 |
101 |
|
|
- Updated to Nag 2.3.3 |
102 |
|
|
|
103 |
|
|
* Wed Jun 17 2009 John H. Bennett III <bennettj@johnbennettservices.com> 2.3.2-1 |
104 |
|
|
- Updated to Nag 2.3.2 |
105 |
|
|
|
106 |
|
|
* Sat Dec 06 2008 John H. Bennett III <bennettj@johnbennettservices.com> 2.3.1-1 |
107 |
|
|
- Updated to Nag 2.3.1 |
108 |
|
|
|
109 |
|
|
* Sun Sep 28 2008 John H. Bennett III <bennettj@johnbennettservices.com> 2.3-1 |
110 |
|
|
- Updated to Nag 2.3 |
111 |
|
|
|
112 |
|
|
* Mon Jun 2 2008 John H. Bennett III <bennettj@johnbennettservices.com> 2.2-1 |
113 |
|
|
- initial RPM roll for Nag 2.2 |