/[smecontribs]/rpms/nextcloud/contribs10/nextcloud.spec
ViewVC logotype

Annotation of /rpms/nextcloud/contribs10/nextcloud.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.7 - (hide annotations) (download)
Fri Jul 8 15:17:33 2022 UTC (22 months, 2 weeks ago) by jpp
Branch: MAIN
CVS Tags: nextcloud-24_0_2-3_el7_sme
Changes since 1.6: +6 -74 lines
* Fri Jul 08 2022 Jean-Philippe Pialasse <tests@pialasse.com> 24.0.2-3.sme
- removing pre and postun scripts
- fix dist permissions

1 jpp 1.4 %define version 24.0.2
2 jpp 1.7 %define release 3
3 jpp 1.1
4     %define apache_serverroot /usr/share
5     %define apache_confdir /etc/httpd/conf.d
6 jpp 1.4 %define nc_dir %{apache_serverroot}/nextcloud-src
7 jpp 1.1 %define nc_config_dir %{nc_dir}/config
8     %define nc_data_dir %{nc_dir}/data
9    
10     %define nc_user www
11     %define nc_group www
12    
13     # Turn off the brp-python-bytecompile script
14     %global __os_install_post %(echo '%{__os_install_post}' | sed -e 's!/usr/lib[^[:space:]]*/brp-python-bytecompile[[:space:]].*$!!g')
15    
16    
17     Summary: Nextcloud package
18     Name: nextcloud
19     Version: %{version}
20     Release: %{release}%{?dist}
21     License: GPL
22     Source: https://download.nextcloud.com/server/releases/nextcloud-%{version}.tar.bz2
23     Source1: nextcloud.conf
24     BuildArch: noarch
25     URL: https://nextcloud.com/
26    
27     BuildRequires: httpd
28    
29     Requires: httpd
30     # Required php packages
31 jpp 1.2 Requires: php74
32     Requires: php74-php-fpm
33     Requires: php74-php-gd
34     Requires: php74-php-pdo
35     Requires: php74-php-mbstring
36     Requires: php74-php-pecl-zip
37     Requires: php74-php-imagick
38 jpp 1.1
39     # Recommended php packages
40 jpp 1.2 Requires: php74-php-intl
41     Requires: php74-php-mcrypt
42 jpp 1.1
43     # Required php packages for specific apps
44 jpp 1.2 Requires: php74-php-ldap
45 jpp 1.1
46     # Required php packages for MariaDB
47 jpp 1.2 Requires: php74-php-mysqlnd
48 jpp 1.1 #rh-php71-php-pdo_mysql
49    
50     # Conflicts: nextcloud < 15
51    
52     %description
53     Nextcloud files and configuration.
54    
55     This package installs as follows:
56     nc_dir: %{nc_dir}
57     nc_data_dir: %{nc_data_dir}
58     nc_config_dir: %{nc_config_dir}
59    
60 jpp 1.4
61     %package src
62     Summary: Webtatic Repository
63     %description src
64     Nextcloud files and configuration.
65    
66     This package installs as follows:
67     nc_dir: %{nc_dir}
68     nc_data_dir: %{nc_data_dir}
69     nc_config_dir: %{nc_config_dir}
70    
71 jpp 1.1 %pre
72    
73     %postun
74    
75     %install
76     rm -rf %{buildroot}
77     mkdir -p %{buildroot}/%{nc_data_dir}
78 jpp 1.4 mkdir -p %{buildroot}/usr/share/nextcloud-src
79     tar xf %{SOURCE0} -C %{buildroot}/usr/share/nextcloud-src --strip-components 1
80     #mv %{buildroot}/usr/share/nextcloud %{buildroot}/usr/share/nextcloud-src
81 jpp 1.1
82     mkdir -p %{buildroot}/%{nc_dir}
83     mkdir -p %{buildroot}/%{nc_dir}/etc
84     mkdir -p %{buildroot}/%{nc_data_dir}
85     mkdir -p %{buildroot}/%{nc_config_dir}
86     # mkdir -p %{buildroot}/%{nc_dir}/assets
87     mkdir -p %{buildroot}/%{nc_dir}/updater
88    
89     mkdir -p %{buildroot}/etc/httpd/conf.d
90     cp %{SOURCE1} %{buildroot}/etc/httpd/conf.d
91    
92    
93 jpp 1.4 %files src
94 jpp 1.1 %defattr(0640,root,%{nc_group},0750)
95     %dir %attr(0775,root,%{nc_group}) %{nc_dir}
96     %attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/occ
97     %attr(0750,%{nc_user},%{nc_group}) %{nc_dir}/apps
98     # %attr(0750,%{nc_user},%{nc_group}) %{nc_dir}/assets
99     %attr(0750,%{nc_user},%{nc_group}) %{nc_dir}/updater
100     %attr(0775,%{nc_user},%{nc_group}) %{nc_data_dir}
101     %attr(0775,%{nc_user},%{nc_group}) %{nc_config_dir}
102     %attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/lib
103     %attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/ocm-provider
104     %attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/core
105 jpp 1.3 #%attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/settings
106 jpp 1.1 %attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/3rdparty
107     %attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/resources
108     %attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/themes
109     %attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/ocs*
110     %attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/*.php
111     %attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/AUTHORS
112     %attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/COPYING
113     %attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/index.html
114     %attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/robots.txt
115     %attr(0644,%{nc_user},%{nc_group}) %{nc_dir}/.htaccess
116 jpp 1.7 %attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/dist
117 jpp 1.1
118     %config(noreplace) %attr(0644,%{nc_user},%{nc_group}) %{nc_dir}/.user.ini
119     %config(noreplace) %attr(0644,root,root) /etc/httpd/conf.d/nextcloud.conf
120    
121     %defattr(0644,%{nc_user},%{nc_group},0755)
122    
123    
124     %changelog
125 jpp 1.7 * Fri Jul 08 2022 Jean-Philippe Pialasse <tests@pialasse.com> 24.0.2-3.sme
126     - removing pre and postun scripts
127     - fix dist permissions
128    
129 jpp 1.4 * Fri Jul 08 2022 Jean-Philippe Pialasse <tests@pialasse.com> 24.0.2-2.sme
130     - update to release 24.0.2
131     - make rpm a -src to avoid conflict between webupdates and rpm
132    
133     * Sun Nov 08 2020 Jean-Philipe Pialasse <tests@pialasse.com> 20.0.1-2.sme
134 jpp 1.2 - first import in SME10 [SME: 11086]
135     - update to release 20.0.1
136    
137 jpp 1.1 * Sun Dec 15 2019 Jean-Philipe Pialasse <tests@pialasse.com> 17.0.1-1.sme
138     - update to release 17.0.1
139    
140     * Sun Sep 08 2019 Jean-Philipe Pialasse <tests@pialasse.com> 16.0.4-1.sme
141     - Update to release 16.0.4 [SME: 10803]
142    
143     * Wed Mar 06 2019 Jean-Philipe Pialasse <tests@pialasse.com> 15.0.0-6.sme
144     - fix typo in postun script [SME: 10747]
145    
146     * Tue Jan 08 2019 Jean-Philipe Pialasse <tests@pialasse.com> 15.0.0-5.sme
147     - remove conflicts nextcloud <15 to allow people to use the rpm update if they are
148     with manual updated version 14 with rpm version 13 [SME: 10696]
149    
150     * Mon Jan 07 2019 Jean-Philipe Pialasse <tests@pialasse.com> 15.0.0-4.sme
151     - prevent rpm to upgrade if webupdate has been used [SME: 10670]
152     and rpm version is < to on disk version
153     or if rppm version is more than one major release greater
154    
155     * Fri Dec 21 2018 Jean-Philipe Pialasse <tests@pialasse.com> 15.0.0-3.sme
156     - Update to release 15.0.0 [SME: 10669]
157    
158     * Wed Dec 19 2018 Jean-Philipe Pialasse <tests@pialasse.com> 13.0.1-5.sme
159     - fix failure to update [SME: 10596]
160     remove assets folder before 13.0.4 update
161    
162     * Sat Apr 07 2018 Jean-Philipe Pialasse <tests@pialasse.com> 13.0.1-4.sme
163     - missing dependency for php71-php-pecl-zip [SME: 10554]
164    
165     * Wed Mar 28 2018 Jean-Philipe Pialasse <tests@pialasse.com> 13.0.1-3.sme
166     - import for SME9 using remi scl
167    
168     * Mon Mar 19 2018 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - 13.0.1-1
169     - Update to release 13.0.1
170    
171     * Tue Mar 06 2018 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - 13.0.0-1
172     - Update to release 13.0.0
173    
174     * Thu Jan 25 2018 Alessandro Polidori <alessandro.polidori@nethesis.it> - 12.0.5-1
175     - Update to release 12.0.5
176    
177     * Mon Jan 15 2018 Alessandro Polidori <alessandro.polidori@nethesis.it> - 12.0.4-2
178     - Spec: remove "config" sign from .htaccess
179    
180     * Thu Dec 14 2017 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - 12.0.4-1
181     - Update to release 12.0.4
182    
183     * Wed Sep 27 2017 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - 12.0.3
184     - Update to release 12.0.3
185    
186     * Tue Aug 29 2017 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - 12.0.2-2
187     - Avoid security warnings on python compiled files
188    
189     * Wed Aug 23 2017 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - 12.0.2
190     - Update to release 12.0.2
191    
192     * Wed May 24 2017 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - 12.0.0
193     - Update to release 12.0.0
194     - Fix spec warnings - Thanks to @mbevc1
195    
196     * Wed May 17 2017 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - 11.0.3-2
197     - Fix WebDAV authentication - Thanks to Davide Principi
198    
199     * Wed May 17 2017 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - 11.0.3
200     - Update to release 11.0.3
201    
202     * Wed Mar 15 2017 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - 11.0.2
203     - Update to release 11.0.2
204     - Move installation inside /usr/share/nextcloud
205     - Switch to php-fpm
206    
207     * Thu Dec 15 2016 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - 10.0.2
208     - Bump release: 10.0.2
209    
210     * Mon Aug 01 2016 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - 9.0.53-2
211     - First Nextcloud release - NethServer/dev#5055
212    

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed