/[smecontribs]/rpms/nextcloud/contribs10/nextcloud.spec
ViewVC logotype

Annotation of /rpms/nextcloud/contribs10/nextcloud.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.10 - (hide annotations) (download)
Mon Jan 29 03:36:49 2024 UTC (3 months, 3 weeks ago) by jpp
Branch: MAIN
CVS Tags: nextcloud-26_0_11-1_el7_sme, HEAD
Changes since 1.9: +5 -0 lines
* Sun Jan 28 2024 Jean-Philippe Pialasse <tests@pialasse.com> 26.0.11-1.sme
- update to release 26.0.11

1 jpp 1.8 %define version 26.0.11
2     %define release 1
3 jpp 1.1
4     %define apache_serverroot /usr/share
5     %define apache_confdir /etc/httpd/conf.d
6 jpp 1.4 %define nc_dir %{apache_serverroot}/nextcloud-src
7 jpp 1.1 %define nc_config_dir %{nc_dir}/config
8     %define nc_data_dir %{nc_dir}/data
9    
10     %define nc_user www
11     %define nc_group www
12    
13     # Turn off the brp-python-bytecompile script
14     %global __os_install_post %(echo '%{__os_install_post}' | sed -e 's!/usr/lib[^[:space:]]*/brp-python-bytecompile[[:space:]].*$!!g')
15    
16    
17     Summary: Nextcloud package
18     Name: nextcloud
19     Version: %{version}
20     Release: %{release}%{?dist}
21     License: GPL
22     Source: https://download.nextcloud.com/server/releases/nextcloud-%{version}.tar.bz2
23     Source1: nextcloud.conf
24     BuildArch: noarch
25     URL: https://nextcloud.com/
26    
27     BuildRequires: httpd
28    
29     Requires: httpd
30     # Required php packages
31 jpp 1.8 Requires: php81
32     Requires: php81-php-fpm
33     Requires: php81-php-gd
34     Requires: php81-php-pdo
35     Requires: php81-php-mbstring
36     Requires: php81-php-pecl-zip
37     Requires: php81-php-imagick
38 jpp 1.1
39     # Recommended php packages
40 jpp 1.8 Requires: php81-php-intl
41     Requires: php81-php-mcrypt
42 jpp 1.1
43     # Required php packages for specific apps
44 jpp 1.8 Requires: php81-php-ldap
45 jpp 1.1
46     # Required php packages for MariaDB
47 jpp 1.8 Requires: php81-php-mysqlnd
48 jpp 1.1 #rh-php71-php-pdo_mysql
49    
50    
51     %description
52     Nextcloud files and configuration.
53    
54     This package installs as follows:
55     nc_dir: %{nc_dir}
56     nc_data_dir: %{nc_data_dir}
57     nc_config_dir: %{nc_config_dir}
58    
59 jpp 1.4
60     %package src
61     Summary: Webtatic Repository
62     %description src
63     Nextcloud files and configuration.
64    
65     This package installs as follows:
66     nc_dir: %{nc_dir}
67     nc_data_dir: %{nc_data_dir}
68     nc_config_dir: %{nc_config_dir}
69    
70 jpp 1.1 %pre
71    
72     %postun
73    
74     %install
75     rm -rf %{buildroot}
76     mkdir -p %{buildroot}/%{nc_data_dir}
77 jpp 1.4 mkdir -p %{buildroot}/usr/share/nextcloud-src
78     tar xf %{SOURCE0} -C %{buildroot}/usr/share/nextcloud-src --strip-components 1
79     #mv %{buildroot}/usr/share/nextcloud %{buildroot}/usr/share/nextcloud-src
80 jpp 1.1
81     mkdir -p %{buildroot}/%{nc_dir}
82     mkdir -p %{buildroot}/%{nc_dir}/etc
83     mkdir -p %{buildroot}/%{nc_data_dir}
84     mkdir -p %{buildroot}/%{nc_config_dir}
85     # mkdir -p %{buildroot}/%{nc_dir}/assets
86     mkdir -p %{buildroot}/%{nc_dir}/updater
87    
88     mkdir -p %{buildroot}/etc/httpd/conf.d
89     cp %{SOURCE1} %{buildroot}/etc/httpd/conf.d
90    
91    
92 jpp 1.4 %files src
93 jpp 1.1 %defattr(0640,root,%{nc_group},0750)
94     %dir %attr(0775,root,%{nc_group}) %{nc_dir}
95     %attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/occ
96     %attr(0750,%{nc_user},%{nc_group}) %{nc_dir}/apps
97     # %attr(0750,%{nc_user},%{nc_group}) %{nc_dir}/assets
98     %attr(0750,%{nc_user},%{nc_group}) %{nc_dir}/updater
99     %attr(0775,%{nc_user},%{nc_group}) %{nc_data_dir}
100     %attr(0775,%{nc_user},%{nc_group}) %{nc_config_dir}
101     %attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/lib
102 jpp 1.9 #%attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/ocm-provider
103 jpp 1.1 %attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/core
104 jpp 1.3 #%attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/settings
105 jpp 1.1 %attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/3rdparty
106     %attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/resources
107     %attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/themes
108     %attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/ocs*
109     %attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/*.php
110     %attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/AUTHORS
111     %attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/COPYING
112     %attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/index.html
113     %attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/robots.txt
114     %attr(0644,%{nc_user},%{nc_group}) %{nc_dir}/.htaccess
115 jpp 1.7 %attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/dist
116 jpp 1.1
117 jpp 1.10 %attr(0644,%{nc_user},%{nc_group}) %{nc_dir}/composer.json
118     %attr(0644,%{nc_user},%{nc_group}) %{nc_dir}/composer.lock
119     %attr(0644,%{nc_user},%{nc_group}) %{nc_dir}/package-lock.json
120     %attr(0644,%{nc_user},%{nc_group}) %{nc_dir}/package.json
121    
122 jpp 1.1 %config(noreplace) %attr(0644,%{nc_user},%{nc_group}) %{nc_dir}/.user.ini
123     %config(noreplace) %attr(0644,root,root) /etc/httpd/conf.d/nextcloud.conf
124    
125     %defattr(0644,%{nc_user},%{nc_group},0755)
126    
127    
128     %changelog
129 jpp 1.8 * Sun Jan 28 2024 Jean-Philippe Pialasse <tests@pialasse.com> 26.0.11-1.sme
130     - update to release 26.0.11
131    
132 jpp 1.7 * Fri Jul 08 2022 Jean-Philippe Pialasse <tests@pialasse.com> 24.0.2-3.sme
133     - removing pre and postun scripts
134     - fix dist permissions
135    
136 jpp 1.4 * Fri Jul 08 2022 Jean-Philippe Pialasse <tests@pialasse.com> 24.0.2-2.sme
137     - update to release 24.0.2
138     - make rpm a -src to avoid conflict between webupdates and rpm
139    
140     * Sun Nov 08 2020 Jean-Philipe Pialasse <tests@pialasse.com> 20.0.1-2.sme
141 jpp 1.2 - first import in SME10 [SME: 11086]
142     - update to release 20.0.1
143    
144 jpp 1.1 * Sun Dec 15 2019 Jean-Philipe Pialasse <tests@pialasse.com> 17.0.1-1.sme
145     - update to release 17.0.1
146    
147     * Sun Sep 08 2019 Jean-Philipe Pialasse <tests@pialasse.com> 16.0.4-1.sme
148     - Update to release 16.0.4 [SME: 10803]
149    
150     * Wed Mar 06 2019 Jean-Philipe Pialasse <tests@pialasse.com> 15.0.0-6.sme
151     - fix typo in postun script [SME: 10747]
152    
153     * Tue Jan 08 2019 Jean-Philipe Pialasse <tests@pialasse.com> 15.0.0-5.sme
154     - remove conflicts nextcloud <15 to allow people to use the rpm update if they are
155     with manual updated version 14 with rpm version 13 [SME: 10696]
156    
157     * Mon Jan 07 2019 Jean-Philipe Pialasse <tests@pialasse.com> 15.0.0-4.sme
158     - prevent rpm to upgrade if webupdate has been used [SME: 10670]
159     and rpm version is < to on disk version
160     or if rppm version is more than one major release greater
161    
162     * Fri Dec 21 2018 Jean-Philipe Pialasse <tests@pialasse.com> 15.0.0-3.sme
163     - Update to release 15.0.0 [SME: 10669]
164    
165     * Wed Dec 19 2018 Jean-Philipe Pialasse <tests@pialasse.com> 13.0.1-5.sme
166     - fix failure to update [SME: 10596]
167     remove assets folder before 13.0.4 update
168    
169     * Sat Apr 07 2018 Jean-Philipe Pialasse <tests@pialasse.com> 13.0.1-4.sme
170     - missing dependency for php71-php-pecl-zip [SME: 10554]
171    
172     * Wed Mar 28 2018 Jean-Philipe Pialasse <tests@pialasse.com> 13.0.1-3.sme
173     - import for SME9 using remi scl
174    
175     * Mon Mar 19 2018 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - 13.0.1-1
176     - Update to release 13.0.1
177    
178     * Tue Mar 06 2018 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - 13.0.0-1
179     - Update to release 13.0.0
180    
181     * Thu Jan 25 2018 Alessandro Polidori <alessandro.polidori@nethesis.it> - 12.0.5-1
182     - Update to release 12.0.5
183    
184     * Mon Jan 15 2018 Alessandro Polidori <alessandro.polidori@nethesis.it> - 12.0.4-2
185     - Spec: remove "config" sign from .htaccess
186    
187     * Thu Dec 14 2017 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - 12.0.4-1
188     - Update to release 12.0.4
189    
190     * Wed Sep 27 2017 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - 12.0.3
191     - Update to release 12.0.3
192    
193     * Tue Aug 29 2017 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - 12.0.2-2
194     - Avoid security warnings on python compiled files
195    
196     * Wed Aug 23 2017 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - 12.0.2
197     - Update to release 12.0.2
198    
199     * Wed May 24 2017 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - 12.0.0
200     - Update to release 12.0.0
201     - Fix spec warnings - Thanks to @mbevc1
202    
203     * Wed May 17 2017 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - 11.0.3-2
204     - Fix WebDAV authentication - Thanks to Davide Principi
205    
206     * Wed May 17 2017 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - 11.0.3
207     - Update to release 11.0.3
208    
209     * Wed Mar 15 2017 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - 11.0.2
210     - Update to release 11.0.2
211     - Move installation inside /usr/share/nextcloud
212     - Switch to php-fpm
213    
214     * Thu Dec 15 2016 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - 10.0.2
215     - Bump release: 10.0.2
216    
217     * Mon Aug 01 2016 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - 9.0.53-2
218     - First Nextcloud release - NethServer/dev#5055
219    

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed