/[smecontribs]/rpms/nextcloud/contribs9/nextcloud.spec
ViewVC logotype

Annotation of /rpms/nextcloud/contribs9/nextcloud.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.2 - (hide annotations) (download)
Thu Mar 29 17:55:24 2018 UTC (6 years, 1 month ago) by jpp
Branch: MAIN
CVS Tags: nextcloud-13_0_1-3_el6_sme
Changes since 1.1: +2 -2 lines
* Wed Mar 28 2018 Jean-Philipe Pialasse <tests@pialasse.com> 13.0.1-3.sme
- import for SME9 using remi scl

1 jpp 1.1 %define version 13.0.1
2 jpp 1.2 %define release 3
3 jpp 1.1
4     %define apache_serverroot /usr/share
5     %define apache_confdir /etc/httpd/conf.d
6     %define nc_dir %{apache_serverroot}/nextcloud
7     %define nc_config_dir %{nc_dir}/config
8     %define nc_data_dir %{nc_dir}/data
9    
10     %define nc_user apache
11     %define nc_group apache
12    
13     # Turn off the brp-python-bytecompile script
14     %global __os_install_post %(echo '%{__os_install_post}' | sed -e 's!/usr/lib[^[:space:]]*/brp-python-bytecompile[[:space:]].*$!!g')
15    
16    
17     Summary: Nextcloud package
18     Name: nextcloud
19     Version: %{version}
20     Release: %{release}%{?dist}
21     License: GPL
22     Source: https://download.nextcloud.com/server/releases/nextcloud-%{version}.tar.bz2
23     Source1: nextcloud.conf
24     BuildArch: noarch
25     URL: https://nextcloud.com/
26    
27     BuildRequires: httpd
28    
29     Requires: httpd
30     # Required php packages
31     Requires: php71
32     Requires: php71-php-fpm
33     Requires: php71-php-gd
34     Requires: php71-php-pdo
35     Requires: php71-php-mbstring
36    
37     # Recommended php packages
38     Requires: php71-php-intl
39     Requires: php71-php-mcrypt
40    
41     # Required php packages for specific apps
42     Requires: php71-php-ldap
43    
44     # Required php packages for MariaDB
45     Requires: php71-php-mysqlnd
46     #rh-php71-php-pdo_mysql
47    
48    
49     %description
50     Nextcloud files and configuration.
51    
52     This package installs as follows:
53     nc_dir: %{nc_dir}
54     nc_data_dir: %{nc_data_dir}
55     nc_config_dir: %{nc_config_dir}
56    
57    
58     %install
59     rm -rf %{buildroot}
60     mkdir -p %{buildroot}/%{nc_data_dir}
61     mkdir -p %{buildroot}/usr/share
62     tar xf %{SOURCE0} -C %{buildroot}/usr/share
63    
64     mkdir -p %{buildroot}/%{nc_dir}
65     mkdir -p %{buildroot}/%{nc_dir}/etc
66     mkdir -p %{buildroot}/%{nc_data_dir}
67     mkdir -p %{buildroot}/%{nc_config_dir}
68     mkdir -p %{buildroot}/%{nc_dir}/assets
69     mkdir -p %{buildroot}/%{nc_dir}/updater
70    
71     mkdir -p %{buildroot}/etc/httpd/conf.d
72     cp %{SOURCE1} %{buildroot}/etc/httpd/conf.d
73    
74    
75     %files
76     %defattr(0640,root,%{nc_group},0750)
77     %dir %attr(0755,root,%{nc_group}) %{nc_dir}
78     %attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/occ
79     %attr(0750,%{nc_user},%{nc_group}) %{nc_dir}/apps
80     %attr(0750,%{nc_user},%{nc_group}) %{nc_dir}/assets
81     %attr(0750,%{nc_user},%{nc_group}) %{nc_dir}/updater
82     %attr(0775,%{nc_user},%{nc_group}) %{nc_data_dir}
83     %attr(0775,%{nc_user},%{nc_group}) %{nc_config_dir}
84     %attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/lib
85     %attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/core
86     %attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/settings
87     %attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/3rdparty
88     %attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/resources
89     %attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/themes
90     %attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/ocs*
91     %attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/*.php
92     %attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/AUTHORS
93     %attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/index.html
94     %attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/robots.txt
95     %attr(0644,%{nc_user},%{nc_group}) %{nc_dir}/.htaccess
96    
97     %config(noreplace) %attr(0644,%{nc_user},%{nc_group}) %{nc_dir}/.user.ini
98     %config(noreplace) %attr(0644,root,root) /etc/httpd/conf.d/nextcloud.conf
99    
100     %defattr(0644,%{nc_user},%{nc_group},0755)
101    
102    
103     %changelog
104 jpp 1.2 * Wed Mar 28 2018 Jean-Philipe Pialasse <tests@pialasse.com> 13.0.1-3.sme
105 jpp 1.1 - import for SME9 using remi scl
106    
107     * Mon Mar 19 2018 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - 13.0.1-1
108     - Update to release 13.0.1
109    
110     * Tue Mar 06 2018 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - 13.0.0-1
111     - Update to release 13.0.0
112    
113     * Thu Jan 25 2018 Alessandro Polidori <alessandro.polidori@nethesis.it> - 12.0.5-1
114     - Update to release 12.0.5
115    
116     * Mon Jan 15 2018 Alessandro Polidori <alessandro.polidori@nethesis.it> - 12.0.4-2
117     - Spec: remove "config" sign from .htaccess
118    
119     * Thu Dec 14 2017 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - 12.0.4-1
120     - Update to release 12.0.4
121    
122     * Wed Sep 27 2017 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - 12.0.3
123     - Update to release 12.0.3
124    
125     * Tue Aug 29 2017 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - 12.0.2-2
126     - Avoid security warnings on python compiled files
127    
128     * Wed Aug 23 2017 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - 12.0.2
129     - Update to release 12.0.2
130    
131     * Wed May 24 2017 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - 12.0.0
132     - Update to release 12.0.0
133     - Fix spec warnings - Thanks to @mbevc1
134    
135     * Wed May 17 2017 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - 11.0.3-2
136     - Fix WebDAV authentication - Thanks to Davide Principi
137    
138     * Wed May 17 2017 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - 11.0.3
139     - Update to release 11.0.3
140    
141     * Wed Mar 15 2017 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - 11.0.2
142     - Update to release 11.0.2
143     - Move installation inside /usr/share/nextcloud
144     - Switch to php-fpm
145    
146     * Thu Dec 15 2016 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - 10.0.2
147     - Bump release: 10.0.2
148    
149     * Mon Aug 01 2016 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - 9.0.53-2
150     - First Nextcloud release - NethServer/dev#5055
151    

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed