/[smecontribs]/rpms/nextcloud/contribs9/nextcloud.spec
ViewVC logotype

Annotation of /rpms/nextcloud/contribs9/nextcloud.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.4 - (hide annotations) (download)
Thu Dec 20 02:56:20 2018 UTC (5 years, 5 months ago) by jpp
Branch: MAIN
CVS Tags: nextcloud-13_0_1-5_el6_sme
Changes since 1.3: +8 -4 lines
* Wed Dec 19 2018 Jean-Philipe Pialasse <tests@pialasse.com> 13.0.1-5.sme
- fix failure to update [SME: 10596]
  remove assets folder before 13.0.4  update

1 jpp 1.1 %define version 13.0.1
2 jpp 1.4 %define release 5
3 jpp 1.1
4     %define apache_serverroot /usr/share
5     %define apache_confdir /etc/httpd/conf.d
6     %define nc_dir %{apache_serverroot}/nextcloud
7     %define nc_config_dir %{nc_dir}/config
8     %define nc_data_dir %{nc_dir}/data
9    
10     %define nc_user apache
11     %define nc_group apache
12    
13     # Turn off the brp-python-bytecompile script
14     %global __os_install_post %(echo '%{__os_install_post}' | sed -e 's!/usr/lib[^[:space:]]*/brp-python-bytecompile[[:space:]].*$!!g')
15    
16    
17     Summary: Nextcloud package
18     Name: nextcloud
19     Version: %{version}
20     Release: %{release}%{?dist}
21     License: GPL
22     Source: https://download.nextcloud.com/server/releases/nextcloud-%{version}.tar.bz2
23     Source1: nextcloud.conf
24     BuildArch: noarch
25     URL: https://nextcloud.com/
26    
27     BuildRequires: httpd
28    
29     Requires: httpd
30     # Required php packages
31     Requires: php71
32     Requires: php71-php-fpm
33     Requires: php71-php-gd
34     Requires: php71-php-pdo
35     Requires: php71-php-mbstring
36 jpp 1.3 Requires: php71-php-pecl-zip
37 jpp 1.1
38     # Recommended php packages
39     Requires: php71-php-intl
40     Requires: php71-php-mcrypt
41    
42     # Required php packages for specific apps
43     Requires: php71-php-ldap
44    
45     # Required php packages for MariaDB
46     Requires: php71-php-mysqlnd
47     #rh-php71-php-pdo_mysql
48    
49    
50     %description
51     Nextcloud files and configuration.
52    
53     This package installs as follows:
54     nc_dir: %{nc_dir}
55     nc_data_dir: %{nc_data_dir}
56     nc_config_dir: %{nc_config_dir}
57    
58    
59     %install
60     rm -rf %{buildroot}
61     mkdir -p %{buildroot}/%{nc_data_dir}
62     mkdir -p %{buildroot}/usr/share
63     tar xf %{SOURCE0} -C %{buildroot}/usr/share
64    
65     mkdir -p %{buildroot}/%{nc_dir}
66     mkdir -p %{buildroot}/%{nc_dir}/etc
67     mkdir -p %{buildroot}/%{nc_data_dir}
68     mkdir -p %{buildroot}/%{nc_config_dir}
69 jpp 1.4 # mkdir -p %{buildroot}/%{nc_dir}/assets
70 jpp 1.1 mkdir -p %{buildroot}/%{nc_dir}/updater
71    
72     mkdir -p %{buildroot}/etc/httpd/conf.d
73     cp %{SOURCE1} %{buildroot}/etc/httpd/conf.d
74    
75    
76     %files
77     %defattr(0640,root,%{nc_group},0750)
78 jpp 1.4 %dir %attr(0775,root,%{nc_group}) %{nc_dir}
79 jpp 1.1 %attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/occ
80     %attr(0750,%{nc_user},%{nc_group}) %{nc_dir}/apps
81 jpp 1.4 # %attr(0750,%{nc_user},%{nc_group}) %{nc_dir}/assets
82 jpp 1.1 %attr(0750,%{nc_user},%{nc_group}) %{nc_dir}/updater
83     %attr(0775,%{nc_user},%{nc_group}) %{nc_data_dir}
84     %attr(0775,%{nc_user},%{nc_group}) %{nc_config_dir}
85     %attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/lib
86     %attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/core
87     %attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/settings
88     %attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/3rdparty
89     %attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/resources
90     %attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/themes
91     %attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/ocs*
92     %attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/*.php
93     %attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/AUTHORS
94     %attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/index.html
95     %attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/robots.txt
96     %attr(0644,%{nc_user},%{nc_group}) %{nc_dir}/.htaccess
97    
98     %config(noreplace) %attr(0644,%{nc_user},%{nc_group}) %{nc_dir}/.user.ini
99     %config(noreplace) %attr(0644,root,root) /etc/httpd/conf.d/nextcloud.conf
100    
101     %defattr(0644,%{nc_user},%{nc_group},0755)
102    
103    
104     %changelog
105 jpp 1.4 * Wed Dec 19 2018 Jean-Philipe Pialasse <tests@pialasse.com> 13.0.1-5.sme
106     - fix failure to update [SME: 10596]
107     remove assets folder before 13.0.4 update
108    
109 jpp 1.3 * Sat Apr 07 2018 Jean-Philipe Pialasse <tests@pialasse.com> 13.0.1-4.sme
110     - missing dependency for php71-php-pecl-zip [SME: 10554]
111    
112 jpp 1.2 * Wed Mar 28 2018 Jean-Philipe Pialasse <tests@pialasse.com> 13.0.1-3.sme
113 jpp 1.1 - import for SME9 using remi scl
114    
115     * Mon Mar 19 2018 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - 13.0.1-1
116     - Update to release 13.0.1
117    
118     * Tue Mar 06 2018 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - 13.0.0-1
119     - Update to release 13.0.0
120    
121     * Thu Jan 25 2018 Alessandro Polidori <alessandro.polidori@nethesis.it> - 12.0.5-1
122     - Update to release 12.0.5
123    
124     * Mon Jan 15 2018 Alessandro Polidori <alessandro.polidori@nethesis.it> - 12.0.4-2
125     - Spec: remove "config" sign from .htaccess
126    
127     * Thu Dec 14 2017 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - 12.0.4-1
128     - Update to release 12.0.4
129    
130     * Wed Sep 27 2017 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - 12.0.3
131     - Update to release 12.0.3
132    
133     * Tue Aug 29 2017 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - 12.0.2-2
134     - Avoid security warnings on python compiled files
135    
136     * Wed Aug 23 2017 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - 12.0.2
137     - Update to release 12.0.2
138    
139     * Wed May 24 2017 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - 12.0.0
140     - Update to release 12.0.0
141     - Fix spec warnings - Thanks to @mbevc1
142    
143     * Wed May 17 2017 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - 11.0.3-2
144     - Fix WebDAV authentication - Thanks to Davide Principi
145    
146     * Wed May 17 2017 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - 11.0.3
147     - Update to release 11.0.3
148    
149     * Wed Mar 15 2017 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - 11.0.2
150     - Update to release 11.0.2
151     - Move installation inside /usr/share/nextcloud
152     - Switch to php-fpm
153    
154     * Thu Dec 15 2016 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - 10.0.2
155     - Bump release: 10.0.2
156    
157     * Mon Aug 01 2016 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - 9.0.53-2
158     - First Nextcloud release - NethServer/dev#5055
159    

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed