1 |
jpp |
1.5 |
%define version 15.0.0 |
2 |
jpp |
1.6 |
%define release 2 |
3 |
jpp |
1.1 |
|
4 |
|
|
%define apache_serverroot /usr/share |
5 |
|
|
%define apache_confdir /etc/httpd/conf.d |
6 |
|
|
%define nc_dir %{apache_serverroot}/nextcloud |
7 |
|
|
%define nc_config_dir %{nc_dir}/config |
8 |
|
|
%define nc_data_dir %{nc_dir}/data |
9 |
|
|
|
10 |
jpp |
1.5 |
%define nc_user www |
11 |
|
|
%define nc_group www |
12 |
jpp |
1.1 |
|
13 |
|
|
# Turn off the brp-python-bytecompile script |
14 |
|
|
%global __os_install_post %(echo '%{__os_install_post}' | sed -e 's!/usr/lib[^[:space:]]*/brp-python-bytecompile[[:space:]].*$!!g') |
15 |
|
|
|
16 |
|
|
|
17 |
|
|
Summary: Nextcloud package |
18 |
|
|
Name: nextcloud |
19 |
|
|
Version: %{version} |
20 |
|
|
Release: %{release}%{?dist} |
21 |
|
|
License: GPL |
22 |
|
|
Source: https://download.nextcloud.com/server/releases/nextcloud-%{version}.tar.bz2 |
23 |
|
|
Source1: nextcloud.conf |
24 |
|
|
BuildArch: noarch |
25 |
|
|
URL: https://nextcloud.com/ |
26 |
|
|
|
27 |
|
|
BuildRequires: httpd |
28 |
|
|
|
29 |
|
|
Requires: httpd |
30 |
|
|
# Required php packages |
31 |
|
|
Requires: php71 |
32 |
|
|
Requires: php71-php-fpm |
33 |
|
|
Requires: php71-php-gd |
34 |
|
|
Requires: php71-php-pdo |
35 |
|
|
Requires: php71-php-mbstring |
36 |
jpp |
1.3 |
Requires: php71-php-pecl-zip |
37 |
jpp |
1.5 |
Requires: php71-php-imagick |
38 |
jpp |
1.1 |
|
39 |
|
|
# Recommended php packages |
40 |
|
|
Requires: php71-php-intl |
41 |
|
|
Requires: php71-php-mcrypt |
42 |
|
|
|
43 |
|
|
# Required php packages for specific apps |
44 |
|
|
Requires: php71-php-ldap |
45 |
|
|
|
46 |
|
|
# Required php packages for MariaDB |
47 |
|
|
Requires: php71-php-mysqlnd |
48 |
|
|
#rh-php71-php-pdo_mysql |
49 |
|
|
|
50 |
|
|
|
51 |
|
|
%description |
52 |
|
|
Nextcloud files and configuration. |
53 |
|
|
|
54 |
|
|
This package installs as follows: |
55 |
|
|
nc_dir: %{nc_dir} |
56 |
|
|
nc_data_dir: %{nc_data_dir} |
57 |
|
|
nc_config_dir: %{nc_config_dir} |
58 |
|
|
|
59 |
|
|
|
60 |
|
|
%install |
61 |
|
|
rm -rf %{buildroot} |
62 |
|
|
mkdir -p %{buildroot}/%{nc_data_dir} |
63 |
|
|
mkdir -p %{buildroot}/usr/share |
64 |
|
|
tar xf %{SOURCE0} -C %{buildroot}/usr/share |
65 |
|
|
|
66 |
|
|
mkdir -p %{buildroot}/%{nc_dir} |
67 |
|
|
mkdir -p %{buildroot}/%{nc_dir}/etc |
68 |
|
|
mkdir -p %{buildroot}/%{nc_data_dir} |
69 |
|
|
mkdir -p %{buildroot}/%{nc_config_dir} |
70 |
jpp |
1.4 |
# mkdir -p %{buildroot}/%{nc_dir}/assets |
71 |
jpp |
1.1 |
mkdir -p %{buildroot}/%{nc_dir}/updater |
72 |
|
|
|
73 |
|
|
mkdir -p %{buildroot}/etc/httpd/conf.d |
74 |
|
|
cp %{SOURCE1} %{buildroot}/etc/httpd/conf.d |
75 |
|
|
|
76 |
|
|
|
77 |
|
|
%files |
78 |
|
|
%defattr(0640,root,%{nc_group},0750) |
79 |
jpp |
1.4 |
%dir %attr(0775,root,%{nc_group}) %{nc_dir} |
80 |
jpp |
1.1 |
%attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/occ |
81 |
|
|
%attr(0750,%{nc_user},%{nc_group}) %{nc_dir}/apps |
82 |
jpp |
1.4 |
# %attr(0750,%{nc_user},%{nc_group}) %{nc_dir}/assets |
83 |
jpp |
1.1 |
%attr(0750,%{nc_user},%{nc_group}) %{nc_dir}/updater |
84 |
|
|
%attr(0775,%{nc_user},%{nc_group}) %{nc_data_dir} |
85 |
|
|
%attr(0775,%{nc_user},%{nc_group}) %{nc_config_dir} |
86 |
|
|
%attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/lib |
87 |
|
|
%attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/core |
88 |
|
|
%attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/settings |
89 |
|
|
%attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/3rdparty |
90 |
|
|
%attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/resources |
91 |
|
|
%attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/themes |
92 |
|
|
%attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/ocs* |
93 |
|
|
%attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/*.php |
94 |
|
|
%attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/AUTHORS |
95 |
|
|
%attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/index.html |
96 |
|
|
%attr(0755,%{nc_user},%{nc_group}) %{nc_dir}/robots.txt |
97 |
|
|
%attr(0644,%{nc_user},%{nc_group}) %{nc_dir}/.htaccess |
98 |
|
|
|
99 |
|
|
%config(noreplace) %attr(0644,%{nc_user},%{nc_group}) %{nc_dir}/.user.ini |
100 |
|
|
%config(noreplace) %attr(0644,root,root) /etc/httpd/conf.d/nextcloud.conf |
101 |
|
|
|
102 |
|
|
%defattr(0644,%{nc_user},%{nc_group},0755) |
103 |
|
|
|
104 |
|
|
|
105 |
|
|
%changelog |
106 |
jpp |
1.6 |
* Fri Dec 21 2018 Jean-Philipe Pialasse <tests@pialasse.com> 15.0.0-2.sme |
107 |
jpp |
1.5 |
- Update to release 15.0.0 [SME: 10669] |
108 |
|
|
|
109 |
jpp |
1.4 |
* Wed Dec 19 2018 Jean-Philipe Pialasse <tests@pialasse.com> 13.0.1-5.sme |
110 |
|
|
- fix failure to update [SME: 10596] |
111 |
|
|
remove assets folder before 13.0.4 update |
112 |
|
|
|
113 |
jpp |
1.3 |
* Sat Apr 07 2018 Jean-Philipe Pialasse <tests@pialasse.com> 13.0.1-4.sme |
114 |
|
|
- missing dependency for php71-php-pecl-zip [SME: 10554] |
115 |
|
|
|
116 |
jpp |
1.2 |
* Wed Mar 28 2018 Jean-Philipe Pialasse <tests@pialasse.com> 13.0.1-3.sme |
117 |
jpp |
1.1 |
- import for SME9 using remi scl |
118 |
|
|
|
119 |
|
|
* Mon Mar 19 2018 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - 13.0.1-1 |
120 |
|
|
- Update to release 13.0.1 |
121 |
|
|
|
122 |
|
|
* Tue Mar 06 2018 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - 13.0.0-1 |
123 |
|
|
- Update to release 13.0.0 |
124 |
|
|
|
125 |
|
|
* Thu Jan 25 2018 Alessandro Polidori <alessandro.polidori@nethesis.it> - 12.0.5-1 |
126 |
|
|
- Update to release 12.0.5 |
127 |
|
|
|
128 |
|
|
* Mon Jan 15 2018 Alessandro Polidori <alessandro.polidori@nethesis.it> - 12.0.4-2 |
129 |
|
|
- Spec: remove "config" sign from .htaccess |
130 |
|
|
|
131 |
|
|
* Thu Dec 14 2017 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - 12.0.4-1 |
132 |
|
|
- Update to release 12.0.4 |
133 |
|
|
|
134 |
|
|
* Wed Sep 27 2017 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - 12.0.3 |
135 |
|
|
- Update to release 12.0.3 |
136 |
|
|
|
137 |
|
|
* Tue Aug 29 2017 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - 12.0.2-2 |
138 |
|
|
- Avoid security warnings on python compiled files |
139 |
|
|
|
140 |
|
|
* Wed Aug 23 2017 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - 12.0.2 |
141 |
|
|
- Update to release 12.0.2 |
142 |
|
|
|
143 |
|
|
* Wed May 24 2017 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - 12.0.0 |
144 |
|
|
- Update to release 12.0.0 |
145 |
|
|
- Fix spec warnings - Thanks to @mbevc1 |
146 |
|
|
|
147 |
|
|
* Wed May 17 2017 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - 11.0.3-2 |
148 |
|
|
- Fix WebDAV authentication - Thanks to Davide Principi |
149 |
|
|
|
150 |
|
|
* Wed May 17 2017 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - 11.0.3 |
151 |
|
|
- Update to release 11.0.3 |
152 |
|
|
|
153 |
|
|
* Wed Mar 15 2017 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - 11.0.2 |
154 |
|
|
- Update to release 11.0.2 |
155 |
|
|
- Move installation inside /usr/share/nextcloud |
156 |
|
|
- Switch to php-fpm |
157 |
|
|
|
158 |
|
|
* Thu Dec 15 2016 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - 10.0.2 |
159 |
|
|
- Bump release: 10.0.2 |
160 |
|
|
|
161 |
|
|
* Mon Aug 01 2016 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - 9.0.53-2 |
162 |
|
|
- First Nextcloud release - NethServer/dev#5055 |
163 |
|
|
|