1 |
slords |
1.1 |
%define name ocs |
2 |
|
|
Summary: ocs is an Information Resource Manager |
3 |
|
|
Name: %{name} |
4 |
|
|
%define version 1.01 |
5 |
|
|
%define release 1 |
6 |
|
|
Version: %{version} |
7 |
|
|
Release: %{release}%{?dist} |
8 |
|
|
License: GNU GPL version 2 |
9 |
|
|
URL: http://www.ocsinventory-ng.org/ |
10 |
|
|
Group: SMEserver/addon |
11 |
|
|
Source: OCSNG_LINUX_SERVER_1.01.tar.gz |
12 |
|
|
BuildArchitectures: noarch |
13 |
|
|
BuildRoot: /var/tmp/%{name}-%{version} |
14 |
|
|
Requires: e-smith-release >= 7.0 |
15 |
|
|
AutoReqProv: no |
16 |
|
|
|
17 |
|
|
%description |
18 |
|
|
http://www.ocsinventory-ng.org/ |
19 |
|
|
Open Computer and Software Inventory Next Generation is an |
20 |
|
|
application designed to help a network or system administrator |
21 |
|
|
keep track of the computers configuration and |
22 |
|
|
software that are installed on the network. |
23 |
|
|
|
24 |
|
|
|
25 |
|
|
%changelog |
26 |
|
|
* Mon Dec 24 2007 Stephen Noble <support@dungog.net> 1.01-1 |
27 |
|
|
- initial release |
28 |
|
|
- builds from unchanged .tgz |
29 |
|
|
|
30 |
|
|
%prep |
31 |
|
|
%setup -c -n %{name} |
32 |
|
|
%build |
33 |
|
|
#this lets you drop a .tgz in with the root and it builds ok |
34 |
|
|
mkdir -p root/opt/inventory |
35 |
|
|
mv OCSNG_LINUX_SERVER_1.01 root/opt/inventory/ocs |
36 |
|
|
|
37 |
|
|
#fix later somehow, rpmbuild doesn't like files with spaces, so remove these files from the .tar.gz |
38 |
|
|
#error: Two files on one line: /opt/inventory/OCSNG_LINUX_SERVER_1.01/ocsreports/image/logo OCS-ng-48.png |
39 |
|
|
#error: Two files on one line: /opt/inventory/OCSNG_LINUX_SERVER_1.01/ocsreports/image/utilisateur OK.png |
40 |
|
|
|
41 |
|
|
%install |
42 |
|
|
rm -rf $RPM_BUILD_ROOT |
43 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
44 |
|
|
rm -f %{name}-%{version}-filelist |
45 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
46 |
|
|
--file '/opt/inventory/ocs/ocsreports/dbconfig.inc.php' 'attr(440,root,www)' \ |
47 |
|
|
> %{name}-%{version}-filelist |
48 |
|
|
|
49 |
|
|
%clean |
50 |
|
|
cd .. |
51 |
|
|
rm -rf %{name} |
52 |
|
|
|
53 |
|
|
%pre |
54 |
|
|
%preun |
55 |
|
|
%post |
56 |
|
|
%postun |
57 |
|
|
|
58 |
|
|
%files -f %{name}-%{version}-filelist |
59 |
|
|
%defattr(-,root,root) |