1 |
slords |
1.5 |
# $Id: ocs.spec,v 1.4 2008/04/02 15:03:55 slords Exp $ |
2 |
slords |
1.4 |
# Authority: dungog |
3 |
|
|
# Name: Stephen Noble |
4 |
|
|
|
5 |
slords |
1.1 |
%define name ocs |
6 |
|
|
Summary: ocs is an Information Resource Manager |
7 |
|
|
Name: %{name} |
8 |
|
|
%define version 1.01 |
9 |
|
|
%define release 1 |
10 |
|
|
Version: %{version} |
11 |
|
|
Release: %{release}%{?dist} |
12 |
|
|
License: GNU GPL version 2 |
13 |
|
|
URL: http://www.ocsinventory-ng.org/ |
14 |
|
|
Group: SMEserver/addon |
15 |
|
|
Source: OCSNG_LINUX_SERVER_1.01.tar.gz |
16 |
|
|
BuildArchitectures: noarch |
17 |
|
|
BuildRoot: /var/tmp/%{name}-%{version} |
18 |
|
|
Requires: e-smith-release >= 7.0 |
19 |
slords |
1.3 |
BuildRequires: e-smith-devtools |
20 |
slords |
1.1 |
AutoReqProv: no |
21 |
|
|
|
22 |
|
|
%description |
23 |
|
|
http://www.ocsinventory-ng.org/ |
24 |
|
|
Open Computer and Software Inventory Next Generation is an |
25 |
|
|
application designed to help a network or system administrator |
26 |
|
|
keep track of the computers configuration and |
27 |
|
|
software that are installed on the network. |
28 |
|
|
|
29 |
|
|
|
30 |
|
|
%changelog |
31 |
|
|
* Mon Dec 24 2007 Stephen Noble <support@dungog.net> 1.01-1 |
32 |
|
|
- initial release |
33 |
|
|
- builds from unchanged .tgz |
34 |
|
|
|
35 |
|
|
%prep |
36 |
|
|
%setup -c -n %{name} |
37 |
|
|
%build |
38 |
|
|
#this lets you drop a .tgz in with the root and it builds ok |
39 |
|
|
mkdir -p root/opt/inventory |
40 |
|
|
mv OCSNG_LINUX_SERVER_1.01 root/opt/inventory/ocs |
41 |
|
|
|
42 |
|
|
#fix later somehow, rpmbuild doesn't like files with spaces, so remove these files from the .tar.gz |
43 |
|
|
#error: Two files on one line: /opt/inventory/OCSNG_LINUX_SERVER_1.01/ocsreports/image/logo OCS-ng-48.png |
44 |
|
|
#error: Two files on one line: /opt/inventory/OCSNG_LINUX_SERVER_1.01/ocsreports/image/utilisateur OK.png |
45 |
|
|
|
46 |
|
|
%install |
47 |
|
|
rm -rf $RPM_BUILD_ROOT |
48 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
49 |
|
|
rm -f %{name}-%{version}-filelist |
50 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
51 |
|
|
--file '/opt/inventory/ocs/ocsreports/dbconfig.inc.php' 'attr(440,root,www)' \ |
52 |
|
|
> %{name}-%{version}-filelist |
53 |
|
|
|
54 |
|
|
%clean |
55 |
|
|
cd .. |
56 |
|
|
rm -rf %{name} |
57 |
|
|
|
58 |
|
|
%pre |
59 |
|
|
%preun |
60 |
|
|
%post |
61 |
|
|
%postun |
62 |
|
|
|
63 |
|
|
%files -f %{name}-%{version}-filelist |
64 |
|
|
%defattr(-,root,root) |