/[smecontribs]/rpms/perl-Ezmlm/contribs10/Ezmlm.spec
ViewVC logotype

Annotation of /rpms/perl-Ezmlm/contribs10/Ezmlm.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.3 - (hide annotations) (download)
Tue Mar 15 19:50:57 2022 UTC (2 years, 2 months ago) by jpp
Branch: MAIN
CVS Tags: perl-Ezmlm-0_08-4_el7_sme, HEAD
Changes since 1.2: +6 -1 lines
* Tue Mar 15 2022 Jean-Philippe Pialasse <tests@pialasse.com> 0.08-4.sme
- build for SME10 [SME: 11288]
  prepare Buildrequire for better configuration, when perl-gpg-ezmlm
  will be available could make it for gpg encrypted.

1 jpp 1.3 # $Id: Ezmlm.spec,v 1.2 2022/03/15 19:48:46 jpp Exp $
2 jpp 1.1 # Authority: gordonr
3     # Name: Gordon Rowell
4    
5     #
6     # - Ezmlm -
7     # This spec file was automatically generated by cpan2rpm [ver: 2.028]
8     # The following arguments were used:
9     # --make-no-test Ezmlm
10     # For more information on cpan2rpm please visit: http://perl.arix.com/
11     #
12    
13     %define pkgname Ezmlm
14     %define filelist %{pkgname}-%{version}-filelist
15     %define NVR %{pkgname}-%{version}-%{release}
16     %define maketest 0
17    
18     name: perl-Ezmlm
19     summary: Ezmlm - Object Methods for Ezmlm Mailing Lists
20     version: 0.08
21     release: 4%{?dist}
22     license: Artistic
23     group: Applications/CPAN
24     url: http://www.cpan.org
25     buildroot: %{_tmppath}/%{name}-%{version}-%(id -u -n)
26     buildarch: noarch
27     prefix: %(echo %{_prefix})
28     source: http://search.cpan.org//CPAN/authors/id/S/SU/SUMPFRALL/Ezmlm-0.08.2.tar.gz
29     Patch0: perl-Ezmlm-0.08-2-dirsubdir.patch
30     Patch1: perl-Ezmlm-0.08-2-v722flags.patch
31     Patch2: perl-Ezmlm-0.08-2-moreflagsv722.patch
32     BuildRequires: perl-devel
33 jpp 1.2 BuildRequires: ezmlm-idx
34     BuildRequires: qmail
35     BuildRequires: perl-Crypt-GPG
36 jpp 1.1
37     %description
38     use Mail::Ezmlm;
39     $list = new Mail::Ezmlm;
40    
41     The rest is a bit complicated for a Synopsis, see the description.
42    
43     #
44     # This package was generated automatically with the cpan2rpm
45     # utility. To get this software or for more information
46     # please visit: http://perl.arix.com/
47     #
48    
49     %prep
50     %setup -q -n %{pkgname}-%{version}.2
51     chmod -R u+w %{_builddir}/%{pkgname}-%{version}.2
52     %patch0 -p1
53     %patch1 -p1
54     %patch2 -p1
55    
56     %build
57     grep -rsl '^#!.*perl' . |
58     grep -v '.bak$' |xargs --no-run-if-empty \
59     %__perl -MExtUtils::MakeMaker -e 'MY->fixin(@ARGV)'
60     CFLAGS="$RPM_OPT_FLAGS"
61     %{__perl} Makefile.PL `%{__perl} -MExtUtils::MakeMaker -e ' print qq|PREFIX=%{buildroot}%{_prefix}| if \$ExtUtils::MakeMaker::VERSION =~ /5\.9[1-6]|6\.0[0-5]/ '`
62     %{__make}
63     %if %maketest
64     %{__make} test
65     %endif
66    
67     %install
68     [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
69    
70     %{makeinstall} `%{__perl} -MExtUtils::MakeMaker -e ' print \$ExtUtils::MakeMaker::VERSION <= 6.05 ? qq|PREFIX=%{buildroot}%{_prefix}| : qq|DESTDIR=%{buildroot}| '`
71    
72     cmd=/usr/share/spec-helper/compress_files
73     [ -x $cmd ] || cmd=/usr/lib/rpm/brp-compress
74     [ -x $cmd ] && $cmd
75    
76     # SuSE Linux
77     if [ -e /etc/SuSE-release -o -e /etc/UnitedLinux-release ]
78     then
79     %{__mkdir_p} %{buildroot}/var/adm/perl-modules
80     %{__cat} `find %{buildroot} -name "perllocal.pod"` \
81     | %{__sed} -e s+%{buildroot}++g \
82     > %{buildroot}/var/adm/perl-modules/%{name}
83     fi
84    
85     # remove special files
86     find %{buildroot} -name "perllocal.pod" \
87     -o -name ".packlist" \
88     -o -name "*.bs" \
89     |xargs -i rm -f {}
90    
91     # no empty directories
92     find %{buildroot}%{_prefix} \
93     -type d -depth \
94     -exec rmdir {} \; 2>/dev/null
95    
96     %{__perl} -MFile::Find -le '
97     find({ wanted => \&wanted, no_chdir => 1}, "%{buildroot}");
98     print "%doc Changes README";
99     for my $x (sort @dirs, @files) {
100     push @ret, $x unless indirs($x);
101     }
102     print join "\n", sort @ret;
103    
104     sub wanted {
105     return if /auto$/;
106    
107     local $_ = $File::Find::name;
108     my $f = $_; s|^\Q%{buildroot}\E||;
109     return unless length;
110     return $files[@files] = $_ if -f $f;
111    
112     $d = $_;
113     /\Q$d\E/ && return for reverse sort @INC;
114     $d =~ /\Q$_\E/ && return
115     for qw|/etc %_prefix/man %_prefix/bin %_prefix/share|;
116    
117     $dirs[@dirs] = $_;
118     }
119    
120     sub indirs {
121     my $x = shift;
122     $x =~ /^\Q$_\E\// && $x ne $_ && return 1 for @dirs;
123     }
124     ' > %filelist
125    
126     [ -z %filelist ] && {
127     echo "ERROR: empty %files listing"
128     exit -1
129     }
130    
131     %clean
132     [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
133    
134     %files -f %filelist
135     %defattr(-,root,root)
136    
137     %changelog
138 jpp 1.3 * Tue Mar 15 2022 Jean-Philippe Pialasse <tests@pialasse.com> 0.08-4.sme
139     - build for SME10 [SME: 11288]
140     prepare Buildrequire for better configuration, when perl-gpg-ezmlm
141     will be available could make it for gpg encrypted.
142    
143 jpp 1.1 * Thu Apr 21 2016 Jean-Philipe Pialasse <tests@pialasse.com> 0.08-4.sme
144     - updated available flags in 7.2.2 [SME: 9470]
145    
146     * Wed Apr 20 2016 Jean-Philipe Pialasse <tests@pialasse.com> 0.08.2-3.sme
147     - fix bad syntax for calling ezmlm-* fucntion with subdir [SME: 9470]
148     - added ability to get config tag from v7.2.2 ml
149    
150     * Tue Apr 19 2016 Jean-Philipe Pialasse <tests@pialasse.com> 0.08-2.sme
151     - update to 0.08.2
152    
153     * Wed Apr 23 2008 Shad L. Lords <slords@mail.com> 0.07-2.sme
154     - Initial build.

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed