/[smecontribs]/rpms/perl-Ezmlm/contribs9/Ezmlm.spec
ViewVC logotype

Annotation of /rpms/perl-Ezmlm/contribs9/Ezmlm.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.2 - (hide annotations) (download)
Fri Apr 22 09:19:36 2016 UTC (8 years ago) by unnilennium
Branch: MAIN
CVS Tags: perl-Ezmlm-0_08-4_el6_sme, HEAD
Changes since 1.1: +2 -1 lines
* Thu Apr 21 2016 Jean-Philipe Pialasse <tests@pialasse.com> 0.08-4.sme
- updated available flags in 7.2.2  [SME: 9470]

1 unnilennium 1.2 # $Id: Ezmlm.spec,v 1.1 2016/04/22 09:13:02 unnilennium Exp $
2 unnilennium 1.1 # Authority: gordonr
3     # Name: Gordon Rowell
4    
5     #
6     # - Ezmlm -
7     # This spec file was automatically generated by cpan2rpm [ver: 2.028]
8     # The following arguments were used:
9     # --make-no-test Ezmlm
10     # For more information on cpan2rpm please visit: http://perl.arix.com/
11     #
12    
13     %define pkgname Ezmlm
14     %define filelist %{pkgname}-%{version}-filelist
15     %define NVR %{pkgname}-%{version}-%{release}
16     %define maketest 0
17    
18     name: perl-Ezmlm
19     summary: Ezmlm - Object Methods for Ezmlm Mailing Lists
20     version: 0.08
21     release: 4%{?dist}
22     license: Artistic
23     group: Applications/CPAN
24     url: http://www.cpan.org
25     buildroot: %{_tmppath}/%{name}-%{version}-%(id -u -n)
26     buildarch: noarch
27     prefix: %(echo %{_prefix})
28     source: http://search.cpan.org//CPAN/authors/id/S/SU/SUMPFRALL/Ezmlm-0.08.2.tar.gz
29     Patch0: perl-Ezmlm-0.08-2-dirsubdir.patch
30     Patch1: perl-Ezmlm-0.08-2-v722flags.patch
31     Patch2: perl-Ezmlm-0.08-2-moreflagsv722.patch
32 unnilennium 1.2 BuildRequires: perl-devel
33 unnilennium 1.1
34     %description
35     use Mail::Ezmlm;
36     $list = new Mail::Ezmlm;
37    
38     The rest is a bit complicated for a Synopsis, see the description.
39    
40     #
41     # This package was generated automatically with the cpan2rpm
42     # utility. To get this software or for more information
43     # please visit: http://perl.arix.com/
44     #
45    
46     %prep
47     %setup -q -n %{pkgname}-%{version}.2
48     chmod -R u+w %{_builddir}/%{pkgname}-%{version}.2
49     %patch0 -p1
50     %patch1 -p1
51     %patch2 -p1
52    
53     %build
54     grep -rsl '^#!.*perl' . |
55     grep -v '.bak$' |xargs --no-run-if-empty \
56     %__perl -MExtUtils::MakeMaker -e 'MY->fixin(@ARGV)'
57     CFLAGS="$RPM_OPT_FLAGS"
58     %{__perl} Makefile.PL `%{__perl} -MExtUtils::MakeMaker -e ' print qq|PREFIX=%{buildroot}%{_prefix}| if \$ExtUtils::MakeMaker::VERSION =~ /5\.9[1-6]|6\.0[0-5]/ '`
59     %{__make}
60     %if %maketest
61     %{__make} test
62     %endif
63    
64     %install
65     [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
66    
67     %{makeinstall} `%{__perl} -MExtUtils::MakeMaker -e ' print \$ExtUtils::MakeMaker::VERSION <= 6.05 ? qq|PREFIX=%{buildroot}%{_prefix}| : qq|DESTDIR=%{buildroot}| '`
68    
69     cmd=/usr/share/spec-helper/compress_files
70     [ -x $cmd ] || cmd=/usr/lib/rpm/brp-compress
71     [ -x $cmd ] && $cmd
72    
73     # SuSE Linux
74     if [ -e /etc/SuSE-release -o -e /etc/UnitedLinux-release ]
75     then
76     %{__mkdir_p} %{buildroot}/var/adm/perl-modules
77     %{__cat} `find %{buildroot} -name "perllocal.pod"` \
78     | %{__sed} -e s+%{buildroot}++g \
79     > %{buildroot}/var/adm/perl-modules/%{name}
80     fi
81    
82     # remove special files
83     find %{buildroot} -name "perllocal.pod" \
84     -o -name ".packlist" \
85     -o -name "*.bs" \
86     |xargs -i rm -f {}
87    
88     # no empty directories
89     find %{buildroot}%{_prefix} \
90     -type d -depth \
91     -exec rmdir {} \; 2>/dev/null
92    
93     %{__perl} -MFile::Find -le '
94     find({ wanted => \&wanted, no_chdir => 1}, "%{buildroot}");
95     print "%doc Changes README";
96     for my $x (sort @dirs, @files) {
97     push @ret, $x unless indirs($x);
98     }
99     print join "\n", sort @ret;
100    
101     sub wanted {
102     return if /auto$/;
103    
104     local $_ = $File::Find::name;
105     my $f = $_; s|^\Q%{buildroot}\E||;
106     return unless length;
107     return $files[@files] = $_ if -f $f;
108    
109     $d = $_;
110     /\Q$d\E/ && return for reverse sort @INC;
111     $d =~ /\Q$_\E/ && return
112     for qw|/etc %_prefix/man %_prefix/bin %_prefix/share|;
113    
114     $dirs[@dirs] = $_;
115     }
116    
117     sub indirs {
118     my $x = shift;
119     $x =~ /^\Q$_\E\// && $x ne $_ && return 1 for @dirs;
120     }
121     ' > %filelist
122    
123     [ -z %filelist ] && {
124     echo "ERROR: empty %files listing"
125     exit -1
126     }
127    
128     %clean
129     [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
130    
131     %files -f %filelist
132     %defattr(-,root,root)
133    
134     %changelog
135     * Thu Apr 21 2016 Jean-Philipe Pialasse <tests@pialasse.com> 0.08-4.sme
136     - updated available flags in 7.2.2 [SME: 9470]
137    
138     * Wed Apr 20 2016 Jean-Philipe Pialasse <tests@pialasse.com> 0.08.2-3.sme
139     - fix bad syntax for calling ezmlm-* fucntion with subdir [SME: 9470]
140     - added ability to get config tag from v7.2.2 ml
141    
142     * Tue Apr 19 2016 Jean-Philipe Pialasse <tests@pialasse.com> 0.08-2.sme
143     - update to 0.08.2
144    
145     * Wed Apr 23 2008 Shad L. Lords <slords@mail.com> 0.07-2.sme
146     - Initial build.

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed