1 |
Name: perl-Net-NTP |
2 |
Version: 1.5 |
3 |
Release: 1 |
4 |
Summary: Lookup the username on the remote end of a TCP/IP connection |
5 |
License: Artistic |
6 |
Group: Development/Libraries |
7 |
URL: http://search.cpan.org/dist/Net-NTP/ |
8 |
Source0: https://cpan.metacpan.org/authors/id/A/AB/ABH/Net-NTP-1.5.tar.gz |
9 |
|
10 |
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) |
11 |
BuildArch: noarch |
12 |
BuildRequires: perl(Carp) |
13 |
BuildRequires: perl(Config) |
14 |
BuildRequires: perl(Exporter) |
15 |
BuildRequires: perl(ExtUtils::MakeMaker) |
16 |
BuildRequires: perl(Socket) |
17 |
BuildRequires: perl(Test::More) |
18 |
Requires: perl(Carp) |
19 |
Requires: perl(Config) |
20 |
Requires: perl(Exporter) |
21 |
Requires: perl(Socket) |
22 |
Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version)) |
23 |
|
24 |
%description |
25 |
Perl extension for decoding NTP server responses |
26 |
|
27 |
%prep |
28 |
%setup -q -n Net-NTP-%{version} |
29 |
|
30 |
%build |
31 |
%{__perl} Makefile.PL INSTALLDIRS=vendor |
32 |
make %{?_smp_mflags} |
33 |
|
34 |
%install |
35 |
rm -rf $RPM_BUILD_ROOT |
36 |
|
37 |
make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT |
38 |
|
39 |
find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} \; |
40 |
find $RPM_BUILD_ROOT -depth -type d -exec rmdir {} 2>/dev/null \; |
41 |
|
42 |
%{_fixperms} $RPM_BUILD_ROOT/* |
43 |
|
44 |
%check |
45 |
make test |
46 |
|
47 |
%clean |
48 |
rm -rf $RPM_BUILD_ROOT |
49 |
|
50 |
%files |
51 |
%defattr(-,root,root,-) |
52 |
%doc Changes META.json README |
53 |
%{perl_vendorlib}/* |
54 |
%{_mandir}/man3/* |
55 |
|
56 |
%changelog |
57 |
* Sun May 02 2021 John Crisp <jcrisp@safeandsoundit.co.uk> 1.5-1-sme |
58 |
First import to contribs [SME: 11587] |
59 |
|