/[smecontribs]/rpms/php5-cgi/contribs7/php5-cgi.spec
ViewVC logotype

Annotation of /rpms/php5-cgi/contribs7/php5-cgi.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.1 - (hide annotations) (download)
Wed Mar 4 17:04:43 2009 UTC (15 years, 3 months ago) by slords
Branch: MAIN
Rename spec

1 slords 1.1 # $Id: php5-sme.spec,v 1.2 2009/03/04 15:02:45 slords Exp $
2     # Authority: ????
3     # Name: David Harper
4    
5     %define rhel4 1
6    
7     %define contentdir /var/www
8     %define with_oci8 %{?_with_oci8:1}%{!?_with_oci8:0}
9     %define with_mssql %{?_with_mssql:1}%{!?_with_mssql:0}
10     %define with_mhash %{?_with_mhash:1}%{!?_with_mhash:0}
11     %define with_mcrypt %{?_with_mcrypt:1}%{!?_with_mcrypt:0}
12     %define with_mbstring %{?_with_mbstring:1}%{!?_with_mbstring:0}
13     %define with_tidy %{?_with_tidy:1}%{!?_with_tidy:0}
14    
15     Summary: The PHP HTML-embedded scripting language. (PHP: Hypertext Preprocessor)
16     Name: php5-cgi
17     Version: 5.2.8
18     Release: 1%{?dist}
19     %{?rh90:Epoch: 1 }
20     License: The PHP License
21     Group: Development/Languages
22     URL: http://www.php.net/
23    
24     Source0: http://www.php.net/distributions/php-%{version}.tar.bz2
25    
26     Source50: php5.conf
27    
28     #Patch2: php-4.3.4-config.patch
29     #Patch3: php-4.2.2-lib64.patch
30     #Patch4: php-4.2.2-cxx.patch
31     #Patch5: php-4.3.3-install.patch
32     #Patch6: php-4.3.1-tests.patch
33     #Patch7: php-4.3.2-libtool15.patch
34     #Patch8: php-4.3.3-miscfix.patch
35     #Patch9: php-4.3.6-umask.patch
36     Patch10: php-4.3.7-handler.patch
37     Patch11: php-4.3.8-fdsetsize.patch
38    
39     # Fixes for extension modules
40     #Patch21: php-4.3.1-odbc.patch
41     #Patch22: php-4.3.2-db4.patch
42     #Patch23: php-4.3.7-gmppowm.patch
43    
44     # Functional changes
45     #Patch30: php-4.3.1-dlopen.patch
46     #Patch31: php-4.3.4-easter.patch
47    
48     BuildRoot: %{_tmppath}/%{name}-root
49    
50     BuildRequires: bzip2-devel, curl-devel >= 7.9, db4-devel, expat-devel, freetype-devel
51     BuildRequires: gd-devel >= 1.8.4, gmp-devel, aspell-devel
52     BuildRequires: httpd-devel, libjpeg-devel, libpng-devel, pam-devel
53     BuildRequires: libstdc++-devel, ncurses-devel, openssl-devel
54     BuildRequires: zlib-devel, pcre-devel libxml2-devel
55     %{?rhel4:BuildRequires: libgcrypt-devel, libxml2-devel, libxslt-devel}
56     BuildRequires: bzip2, fileutils, perl, libtool >= 1.4.3
57     %{?_with_tidy:BuildRequires: tidy}
58     %{?_with_tidy:Requires: tidy}
59    
60     Obsoletes: php-dbg, mod_php, php3, phpfi, stronghold-php, php-xslt
61     # Enforce Apache module ABI compatibility
62     Requires: httpd-mmn = %(cat %{_includedir}/httpd/.mmn || echo missing-httpd-devel)
63     Requires: php5-cgi-pear
64     Conflicts: php >= 5.0.0
65     # Require extension which was previously built-in
66     # Requires: php-mbstring = %{version}-%{release}
67     # ^^ dunno if mbstring is required anymore, couldn't get it to compile
68     # initially so I nuked the requirement
69    
70    
71     %description
72     PHP is an HTML-embedded scripting language. PHP attempts to make it
73     easy for developers to write dynamically generated webpages. PHP also
74     offers built-in database integration for several commercial and
75     non-commercial database management systems, so writing a
76     database-enabled webpage with PHP is fairly simple. The most common
77     use of PHP coding is probably as a replacement for CGI scripts. The
78     mod_php module enables the Apache Web server to understand and process
79     the embedded PHP language in Web pages.
80    
81     This is a CGI build of PHP5. This is to assist hosts in deploying PHP5 side by side with PHP4. After installation it is recommended the following lines be added to a servers startup scripts to avoid the requirement of a shebang line on .php5 files:
82    
83     # Allow PHP5 to run without shebang
84     modprobe binfmt_misc
85     echo ':PHP5:E::php5::/usr/bin/php5/php:' > /proc/sys/fs/binfmt_misc/register
86    
87     %package devel
88     Group: Development/Libraries
89     Summary: Files needed for building PHP extensions.
90     Requires: php5-cgi = %{version}-%{release}
91    
92     %description devel
93     The php-devel package contains the files needed for building PHP
94     extensions. If you need to compile your own PHP extensions, you will
95     need to install this package.
96    
97     %package pear
98     Group: Development/Languages
99     Summary: PHP Extension and Application Repository Components
100     Requires: php5-cgi
101    
102     %description pear
103     PEAR is a framework and distribution system for reusable PHP
104     components. This package contains a set of PHP components from the
105     PEAR repository.
106    
107     %package imap
108     Summary: An Apache module for PHP applications that use IMAP.
109     Group: Development/Languages
110     Requires: php5-cgi = %{version}-%{release}
111     Obsoletes: mod_php3-imap, stronghold-php-imap
112     BuildRequires: krb5-devel, openssl-devel
113     %{?rh73:BuildRequires: imap-devel}
114     %{?rh90:BuildRequires: imap-devel}
115     %{?rhel3:BuildRequires: imap-devel}
116     %{?rhfc1:BuildRequires: imap-devel}
117     %{?rhfc2:BuildRequires: libc-client-devel}
118     %{?rhel4:BuildRequires: libc-client-devel}
119    
120    
121     %description imap
122     The php-imap package contains a dynamic shared object (DSO) for the
123     Apache Web server. When compiled into Apache, the php-imap module will
124     add IMAP (Internet Message Access Protocol) support to PHP. IMAP is a
125     protocol for retrieving and uploading e-mail messages on mail
126     servers. PHP is an HTML-embedded scripting language. If you need IMAP
127     support for PHP applications, you will need to install this package
128     and the php package.
129    
130     %package ldap
131     Summary: A module for PHP applications that use LDAP.
132     Group: Development/Languages
133     Requires: php5-cgi = %{version}-%{release}
134     Obsoletes: mod_php3-ldap, stronghold-php-ldap
135     BuildRequires: cyrus-sasl-devel, openldap-devel, openssl-devel
136    
137     %description ldap
138     The php-ldap package is a dynamic shared object (DSO) for the Apache
139     Web server that adds Lightweight Directory Access Protocol (LDAP)
140     support to PHP. LDAP is a set of protocols for accessing directory
141     services over the Internet. PHP is an HTML-embedded scripting
142     language. If you need LDAP support for PHP applications, you will
143     need to install this package in addition to the php package.
144    
145     %package mysql
146     Summary: A module for PHP applications that use MySQL databases.
147     Group: Development/Languages
148     Requires: php5-cgi = %{version}-%{release}
149     Provides: php_database
150     Obsoletes: mod_php3-mysql, stronghold-php-mysql
151     BuildRequires: mysql-devel
152    
153     %description mysql
154     The php-mysql package contains a dynamic shared object that will add
155     MySQL database support to PHP. MySQL is an object-relational database
156     management system. PHP is an HTML-embeddable scripting language. If
157     you need MySQL support for PHP applications, you will need to install
158     this package and the php or mod_php package.
159    
160     %package pgsql
161     Summary: A PostgreSQL database module for PHP.
162     Group: Development/Languages
163     Requires: php5-cgi = %{version}-%{release}
164     Provides: php_database
165     Obsoletes: mod_php3-pgsql, stronghold-php-pgsql
166     BuildRequires: krb5-devel, openssl-devel
167     %{?rh73:BuildRequires: postgresql-devel}
168     %{?rhfc1:BuildRequires: postgresql-devel}
169     %{?rhfc2:BuildRequires: postgresql-devel}
170     %{?rhel3:BuildRequires: rh-postgresql-devel}
171     %{?rhel4:BuildRequires: postgresql-devel}
172     %{?rh90:BuildRequires: postgresql-devel}
173    
174    
175     %description pgsql
176     The php-pgsql package includes a dynamic shared object (DSO) that can
177     be compiled in to the Apache Web server to add PostgreSQL database
178     support to PHP. PostgreSQL is an object-relational database management
179     system that supports almost all SQL constructs. PHP is an
180     HTML-embedded scripting language. If you need back-end support for
181     PostgreSQL, you should install this package in addition to the main
182     php package.
183    
184     %package odbc
185     Group: Development/Languages
186     Requires: php5-cgi = %{version}-%{release}
187     Summary: A module for PHP applications that use ODBC databases.
188     Provides: php_database
189     Obsoletes: stronghold-php-odbc
190     BuildRequires: unixODBC-devel
191    
192     %description odbc
193     The php-odbc package contains a dynamic shared object that will add
194     database support through ODBC to PHP. ODBC is an open specification
195     which provides a consistent API for developers to use for accessing
196     data sources (which are often, but not always, databases). PHP is an
197     HTML-embeddable scripting language. If you need ODBC support for PHP
198     applications, you will need to install this package and the php
199     package.
200    
201     %if %{with_oci8}
202     %package oci8
203     Group: Development/Languages
204     Requires: php5-cgi = %{version}-%{release}
205     Summary: A module for PHP applications that use OCI8 databases.
206     Provides: php_database
207    
208     %description oci8
209     The php-oci8 package contains a dynamic shared object that will add
210     support for accessing OCI8 databases to PHP.
211     %endif
212    
213     %if %{with_mssql}
214     %package mssql
215     Group: Development/Languages
216     Requires: php5-cgi = %{version}-%{release}, freetds
217     Summary: A module for PHP applications that use MSSQL databases.
218     Provides: php_database
219     BuildRequires: freetds-devel
220    
221     %description mssql
222     The mssql package contains a dynamic shared object that will add
223     support for accessing MSSQL databases to PHP.
224     %endif
225    
226     %if %{with_mhash}
227     %package mhash
228     Summary: A module for PHP applications that use Mhash.
229     Group: Development/Languages
230     Requires: php5-cgi = %{version}-%{release}
231     BuildRequires: mhash-devel
232    
233     %description mhash
234     The php-mhash package is a dynamic shared object (DSO) for the Apache
235     Web server that adds Mhash support to PHP.
236     %endif
237    
238    
239     %if %{with_mcrypt}
240     %package mcrypt
241     Group: Development/Languages
242     BuildRequires: libmcrypt, libmcrypt-devel
243     Requires: php5-cgi = %{version}-%{release}, libmcrypt
244     Summary: A module for PHP applications to use the mcrypt library
245    
246     %description mcrypt
247     The php-mcrypt library includes a dynamic shared object (DSO) that adds
248     Mcrypt support to PHP4. The libmcrypt is a data encryption library. The
249     library is thread safe and provides encryption and decryption functions.
250     This version of the library supports many encryption algorithms and
251     encryption modes. Some algorithms which are supported: SERPENT,
252     RIJNDAEL, 3DES, GOST, SAFER+, CAST-256, RC2, XTEA, 3WAY, TWOFISH,
253     BLOWFISH, ARCFOUR, WAKE and more. Install this package in addition
254     to main PHP package if you plan to use any of these algorithms.
255     %endif
256    
257    
258     %package snmp
259     Summary: A module for PHP applications that query SNMP-managed devices.
260     Group: Development/Languages
261     Requires: php5-cgi = %{version}-%{release}
262     BuildRequires: net-snmp-devel, elfutils-devel
263     # elfutils-devel requirement workaround for #103982
264    
265     %description snmp
266     The php-snmp package contains a dynamic shared object that will add
267     support for querying SNMP devices to PHP. PHP is an HTML-embeddable
268     scripting language. If you need SNMP support for PHP applications, you
269     will need to install this package and the php package.
270    
271     %package xmlrpc
272     Summary: A module for PHP applications which use the XML-RPC protocol
273     Group: Development/Languages
274     Requires: php5-cgi = %{version}-%{release}
275     BuildRequires: expat-devel
276    
277     %description xmlrpc
278     The php-xmlrpc package contains a dynamic shared object that will add
279     support for the XML-RPC protocol to PHP.
280    
281     %package mbstring
282     Summary: A module for PHP applications which need multi-byte string handling
283     Group: Development/Languages
284     Requires: php5-cgi = %{version}-%{release}
285    
286     %description mbstring
287     The php-mbstring package contains a dynamic shared object that will add
288     support for multi-byte string handling to PHP.
289    
290     %prep
291     %setup -q -n php-%{version}
292     #%patch2 -p1 -b .config
293     #%patch3 -p1 -b .lib64
294     #%patch4 -p1 -b .cxx
295     #%patch5 -p1 -b .install
296     #%patch6 -p1 -b .tests
297     #%patch7 -p1 -b .libtool15
298     #%patch8 -p1 -b .miscfix
299     #%patch9 -p1 -b .umask
300     #%patch10 -p1 -b .handler
301     #%patch11 -p1 -b .fdsetsize
302    
303     #%patch21 -p1 -b .odbc
304     #%patch22 -p1 -b .db4
305     #%patch23 -p1 -b .gmppowm
306    
307     #%patch30 -p1 -b .dlopen
308     ##%patch31 -p1 -b .easter
309    
310     # Prevent %%doc confusion over LICENSE files
311     cp Zend/LICENSE Zend/ZEND_LICENSE
312     cp TSRM/LICENSE TSRM_LICENSE
313     cp regex/COPYRIGHT regex_COPYRIGHT
314     cp ext/gd/libgd/README gd_README
315    
316     # Source is built twice: once for /usr/bin/php5/php, once for the Apache DSO.
317     mkdir build-cgi
318    
319     # Use correct libdir
320     perl -pi -e 's|%{_prefix}/lib|%{_libdir}|' php.ini-recommended
321     perl -pi -e 's|extension_dir \= \"\.\/\"|extension_dir \= \"%{_libdir}\/php5\/\"|' php.ini-recommended
322    
323     # Remove bogus test; position of read position after fopen(, "a+")
324     # is not defined by C standard, so don't presume anything.
325     rm -f ext/standard/tests/file/bug21131.phpt
326    
327     # Tests that fail.
328     rm -f ext/standard/tests/file/bug22414.phpt \
329     ext/session/tests/019.phpt \
330     ext/standard/tests/math/pow.phpt \
331     ext/standard/tests/math/round.phpt \
332     ext/standard/tests/math/abs.phpt \
333     ext/iconv/tests/bug16069.phpt
334    
335     : Build for oci8=%{with_oci8} mssql=%{with_mssql} mhash=%{with_mhash} mcrypt=%{with_mcrypt}
336    
337     %build
338    
339     CFLAGS="$RPM_OPT_FLAGS -Wall -fno-strict-aliasing"; export CFLAGS
340    
341     # Install extension modules in %{_libdir}/php5.
342     EXTENSION_DIR=%{_libdir}/php5; export EXTENSION_DIR
343    
344     # pull latest ltmain.sh, AC_PROG_LIBTOOL
345     libtoolize --force --copy
346     # force aclocal run during buildconf
347     touch acinclude.m4
348    
349     # Regenerate configure scripts (patches change config.m4's)
350     ./buildconf --force
351    
352     # Shell function to configure and build a PHP tree.
353     build() {
354     # bison-1.875-2 seems to produce a broken parser; workaround.
355     mkdir Zend && cp ../Zend/zend_{language,ini}_{parser,scanner}.[ch] Zend
356     ln -sf ../configure
357     %configure \
358     --bindir=%{_bindir}/php5 \
359     --sbindir=%{_sbindir}/php5 \
360     --libdir=%{_libdir}/php5 \
361     --includedir=/usr/include/php5 \
362     --cache-file=../config.cache \
363     --sysconfdir=/etc/php5 \
364     --with-config-file-path=%{_sysconfdir}/php5 \
365     --with-config-file-scan-dir=%{_sysconfdir}/php5/php5.d \
366     --enable-discard-path \
367     --disable-debug \
368     --enable-pic \
369     --disable-rpath \
370     --enable-inline-optimization \
371     --with-bz2 \
372     --with-kerberos \
373     --with-db4=%{_prefix} \
374     --with-curl \
375     --with-exec-dir=%{_bindir}/php5 \
376     --with-freetype-dir=%{_prefix} \
377     --with-png-dir=%{_prefix} \
378     --with-gd \
379     --enable-gd-native-ttf \
380     --without-gdbm \
381     --with-gettext \
382     --with-ncurses \
383     --with-gmp \
384     --with-iconv \
385     --with-jpeg-dir=%{_prefix} \
386     --with-openssl \
387     --with-png \
388     --with-pspell \
389     --with-regex=system \
390     --with-xml \
391     --with-expat-dir=%{_prefix} \
392     --with-dom=shared,%{_prefix} \
393     --with-dom-xslt=%{_prefix} --with-dom-exslt=%{_prefix} \
394     --with-xsl \
395     --with-xmlrpc=shared \
396     %{?rhfc1:--with-pcre-regex=%{_prefix} } \
397     %{?rhfc2:--with-pcre-regex=%{_prefix} } \
398     --with-zlib \
399     --with-layout=GNU \
400     --enable-bcmath \
401     --enable-exif \
402     --enable-ftp \
403     --enable-magic-quotes \
404     --enable-safe-mode \
405     --enable-sockets \
406     --enable-sysvsem \
407     --enable-sysvshm \
408     --enable-track-vars \
409     --enable-trans-sid \
410     --enable-yp \
411     --enable-wddx \
412     --with-pear=/usr/share/pear5 \
413     --with-imap=shared --with-imap-ssl \
414     %{?rhfc1:--with-kerberos } \
415     %{?rhfc2:--with-kerberos } \
416     %{?rhel3:--with-kerberos=/usr/kerberos } \
417     %{?rhel4:--with-kerberos } \
418     %{?rh90:--with-kerberos=/usr/kerberos } \
419     --with-ldap=shared \
420     --with-mysql=shared,/usr \
421     %{?_with_oci8:--with-oci8=shared} \
422     %{?_with_mssql:--with-mssql=shared} \
423     %{?_with_mhash:--with-mhash=shared} \
424     %{?_with_mcrypt:--with-mcrypt=shared} \
425     --with-pgsql=shared \
426     --with-snmp=shared,%{_prefix} \
427     --with-snmp=shared \
428     --enable-ucd-snmp-hack \
429     --with-unixODBC=shared,%{_prefix} \
430     --enable-memory-limit \
431     --enable-bcmath \
432     --enable-shmop \
433     --enable-calendar \
434     --enable-dbx \
435     --enable-dio \
436     --enable-mcal \
437     %{?_with_tidy:--with-tidy} \
438     %{?_with_mbstring:--enable-mbstring=shared --enable-mbstr-enc-trans --enable-mbregex} \
439     $*
440    
441     make %{?_smp_mflags}
442     }
443    
444     # Build standalone /usr/bin/php
445     echo "PHP CGI"
446     pushd build-cgi
447     build
448     # Run tests
449     #export NO_INTERACTION=1 REPORT_EXIT_STATUS=1
450     #if ! TZ= LANG= LC_ALL= make test; then
451     # for f in `find .. -name \*.diff -type f -print`; do
452     # echo "TEST FAILURE -- $f --"
453     # cat $f
454     # done
455     #fi
456     #popd
457    
458     %install
459     [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
460    
461     # Hack
462     %{?rh90:install -m 755 -d $RPM_BUILD_ROOT/etc/httpd/conf }
463     %{?rh90:install -m 644 /etc/httpd/conf/httpd.conf $RPM_BUILD_ROOT%{_sysconfdir}/httpd/conf/httpd.conf }
464    
465     # Install from CGI tree
466     pushd build-cgi
467     make install INSTALL_ROOT=$RPM_BUILD_ROOT
468     popd
469    
470     # remove build files
471     rm -fr $RPM_BUILD_ROOT%{_libdir}/php
472    
473     # Install the default configuration file and icons
474     install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/php5
475     install -m 644 php.ini-recommended $RPM_BUILD_ROOT%{_sysconfdir}/php5/php.ini
476     #install -m 755 -d $RPM_BUILD_ROOT%{contentdir}/icons
477     #install -m 644 *.gif $RPM_BUILD_ROOT%{contentdir}/icons/
478    
479     # Apache config fragment
480     install -m 755 -d $RPM_BUILD_ROOT/etc/httpd/conf.d
481     install -m 644 $RPM_SOURCE_DIR/php5.conf $RPM_BUILD_ROOT/etc/httpd/conf.d
482    
483     install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/php5/php5.d
484     install -m 755 -d $RPM_BUILD_ROOT%{_localstatedir}/lib/php5
485     install -m 700 -d $RPM_BUILD_ROOT%{_localstatedir}/lib/php5/session
486    
487     # Generate files lists and stub .ini files for each subpackage
488     for mod in pgsql mysql odbc ldap snmp xmlrpc imap %{?_with_mbstring:mbstring} \
489     %{?_with_oci8:oci8} %{?_with_mssql:mssql} %{?_with_mhash:mhash} %{?_with_mcrypt:mcrypt}; do
490     cat > $RPM_BUILD_ROOT%{_sysconfdir}/php5/php5.d/${mod}.ini <<EOF
491     ; Enable ${mod} extension module
492     extension=${mod}.so
493     EOF
494     cat > files.${mod} <<EOF
495     %{?rhel4:%attr(755,root,root) %{_libdir}/php5/${mod}.so}
496     %{?rhel3:%attr(755,root,root) %{_libdir}/php5/${mod}}
497     %config(noreplace) %attr(644,root,root) %{_sysconfdir}/php5/php5.d/${mod}.ini
498     EOF
499     done
500    
501     # Remove PEAR testsuite
502     rm -rf $RPM_BUILD_ROOT%{_datadir}/pear5/tests
503    
504     # Remove unpackaged files
505     rm -f $RPM_BUILD_ROOT%{_libdir}/php5/*.a \
506     $RPM_BUILD_ROOT%{_bindir}/php5/{phptar,pearize}
507    
508     rm -fr $RPM_BUILD_ROOT/.channels $RPM_BUILD_ROOT/.depdb $RPM_BUILD_ROOT/.depdblock $RPM_BUILD_ROOT/.filemap $RPM_BUILD_ROOT/.lock $RPM_BUILD_ROOT/.registry
509    
510     # Remove irrelevant docs
511     rm -f README.{Zeus,QNX,CVS-RULES}
512    
513     # Post rh90 hack
514     # Hack
515     %{?rh90: rm -f $RPM_BUILD_ROOT%{_sysconfdir}/httpd/conf/httpd.conf* }
516    
517    
518    
519     %clean
520     [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
521     rm files.*
522    
523     %files
524     %defattr(-,root,root)
525     %doc CODING_STANDARDS CREDITS EXTENSIONS INSTALL LICENSE NEWS README*
526     %doc Zend/ZEND_* gd_README TSRM_LICENSE regex_COPYRIGHT
527     %config(noreplace) %{_sysconfdir}/php5/php.ini
528     %config %{_sysconfdir}/php5/pear.conf
529     %{_bindir}/php5/php
530     %{_bindir}/php5/php-cgi
531     %dir %{_libdir}/php5
532     %dir %{_localstatedir}/lib/php5
533     %attr(0700,apache,apache) %dir %{_localstatedir}/lib/php5/session
534     %config %{_sysconfdir}/httpd/conf.d/php5.conf
535     %dir %{_sysconfdir}/php5/php5.d
536     %doc %{_datadir}/man
537    
538     #/usr/share/man/man1/p
539    
540     %files pear
541     %defattr(-,root,root)
542     %{_bindir}/php5/pear
543     %{_datadir}/pear5
544     %{_bindir}/php5/peardev
545     %{_bindir}/php5/pecl
546    
547     %files devel
548     %defattr(-,root,root)
549     %{_bindir}/php5/php-config
550     %{_bindir}/php5/phpize
551     #%{_bindir}/php5/phpextdist
552     %{_includedir}/php5
553     %{_libdir}/php5/build
554    
555     %files pgsql -f files.pgsql
556     %{_libdir}/php5/pgsql.so
557    
558     %files mysql -f files.mysql
559     %{_libdir}/php5/mysql.so
560    
561     %files odbc -f files.odbc
562     %{_libdir}/php5/odbc.so
563    
564     %if %{with_oci8}
565     %files oci8 -f files.oci8
566     %endif
567    
568     %if %{with_mssql}
569     %files mssql -f files.mssql
570     %endif
571    
572     %if %{with_mhash}
573     %files mhash -f files.mhash
574     %endif
575    
576     %if %{with_mcrypt}
577     %files mcrypt -f files.mcrypt
578     %endif
579    
580     %files imap -f files.imap
581     %{_libdir}/php5/imap.so
582    
583     %files ldap -f files.ldap
584     %{_libdir}/php5/ldap.so
585    
586     %files snmp -f files.snmp
587     %{_libdir}/php5/snmp.so
588    
589     %files xmlrpc -f files.xmlrpc
590     %{_libdir}/php5/xmlrpc.so
591    
592     %if %{with_mbstring}
593     %files mbstring -f files.mbstring
594     %endif
595    
596     %changelog
597     * Mon Jan 12 2009 David Harper <davidiwharper@hotmail.com> 5.2.8-1.dh
598     - Upgrade to latest version of PHP
599     - Build fixes for CentOS/SME
600     * Fri Jan 20 2006 Stuart K. Low <stuart@serverpeak.com> 5.1.2-1
601     - Mass upgrade
602     - Added rhel4 flags
603     - Fixed pointers to changed (?) libraries from lib.so to just lib. Odd change.
604     * Fri Jun 10 2005 Stuart K. Low <stuart@serverpeak.com> 5.0.4-2
605     - Fixed tidy again.
606     * Sun May 29 2005 Stuart K. Low <stuart@serverpeak.com> 5.0.4-1
607     - Upgrade to 5.0.4
608     * Sat Feb 19 2005 Stuart K. Low <stuart@serverpeak.com> 5.0.3-3
609     - addition of --with-tidy
610     * Wed Jan 26 2005 Stuart K. Low <stuart@serverpeak.com> 5.0.3-1
611     - initial conversion to a CGI version for PHP5
612     - removed domxml since it's been moved to PECL in PHP5
613     - renamed to php5-cgi for clarity reasons (not to conflict with ARTs PHP5)
614     - removed mbstring dependency, don't know if this is smart
615    
616     * Fri Oct 15 2004 Scott R. Shinn <scott@atomicrocketturtle.com> 4.3.9-11
617     - set the Epoch number for rh90 only, apparently there is some bug in yum on FC1/FC2/3ES that causes issues when using the Epoch
618    
619     * Sat Oct 09 2004 Scott R. Shinn <scott@atomicrocketturtle.com> 4.3.9-10
620     - rebuilt for high file descriptor environments
621    
622     * Fri Oct 08 2004 Scott R. Shinn <scott@atomicrocketturtle.com> 4.3.9-8
623     - logs of bugfixes
624    
625     * Thu Oct 07 2004 Scott R. Shinn <scott@atomicrocketturtle.com> 4.3.9-6
626     - merging my php 4.3.9 rpm with the FC2 version
627    
628     * Fri Jul 16 2004 Joe Orton <jorton@redhat.com> 4.3.8-2.1
629     - revert upstream default php.ini change since 4.3.6
630     - add three FD_SETSIZE changes to main/network.c (#125258)
631    
632     * Wed Jul 14 2004 Joe Orton <jorton@redhat.com> 4.3.8-2.0
633     - update to 4.3.8
634     - add gmp_powm fix (Oskari Saarenmaa, #124318)
635     - split out mbstring extension into php-mbstring subpackage
636     - fix rebuild without bison/flex
637     - have -devel require php of same release
638     - add fixes for memory handling in 2.0 handler SAPI
639    
640     * Wed May 19 2004 Joe Orton <jorton@redhat.com> 4.3.6-5
641     - don't obsolete php-imap (#123580)
642     - unconditionally build -imap subpackage
643    
644     * Thu May 13 2004 Joe Orton <jorton@redhat.com> 4.3.6-4
645     - remove trigger
646    
647     * Thu Apr 22 2004 Joe Orton <jorton@redhat.com> 4.3.6-3
648     - fix umask reset "feature" (#121454)
649     - don't use DL_GLOBAL when dlopen'ing extension modules
650    
651     * Sun Apr 18 2004 Joe Orton <jorton@redhat.com> 4.3.6-2
652     - fix segfault on httpd SIGHUP (upstream #27810)
653    
654     * Fri Apr 16 2004 Joe Orton <jorton@redhat.com> 4.3.6-1
655     - update to 4.3.6 (Robert Scheck, #121011)
656    
657     * Wed Apr 7 2004 Joe Orton <jorton@redhat.com> 4.3.4-11
658     - add back imap subpackage, using libc-client (#115535)
659    
660     * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
661     - rebuilt
662    
663     * Wed Feb 18 2004 Joe Orton <jorton@redhat.com> 4.3.4-10
664     - eliminate /usr/local/lib RPATH in odbc.so
665     - really use system pcre library
666    
667     * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com> 4.3.4-9
668     - rebuilt
669    
670     * Mon Feb 2 2004 Bill Nottingham <notting@redhat.com> 4.3.4-8
671     - obsolete php-imap if we're not building it
672    
673     * Wed Jan 28 2004 Joe Orton <jorton@redhat.com> 4.3.4-7
674     - gd fix for build with recent Freetype2 (from upstream)
675     - remove easter egg (Oden Eriksson, Mandrake)
676    
677     * Wed Jan 21 2004 Joe Orton <jorton@redhat.com> 4.3.4-6
678     - php-pear requires php
679     - also remove extension=imap from php.ini in upgrade trigger
680     - merge from Taroon: allow upgrade from Stronghold 4.0
681    
682     * Wed Jan 21 2004 Joe Orton <jorton@redhat.com> 4.3.4-5
683     - add defattr for php-pear subpackage
684     - restore defaults: output_buffering=Off, register_argc_argv=On
685     - add trigger to handle php.ini upgrades smoothly (#112470)
686    
687     * Tue Jan 13 2004 Joe Orton <jorton@redhat.com> 4.3.4-4
688     - conditionalize support for imap extension for the time being
689     - switch /etc/php.ini to use php.ini-recommended (but leave
690     variables_order as EGPCS) (#97765)
691     - set session.path to /var/lib/php/session by default (#89975)
692     - own /var/lib/php{,/session} and have apache own the latter
693     - split off php-pear subpackage (#83771)
694    
695     * Sat Dec 13 2003 Jeff Johnson <jbj@jbj.org> 4.3.4-3
696     - rebuild against db-4.2.52.
697    
698     * Mon Dec 1 2003 Joe Orton <jorton@redhat.com> 4.3.4-2
699     - rebuild for new libxslt (#110658)
700     - use --with-{mssql,oci8} for enabling extensions (#110482)
701     - fix rebuild issues (Jan Visser, #110274)
702     - remove hard-coded LIBS
703     - conditional support for mhash (Aleksander Adamowski, #111251)
704    
705     * Mon Nov 10 2003 Joe Orton <jorton@redhat.com> 4.3.4-1.1
706     - rebuild for FC1 updates
707    
708     * Mon Nov 10 2003 Joe Orton <jorton@redhat.com> 4.3.4-1
709     - update to 4.3.4
710     - include all licence files
711     - libxmlrpc fixes
712    
713     * Mon Oct 20 2003 Joe Orton <jorton@redhat.com> 4.3.3-6
714     - use bundled libgd (#107407)
715     - remove manual: up-to-date manual sources are no longer DFSG-free;
716     it's too big; it's on the web anyway; #91292, #105804, #107384
717    
718     * Wed Oct 15 2003 Joe Orton <jorton@redhat.com> 4.3.3-5
719     - add php-xmlrpc subpackage (#107138)
720    
721     * Mon Oct 13 2003 Joe Orton <jorton@redhat.com> 4.3.3-4
722     - drop recode support, symbols collide with MySQL
723    
724     * Sun Oct 12 2003 Joe Orton <jorton@redhat.com> 4.3.3-3
725     - split domxml extension into php-domxml subpackage
726     - enable xslt and xml support in domxml extension (#106042)
727     - fix httpd-devel build requirement (#104341)
728     - enable recode extension (#106755)
729     - add workaround for #103982
730    
731     * Thu Sep 25 2003 Jeff Johnson <jbj@jbj.org> 4.3.3-3
732     - rebuild against db-4.2.42.
733    
734     * Sun Sep 7 2003 Joe Orton <jorton@redhat.com> 4.3.3-2
735     - don't use --enable-versioning, it depends on libtool being
736     broken (#103690)
737    
738     * Sun Sep 7 2003 Joe Orton <jorton@redhat.com> 4.3.3-1
739     - update to 4.3.3
740     - add libtool build prereq (#103388)
741     - switch to apache2handler
742    
743     * Mon Jul 28 2003 Joe Orton <jorton@redhat.com> 4.3.2-8
744     - rebuild
745    
746     * Tue Jul 22 2003 Nalin Dahyabhai <nalin@redhat.com> 4.3.2-7
747     - rebuild
748    
749     * Tue Jul 8 2003 Joe Orton <jorton@redhat.com> 4.3.2-6
750     - use system pcre library
751    
752     * Mon Jun 9 2003 Joe Orton <jorton@redhat.com> 4.3.2-5
753     - enable mbstring and mbregex (#81336)
754     - fix use of libtool 1.5
755    
756     * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
757     - rebuilt
758    
759     * Tue Jun 3 2003 Joe Orton <jorton@redhat.com> 4.3.2-3
760     - add lib64 and domxml fixes
761    
762     * Tue Jun 3 2003 Frank Dauer <f@paf.net>
763     - added conditional support for mssql module (#92149)
764    
765     * Fri May 30 2003 Joe Orton <jorton@redhat.com> 4.3.2-2
766     - update the -tests and -lib64 patches
767     - fixes for db4 detection
768     - require aspell-devel >= 0.50.0 for pspell compatibility
769    
770     * Thu May 29 2003 Joe Orton <jorton@redhat.com> 4.3.2-1
771     - update to 4.3.2
772    
773     * Fri May 16 2003 Joe Orton <jorton@redhat.com> 4.3.1-3
774     - link odbc module correctly
775     - patch so that php -n doesn't scan inidir
776     - run tests using php -n, avoid loading system modules
777    
778     * Wed May 14 2003 Joe Orton <jorton@redhat.com> 4.3.1-2
779     - workaround broken parser produced by bison-1.875
780    
781     * Tue May 6 2003 Joe Orton <jorton@redhat.com> 4.3.1-1
782     - update to 4.3.1; run test suite
783     - open extension modules with RTLD_NOW rather than _LAZY
784    
785     * Tue May 6 2003 Joe Orton <jorton@redhat.com> 4.2.2-19
786     - patch for gd 2.x API changes in gd extension
787    
788     * Thu May 1 2003 Joe Orton <jorton@redhat.com> 4.2.2-18
789     - rebuild to use aspell (#89925)
790     - patch to work round conditional AC_PROG_CXX break in autoconf 2.57
791     - fix dba build against db >= 4.1
792    
793     * Mon Feb 24 2003 Joe Orton <jorton@redhat.com> 4.2.2-17
794     - restrict SNMP patch to minimal changes, fixing segv on startup (#84607)
795    
796     * Wed Feb 12 2003 Joe Orton <jorton@redhat.com> 4.2.2-16
797     - prevent startup if using httpd.worker to avoid thread-safety issues.
798     - fix parsing private keys in OpenSSL extension (#83994)
799     - fixes for SNMP extension (backport from 4.3) (#74761)
800    
801     * Wed Jan 29 2003 Joe Orton <jorton@redhat.com> 4.2.2-15
802     - add security fixes for wordwrap() and mail()
803    
804     * Mon Jan 13 2003 Joe Orton <jorton@redhat.com> 4.2.2-14
805     - drop explicit Requires in subpackages, rely on automatic deps.
806     - further fixes for libdir=lib64
807    
808     * Tue Dec 17 2002 Joe Orton <jorton@redhat.com> 4.2.2-13
809     - drop prereq for perl, grep in subpackages
810     - rebuild and patch for OpenSSL 0.9.7
811    
812     * Tue Dec 10 2002 Joe Orton <jorton@redhat.com> 4.2.2-12
813     - backport "ini dir scanning" patch from CVS HEAD; /etc/php.d/*.ini
814     are now loaded at startup; each subpackage places an ini file
815     in that directory rather than munging /etc/php.ini in post/postun.
816     - default config changes: enable short_open_tag; remove settings for
817     php-dbg extension
818    
819     * Wed Dec 4 2002 Joe Orton <jorton@redhat.com> 4.2.2-11
820     - own the /usr/lib/php4 directory (#73894)
821     - reinstate dropped patch to unconditionally disable ZTS
822    
823     * Mon Dec 2 2002 Joe Orton <jorton@redhat.com> 4.2.2-10
824     - remove ldconfig invocation in post/postun
825     - fixes for #73516 (partially), #78586, #75029, #75712, #75878
826    
827     * Wed Nov 6 2002 Joe Orton <jorton@redhat.com> 4.2.2-9
828     - fixes for libdir=/usr/lib64, based on SuSE's patches.
829     - add build prereqs for zlib-devel, imap-devel, curl-devel (#74819)
830     - remove unpackaged files from install root
831     - libtoolize; use configure cache to speed up build
832    
833     * Mon Sep 23 2002 Philip Copeland <bryce@redhat.com> 4.2.2-8.0.6
834     - PHP cannot determine which UID is being used, so safe
835     mode restrictions were always applied. Fixed. (#74396)
836    
837     * Tue Sep 3 2002 Philip Copeland <bryce@redhat.com> 4.2.2-8.0.4
838     - zts support seems to crash out httpd on a *second* sighup
839     ie service httpd start;
840     apachectl restart ; (ok)
841     apachectl restart ; (httpd segv's and collapses)
842     removed --enable-experimental-zts which this seems related to.
843     - Small patch added because some places need to know that they
844     aren't using the ZTS API's (dumb)
845    
846     * Mon Sep 2 2002 Philip Copeland <bryce@redhat.com> 4.2.2-8.0.3
847     - fixup /etc/httpd/conf.d/php.conf to limit largest amount
848     of data accepted (#73254) Limited to 512K (which seems a
849     little excessive but anyway,..)
850     Note: php.conf is part of the srpm sources not part of the
851     php codebase.
852     - ditched extrenious --enable-debugger (was for php-dbg)
853     - When upgrading we tend not to modify /etc/php.ini if it exists,
854     instead we create php.ini.rpmnew. Modified the post scripts to
855     edit php.ini.rpmnew if it exists, so that people can copy
856     over the php.ini.rpmnew as php.ini knowing that it will
857     be an edited version, consistant with what modules they
858     installed #72033
859    
860     * Sun Sep 1 2002 Joe Orton <jorton@redhat.com> 4.2.2-8.0.2
861     - require httpd-mmn for module ABI compatibility
862    
863     * Fri Aug 30 2002 Philip Copeland <bryce@redhat.com> 4.2.2-8.0.1
864     - URLS would drop the last arguments #72752
865     --enable-mbstring
866     --enable-mbstr-enc-trans
867     These were supposed to help provide multibyte language
868     support, however, they cause problems. Removed. Maybe in
869     a later errata when they work.
870     - added small patch to php_variables.c that allows
871     $_GET[<var>] to initialise properly when
872     --enable-mbstr-enc-trans is disabled.
873     - Be consistant with errata naming (8.0.x)
874    
875     * Tue Aug 27 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.2-11
876     - rebuild
877    
878     * Wed Aug 22 2002 Philip Copeland <bryce@redhat.com> 4.2.2-10
879     - Beat down the requirement list to something a little
880     more sane
881    
882     * Wed Aug 14 2002 Bill Nottingham <notting@redhat.com> 4.2.2-9
883     - trim manual language lists
884    
885     * Mon Aug 12 2002 Gary Benson <gbenson@redhat.com> 4.2.2-8
886     - rebuild against httpd-2.0.40
887    
888     * Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com> 4.2.2-7
889     - rebuilt with gcc-3.2 (we hope)
890    
891     * Wed Aug 7 2002 Philip Copeland <bryce@redhat.com> 4.2.2-6
892     - Where multiple cookies are set, only the last one
893     was actually made. Fixes #67853
894    
895     * Mon Aug 5 2002 Philip Copeland <bryce@redhat.com> 4.2.2-5
896     - Shuffled the php/php-devel package file manifest
897     with respect to PEAR (PHP Extension and Application
898     Repository) #70673
899    
900     * Fri Aug 2 2002 Philip Copeland <bryce@redhat.com> 4.2.2-4
901     - #67815, search path doesn't include the pear directory
902     -pear not being installed correctly. Added --with-pear=
903     option.
904    
905     * Tue Jul 23 2002 Tim Powers <timp@redhat.com> 4.2.2-2
906     - build using gcc-3.2-0.1
907    
908     * Mon Jul 22 2002 Philip Copeland <bryce@redhat.com> 4.2.2-1
909     - Yippie 8/ another security vunerability (see
910     http://www.php.net/release_4_2_2.php for details)
911    
912     * Wed Jul 17 2002 Philip Copeland <bryce@redhat.com> 4.2.1-9
913     - Reminder to self that mm was pushed out because it's
914     NOT thread safe.
915     - Updated the manuals (much to Bills horror)
916    
917     * Tue Jul 16 2002 Philip Copeland <bryce@redhat.com> 4.2.1-8
918     - php.ini alteration to fit in with the install/uninstall
919     of various php rpm based installable modules
920    
921     * Mon Jul 15 2002 Philip Copeland <bryce@redhat.com> 4.2.1-8
922     - php -v showing signs of deep unhappiness with the world
923     added --enable-experimental-zts to configure to make it
924     happy again (yes I know experimental sounds 'dangerous'
925     it's just a name for an option we need)
926    
927     * Fri Jul 12 2002 Philip Copeland <bryce@redhat.com> 4.2.1-7
928     - #68715, Wrong name for Mysql Module in php.ini. Fixed.
929    
930     * Fri Jun 28 2002 Philip Copeland <bryce@redhat.com> 4.2.1-6
931     - SNMP fixup
932    
933     * Thu Jun 27 2002 Philip Copeland <bryce@redhat.com> 4.2.1-5
934     - Ah,.. seems httpd2 has been renamed to just plain
935     ol' httpd. Fixed spec file to suit.
936     - ucd-snmp changed to net-snmp overnight...
937     temporarily disabled snmp while I work out the
938     impact of this change and if it is safe
939    
940     * Wed Jun 26 2002 Philip Copeland <bryce@redhat.com> 4.2.1-4
941     - openldap 2.1.x problem solved by Nalin. Sure the ldap
942     API didn't change,... <mutter>. Added TSRMLS_FETCH()
943     to ldap_rebind_proc().
944     - Removed the php-dbg package as thats going to be provided
945     elsewhere
946    
947     * Fri Jun 21 2002 Tim Powers <timp@redhat.com> 4.2.1-3
948     - automated rebuild
949    
950     * Mon Jun 10 2002 Philip Copeland <bryce@redhat.com> 4.2.1-2
951     - Actually mm is now a dead project. Removed permently.
952    
953     * Tue May 28 2002 Gary Benson <gbenson@redhat.com> 4.2.1-2
954     - change paths for httpd-2.0
955     - add the config file
956     - disable mm temporarily
957    
958     * Sun May 26 2002 Tim Powers <timp@redhat.com> 4.2.1-1
959     - automated rebuild
960    
961     * Wed May 22 2002 Philip Copeland <bryce@redhat.com> 4.2.1-0
962     - Initial pristine build of php-4.2.1
963     - Minor patch to get around a 64 bitism
964     - Added in the dgb debugging hooks
965    

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed