/[smecontribs]/rpms/php5-cgi/contribs7/php5-sme.spec
ViewVC logotype

Annotation of /rpms/php5-cgi/contribs7/php5-sme.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.1 - (hide annotations) (download)
Wed Mar 4 14:52:52 2009 UTC (15 years, 3 months ago) by slords
Branch: MAIN
CVS Tags: php5-cgi-5_2_8-1_dh
Initial import of php5-cgi

1 slords 1.1 %{?dist: %{expand: %%define %dist rhel3}}
2    
3     %define contentdir /var/www
4     %define with_oci8 %{?_with_oci8:1}%{!?_with_oci8:0}
5     %define with_mssql %{?_with_mssql:1}%{!?_with_mssql:0}
6     %define with_mhash %{?_with_mhash:1}%{!?_with_mhash:0}
7     %define with_mcrypt %{?_with_mcrypt:1}%{!?_with_mcrypt:0}
8     %define with_mbstring %{?_with_mbstring:1}%{!?_with_mbstring:0}
9     %define with_tidy %{?_with_tidy:1}%{!?_with_tidy:0}
10    
11     Summary: The PHP HTML-embedded scripting language. (PHP: Hypertext Preprocessor)
12     Name: php5-cgi
13     Version: 5.2.8
14     Release: 1.dh
15     %{?rh90:Epoch: 1 }
16     License: The PHP License
17     Group: Development/Languages
18     URL: http://www.php.net/
19    
20     Source0: http://www.php.net/distributions/php-%{version}.tar.bz2
21    
22     Source50: php5.conf
23    
24     #Patch2: php-4.3.4-config.patch
25     #Patch3: php-4.2.2-lib64.patch
26     #Patch4: php-4.2.2-cxx.patch
27     #Patch5: php-4.3.3-install.patch
28     #Patch6: php-4.3.1-tests.patch
29     #Patch7: php-4.3.2-libtool15.patch
30     #Patch8: php-4.3.3-miscfix.patch
31     #Patch9: php-4.3.6-umask.patch
32     Patch10: php-4.3.7-handler.patch
33     Patch11: php-4.3.8-fdsetsize.patch
34    
35     # Fixes for extension modules
36     #Patch21: php-4.3.1-odbc.patch
37     #Patch22: php-4.3.2-db4.patch
38     #Patch23: php-4.3.7-gmppowm.patch
39    
40     # Functional changes
41     #Patch30: php-4.3.1-dlopen.patch
42     #Patch31: php-4.3.4-easter.patch
43    
44     BuildRoot: %{_tmppath}/%{name}-root
45    
46     BuildRequires: bzip2-devel, curl-devel >= 7.9, db4-devel, expat-devel, freetype-devel
47     BuildRequires: gd-devel >= 1.8.4, gmp-devel, aspell-devel
48     BuildRequires: httpd-devel, libjpeg-devel, libpng-devel, pam-devel
49     BuildRequires: libstdc++-devel, ncurses-devel, openssl-devel
50     BuildRequires: zlib-devel, pcre-devel
51     %{?rhel4:BuildRequires: libgcrypt-devel}
52     BuildRequires: bzip2, fileutils, perl, libtool >= 1.4.3
53     %{?_with_tidy:BuildRequires: tidy}
54     %{?_with_tidy:Requires: tidy}
55    
56     Obsoletes: php-dbg, mod_php, php3, phpfi, stronghold-php, php-xslt
57     # Enforce Apache module ABI compatibility
58     Requires: httpd-mmn = %(cat %{_includedir}/httpd/.mmn || echo missing-httpd-devel)
59     Requires: php5-cgi-pear
60     Conflicts: php >= 5.0.0
61     # Require extension which was previously built-in
62     # Requires: php-mbstring = %{version}-%{release}
63     # ^^ dunno if mbstring is required anymore, couldn't get it to compile
64     # initially so I nuked the requirement
65    
66    
67     %description
68     PHP is an HTML-embedded scripting language. PHP attempts to make it
69     easy for developers to write dynamically generated webpages. PHP also
70     offers built-in database integration for several commercial and
71     non-commercial database management systems, so writing a
72     database-enabled webpage with PHP is fairly simple. The most common
73     use of PHP coding is probably as a replacement for CGI scripts. The
74     mod_php module enables the Apache Web server to understand and process
75     the embedded PHP language in Web pages.
76    
77     This is a CGI build of PHP5. This is to assist hosts in deploying PHP5 side by side with PHP4. After installation it is recommended the following lines be added to a servers startup scripts to avoid the requirement of a shebang line on .php5 files:
78    
79     # Allow PHP5 to run without shebang
80     modprobe binfmt_misc
81     echo ':PHP5:E::php5::/usr/bin/php5/php:' > /proc/sys/fs/binfmt_misc/register
82    
83     %package devel
84     Group: Development/Libraries
85     Summary: Files needed for building PHP extensions.
86     Requires: php5-cgi = %{version}-%{release}
87    
88     %description devel
89     The php-devel package contains the files needed for building PHP
90     extensions. If you need to compile your own PHP extensions, you will
91     need to install this package.
92    
93     %package pear
94     Group: Development/Languages
95     Summary: PHP Extension and Application Repository Components
96     Requires: php5-cgi
97    
98     %description pear
99     PEAR is a framework and distribution system for reusable PHP
100     components. This package contains a set of PHP components from the
101     PEAR repository.
102    
103     %package imap
104     Summary: An Apache module for PHP applications that use IMAP.
105     Group: Development/Languages
106     Requires: php5-cgi = %{version}-%{release}
107     Obsoletes: mod_php3-imap, stronghold-php-imap
108     BuildRequires: krb5-devel, openssl-devel
109     %{?rh73:BuildRequires: imap-devel}
110     %{?rh90:BuildRequires: imap-devel}
111     %{?rhel3:BuildRequires: imap-devel}
112     %{?rhfc1:BuildRequires: imap-devel}
113     %{?rhfc2:BuildRequires: libc-client-devel}
114     %{?rhel4:BuildRequires: libc-client-devel}
115    
116    
117     %description imap
118     The php-imap package contains a dynamic shared object (DSO) for the
119     Apache Web server. When compiled into Apache, the php-imap module will
120     add IMAP (Internet Message Access Protocol) support to PHP. IMAP is a
121     protocol for retrieving and uploading e-mail messages on mail
122     servers. PHP is an HTML-embedded scripting language. If you need IMAP
123     support for PHP applications, you will need to install this package
124     and the php package.
125    
126     %package ldap
127     Summary: A module for PHP applications that use LDAP.
128     Group: Development/Languages
129     Requires: php5-cgi = %{version}-%{release}
130     Obsoletes: mod_php3-ldap, stronghold-php-ldap
131     BuildRequires: cyrus-sasl-devel, openldap-devel, openssl-devel
132    
133     %description ldap
134     The php-ldap package is a dynamic shared object (DSO) for the Apache
135     Web server that adds Lightweight Directory Access Protocol (LDAP)
136     support to PHP. LDAP is a set of protocols for accessing directory
137     services over the Internet. PHP is an HTML-embedded scripting
138     language. If you need LDAP support for PHP applications, you will
139     need to install this package in addition to the php package.
140    
141     %package mysql
142     Summary: A module for PHP applications that use MySQL databases.
143     Group: Development/Languages
144     Requires: php5-cgi = %{version}-%{release}
145     Provides: php_database
146     Obsoletes: mod_php3-mysql, stronghold-php-mysql
147     BuildRequires: mysql-devel
148    
149     %description mysql
150     The php-mysql package contains a dynamic shared object that will add
151     MySQL database support to PHP. MySQL is an object-relational database
152     management system. PHP is an HTML-embeddable scripting language. If
153     you need MySQL support for PHP applications, you will need to install
154     this package and the php or mod_php package.
155    
156     %package pgsql
157     Summary: A PostgreSQL database module for PHP.
158     Group: Development/Languages
159     Requires: php5-cgi = %{version}-%{release}
160     Provides: php_database
161     Obsoletes: mod_php3-pgsql, stronghold-php-pgsql
162     BuildRequires: krb5-devel, openssl-devel
163     %{?rh73:BuildRequires: postgresql-devel}
164     %{?rhfc1:BuildRequires: postgresql-devel}
165     %{?rhfc2:BuildRequires: postgresql-devel}
166     %{?rhel3:BuildRequires: rh-postgresql-devel}
167     %{?rhel4:BuildRequires: postgresql-devel}
168     %{?rh90:BuildRequires: postgresql-devel}
169    
170    
171     %description pgsql
172     The php-pgsql package includes a dynamic shared object (DSO) that can
173     be compiled in to the Apache Web server to add PostgreSQL database
174     support to PHP. PostgreSQL is an object-relational database management
175     system that supports almost all SQL constructs. PHP is an
176     HTML-embedded scripting language. If you need back-end support for
177     PostgreSQL, you should install this package in addition to the main
178     php package.
179    
180     %package odbc
181     Group: Development/Languages
182     Requires: php5-cgi = %{version}-%{release}
183     Summary: A module for PHP applications that use ODBC databases.
184     Provides: php_database
185     Obsoletes: stronghold-php-odbc
186     BuildRequires: unixODBC-devel
187    
188     %description odbc
189     The php-odbc package contains a dynamic shared object that will add
190     database support through ODBC to PHP. ODBC is an open specification
191     which provides a consistent API for developers to use for accessing
192     data sources (which are often, but not always, databases). PHP is an
193     HTML-embeddable scripting language. If you need ODBC support for PHP
194     applications, you will need to install this package and the php
195     package.
196    
197     %if %{with_oci8}
198     %package oci8
199     Group: Development/Languages
200     Requires: php5-cgi = %{version}-%{release}
201     Summary: A module for PHP applications that use OCI8 databases.
202     Provides: php_database
203    
204     %description oci8
205     The php-oci8 package contains a dynamic shared object that will add
206     support for accessing OCI8 databases to PHP.
207     %endif
208    
209     %if %{with_mssql}
210     %package mssql
211     Group: Development/Languages
212     Requires: php5-cgi = %{version}-%{release}, freetds
213     Summary: A module for PHP applications that use MSSQL databases.
214     Provides: php_database
215     BuildRequires: freetds-devel
216    
217     %description mssql
218     The mssql package contains a dynamic shared object that will add
219     support for accessing MSSQL databases to PHP.
220     %endif
221    
222     %if %{with_mhash}
223     %package mhash
224     Summary: A module for PHP applications that use Mhash.
225     Group: Development/Languages
226     Requires: php5-cgi = %{version}-%{release}
227     BuildRequires: mhash-devel
228    
229     %description mhash
230     The php-mhash package is a dynamic shared object (DSO) for the Apache
231     Web server that adds Mhash support to PHP.
232     %endif
233    
234    
235     %if %{with_mcrypt}
236     %package mcrypt
237     Group: Development/Languages
238     BuildRequires: libmcrypt, libmcrypt-devel
239     Requires: php5-cgi = %{version}-%{release}, libmcrypt
240     Summary: A module for PHP applications to use the mcrypt library
241    
242     %description mcrypt
243     The php-mcrypt library includes a dynamic shared object (DSO) that adds
244     Mcrypt support to PHP4. The libmcrypt is a data encryption library. The
245     library is thread safe and provides encryption and decryption functions.
246     This version of the library supports many encryption algorithms and
247     encryption modes. Some algorithms which are supported: SERPENT,
248     RIJNDAEL, 3DES, GOST, SAFER+, CAST-256, RC2, XTEA, 3WAY, TWOFISH,
249     BLOWFISH, ARCFOUR, WAKE and more. Install this package in addition
250     to main PHP package if you plan to use any of these algorithms.
251     %endif
252    
253    
254     %package snmp
255     Summary: A module for PHP applications that query SNMP-managed devices.
256     Group: Development/Languages
257     Requires: php5-cgi = %{version}-%{release}
258     BuildRequires: net-snmp-devel, elfutils-devel
259     # elfutils-devel requirement workaround for #103982
260    
261     %description snmp
262     The php-snmp package contains a dynamic shared object that will add
263     support for querying SNMP devices to PHP. PHP is an HTML-embeddable
264     scripting language. If you need SNMP support for PHP applications, you
265     will need to install this package and the php package.
266    
267     %package xmlrpc
268     Summary: A module for PHP applications which use the XML-RPC protocol
269     Group: Development/Languages
270     Requires: php5-cgi = %{version}-%{release}
271     BuildRequires: expat-devel
272    
273     %description xmlrpc
274     The php-xmlrpc package contains a dynamic shared object that will add
275     support for the XML-RPC protocol to PHP.
276    
277     %package mbstring
278     Summary: A module for PHP applications which need multi-byte string handling
279     Group: Development/Languages
280     Requires: php5-cgi = %{version}-%{release}
281    
282     %description mbstring
283     The php-mbstring package contains a dynamic shared object that will add
284     support for multi-byte string handling to PHP.
285    
286     %prep
287     %setup -q -n php-%{version}
288     #%patch2 -p1 -b .config
289     #%patch3 -p1 -b .lib64
290     #%patch4 -p1 -b .cxx
291     #%patch5 -p1 -b .install
292     #%patch6 -p1 -b .tests
293     #%patch7 -p1 -b .libtool15
294     #%patch8 -p1 -b .miscfix
295     #%patch9 -p1 -b .umask
296     #%patch10 -p1 -b .handler
297     #%patch11 -p1 -b .fdsetsize
298    
299     #%patch21 -p1 -b .odbc
300     #%patch22 -p1 -b .db4
301     #%patch23 -p1 -b .gmppowm
302    
303     #%patch30 -p1 -b .dlopen
304     ##%patch31 -p1 -b .easter
305    
306     # Prevent %%doc confusion over LICENSE files
307     cp Zend/LICENSE Zend/ZEND_LICENSE
308     cp TSRM/LICENSE TSRM_LICENSE
309     cp regex/COPYRIGHT regex_COPYRIGHT
310     cp ext/gd/libgd/README gd_README
311    
312     # Source is built twice: once for /usr/bin/php5/php, once for the Apache DSO.
313     mkdir build-cgi
314    
315     # Use correct libdir
316     perl -pi -e 's|%{_prefix}/lib|%{_libdir}|' php.ini-recommended
317     perl -pi -e 's|extension_dir \= \"\.\/\"|extension_dir \= \"%{_libdir}\/php5\/\"|' php.ini-recommended
318    
319     # Remove bogus test; position of read position after fopen(, "a+")
320     # is not defined by C standard, so don't presume anything.
321     rm -f ext/standard/tests/file/bug21131.phpt
322    
323     # Tests that fail.
324     rm -f ext/standard/tests/file/bug22414.phpt \
325     ext/session/tests/019.phpt \
326     ext/standard/tests/math/pow.phpt \
327     ext/standard/tests/math/round.phpt \
328     ext/standard/tests/math/abs.phpt \
329     ext/iconv/tests/bug16069.phpt
330    
331     : Build for oci8=%{with_oci8} mssql=%{with_mssql} mhash=%{with_mhash} mcrypt=%{with_mcrypt}
332    
333     %build
334    
335     CFLAGS="$RPM_OPT_FLAGS -Wall -fno-strict-aliasing"; export CFLAGS
336    
337     if [ ! -r '/usr/lib/libmysqlclient.so' ]
338     then
339     ln -s /usr/lib/mysql/libmysqlclient.so /usr/lib/libmysqlclient.so
340     fi
341    
342     # Install extension modules in %{_libdir}/php5.
343     EXTENSION_DIR=%{_libdir}/php5; export EXTENSION_DIR
344    
345     # pull latest ltmain.sh, AC_PROG_LIBTOOL
346     libtoolize --force --copy
347     # force aclocal run during buildconf
348     touch acinclude.m4
349    
350     # Regenerate configure scripts (patches change config.m4's)
351     ./buildconf --force
352    
353     # Shell function to configure and build a PHP tree.
354     build() {
355     # bison-1.875-2 seems to produce a broken parser; workaround.
356     mkdir Zend && cp ../Zend/zend_{language,ini}_{parser,scanner}.[ch] Zend
357     ln -sf ../configure
358     %configure \
359     --bindir=%{_bindir}/php5 \
360     --sbindir=%{_sbindir}/php5 \
361     --libdir=%{_libdir}/php5 \
362     --includedir=/usr/include/php5 \
363     --cache-file=../config.cache \
364     --sysconfdir=/etc/php5 \
365     --with-config-file-path=%{_sysconfdir}/php5 \
366     --with-config-file-scan-dir=%{_sysconfdir}/php5/php5.d \
367     --enable-discard-path \
368     --disable-debug \
369     --enable-pic \
370     --disable-rpath \
371     --enable-inline-optimization \
372     --with-bz2 \
373     --with-kerberos \
374     --with-db4=%{_prefix} \
375     --with-curl \
376     --with-exec-dir=%{_bindir}/php5 \
377     --with-freetype-dir=%{_prefix} \
378     --with-png-dir=%{_prefix} \
379     --with-gd \
380     --enable-gd-native-ttf \
381     --without-gdbm \
382     --with-gettext \
383     --with-ncurses \
384     --with-gmp \
385     --with-iconv \
386     --with-jpeg-dir=%{_prefix} \
387     --with-openssl \
388     --with-png \
389     --with-pspell \
390     --with-regex=system \
391     --with-xml \
392     --with-expat-dir=%{_prefix} \
393     --with-dom=shared,%{_prefix} \
394     --with-dom-xslt=%{_prefix} --with-dom-exslt=%{_prefix} \
395     --with-xsl \
396     --with-xmlrpc=shared \
397     %{?rhfc1:--with-pcre-regex=%{_prefix} } \
398     %{?rhfc2:--with-pcre-regex=%{_prefix} } \
399     --with-zlib \
400     --with-layout=GNU \
401     --enable-bcmath \
402     --enable-exif \
403     --enable-ftp \
404     --enable-magic-quotes \
405     --enable-safe-mode \
406     --enable-sockets \
407     --enable-sysvsem \
408     --enable-sysvshm \
409     --enable-track-vars \
410     --enable-trans-sid \
411     --enable-yp \
412     --enable-wddx \
413     --with-pear=/usr/share/pear5 \
414     --with-imap=shared --with-imap-ssl \
415     %{?rhfc1:--with-kerberos } \
416     %{?rhfc2:--with-kerberos } \
417     %{?rhel3:--with-kerberos=/usr/kerberos } \
418     %{?rhel4:--with-kerberos } \
419     %{?rh90:--with-kerberos=/usr/kerberos } \
420     --with-ldap=shared \
421     --with-mysql=shared,/usr \
422     %{?_with_oci8:--with-oci8=shared} \
423     %{?_with_mssql:--with-mssql=shared} \
424     %{?_with_mhash:--with-mhash=shared} \
425     %{?_with_mcrypt:--with-mcrypt=shared} \
426     --with-pgsql=shared \
427     --with-snmp=shared,%{_prefix} \
428     --with-snmp=shared \
429     --enable-ucd-snmp-hack \
430     --with-unixODBC=shared,%{_prefix} \
431     --enable-memory-limit \
432     --enable-bcmath \
433     --enable-shmop \
434     --enable-calendar \
435     --enable-dbx \
436     --enable-dio \
437     --enable-mcal \
438     %{?_with_tidy:--with-tidy} \
439     %{?_with_mbstring:--enable-mbstring=shared --enable-mbstr-enc-trans --enable-mbregex} \
440     $*
441    
442     make %{?_smp_mflags}
443     }
444    
445     # Build standalone /usr/bin/php
446     echo "PHP CGI"
447     pushd build-cgi
448     build
449     # Run tests
450     #export NO_INTERACTION=1 REPORT_EXIT_STATUS=1
451     #if ! TZ= LANG= LC_ALL= make test; then
452     # for f in `find .. -name \*.diff -type f -print`; do
453     # echo "TEST FAILURE -- $f --"
454     # cat $f
455     # done
456     #fi
457     #popd
458    
459     %install
460     [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
461    
462     # Hack
463     %{?rh90:install -m 755 -d $RPM_BUILD_ROOT/etc/httpd/conf }
464     %{?rh90:install -m 644 /etc/httpd/conf/httpd.conf $RPM_BUILD_ROOT%{_sysconfdir}/httpd/conf/httpd.conf }
465    
466     # Install from CGI tree
467     pushd build-cgi
468     make install INSTALL_ROOT=$RPM_BUILD_ROOT
469     popd
470    
471     # remove build files
472     rm -fr $RPM_BUILD_ROOT%{_libdir}/php
473    
474     # Install the default configuration file and icons
475     install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/php5
476     install -m 644 php.ini-recommended $RPM_BUILD_ROOT%{_sysconfdir}/php5/php.ini
477     #install -m 755 -d $RPM_BUILD_ROOT%{contentdir}/icons
478     #install -m 644 *.gif $RPM_BUILD_ROOT%{contentdir}/icons/
479    
480     # Apache config fragment
481     install -m 755 -d $RPM_BUILD_ROOT/etc/httpd/conf.d
482     install -m 644 $RPM_SOURCE_DIR/php5.conf $RPM_BUILD_ROOT/etc/httpd/conf.d
483    
484     install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/php5/php5.d
485     install -m 755 -d $RPM_BUILD_ROOT%{_localstatedir}/lib/php5
486     install -m 700 -d $RPM_BUILD_ROOT%{_localstatedir}/lib/php5/session
487    
488     # Generate files lists and stub .ini files for each subpackage
489     for mod in pgsql mysql odbc ldap snmp xmlrpc imap %{?_with_mbstring:mbstring} \
490     %{?_with_oci8:oci8} %{?_with_mssql:mssql} %{?_with_mhash:mhash} %{?_with_mcrypt:mcrypt}; do
491     cat > $RPM_BUILD_ROOT%{_sysconfdir}/php5/php5.d/${mod}.ini <<EOF
492     ; Enable ${mod} extension module
493     extension=${mod}.so
494     EOF
495     cat > files.${mod} <<EOF
496     %{?rhel4:%attr(755,root,root) %{_libdir}/php5/${mod}.so}
497     %{?rhel3:%attr(755,root,root) %{_libdir}/php5/${mod}}
498     %config(noreplace) %attr(644,root,root) %{_sysconfdir}/php5/php5.d/${mod}.ini
499     EOF
500     done
501    
502     # Remove PEAR testsuite
503     rm -rf $RPM_BUILD_ROOT%{_datadir}/pear5/tests
504    
505     # Remove unpackaged files
506     rm -f $RPM_BUILD_ROOT%{_libdir}/php5/*.a \
507     $RPM_BUILD_ROOT%{_bindir}/php5/{phptar,pearize}
508    
509     rm -fr $RPM_BUILD_ROOT/.channels $RPM_BUILD_ROOT/.depdb $RPM_BUILD_ROOT/.depdblock $RPM_BUILD_ROOT/.filemap $RPM_BUILD_ROOT/.lock $RPM_BUILD_ROOT/.registry
510    
511     # Remove irrelevant docs
512     rm -f README.{Zeus,QNX,CVS-RULES}
513    
514     # Post rh90 hack
515     # Hack
516     %{?rh90: rm -f $RPM_BUILD_ROOT%{_sysconfdir}/httpd/conf/httpd.conf* }
517    
518    
519    
520     %clean
521     [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
522     rm files.*
523    
524     %files
525     %defattr(-,root,root)
526     %doc CODING_STANDARDS CREDITS EXTENSIONS INSTALL LICENSE NEWS README*
527     %doc Zend/ZEND_* gd_README TSRM_LICENSE regex_COPYRIGHT
528     %config(noreplace) %{_sysconfdir}/php5/php.ini
529     %config %{_sysconfdir}/php5/pear.conf
530     %{_bindir}/php5/php
531     %{_bindir}/php5/php-cgi
532     %dir %{_libdir}/php5
533     %dir %{_localstatedir}/lib/php5
534     %attr(0700,apache,apache) %dir %{_localstatedir}/lib/php5/session
535     %config %{_sysconfdir}/httpd/conf.d/php5.conf
536     %dir %{_sysconfdir}/php5/php5.d
537     %doc %{_datadir}/man
538    
539     #/usr/share/man/man1/p
540    
541     %files pear
542     %defattr(-,root,root)
543     %{_bindir}/php5/pear
544     %{_datadir}/pear5
545     %{_bindir}/php5/peardev
546     %{_bindir}/php5/pecl
547    
548     %files devel
549     %defattr(-,root,root)
550     %{_bindir}/php5/php-config
551     %{_bindir}/php5/phpize
552     #%{_bindir}/php5/phpextdist
553     %{_includedir}/php5
554     %{_libdir}/php5/build
555    
556     %files pgsql -f files.pgsql
557     %{_libdir}/php5/pgsql.so
558    
559     %files mysql -f files.mysql
560     %{_libdir}/php5/mysql.so
561    
562     %files odbc -f files.odbc
563     %{_libdir}/php5/odbc.so
564    
565     %if %{with_oci8}
566     %files oci8 -f files.oci8
567     %endif
568    
569     %if %{with_mssql}
570     %files mssql -f files.mssql
571     %endif
572    
573     %if %{with_mhash}
574     %files mhash -f files.mhash
575     %endif
576    
577     %if %{with_mcrypt}
578     %files mcrypt -f files.mcrypt
579     %endif
580    
581     %files imap -f files.imap
582     %{_libdir}/php5/imap.so
583    
584     %files ldap -f files.ldap
585     %{_libdir}/php5/ldap.so
586    
587     %files snmp -f files.snmp
588     %{_libdir}/php5/snmp.so
589    
590     %files xmlrpc -f files.xmlrpc
591     %{_libdir}/php5/xmlrpc.so
592    
593     %if %{with_mbstring}
594     %files mbstring -f files.mbstring
595     %endif
596    
597     %changelog
598     * Mon Jan 12 2009 David Harper <davidiwharper@hotmail.com> 5.2.8-1.dh
599     - Upgrade to latest version of PHP
600     - Build fixes for CentOS/SME
601     * Fri Jan 20 2006 Stuart K. Low <stuart@serverpeak.com> 5.1.2-1
602     - Mass upgrade
603     - Added rhel4 flags
604     - Fixed pointers to changed (?) libraries from lib.so to just lib. Odd change.
605     * Fri Jun 10 2005 Stuart K. Low <stuart@serverpeak.com> 5.0.4-2
606     - Fixed tidy again.
607     * Sun May 29 2005 Stuart K. Low <stuart@serverpeak.com> 5.0.4-1
608     - Upgrade to 5.0.4
609     * Sat Feb 19 2005 Stuart K. Low <stuart@serverpeak.com> 5.0.3-3
610     - addition of --with-tidy
611     * Wed Jan 26 2005 Stuart K. Low <stuart@serverpeak.com> 5.0.3-1
612     - initial conversion to a CGI version for PHP5
613     - removed domxml since it's been moved to PECL in PHP5
614     - renamed to php5-cgi for clarity reasons (not to conflict with ARTs PHP5)
615     - removed mbstring dependency, don't know if this is smart
616    
617     * Fri Oct 15 2004 Scott R. Shinn <scott@atomicrocketturtle.com> 4.3.9-11
618     - set the Epoch number for rh90 only, apparently there is some bug in yum on FC1/FC2/3ES that causes issues when using the Epoch
619    
620     * Sat Oct 09 2004 Scott R. Shinn <scott@atomicrocketturtle.com> 4.3.9-10
621     - rebuilt for high file descriptor environments
622    
623     * Fri Oct 08 2004 Scott R. Shinn <scott@atomicrocketturtle.com> 4.3.9-8
624     - logs of bugfixes
625    
626     * Thu Oct 07 2004 Scott R. Shinn <scott@atomicrocketturtle.com> 4.3.9-6
627     - merging my php 4.3.9 rpm with the FC2 version
628    
629     * Fri Jul 16 2004 Joe Orton <jorton@redhat.com> 4.3.8-2.1
630     - revert upstream default php.ini change since 4.3.6
631     - add three FD_SETSIZE changes to main/network.c (#125258)
632    
633     * Wed Jul 14 2004 Joe Orton <jorton@redhat.com> 4.3.8-2.0
634     - update to 4.3.8
635     - add gmp_powm fix (Oskari Saarenmaa, #124318)
636     - split out mbstring extension into php-mbstring subpackage
637     - fix rebuild without bison/flex
638     - have -devel require php of same release
639     - add fixes for memory handling in 2.0 handler SAPI
640    
641     * Wed May 19 2004 Joe Orton <jorton@redhat.com> 4.3.6-5
642     - don't obsolete php-imap (#123580)
643     - unconditionally build -imap subpackage
644    
645     * Thu May 13 2004 Joe Orton <jorton@redhat.com> 4.3.6-4
646     - remove trigger
647    
648     * Thu Apr 22 2004 Joe Orton <jorton@redhat.com> 4.3.6-3
649     - fix umask reset "feature" (#121454)
650     - don't use DL_GLOBAL when dlopen'ing extension modules
651    
652     * Sun Apr 18 2004 Joe Orton <jorton@redhat.com> 4.3.6-2
653     - fix segfault on httpd SIGHUP (upstream #27810)
654    
655     * Fri Apr 16 2004 Joe Orton <jorton@redhat.com> 4.3.6-1
656     - update to 4.3.6 (Robert Scheck, #121011)
657    
658     * Wed Apr 7 2004 Joe Orton <jorton@redhat.com> 4.3.4-11
659     - add back imap subpackage, using libc-client (#115535)
660    
661     * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
662     - rebuilt
663    
664     * Wed Feb 18 2004 Joe Orton <jorton@redhat.com> 4.3.4-10
665     - eliminate /usr/local/lib RPATH in odbc.so
666     - really use system pcre library
667    
668     * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com> 4.3.4-9
669     - rebuilt
670    
671     * Mon Feb 2 2004 Bill Nottingham <notting@redhat.com> 4.3.4-8
672     - obsolete php-imap if we're not building it
673    
674     * Wed Jan 28 2004 Joe Orton <jorton@redhat.com> 4.3.4-7
675     - gd fix for build with recent Freetype2 (from upstream)
676     - remove easter egg (Oden Eriksson, Mandrake)
677    
678     * Wed Jan 21 2004 Joe Orton <jorton@redhat.com> 4.3.4-6
679     - php-pear requires php
680     - also remove extension=imap from php.ini in upgrade trigger
681     - merge from Taroon: allow upgrade from Stronghold 4.0
682    
683     * Wed Jan 21 2004 Joe Orton <jorton@redhat.com> 4.3.4-5
684     - add defattr for php-pear subpackage
685     - restore defaults: output_buffering=Off, register_argc_argv=On
686     - add trigger to handle php.ini upgrades smoothly (#112470)
687    
688     * Tue Jan 13 2004 Joe Orton <jorton@redhat.com> 4.3.4-4
689     - conditionalize support for imap extension for the time being
690     - switch /etc/php.ini to use php.ini-recommended (but leave
691     variables_order as EGPCS) (#97765)
692     - set session.path to /var/lib/php/session by default (#89975)
693     - own /var/lib/php{,/session} and have apache own the latter
694     - split off php-pear subpackage (#83771)
695    
696     * Sat Dec 13 2003 Jeff Johnson <jbj@jbj.org> 4.3.4-3
697     - rebuild against db-4.2.52.
698    
699     * Mon Dec 1 2003 Joe Orton <jorton@redhat.com> 4.3.4-2
700     - rebuild for new libxslt (#110658)
701     - use --with-{mssql,oci8} for enabling extensions (#110482)
702     - fix rebuild issues (Jan Visser, #110274)
703     - remove hard-coded LIBS
704     - conditional support for mhash (Aleksander Adamowski, #111251)
705    
706     * Mon Nov 10 2003 Joe Orton <jorton@redhat.com> 4.3.4-1.1
707     - rebuild for FC1 updates
708    
709     * Mon Nov 10 2003 Joe Orton <jorton@redhat.com> 4.3.4-1
710     - update to 4.3.4
711     - include all licence files
712     - libxmlrpc fixes
713    
714     * Mon Oct 20 2003 Joe Orton <jorton@redhat.com> 4.3.3-6
715     - use bundled libgd (#107407)
716     - remove manual: up-to-date manual sources are no longer DFSG-free;
717     it's too big; it's on the web anyway; #91292, #105804, #107384
718    
719     * Wed Oct 15 2003 Joe Orton <jorton@redhat.com> 4.3.3-5
720     - add php-xmlrpc subpackage (#107138)
721    
722     * Mon Oct 13 2003 Joe Orton <jorton@redhat.com> 4.3.3-4
723     - drop recode support, symbols collide with MySQL
724    
725     * Sun Oct 12 2003 Joe Orton <jorton@redhat.com> 4.3.3-3
726     - split domxml extension into php-domxml subpackage
727     - enable xslt and xml support in domxml extension (#106042)
728     - fix httpd-devel build requirement (#104341)
729     - enable recode extension (#106755)
730     - add workaround for #103982
731    
732     * Thu Sep 25 2003 Jeff Johnson <jbj@jbj.org> 4.3.3-3
733     - rebuild against db-4.2.42.
734    
735     * Sun Sep 7 2003 Joe Orton <jorton@redhat.com> 4.3.3-2
736     - don't use --enable-versioning, it depends on libtool being
737     broken (#103690)
738    
739     * Sun Sep 7 2003 Joe Orton <jorton@redhat.com> 4.3.3-1
740     - update to 4.3.3
741     - add libtool build prereq (#103388)
742     - switch to apache2handler
743    
744     * Mon Jul 28 2003 Joe Orton <jorton@redhat.com> 4.3.2-8
745     - rebuild
746    
747     * Tue Jul 22 2003 Nalin Dahyabhai <nalin@redhat.com> 4.3.2-7
748     - rebuild
749    
750     * Tue Jul 8 2003 Joe Orton <jorton@redhat.com> 4.3.2-6
751     - use system pcre library
752    
753     * Mon Jun 9 2003 Joe Orton <jorton@redhat.com> 4.3.2-5
754     - enable mbstring and mbregex (#81336)
755     - fix use of libtool 1.5
756    
757     * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
758     - rebuilt
759    
760     * Tue Jun 3 2003 Joe Orton <jorton@redhat.com> 4.3.2-3
761     - add lib64 and domxml fixes
762    
763     * Tue Jun 3 2003 Frank Dauer <f@paf.net>
764     - added conditional support for mssql module (#92149)
765    
766     * Fri May 30 2003 Joe Orton <jorton@redhat.com> 4.3.2-2
767     - update the -tests and -lib64 patches
768     - fixes for db4 detection
769     - require aspell-devel >= 0.50.0 for pspell compatibility
770    
771     * Thu May 29 2003 Joe Orton <jorton@redhat.com> 4.3.2-1
772     - update to 4.3.2
773    
774     * Fri May 16 2003 Joe Orton <jorton@redhat.com> 4.3.1-3
775     - link odbc module correctly
776     - patch so that php -n doesn't scan inidir
777     - run tests using php -n, avoid loading system modules
778    
779     * Wed May 14 2003 Joe Orton <jorton@redhat.com> 4.3.1-2
780     - workaround broken parser produced by bison-1.875
781    
782     * Tue May 6 2003 Joe Orton <jorton@redhat.com> 4.3.1-1
783     - update to 4.3.1; run test suite
784     - open extension modules with RTLD_NOW rather than _LAZY
785    
786     * Tue May 6 2003 Joe Orton <jorton@redhat.com> 4.2.2-19
787     - patch for gd 2.x API changes in gd extension
788    
789     * Thu May 1 2003 Joe Orton <jorton@redhat.com> 4.2.2-18
790     - rebuild to use aspell (#89925)
791     - patch to work round conditional AC_PROG_CXX break in autoconf 2.57
792     - fix dba build against db >= 4.1
793    
794     * Mon Feb 24 2003 Joe Orton <jorton@redhat.com> 4.2.2-17
795     - restrict SNMP patch to minimal changes, fixing segv on startup (#84607)
796    
797     * Wed Feb 12 2003 Joe Orton <jorton@redhat.com> 4.2.2-16
798     - prevent startup if using httpd.worker to avoid thread-safety issues.
799     - fix parsing private keys in OpenSSL extension (#83994)
800     - fixes for SNMP extension (backport from 4.3) (#74761)
801    
802     * Wed Jan 29 2003 Joe Orton <jorton@redhat.com> 4.2.2-15
803     - add security fixes for wordwrap() and mail()
804    
805     * Mon Jan 13 2003 Joe Orton <jorton@redhat.com> 4.2.2-14
806     - drop explicit Requires in subpackages, rely on automatic deps.
807     - further fixes for libdir=lib64
808    
809     * Tue Dec 17 2002 Joe Orton <jorton@redhat.com> 4.2.2-13
810     - drop prereq for perl, grep in subpackages
811     - rebuild and patch for OpenSSL 0.9.7
812    
813     * Tue Dec 10 2002 Joe Orton <jorton@redhat.com> 4.2.2-12
814     - backport "ini dir scanning" patch from CVS HEAD; /etc/php.d/*.ini
815     are now loaded at startup; each subpackage places an ini file
816     in that directory rather than munging /etc/php.ini in post/postun.
817     - default config changes: enable short_open_tag; remove settings for
818     php-dbg extension
819    
820     * Wed Dec 4 2002 Joe Orton <jorton@redhat.com> 4.2.2-11
821     - own the /usr/lib/php4 directory (#73894)
822     - reinstate dropped patch to unconditionally disable ZTS
823    
824     * Mon Dec 2 2002 Joe Orton <jorton@redhat.com> 4.2.2-10
825     - remove ldconfig invocation in post/postun
826     - fixes for #73516 (partially), #78586, #75029, #75712, #75878
827    
828     * Wed Nov 6 2002 Joe Orton <jorton@redhat.com> 4.2.2-9
829     - fixes for libdir=/usr/lib64, based on SuSE's patches.
830     - add build prereqs for zlib-devel, imap-devel, curl-devel (#74819)
831     - remove unpackaged files from install root
832     - libtoolize; use configure cache to speed up build
833    
834     * Mon Sep 23 2002 Philip Copeland <bryce@redhat.com> 4.2.2-8.0.6
835     - PHP cannot determine which UID is being used, so safe
836     mode restrictions were always applied. Fixed. (#74396)
837    
838     * Tue Sep 3 2002 Philip Copeland <bryce@redhat.com> 4.2.2-8.0.4
839     - zts support seems to crash out httpd on a *second* sighup
840     ie service httpd start;
841     apachectl restart ; (ok)
842     apachectl restart ; (httpd segv's and collapses)
843     removed --enable-experimental-zts which this seems related to.
844     - Small patch added because some places need to know that they
845     aren't using the ZTS API's (dumb)
846    
847     * Mon Sep 2 2002 Philip Copeland <bryce@redhat.com> 4.2.2-8.0.3
848     - fixup /etc/httpd/conf.d/php.conf to limit largest amount
849     of data accepted (#73254) Limited to 512K (which seems a
850     little excessive but anyway,..)
851     Note: php.conf is part of the srpm sources not part of the
852     php codebase.
853     - ditched extrenious --enable-debugger (was for php-dbg)
854     - When upgrading we tend not to modify /etc/php.ini if it exists,
855     instead we create php.ini.rpmnew. Modified the post scripts to
856     edit php.ini.rpmnew if it exists, so that people can copy
857     over the php.ini.rpmnew as php.ini knowing that it will
858     be an edited version, consistant with what modules they
859     installed #72033
860    
861     * Sun Sep 1 2002 Joe Orton <jorton@redhat.com> 4.2.2-8.0.2
862     - require httpd-mmn for module ABI compatibility
863    
864     * Fri Aug 30 2002 Philip Copeland <bryce@redhat.com> 4.2.2-8.0.1
865     - URLS would drop the last arguments #72752
866     --enable-mbstring
867     --enable-mbstr-enc-trans
868     These were supposed to help provide multibyte language
869     support, however, they cause problems. Removed. Maybe in
870     a later errata when they work.
871     - added small patch to php_variables.c that allows
872     $_GET[<var>] to initialise properly when
873     --enable-mbstr-enc-trans is disabled.
874     - Be consistant with errata naming (8.0.x)
875    
876     * Tue Aug 27 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.2-11
877     - rebuild
878    
879     * Wed Aug 22 2002 Philip Copeland <bryce@redhat.com> 4.2.2-10
880     - Beat down the requirement list to something a little
881     more sane
882    
883     * Wed Aug 14 2002 Bill Nottingham <notting@redhat.com> 4.2.2-9
884     - trim manual language lists
885    
886     * Mon Aug 12 2002 Gary Benson <gbenson@redhat.com> 4.2.2-8
887     - rebuild against httpd-2.0.40
888    
889     * Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com> 4.2.2-7
890     - rebuilt with gcc-3.2 (we hope)
891    
892     * Wed Aug 7 2002 Philip Copeland <bryce@redhat.com> 4.2.2-6
893     - Where multiple cookies are set, only the last one
894     was actually made. Fixes #67853
895    
896     * Mon Aug 5 2002 Philip Copeland <bryce@redhat.com> 4.2.2-5
897     - Shuffled the php/php-devel package file manifest
898     with respect to PEAR (PHP Extension and Application
899     Repository) #70673
900    
901     * Fri Aug 2 2002 Philip Copeland <bryce@redhat.com> 4.2.2-4
902     - #67815, search path doesn't include the pear directory
903     -pear not being installed correctly. Added --with-pear=
904     option.
905    
906     * Tue Jul 23 2002 Tim Powers <timp@redhat.com> 4.2.2-2
907     - build using gcc-3.2-0.1
908    
909     * Mon Jul 22 2002 Philip Copeland <bryce@redhat.com> 4.2.2-1
910     - Yippie 8/ another security vunerability (see
911     http://www.php.net/release_4_2_2.php for details)
912    
913     * Wed Jul 17 2002 Philip Copeland <bryce@redhat.com> 4.2.1-9
914     - Reminder to self that mm was pushed out because it's
915     NOT thread safe.
916     - Updated the manuals (much to Bills horror)
917    
918     * Tue Jul 16 2002 Philip Copeland <bryce@redhat.com> 4.2.1-8
919     - php.ini alteration to fit in with the install/uninstall
920     of various php rpm based installable modules
921    
922     * Mon Jul 15 2002 Philip Copeland <bryce@redhat.com> 4.2.1-8
923     - php -v showing signs of deep unhappiness with the world
924     added --enable-experimental-zts to configure to make it
925     happy again (yes I know experimental sounds 'dangerous'
926     it's just a name for an option we need)
927    
928     * Fri Jul 12 2002 Philip Copeland <bryce@redhat.com> 4.2.1-7
929     - #68715, Wrong name for Mysql Module in php.ini. Fixed.
930    
931     * Fri Jun 28 2002 Philip Copeland <bryce@redhat.com> 4.2.1-6
932     - SNMP fixup
933    
934     * Thu Jun 27 2002 Philip Copeland <bryce@redhat.com> 4.2.1-5
935     - Ah,.. seems httpd2 has been renamed to just plain
936     ol' httpd. Fixed spec file to suit.
937     - ucd-snmp changed to net-snmp overnight...
938     temporarily disabled snmp while I work out the
939     impact of this change and if it is safe
940    
941     * Wed Jun 26 2002 Philip Copeland <bryce@redhat.com> 4.2.1-4
942     - openldap 2.1.x problem solved by Nalin. Sure the ldap
943     API didn't change,... <mutter>. Added TSRMLS_FETCH()
944     to ldap_rebind_proc().
945     - Removed the php-dbg package as thats going to be provided
946     elsewhere
947    
948     * Fri Jun 21 2002 Tim Powers <timp@redhat.com> 4.2.1-3
949     - automated rebuild
950    
951     * Mon Jun 10 2002 Philip Copeland <bryce@redhat.com> 4.2.1-2
952     - Actually mm is now a dead project. Removed permently.
953    
954     * Tue May 28 2002 Gary Benson <gbenson@redhat.com> 4.2.1-2
955     - change paths for httpd-2.0
956     - add the config file
957     - disable mm temporarily
958    
959     * Sun May 26 2002 Tim Powers <timp@redhat.com> 4.2.1-1
960     - automated rebuild
961    
962     * Wed May 22 2002 Philip Copeland <bryce@redhat.com> 4.2.1-0
963     - Initial pristine build of php-4.2.1
964     - Minor patch to get around a 64 bitism
965     - Added in the dgb debugging hooks
966    

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed