/[smecontribs]/rpms/php5-cgi/contribs7/php5-sme.spec
ViewVC logotype

Annotation of /rpms/php5-cgi/contribs7/php5-sme.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.3 - (hide annotations) (download)
Wed Mar 4 17:04:44 2009 UTC (15 years, 3 months ago) by slords
Branch: MAIN
CVS Tags: HEAD
Changes since 1.2: +1 -1 lines
FILE REMOVED
Rename spec

1 slords 1.3 # $Id: php5-sme.spec,v 1.2 2009/03/04 15:02:45 slords Exp $
2 slords 1.2 # Authority: ????
3     # Name: David Harper
4 slords 1.1
5     %define contentdir /var/www
6     %define with_oci8 %{?_with_oci8:1}%{!?_with_oci8:0}
7     %define with_mssql %{?_with_mssql:1}%{!?_with_mssql:0}
8     %define with_mhash %{?_with_mhash:1}%{!?_with_mhash:0}
9     %define with_mcrypt %{?_with_mcrypt:1}%{!?_with_mcrypt:0}
10     %define with_mbstring %{?_with_mbstring:1}%{!?_with_mbstring:0}
11     %define with_tidy %{?_with_tidy:1}%{!?_with_tidy:0}
12    
13     Summary: The PHP HTML-embedded scripting language. (PHP: Hypertext Preprocessor)
14     Name: php5-cgi
15     Version: 5.2.8
16 slords 1.2 Release: 1%{?dist}
17 slords 1.1 License: The PHP License
18     Group: Development/Languages
19     URL: http://www.php.net/
20    
21     Source0: http://www.php.net/distributions/php-%{version}.tar.bz2
22    
23     Source50: php5.conf
24    
25     #Patch2: php-4.3.4-config.patch
26     #Patch3: php-4.2.2-lib64.patch
27     #Patch4: php-4.2.2-cxx.patch
28     #Patch5: php-4.3.3-install.patch
29     #Patch6: php-4.3.1-tests.patch
30     #Patch7: php-4.3.2-libtool15.patch
31     #Patch8: php-4.3.3-miscfix.patch
32     #Patch9: php-4.3.6-umask.patch
33     Patch10: php-4.3.7-handler.patch
34     Patch11: php-4.3.8-fdsetsize.patch
35    
36     # Fixes for extension modules
37     #Patch21: php-4.3.1-odbc.patch
38     #Patch22: php-4.3.2-db4.patch
39     #Patch23: php-4.3.7-gmppowm.patch
40    
41     # Functional changes
42     #Patch30: php-4.3.1-dlopen.patch
43     #Patch31: php-4.3.4-easter.patch
44    
45     BuildRoot: %{_tmppath}/%{name}-root
46    
47     BuildRequires: bzip2-devel, curl-devel >= 7.9, db4-devel, expat-devel, freetype-devel
48     BuildRequires: gd-devel >= 1.8.4, gmp-devel, aspell-devel
49     BuildRequires: httpd-devel, libjpeg-devel, libpng-devel, pam-devel
50     BuildRequires: libstdc++-devel, ncurses-devel, openssl-devel
51     BuildRequires: zlib-devel, pcre-devel
52     %{?rhel4:BuildRequires: libgcrypt-devel}
53     BuildRequires: bzip2, fileutils, perl, libtool >= 1.4.3
54     %{?_with_tidy:BuildRequires: tidy}
55     %{?_with_tidy:Requires: tidy}
56    
57     Obsoletes: php-dbg, mod_php, php3, phpfi, stronghold-php, php-xslt
58     # Enforce Apache module ABI compatibility
59     Requires: httpd-mmn = %(cat %{_includedir}/httpd/.mmn || echo missing-httpd-devel)
60     Requires: php5-cgi-pear
61     Conflicts: php >= 5.0.0
62     # Require extension which was previously built-in
63     # Requires: php-mbstring = %{version}-%{release}
64     # ^^ dunno if mbstring is required anymore, couldn't get it to compile
65     # initially so I nuked the requirement
66    
67    
68     %description
69     PHP is an HTML-embedded scripting language. PHP attempts to make it
70     easy for developers to write dynamically generated webpages. PHP also
71     offers built-in database integration for several commercial and
72     non-commercial database management systems, so writing a
73     database-enabled webpage with PHP is fairly simple. The most common
74     use of PHP coding is probably as a replacement for CGI scripts. The
75     mod_php module enables the Apache Web server to understand and process
76     the embedded PHP language in Web pages.
77    
78     This is a CGI build of PHP5. This is to assist hosts in deploying PHP5 side by side with PHP4. After installation it is recommended the following lines be added to a servers startup scripts to avoid the requirement of a shebang line on .php5 files:
79    
80     # Allow PHP5 to run without shebang
81     modprobe binfmt_misc
82     echo ':PHP5:E::php5::/usr/bin/php5/php:' > /proc/sys/fs/binfmt_misc/register
83    
84     %package devel
85     Group: Development/Libraries
86     Summary: Files needed for building PHP extensions.
87     Requires: php5-cgi = %{version}-%{release}
88    
89     %description devel
90     The php-devel package contains the files needed for building PHP
91     extensions. If you need to compile your own PHP extensions, you will
92     need to install this package.
93    
94     %package pear
95     Group: Development/Languages
96     Summary: PHP Extension and Application Repository Components
97     Requires: php5-cgi
98    
99     %description pear
100     PEAR is a framework and distribution system for reusable PHP
101     components. This package contains a set of PHP components from the
102     PEAR repository.
103    
104     %package imap
105     Summary: An Apache module for PHP applications that use IMAP.
106     Group: Development/Languages
107     Requires: php5-cgi = %{version}-%{release}
108     Obsoletes: mod_php3-imap, stronghold-php-imap
109     BuildRequires: krb5-devel, openssl-devel
110     %{?rh73:BuildRequires: imap-devel}
111     %{?rh90:BuildRequires: imap-devel}
112     %{?rhel3:BuildRequires: imap-devel}
113     %{?rhfc1:BuildRequires: imap-devel}
114     %{?rhfc2:BuildRequires: libc-client-devel}
115     %{?rhel4:BuildRequires: libc-client-devel}
116    
117    
118     %description imap
119     The php-imap package contains a dynamic shared object (DSO) for the
120     Apache Web server. When compiled into Apache, the php-imap module will
121     add IMAP (Internet Message Access Protocol) support to PHP. IMAP is a
122     protocol for retrieving and uploading e-mail messages on mail
123     servers. PHP is an HTML-embedded scripting language. If you need IMAP
124     support for PHP applications, you will need to install this package
125     and the php package.
126    
127     %package ldap
128     Summary: A module for PHP applications that use LDAP.
129     Group: Development/Languages
130     Requires: php5-cgi = %{version}-%{release}
131     Obsoletes: mod_php3-ldap, stronghold-php-ldap
132     BuildRequires: cyrus-sasl-devel, openldap-devel, openssl-devel
133    
134     %description ldap
135     The php-ldap package is a dynamic shared object (DSO) for the Apache
136     Web server that adds Lightweight Directory Access Protocol (LDAP)
137     support to PHP. LDAP is a set of protocols for accessing directory
138     services over the Internet. PHP is an HTML-embedded scripting
139     language. If you need LDAP support for PHP applications, you will
140     need to install this package in addition to the php package.
141    
142     %package mysql
143     Summary: A module for PHP applications that use MySQL databases.
144     Group: Development/Languages
145     Requires: php5-cgi = %{version}-%{release}
146     Provides: php_database
147     Obsoletes: mod_php3-mysql, stronghold-php-mysql
148     BuildRequires: mysql-devel
149    
150     %description mysql
151     The php-mysql package contains a dynamic shared object that will add
152     MySQL database support to PHP. MySQL is an object-relational database
153     management system. PHP is an HTML-embeddable scripting language. If
154     you need MySQL support for PHP applications, you will need to install
155     this package and the php or mod_php package.
156    
157     %package pgsql
158     Summary: A PostgreSQL database module for PHP.
159     Group: Development/Languages
160     Requires: php5-cgi = %{version}-%{release}
161     Provides: php_database
162     Obsoletes: mod_php3-pgsql, stronghold-php-pgsql
163     BuildRequires: krb5-devel, openssl-devel
164     %{?rh73:BuildRequires: postgresql-devel}
165     %{?rhfc1:BuildRequires: postgresql-devel}
166     %{?rhfc2:BuildRequires: postgresql-devel}
167     %{?rhel3:BuildRequires: rh-postgresql-devel}
168     %{?rhel4:BuildRequires: postgresql-devel}
169     %{?rh90:BuildRequires: postgresql-devel}
170    
171    
172     %description pgsql
173     The php-pgsql package includes a dynamic shared object (DSO) that can
174     be compiled in to the Apache Web server to add PostgreSQL database
175     support to PHP. PostgreSQL is an object-relational database management
176     system that supports almost all SQL constructs. PHP is an
177     HTML-embedded scripting language. If you need back-end support for
178     PostgreSQL, you should install this package in addition to the main
179     php package.
180    
181     %package odbc
182     Group: Development/Languages
183     Requires: php5-cgi = %{version}-%{release}
184     Summary: A module for PHP applications that use ODBC databases.
185     Provides: php_database
186     Obsoletes: stronghold-php-odbc
187     BuildRequires: unixODBC-devel
188    
189     %description odbc
190     The php-odbc package contains a dynamic shared object that will add
191     database support through ODBC to PHP. ODBC is an open specification
192     which provides a consistent API for developers to use for accessing
193     data sources (which are often, but not always, databases). PHP is an
194     HTML-embeddable scripting language. If you need ODBC support for PHP
195     applications, you will need to install this package and the php
196     package.
197    
198     %if %{with_oci8}
199     %package oci8
200     Group: Development/Languages
201     Requires: php5-cgi = %{version}-%{release}
202     Summary: A module for PHP applications that use OCI8 databases.
203     Provides: php_database
204    
205     %description oci8
206     The php-oci8 package contains a dynamic shared object that will add
207     support for accessing OCI8 databases to PHP.
208     %endif
209    
210     %if %{with_mssql}
211     %package mssql
212     Group: Development/Languages
213     Requires: php5-cgi = %{version}-%{release}, freetds
214     Summary: A module for PHP applications that use MSSQL databases.
215     Provides: php_database
216     BuildRequires: freetds-devel
217    
218     %description mssql
219     The mssql package contains a dynamic shared object that will add
220     support for accessing MSSQL databases to PHP.
221     %endif
222    
223     %if %{with_mhash}
224     %package mhash
225     Summary: A module for PHP applications that use Mhash.
226     Group: Development/Languages
227     Requires: php5-cgi = %{version}-%{release}
228     BuildRequires: mhash-devel
229    
230     %description mhash
231     The php-mhash package is a dynamic shared object (DSO) for the Apache
232     Web server that adds Mhash support to PHP.
233     %endif
234    
235    
236     %if %{with_mcrypt}
237     %package mcrypt
238     Group: Development/Languages
239     BuildRequires: libmcrypt, libmcrypt-devel
240     Requires: php5-cgi = %{version}-%{release}, libmcrypt
241     Summary: A module for PHP applications to use the mcrypt library
242    
243     %description mcrypt
244     The php-mcrypt library includes a dynamic shared object (DSO) that adds
245     Mcrypt support to PHP4. The libmcrypt is a data encryption library. The
246     library is thread safe and provides encryption and decryption functions.
247     This version of the library supports many encryption algorithms and
248     encryption modes. Some algorithms which are supported: SERPENT,
249     RIJNDAEL, 3DES, GOST, SAFER+, CAST-256, RC2, XTEA, 3WAY, TWOFISH,
250     BLOWFISH, ARCFOUR, WAKE and more. Install this package in addition
251     to main PHP package if you plan to use any of these algorithms.
252     %endif
253    
254    
255     %package snmp
256     Summary: A module for PHP applications that query SNMP-managed devices.
257     Group: Development/Languages
258     Requires: php5-cgi = %{version}-%{release}
259     BuildRequires: net-snmp-devel, elfutils-devel
260     # elfutils-devel requirement workaround for #103982
261    
262     %description snmp
263     The php-snmp package contains a dynamic shared object that will add
264     support for querying SNMP devices to PHP. PHP is an HTML-embeddable
265     scripting language. If you need SNMP support for PHP applications, you
266     will need to install this package and the php package.
267    
268     %package xmlrpc
269     Summary: A module for PHP applications which use the XML-RPC protocol
270     Group: Development/Languages
271     Requires: php5-cgi = %{version}-%{release}
272     BuildRequires: expat-devel
273    
274     %description xmlrpc
275     The php-xmlrpc package contains a dynamic shared object that will add
276     support for the XML-RPC protocol to PHP.
277    
278     %package mbstring
279     Summary: A module for PHP applications which need multi-byte string handling
280     Group: Development/Languages
281     Requires: php5-cgi = %{version}-%{release}
282    
283     %description mbstring
284     The php-mbstring package contains a dynamic shared object that will add
285     support for multi-byte string handling to PHP.
286    
287     %prep
288     %setup -q -n php-%{version}
289     #%patch2 -p1 -b .config
290     #%patch3 -p1 -b .lib64
291     #%patch4 -p1 -b .cxx
292     #%patch5 -p1 -b .install
293     #%patch6 -p1 -b .tests
294     #%patch7 -p1 -b .libtool15
295     #%patch8 -p1 -b .miscfix
296     #%patch9 -p1 -b .umask
297     #%patch10 -p1 -b .handler
298     #%patch11 -p1 -b .fdsetsize
299    
300     #%patch21 -p1 -b .odbc
301     #%patch22 -p1 -b .db4
302     #%patch23 -p1 -b .gmppowm
303    
304     #%patch30 -p1 -b .dlopen
305     ##%patch31 -p1 -b .easter
306    
307     # Prevent %%doc confusion over LICENSE files
308     cp Zend/LICENSE Zend/ZEND_LICENSE
309     cp TSRM/LICENSE TSRM_LICENSE
310     cp regex/COPYRIGHT regex_COPYRIGHT
311     cp ext/gd/libgd/README gd_README
312    
313     # Source is built twice: once for /usr/bin/php5/php, once for the Apache DSO.
314     mkdir build-cgi
315    
316     # Use correct libdir
317     perl -pi -e 's|%{_prefix}/lib|%{_libdir}|' php.ini-recommended
318     perl -pi -e 's|extension_dir \= \"\.\/\"|extension_dir \= \"%{_libdir}\/php5\/\"|' php.ini-recommended
319    
320     # Remove bogus test; position of read position after fopen(, "a+")
321     # is not defined by C standard, so don't presume anything.
322     rm -f ext/standard/tests/file/bug21131.phpt
323    
324     # Tests that fail.
325     rm -f ext/standard/tests/file/bug22414.phpt \
326     ext/session/tests/019.phpt \
327     ext/standard/tests/math/pow.phpt \
328     ext/standard/tests/math/round.phpt \
329     ext/standard/tests/math/abs.phpt \
330     ext/iconv/tests/bug16069.phpt
331    
332     : Build for oci8=%{with_oci8} mssql=%{with_mssql} mhash=%{with_mhash} mcrypt=%{with_mcrypt}
333    
334     %build
335    
336     CFLAGS="$RPM_OPT_FLAGS -Wall -fno-strict-aliasing"; export CFLAGS
337    
338     if [ ! -r '/usr/lib/libmysqlclient.so' ]
339     then
340     ln -s /usr/lib/mysql/libmysqlclient.so /usr/lib/libmysqlclient.so
341     fi
342    
343     # Install extension modules in %{_libdir}/php5.
344     EXTENSION_DIR=%{_libdir}/php5; export EXTENSION_DIR
345    
346     # pull latest ltmain.sh, AC_PROG_LIBTOOL
347     libtoolize --force --copy
348     # force aclocal run during buildconf
349     touch acinclude.m4
350    
351     # Regenerate configure scripts (patches change config.m4's)
352     ./buildconf --force
353    
354     # Shell function to configure and build a PHP tree.
355     build() {
356     # bison-1.875-2 seems to produce a broken parser; workaround.
357     mkdir Zend && cp ../Zend/zend_{language,ini}_{parser,scanner}.[ch] Zend
358     ln -sf ../configure
359     %configure \
360     --bindir=%{_bindir}/php5 \
361     --sbindir=%{_sbindir}/php5 \
362     --libdir=%{_libdir}/php5 \
363     --includedir=/usr/include/php5 \
364     --cache-file=../config.cache \
365     --sysconfdir=/etc/php5 \
366     --with-config-file-path=%{_sysconfdir}/php5 \
367     --with-config-file-scan-dir=%{_sysconfdir}/php5/php5.d \
368     --enable-discard-path \
369     --disable-debug \
370     --enable-pic \
371     --disable-rpath \
372     --enable-inline-optimization \
373     --with-bz2 \
374     --with-kerberos \
375     --with-db4=%{_prefix} \
376     --with-curl \
377     --with-exec-dir=%{_bindir}/php5 \
378     --with-freetype-dir=%{_prefix} \
379     --with-png-dir=%{_prefix} \
380     --with-gd \
381     --enable-gd-native-ttf \
382     --without-gdbm \
383     --with-gettext \
384     --with-ncurses \
385     --with-gmp \
386     --with-iconv \
387     --with-jpeg-dir=%{_prefix} \
388     --with-openssl \
389     --with-png \
390     --with-pspell \
391     --with-regex=system \
392     --with-xml \
393     --with-expat-dir=%{_prefix} \
394     --with-dom=shared,%{_prefix} \
395     --with-dom-xslt=%{_prefix} --with-dom-exslt=%{_prefix} \
396     --with-xsl \
397     --with-xmlrpc=shared \
398     %{?rhfc1:--with-pcre-regex=%{_prefix} } \
399     %{?rhfc2:--with-pcre-regex=%{_prefix} } \
400     --with-zlib \
401     --with-layout=GNU \
402     --enable-bcmath \
403     --enable-exif \
404     --enable-ftp \
405     --enable-magic-quotes \
406     --enable-safe-mode \
407     --enable-sockets \
408     --enable-sysvsem \
409     --enable-sysvshm \
410     --enable-track-vars \
411     --enable-trans-sid \
412     --enable-yp \
413     --enable-wddx \
414     --with-pear=/usr/share/pear5 \
415     --with-imap=shared --with-imap-ssl \
416     %{?rhfc1:--with-kerberos } \
417     %{?rhfc2:--with-kerberos } \
418     %{?rhel3:--with-kerberos=/usr/kerberos } \
419     %{?rhel4:--with-kerberos } \
420     %{?rh90:--with-kerberos=/usr/kerberos } \
421     --with-ldap=shared \
422     --with-mysql=shared,/usr \
423     %{?_with_oci8:--with-oci8=shared} \
424     %{?_with_mssql:--with-mssql=shared} \
425     %{?_with_mhash:--with-mhash=shared} \
426     %{?_with_mcrypt:--with-mcrypt=shared} \
427     --with-pgsql=shared \
428     --with-snmp=shared,%{_prefix} \
429     --with-snmp=shared \
430     --enable-ucd-snmp-hack \
431     --with-unixODBC=shared,%{_prefix} \
432     --enable-memory-limit \
433     --enable-bcmath \
434     --enable-shmop \
435     --enable-calendar \
436     --enable-dbx \
437     --enable-dio \
438     --enable-mcal \
439     %{?_with_tidy:--with-tidy} \
440     %{?_with_mbstring:--enable-mbstring=shared --enable-mbstr-enc-trans --enable-mbregex} \
441     $*
442    
443     make %{?_smp_mflags}
444     }
445    
446     # Build standalone /usr/bin/php
447     echo "PHP CGI"
448     pushd build-cgi
449     build
450     # Run tests
451     #export NO_INTERACTION=1 REPORT_EXIT_STATUS=1
452     #if ! TZ= LANG= LC_ALL= make test; then
453     # for f in `find .. -name \*.diff -type f -print`; do
454     # echo "TEST FAILURE -- $f --"
455     # cat $f
456     # done
457     #fi
458     #popd
459    
460     %install
461     [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
462    
463     # Hack
464     %{?rh90:install -m 755 -d $RPM_BUILD_ROOT/etc/httpd/conf }
465     %{?rh90:install -m 644 /etc/httpd/conf/httpd.conf $RPM_BUILD_ROOT%{_sysconfdir}/httpd/conf/httpd.conf }
466    
467     # Install from CGI tree
468     pushd build-cgi
469     make install INSTALL_ROOT=$RPM_BUILD_ROOT
470     popd
471    
472     # remove build files
473     rm -fr $RPM_BUILD_ROOT%{_libdir}/php
474    
475     # Install the default configuration file and icons
476     install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/php5
477     install -m 644 php.ini-recommended $RPM_BUILD_ROOT%{_sysconfdir}/php5/php.ini
478     #install -m 755 -d $RPM_BUILD_ROOT%{contentdir}/icons
479     #install -m 644 *.gif $RPM_BUILD_ROOT%{contentdir}/icons/
480    
481     # Apache config fragment
482     install -m 755 -d $RPM_BUILD_ROOT/etc/httpd/conf.d
483     install -m 644 $RPM_SOURCE_DIR/php5.conf $RPM_BUILD_ROOT/etc/httpd/conf.d
484    
485     install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/php5/php5.d
486     install -m 755 -d $RPM_BUILD_ROOT%{_localstatedir}/lib/php5
487     install -m 700 -d $RPM_BUILD_ROOT%{_localstatedir}/lib/php5/session
488    
489     # Generate files lists and stub .ini files for each subpackage
490     for mod in pgsql mysql odbc ldap snmp xmlrpc imap %{?_with_mbstring:mbstring} \
491     %{?_with_oci8:oci8} %{?_with_mssql:mssql} %{?_with_mhash:mhash} %{?_with_mcrypt:mcrypt}; do
492     cat > $RPM_BUILD_ROOT%{_sysconfdir}/php5/php5.d/${mod}.ini <<EOF
493     ; Enable ${mod} extension module
494     extension=${mod}.so
495     EOF
496     cat > files.${mod} <<EOF
497     %{?rhel4:%attr(755,root,root) %{_libdir}/php5/${mod}.so}
498     %{?rhel3:%attr(755,root,root) %{_libdir}/php5/${mod}}
499     %config(noreplace) %attr(644,root,root) %{_sysconfdir}/php5/php5.d/${mod}.ini
500     EOF
501     done
502    
503     # Remove PEAR testsuite
504     rm -rf $RPM_BUILD_ROOT%{_datadir}/pear5/tests
505    
506     # Remove unpackaged files
507     rm -f $RPM_BUILD_ROOT%{_libdir}/php5/*.a \
508     $RPM_BUILD_ROOT%{_bindir}/php5/{phptar,pearize}
509    
510     rm -fr $RPM_BUILD_ROOT/.channels $RPM_BUILD_ROOT/.depdb $RPM_BUILD_ROOT/.depdblock $RPM_BUILD_ROOT/.filemap $RPM_BUILD_ROOT/.lock $RPM_BUILD_ROOT/.registry
511    
512     # Remove irrelevant docs
513     rm -f README.{Zeus,QNX,CVS-RULES}
514    
515     # Post rh90 hack
516     # Hack
517     %{?rh90: rm -f $RPM_BUILD_ROOT%{_sysconfdir}/httpd/conf/httpd.conf* }
518    
519    
520    
521     %clean
522     [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
523     rm files.*
524    
525     %files
526     %defattr(-,root,root)
527     %doc CODING_STANDARDS CREDITS EXTENSIONS INSTALL LICENSE NEWS README*
528     %doc Zend/ZEND_* gd_README TSRM_LICENSE regex_COPYRIGHT
529     %config(noreplace) %{_sysconfdir}/php5/php.ini
530     %config %{_sysconfdir}/php5/pear.conf
531     %{_bindir}/php5/php
532     %{_bindir}/php5/php-cgi
533     %dir %{_libdir}/php5
534     %dir %{_localstatedir}/lib/php5
535     %attr(0700,apache,apache) %dir %{_localstatedir}/lib/php5/session
536     %config %{_sysconfdir}/httpd/conf.d/php5.conf
537     %dir %{_sysconfdir}/php5/php5.d
538     %doc %{_datadir}/man
539    
540     #/usr/share/man/man1/p
541    
542     %files pear
543     %defattr(-,root,root)
544     %{_bindir}/php5/pear
545     %{_datadir}/pear5
546     %{_bindir}/php5/peardev
547     %{_bindir}/php5/pecl
548    
549     %files devel
550     %defattr(-,root,root)
551     %{_bindir}/php5/php-config
552     %{_bindir}/php5/phpize
553     #%{_bindir}/php5/phpextdist
554     %{_includedir}/php5
555     %{_libdir}/php5/build
556    
557     %files pgsql -f files.pgsql
558     %{_libdir}/php5/pgsql.so
559    
560     %files mysql -f files.mysql
561     %{_libdir}/php5/mysql.so
562    
563     %files odbc -f files.odbc
564     %{_libdir}/php5/odbc.so
565    
566     %if %{with_oci8}
567     %files oci8 -f files.oci8
568     %endif
569    
570     %if %{with_mssql}
571     %files mssql -f files.mssql
572     %endif
573    
574     %if %{with_mhash}
575     %files mhash -f files.mhash
576     %endif
577    
578     %if %{with_mcrypt}
579     %files mcrypt -f files.mcrypt
580     %endif
581    
582     %files imap -f files.imap
583     %{_libdir}/php5/imap.so
584    
585     %files ldap -f files.ldap
586     %{_libdir}/php5/ldap.so
587    
588     %files snmp -f files.snmp
589     %{_libdir}/php5/snmp.so
590    
591     %files xmlrpc -f files.xmlrpc
592     %{_libdir}/php5/xmlrpc.so
593    
594     %if %{with_mbstring}
595     %files mbstring -f files.mbstring
596     %endif
597    
598     %changelog
599     * Mon Jan 12 2009 David Harper <davidiwharper@hotmail.com> 5.2.8-1.dh
600     - Upgrade to latest version of PHP
601     - Build fixes for CentOS/SME
602     * Fri Jan 20 2006 Stuart K. Low <stuart@serverpeak.com> 5.1.2-1
603     - Mass upgrade
604     - Added rhel4 flags
605     - Fixed pointers to changed (?) libraries from lib.so to just lib. Odd change.
606     * Fri Jun 10 2005 Stuart K. Low <stuart@serverpeak.com> 5.0.4-2
607     - Fixed tidy again.
608     * Sun May 29 2005 Stuart K. Low <stuart@serverpeak.com> 5.0.4-1
609     - Upgrade to 5.0.4
610     * Sat Feb 19 2005 Stuart K. Low <stuart@serverpeak.com> 5.0.3-3
611     - addition of --with-tidy
612     * Wed Jan 26 2005 Stuart K. Low <stuart@serverpeak.com> 5.0.3-1
613     - initial conversion to a CGI version for PHP5
614     - removed domxml since it's been moved to PECL in PHP5
615     - renamed to php5-cgi for clarity reasons (not to conflict with ARTs PHP5)
616     - removed mbstring dependency, don't know if this is smart
617    
618     * Fri Oct 15 2004 Scott R. Shinn <scott@atomicrocketturtle.com> 4.3.9-11
619     - set the Epoch number for rh90 only, apparently there is some bug in yum on FC1/FC2/3ES that causes issues when using the Epoch
620    
621     * Sat Oct 09 2004 Scott R. Shinn <scott@atomicrocketturtle.com> 4.3.9-10
622     - rebuilt for high file descriptor environments
623    
624     * Fri Oct 08 2004 Scott R. Shinn <scott@atomicrocketturtle.com> 4.3.9-8
625     - logs of bugfixes
626    
627     * Thu Oct 07 2004 Scott R. Shinn <scott@atomicrocketturtle.com> 4.3.9-6
628     - merging my php 4.3.9 rpm with the FC2 version
629    
630     * Fri Jul 16 2004 Joe Orton <jorton@redhat.com> 4.3.8-2.1
631     - revert upstream default php.ini change since 4.3.6
632     - add three FD_SETSIZE changes to main/network.c (#125258)
633    
634     * Wed Jul 14 2004 Joe Orton <jorton@redhat.com> 4.3.8-2.0
635     - update to 4.3.8
636     - add gmp_powm fix (Oskari Saarenmaa, #124318)
637     - split out mbstring extension into php-mbstring subpackage
638     - fix rebuild without bison/flex
639     - have -devel require php of same release
640     - add fixes for memory handling in 2.0 handler SAPI
641    
642     * Wed May 19 2004 Joe Orton <jorton@redhat.com> 4.3.6-5
643     - don't obsolete php-imap (#123580)
644     - unconditionally build -imap subpackage
645    
646     * Thu May 13 2004 Joe Orton <jorton@redhat.com> 4.3.6-4
647     - remove trigger
648    
649     * Thu Apr 22 2004 Joe Orton <jorton@redhat.com> 4.3.6-3
650     - fix umask reset "feature" (#121454)
651     - don't use DL_GLOBAL when dlopen'ing extension modules
652    
653     * Sun Apr 18 2004 Joe Orton <jorton@redhat.com> 4.3.6-2
654     - fix segfault on httpd SIGHUP (upstream #27810)
655    
656     * Fri Apr 16 2004 Joe Orton <jorton@redhat.com> 4.3.6-1
657     - update to 4.3.6 (Robert Scheck, #121011)
658    
659     * Wed Apr 7 2004 Joe Orton <jorton@redhat.com> 4.3.4-11
660     - add back imap subpackage, using libc-client (#115535)
661    
662     * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
663     - rebuilt
664    
665     * Wed Feb 18 2004 Joe Orton <jorton@redhat.com> 4.3.4-10
666     - eliminate /usr/local/lib RPATH in odbc.so
667     - really use system pcre library
668    
669     * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com> 4.3.4-9
670     - rebuilt
671    
672     * Mon Feb 2 2004 Bill Nottingham <notting@redhat.com> 4.3.4-8
673     - obsolete php-imap if we're not building it
674    
675     * Wed Jan 28 2004 Joe Orton <jorton@redhat.com> 4.3.4-7
676     - gd fix for build with recent Freetype2 (from upstream)
677     - remove easter egg (Oden Eriksson, Mandrake)
678    
679     * Wed Jan 21 2004 Joe Orton <jorton@redhat.com> 4.3.4-6
680     - php-pear requires php
681     - also remove extension=imap from php.ini in upgrade trigger
682     - merge from Taroon: allow upgrade from Stronghold 4.0
683    
684     * Wed Jan 21 2004 Joe Orton <jorton@redhat.com> 4.3.4-5
685     - add defattr for php-pear subpackage
686     - restore defaults: output_buffering=Off, register_argc_argv=On
687     - add trigger to handle php.ini upgrades smoothly (#112470)
688    
689     * Tue Jan 13 2004 Joe Orton <jorton@redhat.com> 4.3.4-4
690     - conditionalize support for imap extension for the time being
691     - switch /etc/php.ini to use php.ini-recommended (but leave
692     variables_order as EGPCS) (#97765)
693     - set session.path to /var/lib/php/session by default (#89975)
694     - own /var/lib/php{,/session} and have apache own the latter
695     - split off php-pear subpackage (#83771)
696    
697     * Sat Dec 13 2003 Jeff Johnson <jbj@jbj.org> 4.3.4-3
698     - rebuild against db-4.2.52.
699    
700     * Mon Dec 1 2003 Joe Orton <jorton@redhat.com> 4.3.4-2
701     - rebuild for new libxslt (#110658)
702     - use --with-{mssql,oci8} for enabling extensions (#110482)
703     - fix rebuild issues (Jan Visser, #110274)
704     - remove hard-coded LIBS
705     - conditional support for mhash (Aleksander Adamowski, #111251)
706    
707     * Mon Nov 10 2003 Joe Orton <jorton@redhat.com> 4.3.4-1.1
708     - rebuild for FC1 updates
709    
710     * Mon Nov 10 2003 Joe Orton <jorton@redhat.com> 4.3.4-1
711     - update to 4.3.4
712     - include all licence files
713     - libxmlrpc fixes
714    
715     * Mon Oct 20 2003 Joe Orton <jorton@redhat.com> 4.3.3-6
716     - use bundled libgd (#107407)
717     - remove manual: up-to-date manual sources are no longer DFSG-free;
718     it's too big; it's on the web anyway; #91292, #105804, #107384
719    
720     * Wed Oct 15 2003 Joe Orton <jorton@redhat.com> 4.3.3-5
721     - add php-xmlrpc subpackage (#107138)
722    
723     * Mon Oct 13 2003 Joe Orton <jorton@redhat.com> 4.3.3-4
724     - drop recode support, symbols collide with MySQL
725    
726     * Sun Oct 12 2003 Joe Orton <jorton@redhat.com> 4.3.3-3
727     - split domxml extension into php-domxml subpackage
728     - enable xslt and xml support in domxml extension (#106042)
729     - fix httpd-devel build requirement (#104341)
730     - enable recode extension (#106755)
731     - add workaround for #103982
732    
733     * Thu Sep 25 2003 Jeff Johnson <jbj@jbj.org> 4.3.3-3
734     - rebuild against db-4.2.42.
735    
736     * Sun Sep 7 2003 Joe Orton <jorton@redhat.com> 4.3.3-2
737     - don't use --enable-versioning, it depends on libtool being
738     broken (#103690)
739    
740     * Sun Sep 7 2003 Joe Orton <jorton@redhat.com> 4.3.3-1
741     - update to 4.3.3
742     - add libtool build prereq (#103388)
743     - switch to apache2handler
744    
745     * Mon Jul 28 2003 Joe Orton <jorton@redhat.com> 4.3.2-8
746     - rebuild
747    
748     * Tue Jul 22 2003 Nalin Dahyabhai <nalin@redhat.com> 4.3.2-7
749     - rebuild
750    
751     * Tue Jul 8 2003 Joe Orton <jorton@redhat.com> 4.3.2-6
752     - use system pcre library
753    
754     * Mon Jun 9 2003 Joe Orton <jorton@redhat.com> 4.3.2-5
755     - enable mbstring and mbregex (#81336)
756     - fix use of libtool 1.5
757    
758     * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
759     - rebuilt
760    
761     * Tue Jun 3 2003 Joe Orton <jorton@redhat.com> 4.3.2-3
762     - add lib64 and domxml fixes
763    
764     * Tue Jun 3 2003 Frank Dauer <f@paf.net>
765     - added conditional support for mssql module (#92149)
766    
767     * Fri May 30 2003 Joe Orton <jorton@redhat.com> 4.3.2-2
768     - update the -tests and -lib64 patches
769     - fixes for db4 detection
770     - require aspell-devel >= 0.50.0 for pspell compatibility
771    
772     * Thu May 29 2003 Joe Orton <jorton@redhat.com> 4.3.2-1
773     - update to 4.3.2
774    
775     * Fri May 16 2003 Joe Orton <jorton@redhat.com> 4.3.1-3
776     - link odbc module correctly
777     - patch so that php -n doesn't scan inidir
778     - run tests using php -n, avoid loading system modules
779    
780     * Wed May 14 2003 Joe Orton <jorton@redhat.com> 4.3.1-2
781     - workaround broken parser produced by bison-1.875
782    
783     * Tue May 6 2003 Joe Orton <jorton@redhat.com> 4.3.1-1
784     - update to 4.3.1; run test suite
785     - open extension modules with RTLD_NOW rather than _LAZY
786    
787     * Tue May 6 2003 Joe Orton <jorton@redhat.com> 4.2.2-19
788     - patch for gd 2.x API changes in gd extension
789    
790     * Thu May 1 2003 Joe Orton <jorton@redhat.com> 4.2.2-18
791     - rebuild to use aspell (#89925)
792     - patch to work round conditional AC_PROG_CXX break in autoconf 2.57
793     - fix dba build against db >= 4.1
794    
795     * Mon Feb 24 2003 Joe Orton <jorton@redhat.com> 4.2.2-17
796     - restrict SNMP patch to minimal changes, fixing segv on startup (#84607)
797    
798     * Wed Feb 12 2003 Joe Orton <jorton@redhat.com> 4.2.2-16
799     - prevent startup if using httpd.worker to avoid thread-safety issues.
800     - fix parsing private keys in OpenSSL extension (#83994)
801     - fixes for SNMP extension (backport from 4.3) (#74761)
802    
803     * Wed Jan 29 2003 Joe Orton <jorton@redhat.com> 4.2.2-15
804     - add security fixes for wordwrap() and mail()
805    
806     * Mon Jan 13 2003 Joe Orton <jorton@redhat.com> 4.2.2-14
807     - drop explicit Requires in subpackages, rely on automatic deps.
808     - further fixes for libdir=lib64
809    
810     * Tue Dec 17 2002 Joe Orton <jorton@redhat.com> 4.2.2-13
811     - drop prereq for perl, grep in subpackages
812     - rebuild and patch for OpenSSL 0.9.7
813    
814     * Tue Dec 10 2002 Joe Orton <jorton@redhat.com> 4.2.2-12
815     - backport "ini dir scanning" patch from CVS HEAD; /etc/php.d/*.ini
816     are now loaded at startup; each subpackage places an ini file
817     in that directory rather than munging /etc/php.ini in post/postun.
818     - default config changes: enable short_open_tag; remove settings for
819     php-dbg extension
820    
821     * Wed Dec 4 2002 Joe Orton <jorton@redhat.com> 4.2.2-11
822     - own the /usr/lib/php4 directory (#73894)
823     - reinstate dropped patch to unconditionally disable ZTS
824    
825     * Mon Dec 2 2002 Joe Orton <jorton@redhat.com> 4.2.2-10
826     - remove ldconfig invocation in post/postun
827     - fixes for #73516 (partially), #78586, #75029, #75712, #75878
828    
829     * Wed Nov 6 2002 Joe Orton <jorton@redhat.com> 4.2.2-9
830     - fixes for libdir=/usr/lib64, based on SuSE's patches.
831     - add build prereqs for zlib-devel, imap-devel, curl-devel (#74819)
832     - remove unpackaged files from install root
833     - libtoolize; use configure cache to speed up build
834    
835     * Mon Sep 23 2002 Philip Copeland <bryce@redhat.com> 4.2.2-8.0.6
836     - PHP cannot determine which UID is being used, so safe
837     mode restrictions were always applied. Fixed. (#74396)
838    
839     * Tue Sep 3 2002 Philip Copeland <bryce@redhat.com> 4.2.2-8.0.4
840     - zts support seems to crash out httpd on a *second* sighup
841     ie service httpd start;
842     apachectl restart ; (ok)
843     apachectl restart ; (httpd segv's and collapses)
844     removed --enable-experimental-zts which this seems related to.
845     - Small patch added because some places need to know that they
846     aren't using the ZTS API's (dumb)
847    
848     * Mon Sep 2 2002 Philip Copeland <bryce@redhat.com> 4.2.2-8.0.3
849     - fixup /etc/httpd/conf.d/php.conf to limit largest amount
850     of data accepted (#73254) Limited to 512K (which seems a
851     little excessive but anyway,..)
852     Note: php.conf is part of the srpm sources not part of the
853     php codebase.
854     - ditched extrenious --enable-debugger (was for php-dbg)
855     - When upgrading we tend not to modify /etc/php.ini if it exists,
856     instead we create php.ini.rpmnew. Modified the post scripts to
857     edit php.ini.rpmnew if it exists, so that people can copy
858     over the php.ini.rpmnew as php.ini knowing that it will
859     be an edited version, consistant with what modules they
860     installed #72033
861    
862     * Sun Sep 1 2002 Joe Orton <jorton@redhat.com> 4.2.2-8.0.2
863     - require httpd-mmn for module ABI compatibility
864    
865     * Fri Aug 30 2002 Philip Copeland <bryce@redhat.com> 4.2.2-8.0.1
866     - URLS would drop the last arguments #72752
867     --enable-mbstring
868     --enable-mbstr-enc-trans
869     These were supposed to help provide multibyte language
870     support, however, they cause problems. Removed. Maybe in
871     a later errata when they work.
872     - added small patch to php_variables.c that allows
873     $_GET[<var>] to initialise properly when
874     --enable-mbstr-enc-trans is disabled.
875     - Be consistant with errata naming (8.0.x)
876    
877     * Tue Aug 27 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.2-11
878     - rebuild
879    
880     * Wed Aug 22 2002 Philip Copeland <bryce@redhat.com> 4.2.2-10
881     - Beat down the requirement list to something a little
882     more sane
883    
884     * Wed Aug 14 2002 Bill Nottingham <notting@redhat.com> 4.2.2-9
885     - trim manual language lists
886    
887     * Mon Aug 12 2002 Gary Benson <gbenson@redhat.com> 4.2.2-8
888     - rebuild against httpd-2.0.40
889    
890     * Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com> 4.2.2-7
891     - rebuilt with gcc-3.2 (we hope)
892    
893     * Wed Aug 7 2002 Philip Copeland <bryce@redhat.com> 4.2.2-6
894     - Where multiple cookies are set, only the last one
895     was actually made. Fixes #67853
896    
897     * Mon Aug 5 2002 Philip Copeland <bryce@redhat.com> 4.2.2-5
898     - Shuffled the php/php-devel package file manifest
899     with respect to PEAR (PHP Extension and Application
900     Repository) #70673
901    
902     * Fri Aug 2 2002 Philip Copeland <bryce@redhat.com> 4.2.2-4
903     - #67815, search path doesn't include the pear directory
904     -pear not being installed correctly. Added --with-pear=
905     option.
906    
907     * Tue Jul 23 2002 Tim Powers <timp@redhat.com> 4.2.2-2
908     - build using gcc-3.2-0.1
909    
910     * Mon Jul 22 2002 Philip Copeland <bryce@redhat.com> 4.2.2-1
911     - Yippie 8/ another security vunerability (see
912     http://www.php.net/release_4_2_2.php for details)
913    
914     * Wed Jul 17 2002 Philip Copeland <bryce@redhat.com> 4.2.1-9
915     - Reminder to self that mm was pushed out because it's
916     NOT thread safe.
917     - Updated the manuals (much to Bills horror)
918    
919     * Tue Jul 16 2002 Philip Copeland <bryce@redhat.com> 4.2.1-8
920     - php.ini alteration to fit in with the install/uninstall
921     of various php rpm based installable modules
922    
923     * Mon Jul 15 2002 Philip Copeland <bryce@redhat.com> 4.2.1-8
924     - php -v showing signs of deep unhappiness with the world
925     added --enable-experimental-zts to configure to make it
926     happy again (yes I know experimental sounds 'dangerous'
927     it's just a name for an option we need)
928    
929     * Fri Jul 12 2002 Philip Copeland <bryce@redhat.com> 4.2.1-7
930     - #68715, Wrong name for Mysql Module in php.ini. Fixed.
931    
932     * Fri Jun 28 2002 Philip Copeland <bryce@redhat.com> 4.2.1-6
933     - SNMP fixup
934    
935     * Thu Jun 27 2002 Philip Copeland <bryce@redhat.com> 4.2.1-5
936     - Ah,.. seems httpd2 has been renamed to just plain
937     ol' httpd. Fixed spec file to suit.
938     - ucd-snmp changed to net-snmp overnight...
939     temporarily disabled snmp while I work out the
940     impact of this change and if it is safe
941    
942     * Wed Jun 26 2002 Philip Copeland <bryce@redhat.com> 4.2.1-4
943     - openldap 2.1.x problem solved by Nalin. Sure the ldap
944     API didn't change,... <mutter>. Added TSRMLS_FETCH()
945     to ldap_rebind_proc().
946     - Removed the php-dbg package as thats going to be provided
947     elsewhere
948    
949     * Fri Jun 21 2002 Tim Powers <timp@redhat.com> 4.2.1-3
950     - automated rebuild
951    
952     * Mon Jun 10 2002 Philip Copeland <bryce@redhat.com> 4.2.1-2
953     - Actually mm is now a dead project. Removed permently.
954    
955     * Tue May 28 2002 Gary Benson <gbenson@redhat.com> 4.2.1-2
956     - change paths for httpd-2.0
957     - add the config file
958     - disable mm temporarily
959    
960     * Sun May 26 2002 Tim Powers <timp@redhat.com> 4.2.1-1
961     - automated rebuild
962    
963     * Wed May 22 2002 Philip Copeland <bryce@redhat.com> 4.2.1-0
964     - Initial pristine build of php-4.2.1
965     - Minor patch to get around a 64 bitism
966     - Added in the dgb debugging hooks
967    

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed