/[smecontribs]/rpms/phpMyAdmin47/contribs9/phpMyAdmin47.spec
ViewVC logotype

Annotation of /rpms/phpMyAdmin47/contribs9/phpMyAdmin47.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.1 - (hide annotations) (download)
Wed Dec 6 20:50:19 2017 UTC (6 years, 5 months ago) by jpp
Branch: MAIN
CVS Tags: phpMyAdmin47-4_7_6-1_el6_sme
Initial import

1 jpp 1.1 %{!?_pkgdocdir: %global _pkgdocdir %{_docdir}/%{name}-%{version}}
2     %global pkgname phpMyAdmin
3     %global pkgnameV phpMyAdmin47
4    
5     # If php-mcrypt is available, it should be preferred. Otherwise the pure
6     # phpseclib alternative alternative can be used externally or internally.
7     %global mcrypt 1
8     %global seclib 0
9    
10     # Having below mentioned separate projects externally or only internally?
11     %global gettext 0
12     # getext included in php common since php55
13     %global tcpdf 0
14     %global optdatadir /opt
15    
16     Summary: Handle the administration of MySQL over the World Wide Web
17     Name: phpMyAdmin47
18     Version: 4.7.6
19     Release: 1%{?dist}
20     License: GPLv2+
21     Group: Applications/Internet
22     URL: https://www.phpmyadmin.net/
23     Source0: https://files.phpmyadmin.net/%{pkgname}/%{version}/%{pkgname}-%{version}-all-languages.tar.xz
24     Source1: https://files.phpmyadmin.net/%{pkgname}/%{version}/%{pkgname}-%{version}-all-languages.tar.xz.asc
25     Source2: phpMyAdmin-config.inc.php
26     Source3: phpMyAdmin.htaccess
27     #Patch0: phpMyAdmin-4.0.10-remove-flash.patch
28     #Patch1: phpMyAdmin-4.0.10.17-system-phpseclib.patch
29     # Optional (and partially redundant) runtime requirements: php-bcmath, php-gmp, php-recode, php-soap
30     Requires: php55-php >= 5.5, php55-php-filter, php55-php-xmlwriter
31     Requires: webserver, php55-php-bz2, php55-php-ctype, php55-php-curl, php55-php-date, php55-php-gd, php55-php-hash, php55-php-iconv
32     Requires: php55-php-json, php55-php-libxml, php55-php-mbstring, php55-php-mysqli, php55-php-pcre, php55-php-session, php55-php-simplexml
33     Requires: php55-php-spl, php55-php-zip, php55-php-zlib
34    
35     Requires: php56-php >= 5.5, php56-php-filter, php56-php-xmlwriter
36     Requires: webserver, php56-php-bz2, php56-php-ctype, php56-php-curl, php56-php-date, php56-php-gd, php56-php-hash, php56-php-iconv
37     Requires: php56-php-json, php56-php-libxml, php56-php-mbstring, php56-php-mysqli, php56-php-pcre, php56-php-session, php56-php-simplexml
38     Requires: php56-php-spl, php56-php-zip, php56-php-zlib
39    
40     Requires: php70-php >= 5.5, php70-php-filter, php70-php-xmlwriter
41     Requires: webserver, php70-php-bz2, php70-php-ctype, php70-php-curl, php70-php-date, php70-php-gd, php70-php-hash, php70-php-iconv
42     Requires: php70-php-json, php70-php-libxml, php70-php-mbstring, php70-php-mysqli, php70-php-pcre, php70-php-session, php70-php-simplexml
43     Requires: php70-php-spl, php70-php-zip, php70-php-zlib
44    
45     Requires: php71-php >= 5.5, php71-php-filter, php71-php-xmlwriter
46     Requires: webserver, php71-php-bz2, php71-php-ctype, php71-php-curl, php71-php-date, php71-php-gd, php71-php-hash, php71-php-iconv
47     Requires: php71-php-json, php71-php-libxml, php71-php-mbstring, php71-php-mysqli, php71-php-pcre, php71-php-session, php71-php-simplexml
48     Requires: php71-php-spl, php71-php-zip, php71-php-zlib
49    
50    
51     %if 0%{?mcrypt}
52     Requires: php55-php-mcrypt
53     Requires: php56-php-mcrypt
54     Requires: php70-php-mcrypt
55     Requires: php71-php-mcrypt
56     %else
57     %if 0%{?seclib}
58     Requires: php55-php-phpseclib-crypt-aes
59     %endif
60     %endif
61     %if 0%{?gettext}
62     Requires: php55-php-gettext
63     %endif
64     # Optional runtime requirements for tcpdf: php-openssl, php-tidy (usually not required in phpMyAdmin)
65     %if 0%{?tcpdf}
66     Requires: php55-php-tcpdf, php55-php-tcpdf-dejavu-sans-fonts
67     %endif
68     Provides: phpMyAdmin47 = %{version}-%{release}
69     BuildArch: noarch
70     BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
71    
72     %description
73     phpMyAdmin is a tool written in PHP intended to handle the administration of
74     MySQL over the World Wide Web. Most frequently used operations are supported
75     by the user interface (managing databases, tables, fields, relations, indexes,
76     users, permissions), while you still have the ability to directly execute any
77     SQL statement.
78    
79     Features include an intuitive web interface, support for most MySQL features
80     (browse and drop databases, tables, views, fields and indexes, create, copy,
81     drop, rename and alter databases, tables, fields and indexes, maintenance
82     server, databases and tables, with proposals on server configuration, execute,
83     edit and bookmark any SQL-statement, even batch-queries, manage MySQL users
84     and privileges, manage stored procedures and triggers), import data from CSV
85     and SQL, export data to various formats: CSV, SQL, XML, PDF, OpenDocument Text
86     and Spreadsheet, Word, Excel, LATEX and others, administering multiple servers,
87     creating PDF graphics of your database layout, creating complex queries using
88     Query-by-example (QBE), searching globally in a database or a subset of it,
89     transforming stored data into any format using a set of predefined functions,
90     like displaying BLOB-data as image or download-link and much more...
91    
92     %prep
93     %setup -q -n %{pkgname}-%{version}-all-languages
94     #%patch0 -p1
95     #%patch1 -p1
96    
97     # Setup vendor config file
98     sed -e "/'CHANGELOG_FILE'/s@./ChangeLog@%{_pkgdocdir}/ChangeLog@" \
99     -e "/'LICENSE_FILE'/s@./LICENSE@%{_pkgdocdir}/LICENSE@" \
100     -e "/'CONFIG_DIR'/s@''@'%{_sysconfdir}/%{pkgnameV}/'@" \
101     -e "/'SETUP_CONFIG_FILE'/s@./config/config.inc.php@%{_localstatedir}/lib/%{pkgnameV}/config/config.inc.php@" \
102     %if 0%{?gettext}
103     -e "/'GETTEXT_INC'/s@./libraries/php-gettext/gettext.inc@%{_datadir}/php/gettext/gettext.inc@" \
104     %endif
105     %if 0%{?tcpdf}
106     -e "/'TCPDF_INC'/s@./libraries/tcpdf/tcpdf.php@%{_datadir}/php/tcpdf/tcpdf.php@" \
107     %endif
108     %if 0%{?mcrypt}%{?seclib}
109     -e "/'PHPSECLIB_INC_DIR'/s@./libraries/phpseclib@%{_datadir}/pear@" \
110     %endif
111     -i libraries/vendor_config.php
112    
113     # Remove bundled libraries
114     %if 0%{?gettext}
115     rm -rf libraries/php-gettext/
116     %endif
117    
118     %if 0%{?tcpdf}
119     rm -rf libraries/tcpdf/
120     %endif
121    
122     %if 0%{?mcrypt}%{?seclib}
123     rm -rf libraries/phpseclib/
124     %endif
125    
126     # Remove sources of JavaScript library
127     rm -rf js/jquery/src/
128    
129     # Remove files related to Flash file (*.swf)
130     rm -f js/canvg/flashcanvas.{js,swf}
131    
132     %build
133    
134     %install
135     rm -rf $RPM_BUILD_ROOT
136     mkdir -p $RPM_BUILD_ROOT{%{optdatadir}/%{pkgnameV},%{_sysconfdir}/{httpd/conf.d,%{pkgnameV}}}/
137     mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/lib/%{pkgnameV}/{upload,save,config}/
138     cp -ad * $RPM_BUILD_ROOT%{optdatadir}/%{pkgnameV}/
139     install -p -m 644 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/conf.d/%{pkgnameV}.conf
140     install -p -m 644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/%{pkgnameV}/config.inc.php
141    
142     rm -f $RPM_BUILD_ROOT%{optdatadir}/%{pkgnameV}/{[CDLR]*,*.txt,config.sample.inc.php}
143     rm -rf $RPM_BUILD_ROOT%{optdatadir}/%{pkgnameV}/{doc,examples}/
144     rm -f doc/html/.buildinfo
145    
146     mkdir -p $RPM_BUILD_ROOT%{optdatadir}/%{pkgnameV}/doc/
147     ln -s ../../..%{_pkgdocdir}/html/ $RPM_BUILD_ROOT%{optdatadir}/%{pkgnameV}/doc/html
148     mv -f config.sample.inc.php examples/
149    
150     %clean
151     rm -rf $RPM_BUILD_ROOT
152    
153     %post
154     # Generate a secret key for this installation
155     sed -e "/'blowfish_secret'/s/MUSTBECHANGEDONINSTALL/$(cat /dev/urandom | tr -dc 'a-zA-Z0-9' | fold -w 32 | head -n 1)/" \
156     -i %{_sysconfdir}/%{pkgnameV}/config.inc.php
157    
158     %files
159     %defattr(-,root,root,-)
160     %doc ChangeLog README LICENSE doc/html/ examples/
161     %{optdatadir}/%{pkgnameV}/
162     %dir %attr(0750,root,apache) %{_sysconfdir}/%{pkgnameV}/
163     %config(noreplace) %attr(0640,root,apache) %{_sysconfdir}/%{pkgnameV}/config.inc.php
164     %config(noreplace) %{_sysconfdir}/httpd/conf.d/%{pkgnameV}.conf
165     %dir %{_localstatedir}/lib/%{pkgnameV}/
166     %dir %attr(0750,apache,apache) %{_localstatedir}/lib/%{pkgnameV}/upload/
167     %dir %attr(0750,apache,apache) %{_localstatedir}/lib/%{pkgnameV}/save/
168     %dir %attr(0750,apache,apache) %{_localstatedir}/lib/%{pkgnameV}/config/
169    
170     %changelog
171     * Mon Jun 26 2017 Robert Scheck <robert@fedoraproject.org> 4.0.10.20-1
172     - Upgrade to 4.0.10.20 (#1437828, #1464267)
173    
174     * Thu Feb 23 2017 Robert Scheck <robert@fedoraproject.org> 4.0.10.19-1
175     - Upgrade to 4.0.10.19 (#1415995, #1415996, #1415997, #1415998,
176     #1415999, #1416000)
177     - Require php-mysqli instead of php-mysql (#1421913)
178    
179     * Mon Nov 28 2016 Robert Scheck <robert@fedoraproject.org> 4.0.10.18-1
180     - Upgrade to 4.0.10.18 (#1399197)
181    
182     * Sun Aug 28 2016 Robert Scheck <robert@fedoraproject.org> 4.0.10.17-2
183     - Fix usage of internal vs. external phpseclib or mcrypt alternative
184     - Ensure that 'blowfish_secret' is 32 characters for new installation
185    
186     * Sun Aug 28 2016 Robert Scheck <robert@fedoraproject.org> 4.0.10.17-1
187     - Upgrade to 4.0.10.17 (#1370778)
188    
189     * Thu Jun 23 2016 Robert Scheck <robert@fedoraproject.org> 4.0.10.16-1
190     - Upgrade to 4.0.10.16 (#1349500)
191    
192     * Sat Jun 04 2016 Robert Scheck <robert@fedoraproject.org> 4.0.10.15-2
193     - Added upstream patch to avoid information disclosure (#1340065)
194    
195     * Thu Mar 03 2016 Robert Scheck <robert@fedoraproject.org> 4.0.10.15-1
196     - Upgrade to 4.0.10.15 (#1313221, #1313224, #1313695, #1313696)
197    
198     * Sat Feb 27 2016 Robert Scheck <robert@fedoraproject.org> 4.0.10.14-2
199     - Use MCRYPT_DEV_URANDOM in mcrypt_create_iv() (rather PHP default)
200    
201     * Sat Jan 30 2016 Robert Scheck <robert@fedoraproject.org> 4.0.10.14-1
202     - Upgrade to 4.0.10.14
203    
204     * Thu Jan 28 2016 Robert Scheck <robert@fedoraproject.org> 4.0.10.13-1
205     - Upgrade to 4.0.10.13
206    
207     * Fri Dec 25 2015 Robert Scheck <robert@fedoraproject.org> 4.0.10.12-1
208     - Upgrade to 4.0.10.12 (#1294254)
209    
210     * Sun Oct 25 2015 Robert Scheck <robert@fedoraproject.org> 4.0.10.11-1
211     - Upgrade to 4.0.10.11
212    
213     * Thu May 14 2015 Robert Scheck <robert@fedoraproject.org> 4.0.10.10-1
214     - Upgrade to 4.0.10.10 (#1221588, #1221580, #1221581)
215    
216     * Wed Mar 04 2015 Robert Scheck <robert@fedoraproject.org> 4.0.10.9-1
217     - Upgrade to 4.0.10.9
218    
219     * Wed Jan 07 2015 Robert Scheck <robert@fedoraproject.org> 4.0.10.8-1
220     - Upgrade to 4.0.10.8
221    
222     * Thu Dec 11 2014 Robert Scheck <robert@fedoraproject.org> 4.0.10.7-2
223     - Use %%{pkgname} rather %%{name} in %%post scriptlet (#1173189)
224    
225     * Thu Dec 04 2014 Robert Scheck <robert@fedoraproject.org> 4.0.10.7-1
226     - Upgrade to 4.0.10.7
227    
228     * Thu Nov 20 2014 Robert Scheck <robert@fedoraproject.org> 4.0.10.6-1
229     - Upgrade to 4.0.10.6
230    
231     * Wed Oct 22 2014 Robert Scheck <robert@fedoraproject.org> 4.0.10.5-1
232     - Upgrade to 4.0.10.5 (#1155362)
233    
234     * Thu Oct 02 2014 Robert Scheck <robert@fedoraproject.org> 4.0.10.4-1
235     - Upgrade to 4.0.10.4 (#1148664)
236    
237     * Wed Sep 17 2014 Robert Scheck <robert@fedoraproject.org> 4.0.10.3-2
238     - Move rm(1) calls from %%install to %%prep (#1121355 #c10)
239    
240     * Tue Sep 16 2014 Robert Scheck <robert@fedoraproject.org> 4.0.10.3-1
241     - Upgrade to 4.0.10.3 (#1141635)
242    
243     * Mon Sep 01 2014 Robert Scheck <robert@fedoraproject.org> 4.0.10.2-2
244     - Corrected wrong permissions of /etc/phpMyAdmin/ directory
245    
246     * Mon Aug 18 2014 Robert Scheck <robert@fedoraproject.org> 4.0.10.2-1
247     - Upgrade to 4.0.10.2 (#1130865)
248    
249     * Tue Jul 22 2014 Robert Scheck <robert@fedoraproject.org> 4.0.10.1-1
250     - Upgrade to 4.0.10.1 (#548260, #959946, #989660, #989668, #993613
251     and #1000261, #1067713, #1110877, #1117600, #1117601)
252     - Switch from HTTP- to cookie-based authentication (for php-fpm)
253    
254     * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.5.8.2-3
255     - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
256    
257     * Thu Dec 12 2013 Ville Skyttä <ville.skytta@iki.fi> - 3.5.8.2-2
258     - Fix paths to changelog and license when doc dir is unversioned (#994036).
259     - Fix source URL, use xz compressed tarball.
260    
261     * Wed Oct 09 2013 Paul Wouters <pwouters@redhat.com> - 3.5.8.2-1
262     - Upgrade to 3.5.8.2 (Various security issues)
263    
264     * Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.5.8.1-2
265     - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
266    
267     * Thu Apr 25 2013 Robert Scheck <robert@fedoraproject.org> 3.5.8.1-1
268     - Upgrade to 3.5.8.1 (#956398, #956401)
269    
270     * Sat Apr 13 2013 Robert Scheck <robert@fedoraproject.org> 3.5.8-1
271     - Upgrade to 3.5.8 (#949868)
272    
273     * Sat Feb 23 2013 Robert Scheck <robert@fedoraproject.org> 3.5.7-1
274     - Upgrade to 3.5.7 (#912097)
275    
276     * Sun Feb 10 2013 Robert Scheck <robert@fedoraproject.org> 3.5.6-1
277     - Upgrade to 3.5.6 (#889450)
278    
279     * Sun Nov 18 2012 Robert Scheck <robert@fedoraproject.org> 3.5.4-1
280     - Upgrade to 3.5.4 (#877727)
281    
282     * Tue Oct 09 2012 Robert Scheck <robert@fedoraproject.org> 3.5.3-1
283     - Upgrade to 3.5.3
284    
285     * Wed Aug 15 2012 Robert Scheck <robert@fedoraproject.org> 3.5.2.2-1
286     - Upgrade to 3.5.2.2 (#845736)
287    
288     * Sat Aug 11 2012 Robert Scheck <robert@fedoraproject.org> 3.5.2.1-1
289     - Upgrade to 3.5.2.1 (#845736)
290    
291     * Mon Jul 30 2012 Robert Scheck <robert@fedoraproject.org> 3.5.2-1
292     - Upgrade to 3.5.2 (#838310)
293    
294     * Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.5.1-2
295     - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
296    
297     * Sun May 06 2012 Robert Scheck <robert@fedoraproject.org> 3.5.1-1
298     - Upgrade to 3.5.1 (#819171)
299    
300     * Sat May 05 2012 Remi Collet <remi@fedoraproject.org> 3.5.0-2
301     - make configuration compatible apache 2.2 / 2.4
302    
303     * Sun Apr 08 2012 Robert Scheck <robert@fedoraproject.org> 3.5.0-1
304     - Upgrade to 3.5.0 (#790782, #795020, #809146)
305    
306     * Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.4.9-2
307     - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
308    
309     * Thu Dec 22 2011 Robert Scheck <robert@fedoraproject.org> 3.4.9-1
310     - Upgrade to 3.4.9 (#769818)
311    
312     * Sun Dec 04 2011 Robert Scheck <robert@fedoraproject.org> 3.4.8-1
313     - Upgrade to 3.4.8 (#759441)
314    
315     * Sat Nov 12 2011 Robert Scheck <robert@fedoraproject.org> 3.4.7.1-1
316     - Upgrade to 3.4.7.1 (#753119)
317    
318     * Sat Nov 05 2011 Robert Scheck <robert@fedoraproject.org> 3.4.7-1
319     - Upgrade to 3.4.7 (#746630, #746880)
320    
321     * Sun Sep 18 2011 Robert Scheck <robert@fedoraproject.org> 3.4.5-1
322     - Upgrade to 3.4.5 (#733638, #738681, #629214)
323    
324     * Thu Aug 25 2011 Robert Scheck <robert@fedoraproject.org> 3.4.4-1
325     - Upgrade to 3.4.4 (#733475, #733477, #733480)
326    
327     * Tue Jul 26 2011 Robert Scheck <robert@fedoraproject.org> 3.4.3.2-2
328     - Disabled the warning for missing internal database relation
329     - Reworked spec file to build phpMyAdmin3 for RHEL 5 (#725885)
330    
331     * Mon Jul 25 2011 Robert Scheck <robert@fedoraproject.org> 3.4.3.2-1
332     - Upgrade to 3.4.3.2 (#725377, #725381, #725382, #725383, #725384)
333    
334     * Wed Jul 06 2011 Robert Scheck <robert@fedoraproject.org> 3.4.3.1-1
335     - Upgrade to 3.4.3.1 (#718964)
336    
337     * Mon Jun 13 2011 Robert Scheck <robert@fedoraproject.org> 3.4.2-1
338     - Upgrade to 3.4.2 (#711743)
339    
340     * Sun May 29 2011 Robert Scheck <robert@fedoraproject.org> 3.4.1-1
341     - Upgrade to 3.4.1 (#704171)
342    
343     * Mon Mar 21 2011 Robert Scheck <robert@fedoraproject.org> 3.3.10-1
344     - Upstream released 3.3.10 (#661335, #662366, #662367, #689213)
345    
346     * Sun Feb 13 2011 Robert Scheck <robert@fedoraproject.org> 3.3.9.2-1
347     - Upstream released 3.3.9.2 (#676172)
348    
349     * Thu Feb 10 2011 Robert Scheck <robert@fedoraproject.org> 3.3.9.1-1
350     - Upstream released 3.3.9.1 (#676172)
351    
352     * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.3.9-2
353     - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
354    
355     * Mon Jan 03 2011 Robert Scheck <robert@fedoraproject.org> 3.3.9-1
356     - Upstream released 3.3.9 (#666925)
357    
358     * Mon Nov 29 2010 Robert Scheck <robert@fedoraproject.org> 3.3.8.1-1
359     - Upstream released 3.3.8.1
360    
361     * Fri Oct 29 2010 Robert Scheck <robert@fedoraproject.org> 3.3.8-1
362     - Upstream released 3.3.8 (#631748)
363    
364     * Wed Sep 08 2010 Robert Scheck <robert@fedoraproject.org> 3.3.7-1
365     - Upstream released 3.3.7 (#631824, #631829)
366    
367     * Sun Aug 29 2010 Robert Scheck <robert@fedoraproject.org> 3.3.6-1
368     - Upstream released 3.3.6 (#628301)
369    
370     * Fri Aug 20 2010 Robert Scheck <robert@fedoraproject.org> 3.3.5.1-1
371     - Upstream released 3.3.5.1 (#625877, #625878)
372     - Added patch to fix wrong variable check at nopassword (#622428)
373    
374     * Tue Jul 27 2010 Robert Scheck <robert@fedoraproject.org> 3.3.5-1
375     - Upstream released 3.3.5 (#618586)
376    
377     * Tue Jun 29 2010 Robert Scheck <robert@fedoraproject.org> 3.3.4-1
378     - Upstream released 3.3.4 (#609057)
379    
380     * Sat Jun 26 2010 Robert Scheck <robert@fedoraproject.org> 3.3.3-1
381     - Upstream released 3.3.3 (#558322, #589288, #589487)
382    
383     * Sun Jan 10 2010 Robert Scheck <robert@fedoraproject.org> 3.2.5-1
384     - Upstream released 3.2.5
385    
386     * Thu Dec 03 2009 Robert Scheck <robert@fedoraproject.org> 3.2.4-1
387     - Upstream released 3.2.4 (#540871, #540891)
388    
389     * Thu Nov 05 2009 Robert Scheck <robert@fedoraproject.org> 3.2.3-1
390     - Upstream released 3.2.3
391    
392     * Tue Oct 13 2009 Robert Scheck <robert@fedoraproject.org> 3.2.2.1-1
393     - Upstream released 3.2.2.1 (#528769)
394     - Require php-mcrypt for cookie authentication (#526979)
395    
396     * Sun Sep 13 2009 Robert Scheck <robert@fedoraproject.org> 3.2.2-1
397     - Upstream released 3.2.2
398    
399     * Sun Sep 06 2009 Robert Scheck <robert@fedoraproject.org> 3.2.1-2
400     - Added ::1 for localhost/loopback access (for IPv6 users)
401    
402     * Mon Aug 10 2009 Robert Scheck <robert@fedoraproject.org> 3.2.1-1
403     - Upstream released 3.2.1
404    
405     * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.0.1-2
406     - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
407    
408     * Tue Jun 30 2009 Robert Scheck <robert@fedoraproject.org> 3.2.0.1-1
409     - Upstream released 3.2.0.1 (#508879)
410    
411     * Tue Jun 30 2009 Robert Scheck <robert@fedoraproject.org> 3.2.0-1
412     - Upstream released 3.2.0
413    
414     * Fri May 15 2009 Robert Scheck <robert@fedoraproject.org> 3.1.5-1
415     - Upstream released 3.1.5
416    
417     * Sat Apr 25 2009 Robert Scheck <robert@fedoraproject.org> 3.1.4-1
418     - Upstream released 3.1.4
419    
420     * Tue Apr 14 2009 Robert Scheck <robert@fedoraproject.org> 3.1.3.2-1
421     - Upstream released 3.1.3.2 (#495768)
422    
423     * Wed Mar 25 2009 Robert Scheck <robert@fedoraproject.org> 3.1.3.1-1
424     - Upstream released 3.1.3.1 (#492066)
425    
426     * Sun Mar 01 2009 Robert Scheck <robert@fedoraproject.org> 3.1.3-1
427     - Upstream released 3.1.3
428    
429     * Mon Feb 23 2009 Robert Scheck <robert@fedoraproject.org> 3.1.2-2
430     - Rebuilt against rpm 4.6
431    
432     * Tue Jan 20 2009 Robert Scheck <robert@fedoraproject.org> 3.1.2-1
433     - Upstream released 3.1.2
434    
435     * Thu Dec 11 2008 Robert Scheck <robert@fedoraproject.org> 3.1.1-1
436     - Upstream released 3.1.1 (#475954)
437    
438     * Sat Nov 29 2008 Robert Scheck <robert@fedoraproject.org> 3.1.0-1
439     - Upstream released 3.1.0
440     - Replaced LocationMatch with Directory directive (#469451)
441    
442     * Thu Oct 30 2008 Robert Scheck <robert@fedoraproject.org> 3.0.1.1-1
443     - Upstream released 3.0.1.1 (#468974)
444    
445     * Wed Oct 22 2008 Robert Scheck <robert@fedoraproject.org> 3.0.1-1
446     - Upstream released 3.0.1
447    
448     * Sun Oct 19 2008 Robert Scheck <robert@fedoraproject.org> 3.0.0-1
449     - Upstream released 3.0.0
450    
451     * Mon Sep 22 2008 Robert Scheck <robert@fedoraproject.org> 2.11.9.2-1
452     - Upstream released 2.11.9.2 (#463260)
453    
454     * Tue Sep 16 2008 Robert Scheck <robert@fedoraproject.org> 2.11.9.1-1
455     - Upstream released 2.11.9.1 (#462430)
456    
457     * Fri Aug 29 2008 Robert Scheck <robert@fedoraproject.org> 2.11.9-1
458     - Upstream released 2.11.9
459    
460     * Mon Jul 28 2008 Robert Scheck <robert@fedoraproject.org> 2.11.8.1-1
461     - Upstream released 2.11.8.1 (#456637, #456950)
462    
463     * Mon Jul 28 2008 Robert Scheck <robert@fedoraproject.org> 2.11.8-1
464     - Upstream released 2.11.8 (#456637)
465    
466     * Tue Jul 15 2008 Robert Scheck <robert@fedoraproject.org> 2.11.7.1-1
467     - Upstream released 2.11.7.1 (#455520)
468    
469     * Mon Jun 23 2008 Robert Scheck <robert@fedoraproject.org> 2.11.7-1
470     - Upstream released 2.11.7 (#452497)
471    
472     * Tue Apr 29 2008 Robert Scheck <robert@fedoraproject.org> 2.11.6-1
473     - Upstream released 2.11.6
474    
475     * Tue Apr 22 2008 Robert Scheck <robert@fedoraproject.org> 2.11.5.2-1
476     - Upstream released 2.11.5.2 (#443683)
477    
478     * Sat Mar 29 2008 Robert Scheck <robert@fedoraproject.org> 2.11.5.1-1
479     - Upstream released 2.11.5.1
480    
481     * Mon Mar 03 2008 Robert Scheck <robert@fedoraproject.org> 2.11.5-1
482     - Upstream released 2.11.5
483    
484     * Sun Jan 13 2008 Robert Scheck <robert@fedoraproject.org> 2.11.4-1
485     - Upstream released 2.11.4
486     - Corrected mod_security example in configuration file (#427119)
487    
488     * Sun Dec 09 2007 Robert Scheck <robert@fedoraproject.org> 2.11.3-1
489     - Upstream released 2.11.3
490     - Removed the RPM scriptlets doing httpd restarts (#227025)
491     - Patched an information disclosure known as CVE-2007-0095 (#221694)
492     - Provide virtual phpmyadmin package and a httpd alias (#231431)
493    
494     * Wed Nov 21 2007 Robert Scheck <robert@fedoraproject.org> 2.11.2.2-1
495     - Upstream released 2.11.2.2 (#393771)
496    
497     * Tue Nov 20 2007 Mike McGrath <mmcgrath@redhat.com> 2.11.2.1-1
498     - Upstream released new version
499    
500     * Mon Oct 29 2007 Mike McGrath <mmcgrath@redhat.com> 2.11.2-1
501     * upstream released new version
502    
503     * Mon Oct 22 2007 Mike McGrath <mmcgrath@redhat.com> 2.11.1.2-1
504     * upstream released new version
505    
506     * Thu Sep 06 2007 Mike McGrath <mmcgrath@redhat.com> 2.11.0-1
507     - Upstream released new version
508     - Altered sources file as required
509     - Added proper license
510    
511     * Mon Jul 23 2007 Mike McGrath <mmcgrath@redhat.com> 2.10.3-1
512     - Upstream released new version
513    
514     * Sat Mar 10 2007 Mike McGrath <mmcgrath@redhat.com> 2.10.0.2-3
515     - Switched to the actual all-languages, not just utf-8
516    
517     * Sun Mar 04 2007 Mike McGrath <mmcgrath@redhat.com> 2.10.0.2-1
518     - Upstream released new version
519    
520     * Sat Jan 20 2007 Mike McGrath <imlinux@gmail.com> 2.9.2-1
521     - Upstream released new version
522    
523     * Fri Dec 08 2006 Mike McGrath <imlinux@gmail.com> 2.9.1.1-2
524     - Fixed bug in spec file
525    
526     * Fri Dec 08 2006 Mike McGrath <imlinux@gmail.com> 2.9.1.1-1
527     - Upstream released new version
528    
529     * Wed Nov 15 2006 Mike McGrath <imlinux@gmail.com> 2.9.1-3alpha
530     - Added dist tag
531    
532     * Wed Nov 15 2006 Mike McGrath <imlinux@gmail.com> 2.9.1-2alpha
533     - Fixed 215159
534    
535     * Fri Nov 10 2006 Mike McGrath <imlinux@gmail.com> 2.9.1-1alpha
536     - Added alpha tag since this is a release candidate
537    
538     * Tue Nov 07 2006 Mike McGrath <imlinux@gmail.com> 2.9.1-1
539     - Upstream released new version
540    
541     * Wed Oct 04 2006 Mike McGrath <imlinux@gmail.com> 2.9.0.2-1
542     - Upstream released new version
543    
544     * Thu Jul 06 2006 Mike McGrath <imlinux@gmail.com> 2.8.2-2
545     - Fixed a typo in the Apache config
546    
547     * Mon Jul 03 2006 Mike McGrath <imlinux@gmail.com> 2.8.2-1
548     - Upstream released 2.8.2
549     - Added more restrictive directives to httpd/conf.d/phpMyAdmin.conf
550     - removed htaccess file from the libraries dir
551     - Specific versions for various requires
552    
553     * Sat May 13 2006 Mike McGrath <imlinux@gmail.com> 2.8.0.4-1
554     - Upstream released 2.8.0.4
555     - Added requires php, instead of requires httpd, now using webserver
556    
557     * Sun May 07 2006 Mike McGrath <imlinux@gmail.com> 2.8.0.3-2
558     - Added mysql-php and php-mbstring as a requires
559    
560     * Fri Apr 07 2006 Mike McGrath <imlinux@gmail.com> 2.8.0.3-1
561     - Fixed XSS vulnerability: PMASA-2006-1
562     - It was possible to conduct an XSS attack with a direct call to some scripts
563     - under the themes directory.
564    
565     * Tue Apr 04 2006 Mike McGrath <imlinux@gmail.com> 2.8.0.2-3
566     - Made config files actually configs
567     - Moved doc files to the doc dir
568    
569     * Tue Apr 04 2006 Mike McGrath <imlinux@gmail.com> 2.8.0.2-2
570     - Moved everything to %{_datadir}
571     - Moved config file to /etc/
572     - Used description from phpMyAdmin project info
573    
574     * Mon Apr 03 2006 Mike McGrath <imlinux@gmail.com> 2.8.0.2-1
575     - Initial Spec file creation for Fedora

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed