1 |
jpp |
1.1 |
%global sname phppgadmin |
2 |
|
|
|
3 |
|
|
Summary: Web-based PostgreSQL administration |
4 |
|
|
Name: phpPgAdmin |
5 |
|
|
Version: 7.13.0 |
6 |
jpp |
1.2 |
Release: 2%{?dist} |
7 |
jpp |
1.1 |
License: GPLv2+ and (LGPLv2+ or BSD) and ASL 2.0 and MIT |
8 |
|
|
URL: https://github.com/%{sname}/%{sname} |
9 |
|
|
|
10 |
|
|
Source0: https://github.com/%{sname}/%{sname}/releases/download/REL_7-13-0/%{name}-%{version}.tar.bz2 |
11 |
|
|
Source1: %{name}.conf |
12 |
|
|
|
13 |
jpp |
1.2 |
Requires: php72-php , php74-php , gawk |
14 |
|
|
Requires: php72-php-pgsql , php74-php-pgsql , httpd |
15 |
jpp |
1.1 |
Requires(post): systemd |
16 |
|
|
Requires(postun): systemd |
17 |
|
|
BuildArch: noarch |
18 |
|
|
|
19 |
|
|
%global _phppgadmindir %{_datadir}/%{name} |
20 |
|
|
|
21 |
|
|
Patch1: %{name}-langcheck.patch |
22 |
|
|
|
23 |
|
|
%description |
24 |
|
|
phpPgAdmin is a fully functional web-based administration utility for |
25 |
|
|
a PostgreSQL database server. It handles all the basic functionality |
26 |
|
|
as well as some advanced features such as triggers, views and |
27 |
|
|
functions (stored procedures). It also has Slony-I support. |
28 |
|
|
|
29 |
|
|
%prep |
30 |
|
|
%setup -q -n %{name}-%{version} |
31 |
|
|
%patch1 -p0 |
32 |
|
|
|
33 |
|
|
%build |
34 |
|
|
|
35 |
|
|
%install |
36 |
|
|
%{__rm} -rf %{buildroot} |
37 |
|
|
%{__install} -d %{buildroot}%{_phppgadmindir} |
38 |
|
|
%{__install} -d %{buildroot}%{_phppgadmindir}/conf |
39 |
|
|
%{__install} -d %{buildroot}%{_sysconfdir}/%{name} |
40 |
|
|
%{__install} -d %{buildroot}%{_sysconfdir}/httpd/conf.d/ |
41 |
|
|
%{__install} -m 644 -p *.php %{buildroot}%{_phppgadmindir} |
42 |
|
|
%{__cp} -ap *.js robots.txt classes help js libraries themes images lang plugins xloadtree %{buildroot}%{_phppgadmindir} |
43 |
|
|
%{__install} -m 755 -p %{SOURCE1} %{buildroot}%{_sysconfdir}/httpd/conf.d/%{name}.conf |
44 |
|
|
%{__install} -m 755 conf/* %{buildroot}%{_sysconfdir}/%{name} |
45 |
|
|
%{__ln_s} %{_sysconfdir}/%{name}/config.inc.php %{buildroot}/%{_phppgadmindir}/conf/config.inc.php |
46 |
|
|
%{__ln_s} %{_sysconfdir}/%{name}/config.inc.php-dist %{buildroot}/%{_phppgadmindir}/conf/config.inc.php-dist |
47 |
|
|
|
48 |
|
|
%post |
49 |
jpp |
1.2 |
#/usr/bin/systemctl reload httpd.service |
50 |
jpp |
1.1 |
|
51 |
|
|
%postun |
52 |
jpp |
1.2 |
#/usr/bin/systemctl reload httpd.service |
53 |
jpp |
1.1 |
|
54 |
|
|
%files |
55 |
|
|
%doc CREDITS DEVELOPERS FAQ HISTORY INSTALL LICENSE TODO TRANSLATORS |
56 |
|
|
%dir %{_phppgadmindir} |
57 |
|
|
%dir %{_sysconfdir}/%{name} |
58 |
|
|
%dir %{_phppgadmindir}/conf |
59 |
|
|
%config(noreplace) %{_sysconfdir}/%{name}/* |
60 |
|
|
%config(noreplace) %{_sysconfdir}/httpd/conf.d/%{name}.conf |
61 |
|
|
%attr(644,root,root) %{_phppgadmindir}/*.php |
62 |
|
|
%{_phppgadmindir}/*.js |
63 |
|
|
%{_phppgadmindir}/robots.txt |
64 |
|
|
%{_phppgadmindir}/classes |
65 |
|
|
%{_phppgadmindir}/help |
66 |
|
|
%{_phppgadmindir}/images |
67 |
|
|
%{_phppgadmindir}/js/*.js |
68 |
|
|
%{_phppgadmindir}/libraries |
69 |
|
|
%{_phppgadmindir}/plugins/Report/* |
70 |
|
|
%{_phppgadmindir}/plugins/GuiControl/* |
71 |
|
|
%{_phppgadmindir}/themes |
72 |
|
|
%{_phppgadmindir}/xloadtree |
73 |
|
|
%{_phppgadmindir}/conf/* |
74 |
|
|
%dir %{_phppgadmindir}/lang |
75 |
|
|
%attr(644,root,root) %{_phppgadmindir}/lang/*.php |
76 |
|
|
%attr(644,root,root) %{_phppgadmindir}/lang/README |
77 |
|
|
%attr(755,root,root) %{_phppgadmindir}/lang/langcheck |
78 |
|
|
%attr(755,root,root) %{_phppgadmindir}/lang/synch |
79 |
|
|
|
80 |
|
|
%changelog |
81 |
jpp |
1.2 |
* Mon Dec 26 2022 Jean-Philippe Pialasse <tests@pialasse.com> 7.13.0-2.sme |
82 |
|
|
- use php74 scl for SME |
83 |
|
|
- remove post and postun |
84 |
|
|
|
85 |
jpp |
1.1 |
* Mon Nov 9 2020 Devrim Gündüz <devrim@gunduz.org> - 7.13.0-1 |
86 |
|
|
- Update to 7.13.0 |
87 |
|
|
|
88 |
|
|
* Wed Feb 5 2020 Devrim Gündüz <devrim@gunduz.org> - 7.12.1-1 |
89 |
|
|
- Update to 7.12.1 |
90 |
|
|
|
91 |
|
|
* Fri Sep 6 2019 Devrim Gündüz <devrim@gunduz.org> - 5.6-1 |
92 |
|
|
- Update to 5.6 |
93 |
|
|
- Fix a few rpmlint warnings |
94 |
|
|
- Update URLs |
95 |
|
|
- Use more macros |