/[smecontribs]/rpms/phpki/contribs7/phpki.spec
ViewVC logotype

Annotation of /rpms/phpki/contribs7/phpki.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.2 - (hide annotations) (download)
Mon Mar 2 23:53:29 2009 UTC (15 years, 2 months ago) by slords
Branch: MAIN
CVS Tags: phpki-0_82-7_el4_sme
Changes since 1.1: +4 -2 lines
Spec updates

1 slords 1.2 # $Id$
2     # Authority: vip-ire
3     # Name: Daniel Berteaud
4    
5 slords 1.1 %define name phpki
6     %define version 0.82
7     %define release 7
8     Summary: Phpki is a simple certificate management suite
9     Name: %{name}
10     Version: %{version}
11     Release: %{release}%{?dist}
12     License: GNU GPL version 2
13     URL: http://sourceforge.net/projects/phpki/
14     Group: SMEserver/addon
15     #wget http://www.fooweb.com/downloads/foo-3.6.431.tar.gz
16     Source: phpki-0.82.tar.gz
17     Patch1: phpki-0.82-email_signing.patch
18     Patch2: phpki-0.82-sme_openvpn_bridge_compat.patch
19     Patch3: phpki-0.82-sme_admin_user.patch
20     Patch4: phpki-0.82-openvpn_static_key.patch
21     Patch5: phpki-0.82-expirey.patch
22     Patch6: phpki-0.82-dl_display_ta_dh.patch
23     Patch7: phpki-0.82-dl_crl_in_pem.patch
24     Patch8: phpki-0.82-remove_email_from_upload_file_name.patch
25     Patch9: phpki-0.82-display_root_pem.patch
26     Patch10: phpki-0.82-disable_download_after_create.patch
27     Patch11: phpki-0.82-remove_security_warning.patch
28     Patch12: phpki-0.82-remove_email_from_upload_file_name.patch2
29    
30     BuildArch: noarch
31     BuildRoot: /var/tmp/%{name}-%{version}
32     Requires: e-smith-release >= 7.0
33     Requires: php
34     Requires: openssl
35     Requires: openvpn
36     AutoReqProv: no
37    
38     %description
39     http://sourceforge.net/projects/phpki/
40     PHPki is an Open Source Web application for managing a multi-agency PKI for HIPAA compliance.
41     With it, you may create and centrally manage X.509 certificates for use with S/MIME enabled
42     e-mail clients, SSL servers, and VPN applications.
43    
44     %changelog
45     * Tue Jan 20 2009 Daniel B. <daniel@firewall-services.com> [0.82-7]
46     - Don't replace config file on upgrades
47    
48     * Wed Jan 07 2009 Daniel B. <daniel@firewall-services.com> [0.82-6]
49     - Remove the email address from the file name during upload (in search page)
50     - Remove secure.sh script
51    
52     * Tue Dec 16 2008 Daniel B. <daniel@firewall-services.com> [0.82-5]
53     - Link index.php to setup-presetup.php
54    
55     * Mon Dec 08 2008 Daniel B. <daniel@firewall-services.com> [0.82-4]
56     - Changes so certificates imported from openvpn-bridge are recognized
57     - Configure default admin user to 'admin'
58     - Create a static key for OpenVPN TLS auth (requires openvpn)
59     - Add expirey values (3 Months, 6 Months)
60     - Display or download takey.pem and dhparam1024.pem from
61     the certificate management menue
62     - Display the Root certificate in PEM format
63     - Possibility to download the CRL in PEM format
64     - Remove the email address from the file name during upload
65     - Disable download of certificate after creating a new one
66     - Remove security warning after setup
67    
68     * Wed Dec 05 2008 Daniel B. <daniel@firewall-services.com> [0.82-3]
69     - Correct extension name for email_signing certificates
70     - Remove links, and recreate them in the %post section so upgrade can be done smoothly
71    
72     * Wed Nov 26 2008 Daniel B. <daniel@firewall-services.com> [0.82-0]
73     - initial release
74     - builds from unchanged .tar.gz
75    
76     %prep
77     %setup -c -n %{name}
78     %patch1 -p1
79     %patch2 -p1
80     %patch3 -p1
81     %patch4 -p1
82     %patch5 -p1
83     %patch6 -p1
84     %patch7 -p1
85     %patch8 -p1
86     %patch9 -p1
87     %patch10 -p1
88     %patch11 -p1
89     %patch12 -p1
90    
91     %build
92     #drop in an unchanged .tgz, if required rename directory here, eg remove version number.
93     %{__mkdir_p} root/opt/phpki/html
94     %{__mkdir_p} root/opt/phpki/phpki-store
95     %{__mv} %{name}-%{version}/* root/opt/phpki/html/
96    
97     # Remove links to setup page so upgrades can be done smoothly
98     %{__rm} -f root/opt/phpki/html/index.php
99     %{__rm} -f root/opt/phpki/html/ca/index.php
100     %{__rm} -f root/opt/phpki/html/setup.php
101    
102     # This script shouldn't be here
103     %{__rm} -f root/opt/phpki/html/secure.sh
104    
105    
106     %install
107     rm -rf $RPM_BUILD_ROOT
108     (cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT)
109     rm -f %{name}-%{version}-filelist
110     /sbin/e-smith/genfilelist $RPM_BUILD_ROOT \
111     --file '/opt/phpki/html/config.php' 'attr(660,root,phpki) %config(noreplace)' \
112     --file '/opt/phpki/html/openssl.cnf' 'attr(660,root,phpki) %config(noreplace)' \
113     --dir '/opt/phpki/html' 'attr(770,root,phpki)' \
114     --dir '/opt/phpki/html/ca' 'attr(770,root,phpki)' \
115     --dir '/opt/phpki/phpki-store' 'attr(750,phpki,phpki)' \
116     > %{name}-%{version}-filelist
117    
118     %files -f %{name}-%{version}-filelist
119     %defattr(-,root,root)
120    
121     %clean
122     cd ..
123     rm -rf $RPM_BUILD_ROOT
124    
125     %pre
126     if ! /usr/bin/id phpki &>/dev/null; then
127     /usr/sbin/useradd -c 'Phpki User' -s /sbin/nologin -r -d /opt/phpki/phpki-store phpki &>/dev/null || \
128     %logmsg "Unexpected error adding user \"phpki\". Abort installation."
129     fi
130    
131     %preun
132    
133     %post
134     # First install, point index.php to setup.php
135     if [ $1 == 1 ]; then
136     %{__ln_s} /opt/phpki/html/setup.php-presetup /opt/phpki/html/index.php
137     %{__ln_s} /opt/phpki/html/setup.php-presetup /opt/phpki/html/setup.php
138     echo "<?php
139     header(\"Location: ./../index.php\");
140     ?>
141     " > /opt/phpki/html/ca/index.php
142    
143     fi
144    
145     %postun
146    
147     true

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed