/[smecontribs]/rpms/phpki/contribs7/phpki.spec
ViewVC logotype

Annotation of /rpms/phpki/contribs7/phpki.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.3 - (hide annotations) (download)
Tue Mar 3 18:36:43 2009 UTC (15 years, 2 months ago) by vip-ire
Branch: MAIN
CVS Tags: phpki-0_82-8_el4_sme
Changes since 1.2: +8 -2 lines
Add e-smith-devtools as a dependencie

1 vip-ire 1.3 # $Id: phpki.spec,v 1.2 2009/03/02 23:53:29 slords Exp $
2 slords 1.2 # Authority: vip-ire
3     # Name: Daniel Berteaud
4    
5 slords 1.1 %define name phpki
6     %define version 0.82
7 vip-ire 1.3 %define release 8
8 slords 1.1 Summary: Phpki is a simple certificate management suite
9     Name: %{name}
10     Version: %{version}
11     Release: %{release}%{?dist}
12     License: GNU GPL version 2
13     URL: http://sourceforge.net/projects/phpki/
14     Group: SMEserver/addon
15     #wget http://www.fooweb.com/downloads/foo-3.6.431.tar.gz
16     Source: phpki-0.82.tar.gz
17     Patch1: phpki-0.82-email_signing.patch
18     Patch2: phpki-0.82-sme_openvpn_bridge_compat.patch
19     Patch3: phpki-0.82-sme_admin_user.patch
20     Patch4: phpki-0.82-openvpn_static_key.patch
21     Patch5: phpki-0.82-expirey.patch
22     Patch6: phpki-0.82-dl_display_ta_dh.patch
23     Patch7: phpki-0.82-dl_crl_in_pem.patch
24     Patch8: phpki-0.82-remove_email_from_upload_file_name.patch
25     Patch9: phpki-0.82-display_root_pem.patch
26     Patch10: phpki-0.82-disable_download_after_create.patch
27     Patch11: phpki-0.82-remove_security_warning.patch
28     Patch12: phpki-0.82-remove_email_from_upload_file_name.patch2
29    
30     BuildArch: noarch
31     BuildRoot: /var/tmp/%{name}-%{version}
32 vip-ire 1.3
33     BuildRequires: e-smith-devtools
34    
35 slords 1.1 Requires: e-smith-release >= 7.0
36     Requires: php
37     Requires: openssl
38     Requires: openvpn
39     AutoReqProv: no
40    
41     %description
42     http://sourceforge.net/projects/phpki/
43     PHPki is an Open Source Web application for managing a multi-agency PKI for HIPAA compliance.
44     With it, you may create and centrally manage X.509 certificates for use with S/MIME enabled
45     e-mail clients, SSL servers, and VPN applications.
46    
47     %changelog
48 vip-ire 1.3 * Tue Mar 03 2009 Daniel B. <daniel@firewall-services.com> [0.82-8]
49     - Add e-smith-devtools as a dependencie
50    
51 slords 1.1 * Tue Jan 20 2009 Daniel B. <daniel@firewall-services.com> [0.82-7]
52     - Don't replace config file on upgrades
53    
54     * Wed Jan 07 2009 Daniel B. <daniel@firewall-services.com> [0.82-6]
55     - Remove the email address from the file name during upload (in search page)
56     - Remove secure.sh script
57    
58     * Tue Dec 16 2008 Daniel B. <daniel@firewall-services.com> [0.82-5]
59     - Link index.php to setup-presetup.php
60    
61     * Mon Dec 08 2008 Daniel B. <daniel@firewall-services.com> [0.82-4]
62     - Changes so certificates imported from openvpn-bridge are recognized
63     - Configure default admin user to 'admin'
64     - Create a static key for OpenVPN TLS auth (requires openvpn)
65     - Add expirey values (3 Months, 6 Months)
66     - Display or download takey.pem and dhparam1024.pem from
67     the certificate management menue
68     - Display the Root certificate in PEM format
69     - Possibility to download the CRL in PEM format
70     - Remove the email address from the file name during upload
71     - Disable download of certificate after creating a new one
72     - Remove security warning after setup
73    
74     * Wed Dec 05 2008 Daniel B. <daniel@firewall-services.com> [0.82-3]
75     - Correct extension name for email_signing certificates
76     - Remove links, and recreate them in the %post section so upgrade can be done smoothly
77    
78     * Wed Nov 26 2008 Daniel B. <daniel@firewall-services.com> [0.82-0]
79     - initial release
80     - builds from unchanged .tar.gz
81    
82     %prep
83     %setup -c -n %{name}
84     %patch1 -p1
85     %patch2 -p1
86     %patch3 -p1
87     %patch4 -p1
88     %patch5 -p1
89     %patch6 -p1
90     %patch7 -p1
91     %patch8 -p1
92     %patch9 -p1
93     %patch10 -p1
94     %patch11 -p1
95     %patch12 -p1
96    
97     %build
98     #drop in an unchanged .tgz, if required rename directory here, eg remove version number.
99     %{__mkdir_p} root/opt/phpki/html
100     %{__mkdir_p} root/opt/phpki/phpki-store
101     %{__mv} %{name}-%{version}/* root/opt/phpki/html/
102    
103     # Remove links to setup page so upgrades can be done smoothly
104     %{__rm} -f root/opt/phpki/html/index.php
105     %{__rm} -f root/opt/phpki/html/ca/index.php
106     %{__rm} -f root/opt/phpki/html/setup.php
107    
108     # This script shouldn't be here
109     %{__rm} -f root/opt/phpki/html/secure.sh
110    
111    
112     %install
113     rm -rf $RPM_BUILD_ROOT
114     (cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT)
115     rm -f %{name}-%{version}-filelist
116     /sbin/e-smith/genfilelist $RPM_BUILD_ROOT \
117     --file '/opt/phpki/html/config.php' 'attr(660,root,phpki) %config(noreplace)' \
118     --file '/opt/phpki/html/openssl.cnf' 'attr(660,root,phpki) %config(noreplace)' \
119     --dir '/opt/phpki/html' 'attr(770,root,phpki)' \
120     --dir '/opt/phpki/html/ca' 'attr(770,root,phpki)' \
121     --dir '/opt/phpki/phpki-store' 'attr(750,phpki,phpki)' \
122     > %{name}-%{version}-filelist
123    
124     %files -f %{name}-%{version}-filelist
125     %defattr(-,root,root)
126    
127     %clean
128     cd ..
129     rm -rf $RPM_BUILD_ROOT
130    
131     %pre
132     if ! /usr/bin/id phpki &>/dev/null; then
133     /usr/sbin/useradd -c 'Phpki User' -s /sbin/nologin -r -d /opt/phpki/phpki-store phpki &>/dev/null || \
134     %logmsg "Unexpected error adding user \"phpki\". Abort installation."
135     fi
136    
137     %preun
138    
139     %post
140     # First install, point index.php to setup.php
141     if [ $1 == 1 ]; then
142     %{__ln_s} /opt/phpki/html/setup.php-presetup /opt/phpki/html/index.php
143     %{__ln_s} /opt/phpki/html/setup.php-presetup /opt/phpki/html/setup.php
144     echo "<?php
145     header(\"Location: ./../index.php\");
146     ?>
147     " > /opt/phpki/html/ca/index.php
148    
149     fi
150    
151     %postun
152    
153     true

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed