/[smecontribs]/rpms/phpki/contribs7/phpki.spec
ViewVC logotype

Annotation of /rpms/phpki/contribs7/phpki.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.4 - (hide annotations) (download)
Mon Mar 23 12:35:20 2009 UTC (15 years, 1 month ago) by vip-ire
Branch: MAIN
CVS Tags: phpki-0_82-9_el4_sme
Changes since 1.3: +13 -3 lines
Remove symlinks after uninstall

1 vip-ire 1.4 # $Id: phpki.spec,v 1.3 2009/03/03 18:36:43 vip-ire Exp $
2 slords 1.2 # Authority: vip-ire
3     # Name: Daniel Berteaud
4    
5 slords 1.1 %define name phpki
6     %define version 0.82
7 vip-ire 1.4 %define release 9
8 slords 1.1 Summary: Phpki is a simple certificate management suite
9     Name: %{name}
10     Version: %{version}
11     Release: %{release}%{?dist}
12     License: GNU GPL version 2
13     URL: http://sourceforge.net/projects/phpki/
14     Group: SMEserver/addon
15     #wget http://www.fooweb.com/downloads/foo-3.6.431.tar.gz
16     Source: phpki-0.82.tar.gz
17     Patch1: phpki-0.82-email_signing.patch
18     Patch2: phpki-0.82-sme_openvpn_bridge_compat.patch
19     Patch3: phpki-0.82-sme_admin_user.patch
20     Patch4: phpki-0.82-openvpn_static_key.patch
21     Patch5: phpki-0.82-expirey.patch
22     Patch6: phpki-0.82-dl_display_ta_dh.patch
23     Patch7: phpki-0.82-dl_crl_in_pem.patch
24     Patch8: phpki-0.82-remove_email_from_upload_file_name.patch
25     Patch9: phpki-0.82-display_root_pem.patch
26     Patch10: phpki-0.82-disable_download_after_create.patch
27     Patch11: phpki-0.82-remove_security_warning.patch
28     Patch12: phpki-0.82-remove_email_from_upload_file_name.patch2
29    
30     BuildArch: noarch
31     BuildRoot: /var/tmp/%{name}-%{version}
32 vip-ire 1.3
33     BuildRequires: e-smith-devtools
34    
35 slords 1.1 Requires: e-smith-release >= 7.0
36     Requires: php
37     Requires: openssl
38     Requires: openvpn
39     AutoReqProv: no
40    
41     %description
42     http://sourceforge.net/projects/phpki/
43     PHPki is an Open Source Web application for managing a multi-agency PKI for HIPAA compliance.
44     With it, you may create and centrally manage X.509 certificates for use with S/MIME enabled
45     e-mail clients, SSL servers, and VPN applications.
46    
47     %changelog
48 vip-ire 1.4 * Mon Mar 23 2009 Daniel B. <daniel@firewall-services.com> [0.82-9]
49     - Remove links after uninstall so you can easily re-install the contrib
50     later [SME: 5091]
51    
52 vip-ire 1.3 * Tue Mar 03 2009 Daniel B. <daniel@firewall-services.com> [0.82-8]
53     - Add e-smith-devtools as a dependencie
54    
55 slords 1.1 * Tue Jan 20 2009 Daniel B. <daniel@firewall-services.com> [0.82-7]
56     - Don't replace config file on upgrades
57    
58     * Wed Jan 07 2009 Daniel B. <daniel@firewall-services.com> [0.82-6]
59     - Remove the email address from the file name during upload (in search page)
60     - Remove secure.sh script
61    
62     * Tue Dec 16 2008 Daniel B. <daniel@firewall-services.com> [0.82-5]
63     - Link index.php to setup-presetup.php
64    
65     * Mon Dec 08 2008 Daniel B. <daniel@firewall-services.com> [0.82-4]
66     - Changes so certificates imported from openvpn-bridge are recognized
67     - Configure default admin user to 'admin'
68     - Create a static key for OpenVPN TLS auth (requires openvpn)
69     - Add expirey values (3 Months, 6 Months)
70     - Display or download takey.pem and dhparam1024.pem from
71     the certificate management menue
72     - Display the Root certificate in PEM format
73     - Possibility to download the CRL in PEM format
74     - Remove the email address from the file name during upload
75     - Disable download of certificate after creating a new one
76     - Remove security warning after setup
77    
78     * Wed Dec 05 2008 Daniel B. <daniel@firewall-services.com> [0.82-3]
79     - Correct extension name for email_signing certificates
80     - Remove links, and recreate them in the %post section so upgrade can be done smoothly
81    
82     * Wed Nov 26 2008 Daniel B. <daniel@firewall-services.com> [0.82-0]
83     - initial release
84     - builds from unchanged .tar.gz
85    
86     %prep
87     %setup -c -n %{name}
88     %patch1 -p1
89     %patch2 -p1
90     %patch3 -p1
91     %patch4 -p1
92     %patch5 -p1
93     %patch6 -p1
94     %patch7 -p1
95     %patch8 -p1
96     %patch9 -p1
97     %patch10 -p1
98     %patch11 -p1
99     %patch12 -p1
100    
101     %build
102     #drop in an unchanged .tgz, if required rename directory here, eg remove version number.
103     %{__mkdir_p} root/opt/phpki/html
104     %{__mkdir_p} root/opt/phpki/phpki-store
105     %{__mv} %{name}-%{version}/* root/opt/phpki/html/
106    
107     # Remove links to setup page so upgrades can be done smoothly
108     %{__rm} -f root/opt/phpki/html/index.php
109     %{__rm} -f root/opt/phpki/html/ca/index.php
110     %{__rm} -f root/opt/phpki/html/setup.php
111    
112     # This script shouldn't be here
113     %{__rm} -f root/opt/phpki/html/secure.sh
114    
115    
116     %install
117     rm -rf $RPM_BUILD_ROOT
118     (cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT)
119     rm -f %{name}-%{version}-filelist
120     /sbin/e-smith/genfilelist $RPM_BUILD_ROOT \
121     --file '/opt/phpki/html/config.php' 'attr(660,root,phpki) %config(noreplace)' \
122     --file '/opt/phpki/html/openssl.cnf' 'attr(660,root,phpki) %config(noreplace)' \
123     --dir '/opt/phpki/html' 'attr(770,root,phpki)' \
124     --dir '/opt/phpki/html/ca' 'attr(770,root,phpki)' \
125     --dir '/opt/phpki/phpki-store' 'attr(750,phpki,phpki)' \
126     > %{name}-%{version}-filelist
127    
128     %files -f %{name}-%{version}-filelist
129     %defattr(-,root,root)
130    
131     %clean
132     cd ..
133     rm -rf $RPM_BUILD_ROOT
134    
135     %pre
136     if ! /usr/bin/id phpki &>/dev/null; then
137     /usr/sbin/useradd -c 'Phpki User' -s /sbin/nologin -r -d /opt/phpki/phpki-store phpki &>/dev/null || \
138     %logmsg "Unexpected error adding user \"phpki\". Abort installation."
139     fi
140    
141     %preun
142    
143     %post
144     # First install, point index.php to setup.php
145     if [ $1 == 1 ]; then
146     %{__ln_s} /opt/phpki/html/setup.php-presetup /opt/phpki/html/index.php
147     %{__ln_s} /opt/phpki/html/setup.php-presetup /opt/phpki/html/setup.php
148     echo "<?php
149     header(\"Location: ./../index.php\");
150     ?>
151     " > /opt/phpki/html/ca/index.php
152 vip-ire 1.4 fi
153 slords 1.1
154 vip-ire 1.4 %postun
155     # Remove the links to index.php after uninstall
156     if [ $1 == 0 ]; then
157     %{__rm} -f /opt/phpki/html/index.php
158     %{__rm} -f /opt/phpki/html/setup.php
159     %{__rm} -f /opt/phpki/html/ca/index.php
160 slords 1.1 fi
161    
162    
163     true

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed