1 |
# $Id: phpki.spec,v 1.1 2013/05/24 22:17:29 unnilennium Exp $ |
2 |
# Authority: vip-ire |
3 |
# Name: Daniel Berteaud |
4 |
|
5 |
%define name phpki |
6 |
%define version 0.82 |
7 |
%define release 17 |
8 |
Summary: Phpki is a simple certificate management suite |
9 |
Name: %{name} |
10 |
Version: %{version} |
11 |
Release: %{release}%{?dist} |
12 |
License: GNU GPL version 2 |
13 |
URL: http://sourceforge.net/projects/phpki/ |
14 |
Group: SMEserver/addon |
15 |
#wget http://www.fooweb.com/downloads/foo-3.6.431.tar.gz |
16 |
Source: phpki-0.82.tar.gz |
17 |
Patch1: phpki-0.82-email_signing.patch |
18 |
Patch2: phpki-0.82-sme_openvpn_bridge_compat.patch |
19 |
Patch3: phpki-0.82-sme_admin_user.patch |
20 |
Patch4: phpki-0.82-openvpn_static_key.patch |
21 |
Patch5: phpki-0.82-expirey.patch |
22 |
Patch6: phpki-0.82-dl_display_ta_dh.patch |
23 |
Patch7: phpki-0.82-dl_crl_in_pem.patch |
24 |
Patch8: phpki-0.82-remove_email_from_upload_file_name.patch |
25 |
Patch9: phpki-0.82-display_root_pem.patch |
26 |
Patch10: phpki-0.82-disable_download_after_create.patch |
27 |
Patch11: phpki-0.82-remove_security_warning.patch |
28 |
Patch12: phpki-0.82-remove_email_from_upload_file_name.patch2 |
29 |
Patch13: phpki-0.82-ca_help.patch |
30 |
Patch14: phpki-0.82-empty_pass_php_5.2.patch |
31 |
Patch15: phpki-0.82-update_crl_via_cron.patch |
32 |
Patch16: phpki-0.82-use_sha1.patch |
33 |
Patch17: phpki-0.82-ca_admin_users.patch |
34 |
Patch18: phpki-0.82-nscerttype_not_critical.patch |
35 |
|
36 |
BuildArch: noarch |
37 |
BuildRoot: /var/tmp/%{name}-%{version} |
38 |
|
39 |
BuildRequires: e-smith-devtools |
40 |
|
41 |
Requires: e-smith-release >= 7.0 |
42 |
Requires: php |
43 |
Requires: openssl |
44 |
Requires: openvpn |
45 |
AutoReqProv: no |
46 |
|
47 |
%description |
48 |
http://sourceforge.net/projects/phpki/ |
49 |
PHPki is an Open Source Web application for managing a multi-agency PKI for HIPAA compliance. |
50 |
With it, you may create and centrally manage X.509 certificates for use with S/MIME enabled |
51 |
e-mail clients, SSL servers, and VPN applications. |
52 |
|
53 |
%changelog |
54 |
* Tue Jul 29 2014 Daniel B. <daniel@firewall-services.com> 0.82-17.sme |
55 |
- Don't mark obsolete nsCertType as critical |
56 |
see https://bugzilla.mozilla.org/show_bug.cgi?id=1009161 |
57 |
|
58 |
* Mon Dec 12 2011 Daniel B. <daniel@firewall-services.com> 0.82-16.sme |
59 |
- Remove php-posix dependency (not available, nor needed on SME 7.x) [SME: 6805] |
60 |
|
61 |
* Wed Oct 26 2011 Daniel B. <daniel@firewall-services.com> 0.82-15.sme |
62 |
- Requires php-posix |
63 |
|
64 |
* Wed Jun 29 2011 Daniel B. <daniel@firewall-services.com> 0.82-14.sme |
65 |
- Don't check issuer (everyone allowed to access /ca can manage |
66 |
all the certificates, access to /ca is controlled by apache) |
67 |
|
68 |
* Tue Mar 15 2011 Daniel B. <daniel@firewall-services.com> 0.82-13.sme |
69 |
- Replace md5 with sha1 for signing |
70 |
|
71 |
* Fri May 28 2010 Daniel B. <daniel@firewall-services.com> [0.82-12] |
72 |
- Weekly update the CRL via cron so MS Crypto API will be happy |
73 |
|
74 |
* Thu Mar 18 2010 Daniel B. <daniel@firewall-services.com> [0.82-11] |
75 |
- Fixe empty password with PHP 5.2 (SME 8b5) |
76 |
|
77 |
* Wed Aug 26 2009 Daniel B. <daniel@firewall-services.com> [0.82-10] |
78 |
- Fixe links for CA help page |
79 |
|
80 |
* Mon Mar 23 2009 Daniel B. <daniel@firewall-services.com> [0.82-9] |
81 |
- Remove links after uninstall so you can easily re-install the contrib |
82 |
later [SME: 5091] |
83 |
|
84 |
* Tue Mar 03 2009 Daniel B. <daniel@firewall-services.com> [0.82-8] |
85 |
- Add e-smith-devtools as a dependencie |
86 |
|
87 |
* Tue Jan 20 2009 Daniel B. <daniel@firewall-services.com> [0.82-7] |
88 |
- Don't replace config file on upgrades |
89 |
|
90 |
* Wed Jan 07 2009 Daniel B. <daniel@firewall-services.com> [0.82-6] |
91 |
- Remove the email address from the file name during upload (in search page) |
92 |
- Remove secure.sh script |
93 |
|
94 |
* Tue Dec 16 2008 Daniel B. <daniel@firewall-services.com> [0.82-5] |
95 |
- Link index.php to setup-presetup.php |
96 |
|
97 |
* Mon Dec 08 2008 Daniel B. <daniel@firewall-services.com> [0.82-4] |
98 |
- Changes so certificates imported from openvpn-bridge are recognized |
99 |
- Configure default admin user to 'admin' |
100 |
- Create a static key for OpenVPN TLS auth (requires openvpn) |
101 |
- Add expirey values (3 Months, 6 Months) |
102 |
- Display or download takey.pem and dhparam1024.pem from |
103 |
the certificate management menue |
104 |
- Display the Root certificate in PEM format |
105 |
- Possibility to download the CRL in PEM format |
106 |
- Remove the email address from the file name during upload |
107 |
- Disable download of certificate after creating a new one |
108 |
- Remove security warning after setup |
109 |
|
110 |
* Wed Dec 05 2008 Daniel B. <daniel@firewall-services.com> [0.82-3] |
111 |
- Correct extension name for email_signing certificates |
112 |
- Remove links, and recreate them in the %post section so upgrade can be done smoothly |
113 |
|
114 |
* Wed Nov 26 2008 Daniel B. <daniel@firewall-services.com> [0.82-0] |
115 |
- initial release |
116 |
- builds from unchanged .tar.gz |
117 |
|
118 |
%prep |
119 |
%setup -c -n %{name} |
120 |
%patch1 -p1 |
121 |
%patch2 -p1 |
122 |
%patch3 -p1 |
123 |
%patch4 -p1 |
124 |
%patch5 -p1 |
125 |
%patch6 -p1 |
126 |
%patch7 -p1 |
127 |
%patch8 -p1 |
128 |
%patch9 -p1 |
129 |
%patch10 -p1 |
130 |
%patch11 -p1 |
131 |
%patch12 -p1 |
132 |
%patch13 -p1 |
133 |
%patch14 -p1 |
134 |
%patch15 -p1 |
135 |
%patch16 -p1 |
136 |
%patch17 -p1 |
137 |
%patch18 -p1 |
138 |
|
139 |
%build |
140 |
%{__mkdir_p} root/opt/phpki/html |
141 |
%{__mkdir_p} root/opt/phpki/phpki-store |
142 |
%{__mkdir_p} root/opt/phpki/bin |
143 |
%{__mkdir_p} root/%{_sysconfdir}/cron.weekly/ |
144 |
%{__mv} %{name}-%{version}/gen_crl.php root/opt/phpki/bin/ |
145 |
%{__mv} %{name}-%{version}/* root/opt/phpki/html/ |
146 |
|
147 |
|
148 |
cat <<"HERE" > root/%{_sysconfdir}/cron.weekly/phpki_update_crl |
149 |
#!/bin/bash |
150 |
|
151 |
cd /opt/phpki/bin |
152 |
php ./gen_crl.php 2>&1 > /dev/null |
153 |
|
154 |
HERE |
155 |
|
156 |
|
157 |
# Remove links to setup page so upgrades can be done smoothly |
158 |
%{__rm} -f root/opt/phpki/html/index.php |
159 |
%{__rm} -f root/opt/phpki/html/ca/index.php |
160 |
%{__rm} -f root/opt/phpki/html/setup.php |
161 |
|
162 |
# This script shouldn't be here |
163 |
%{__rm} -f root/opt/phpki/html/secure.sh |
164 |
|
165 |
|
166 |
%install |
167 |
rm -rf $RPM_BUILD_ROOT |
168 |
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
169 |
rm -f %{name}-%{version}-filelist |
170 |
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
171 |
--file '/opt/phpki/html/config.php' 'attr(660,root,phpki) %config(noreplace)' \ |
172 |
--file '/opt/phpki/html/openssl.cnf' 'attr(660,root,phpki) %config(noreplace)' \ |
173 |
--file '%{_sysconfdir}/cron.weekly/phpki_update_crl' 'attr(744,root,root)' \ |
174 |
--dir '/opt/phpki/html' 'attr(770,root,phpki)' \ |
175 |
--dir '/opt/phpki/html/ca' 'attr(770,root,phpki)' \ |
176 |
--dir '/opt/phpki/phpki-store' 'attr(750,phpki,phpki)' \ |
177 |
> %{name}-%{version}-filelist |
178 |
|
179 |
%files -f %{name}-%{version}-filelist |
180 |
%defattr(-,root,root) |
181 |
|
182 |
%clean |
183 |
cd .. |
184 |
rm -rf $RPM_BUILD_ROOT |
185 |
|
186 |
%pre |
187 |
if ! /usr/bin/id phpki &>/dev/null; then |
188 |
/usr/sbin/useradd -c 'Phpki User' -s /sbin/nologin -r -d /opt/phpki/phpki-store phpki &>/dev/null || \ |
189 |
%logmsg "Unexpected error adding user \"phpki\". Abort installation." |
190 |
fi |
191 |
|
192 |
%preun |
193 |
|
194 |
%post |
195 |
# First install, point index.php to setup.php |
196 |
if [ $1 == 1 ]; then |
197 |
%{__ln_s} /opt/phpki/html/setup.php-presetup /opt/phpki/html/index.php |
198 |
%{__ln_s} /opt/phpki/html/setup.php-presetup /opt/phpki/html/setup.php |
199 |
echo "<?php |
200 |
header(\"Location: ./../index.php\"); |
201 |
?> |
202 |
" > /opt/phpki/html/ca/index.php |
203 |
fi |
204 |
|
205 |
%postun |
206 |
# Remove the links to index.php after uninstall |
207 |
if [ $1 == 0 ]; then |
208 |
%{__rm} -f /opt/phpki/html/index.php |
209 |
%{__rm} -f /opt/phpki/html/setup.php |
210 |
%{__rm} -f /opt/phpki/html/ca/index.php |
211 |
fi |
212 |
|
213 |
|
214 |
true |