/[smecontribs]/rpms/phpldapadmin/contribs10/phpldapadmin.spec
ViewVC logotype

Annotation of /rpms/phpldapadmin/contribs10/phpldapadmin.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.3 - (hide annotations) (download)
Thu Sep 30 11:35:06 2021 UTC (2 years, 8 months ago) by jcrisp
Branch: MAIN
CVS Tags: phpldapadmin-1_2_6-3_el7_sme
Changes since 1.2: +6 -3 lines
* Thu Sep 30 2021 John Crisp <jcrisp@safeandsoundit.co.uk> - 1.2.6-3.sme
- Update php versions to php74 [SME: 11700]

1 jcrisp 1.1 Name: phpldapadmin
2     Summary: Web-based tool for managing LDAP servers
3     Version: 1.2.6
4 jcrisp 1.3 Release: 3%{?dist}
5 jcrisp 1.1 Group: Applications/Internet
6     License: GPLv2+
7     URL: http://phpldapadmin.sourceforge.net
8    
9     Source: http://dl.sourceforge.net/sourceforge/phpldapadmin/phpldapadmin-%{version}.tgz
10    
11     Patch0: phpldapadmin-1.2.6-Koozali-config-patches.patch
12     #Patch1: phpldapadmin-1.2.6
13     #Patch2: phpldapadmin-1.2.6
14    
15     BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
16     BuildArch: noarch
17     Requires: webserver
18 jcrisp 1.3 Requires: php74
19     Requires: php74-ldap
20 jcrisp 1.1
21    
22     %description
23     PhpLDAPadmin is a web-based LDAP client.
24     It provides easy, anywhere-accessible, multi-language administration
25     for your LDAP server. Its hierarchical tree-viewer and advanced search
26     functionality make it intuitive to browse and administer your LDAP directory.
27    
28     Since it is a web application, this LDAP browser works on many platforms,
29     making your LDAP server easily manageable from any location.
30    
31     PhpLDAPadmin is the perfect LDAP browser for the LDAP professional
32     and novice alike. Its user base consists mostly of LDAP administration
33     professionals.
34    
35     This version is a fork of the original from this github repo
36     https://github.com/leenooks/phpLDAPadmin
37    
38     Edit %{_sysconfdir}/%{name}/config.php to change default (localhost) LDAP server
39     location and other things. Edit %{_sysconfdir}/httpd/conf.d/%{name}.conf to allow
40     access by remote web-clients.
41    
42    
43     %prep
44     %setup -q -n %{name}-%{version}
45    
46     cp config/config.php.example config/config.php
47    
48     %patch0 -p1
49     #%patch1 -p1
50     #%patch2 -p1
51    
52    
53     %build
54    
55     find . \( -name "*.orig" -o -name "*~" -o -name .gitignore \) -print0 | \
56     xargs -0 rm -f
57     find . -type f -print0 | xargs -0 chmod -x
58    
59    
60     %install
61     rm -rf $RPM_BUILD_ROOT
62    
63     install -d -m755 $RPM_BUILD_ROOT%{_datadir}/%{name}
64     cp -a * $RPM_BUILD_ROOT%{_datadir}/%{name}
65    
66    
67     pushd $RPM_BUILD_ROOT%{_datadir}/%{name}
68     rm -rf doc/ INSTALL LICENSE config/config.php.example
69     rm -rf tools/
70     find locale -name "*.po" -print0 | xargs -0 rm -f
71     popd
72    
73    
74     install -d -m755 $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
75    
76     mv $RPM_BUILD_ROOT%{_datadir}/%{name}/config/* \
77     $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
78     rmdir $RPM_BUILD_ROOT%{_datadir}/%{name}/config
79    
80     UPS=$(echo %{_datadir}/%{name} | sed -e 's,^/,,' -e 's,[^/]*,..,g')
81     ln -s $UPS%{_sysconfdir}/%{name} \
82     $RPM_BUILD_ROOT%{_datadir}/%{name}/config
83    
84     cat <<EOF >%{name}.conf
85     #
86     # %{summary}
87     #
88    
89     Alias /%{name} %{_datadir}/%{name}/htdocs
90     Alias /ldapadmin %{_datadir}/%{name}/htdocs
91    
92     <Directory %{_datadir}/%{name}/htdocs>
93     <IfModule mod_authz_core.c>
94     # Apache 2.4
95     Require local
96     </IfModule>
97     <IfModule !mod_authz_core.c>
98     # Apache 2.2
99     Order Deny,Allow
100     Deny from all
101     Allow from 127.0.0.1
102     Allow from ::1
103     </IfModule>
104     </Directory>
105    
106     EOF
107    
108     install -d $RPM_BUILD_ROOT%{_sysconfdir}/httpd/conf.d
109     install -m644 %{name}.conf $RPM_BUILD_ROOT%{_sysconfdir}/httpd/conf.d
110    
111    
112     %clean
113     rm -rf $RPM_BUILD_ROOT
114    
115    
116     %post
117     if [ $1 -eq 1 ]; then
118     set @@@ `dd bs=128 count=1 </dev/urandom 2>/dev/null | md5sum`
119     sed -i "/session\['blowfish'\] = null;/ {
120     s/^[^\$]*\\\$/\$/
121     s/null;/'$2'; # Autogenerated for `uname -n`/
122     }" %{_sysconfdir}/%{name}/config.php
123     fi
124    
125    
126     %files
127     %defattr(-,root,root,-)
128     %config %dir %{_sysconfdir}/%{name}
129     %attr(640,root,apache) %config(noreplace) %{_sysconfdir}/%{name}/*.php
130     %config(noreplace) %{_sysconfdir}/httpd/conf.d/*.conf
131     %{_datadir}/%{name}
132     %doc INSTALL.md LICENSE config/config.php.example
133    
134    
135     %changelog
136 jcrisp 1.3 * Thu Sep 30 2021 John Crisp <jcrisp@safeandsoundit.co.uk> - 1.2.6-3.sme
137     - Update php versions to php74 [SME: 11700]
138    
139 jcrisp 1.2 * Wed Sep 29 2021 John Crisp <jcrisp@safeandsoundit.co.uk> - 1.2.6-2.sme
140     - Fix the bug number for consistency
141     - Set requires php to 7.3
142    
143     * Tue Sep 28 2021 John Crisp <jcrisp@safeandsoundit.co.uk> - 1.2.6-1.sme
144     - Import for Koozali SME v10 [SME: 11700]
145 jcrisp 1.1
146     * Thu Nov 15 2018 John Crisp <jcrisp@safeandsoundit.co.uk> - 1.2.3.11.sme
147     - Imported as -10 to match current contrib
148     - fix missing source.tar.gz
149    
150     * Sun Jul 16 2017 Dmitry Butskoy <Dmitry@Butskoy.name> - 1.2.3-10
151     - Fix CVE-2017-11107 (#1471112)
152    
153     * Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.3-9
154     - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
155    
156     * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.3-8
157     - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
158    
159     * Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.3-7
160     - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
161    
162     * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.3-6
163     - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
164    
165     * Tue Nov 12 2013 Dmitry Butskoy <Dmitry@Butskoy.name> - 1.2.3-5
166     - Fix compatibility patch for php >= 5.5 (#974928)
167    
168     * Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.3-4
169     - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
170    
171     * Tue Jun 18 2013 Dmitry Butskoy <Dmitry@Butskoy.name> - 1.2.3-3
172     - Add compatibility patch for php >= 5.5
173    
174     * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.3-2
175     - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
176    
177     * Wed Oct 31 2012 Dmitry Butskoy <Dmitry@Butskoy.name> - 1.2.3-1
178     - update to 1.2.3
179     - fix apache config file (#871457)
180    
181     * Tue Sep 18 2012 Dmitry Butskoy <Dmitry@Butskoy.name> - 1.2.2-3.gitbbedf1
182     - update to latest git source (CVE-2012-1114, CVE-2012-1115, #799873)
183    
184     * Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.2-2
185     - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
186    
187     * Thu Feb 2 2012 Dmitry Butskoy <Dmitry@Butskoy.name> - 1.2.2-1
188     - update to 1.2.2
189     - fix CVE-2012-0834 (#786821, patch from upstream)
190    
191     * Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.1.1-3.20111006git
192     - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
193    
194     * Tue Oct 25 2011 Dmitry Butskoy <Dmitry@Butskoy.name> - 1.2.1.1-2.20111006git
195     - update to the latest git #cddf783 to fix security issues
196     (XSS and code injection vulnerabilities, #748538)
197    
198     * Fri Jul 22 2011 Dmitry Butskoy <Dmitry@Butskoy.name> - 1.2.1.1-1
199     - update to 1.2.1.1
200    
201     * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.0.5-3
202     - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
203    
204     * Thu Sep 23 2010 Dmitry Butskoy <Dmitry@Butskoy.name> - 1.2.0.5-2
205     - add patches from Patrick Monnerat <pm@datasphere.ch>:
206     * fix typo (close comment) in config file (#628067)
207     * avoid php-5.3 deprecation errors (#628061)
208     * fix add of parent class attributes (#628060)
209    
210     * Mon Mar 29 2010 Dmitry Butskoy <Dmitry@Butskoy.name> - 1.2.0.5-1
211     - update to 1.2.0.5
212    
213     * Fri Nov 20 2009 Dmitry Butskoy <Dmitry@Butskoy.name> - 1.2.0.4-1
214     - update to 1.2.0.4
215     - allow local IPv6 address by default as well (#539272)
216    
217     * Wed Sep 16 2009 Dmitry Butskoy <Dmitry@Butskoy.name> - 1.2.0.3-1
218     - Upgrade to 1.2.0.3 (#523477)
219    
220     * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0.7-2
221     - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
222    
223     * Thu Apr 9 2009 Dmitry Butskoy <Dmitry@Butskoy.name> - 1.1.0.7-1
224     - update to 1.1.0.7
225    
226     * Fri Sep 26 2008 Dmitry Butskoy <Dmitry@Butskoy.name> - 1.1.0.5-2
227     - update config patch
228    
229     * Wed Feb 13 2008 Dmitry Butskoy <Dmitry@Butskoy.name> - 1.1.0.5-1
230     - upgrade to 1.1.0.5
231    
232     * Fri Aug 17 2007 Dmitry Butskoy <Dmitry@Butskoy.name>
233     - Change License tag to GPLv2+
234     (Note: most files do not specify any license information at all,
235     which could lead just to "GPL+", but some lib/ files specify
236     "GPLv2 or any later" explicitly, hence GPLv2+ wins).
237    
238     * Tue Sep 19 2006 Dmitry Butskoy <Dmitry@Butskoy.name> - 1.0.1-1
239     - upgrade to 1.0.1
240     - drop namingcontexts patch, no more needed for php >= 5.0.6
241    
242     * Fri Sep 1 2006 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.9.8.3-2
243     - rebuild for FC6
244    
245     * Mon May 15 2006 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.9.8.3-1
246     - update to 0.9.8.3
247    
248     * Tue Mar 14 2006 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.9.8.2-1
249     - update to 0.9.8.2
250    
251     * Thu Mar 2 2006 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.9.8.1-1
252     - upgrade to 0.9.8.1
253     - remove unneeded tools dir *.po files in locale dir
254    
255     * Fri Nov 18 2005 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.9.7.2-2
256     - update upstream's tarball (was changed without version increment)
257     - don't treat VERSION as doc file (#173513)
258    
259     * Tue Nov 15 2005 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.9.7.2-1
260     - update to 0.9.7.2
261    
262     * Tue Nov 1 2005 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.9.7.1-1
263     - upgrade to 0.9.7.1
264     - adapt patches and spec to new upstream layout.
265     - don't strip debug anymore -- all seems to work fast enough now.
266    
267     * Tue Sep 27 2005 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.9.7-2
268     - patch cleanups.
269     - accepted for Fedora Extras devel
270     (review by Aurelien Bompard <gauret@free.fr>)
271    
272     * Mon Sep 26 2005 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.9.7-1
273     - upgrade to final 0.9.7
274     - strip debug stuff completely. It gives essential speedup of work.
275     - initial install allow connects from localhost only (security reasons).
276    
277     * Tue Sep 20 2005 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.9.7-0.3.rc3
278     - upgrade to 0.9.7-rc3
279     - add post script to generate blowfish secret on initial installations.
280    
281     * Thu Sep 15 2005 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.9.7-0.2.rc2
282     - upgrade to 0.9.7-rc2, cvs snapshot no more needed.
283    
284     * Tue Sep 13 2005 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.9.7-0.1.20050912
285     - initial release. CVS snapshot is one week later than 0.9.7-rc1 release.
286     - add namingcontexts patch and config patch
287    

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed