/[smecontribs]/rpms/phpldapadmin/contribs10/phpldapadmin.spec
ViewVC logotype

Annotation of /rpms/phpldapadmin/contribs10/phpldapadmin.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.4 - (hide annotations) (download)
Mon Oct 4 11:59:13 2021 UTC (2 years, 7 months ago) by brianr
Branch: MAIN
CVS Tags: phpldapadmin-1_2_6-4_el7_sme, HEAD
Changes since 1.3: +8 -3 lines
* Mon Oct 04 2021 Brian Read <brianr@bjsystems.co.uk> 1.2.6-4.sme
- Remove deps on php74 and add in AutoReqProv [SME: 11699 ]

1 jcrisp 1.1 Name: phpldapadmin
2     Summary: Web-based tool for managing LDAP servers
3     Version: 1.2.6
4 brianr 1.4 Release: 4%{?dist}
5 jcrisp 1.1 Group: Applications/Internet
6     License: GPLv2+
7     URL: http://phpldapadmin.sourceforge.net
8    
9     Source: http://dl.sourceforge.net/sourceforge/phpldapadmin/phpldapadmin-%{version}.tgz
10    
11     Patch0: phpldapadmin-1.2.6-Koozali-config-patches.patch
12     #Patch1: phpldapadmin-1.2.6
13     #Patch2: phpldapadmin-1.2.6
14    
15     BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
16     BuildArch: noarch
17     Requires: webserver
18 brianr 1.4 #Requires: php74
19     #Requires: php74-ldap
20    
21     AutoReqProv: no
22 jcrisp 1.1
23    
24     %description
25     PhpLDAPadmin is a web-based LDAP client.
26     It provides easy, anywhere-accessible, multi-language administration
27     for your LDAP server. Its hierarchical tree-viewer and advanced search
28     functionality make it intuitive to browse and administer your LDAP directory.
29    
30     Since it is a web application, this LDAP browser works on many platforms,
31     making your LDAP server easily manageable from any location.
32    
33     PhpLDAPadmin is the perfect LDAP browser for the LDAP professional
34     and novice alike. Its user base consists mostly of LDAP administration
35     professionals.
36    
37     This version is a fork of the original from this github repo
38     https://github.com/leenooks/phpLDAPadmin
39    
40     Edit %{_sysconfdir}/%{name}/config.php to change default (localhost) LDAP server
41     location and other things. Edit %{_sysconfdir}/httpd/conf.d/%{name}.conf to allow
42     access by remote web-clients.
43    
44    
45     %prep
46     %setup -q -n %{name}-%{version}
47    
48     cp config/config.php.example config/config.php
49    
50     %patch0 -p1
51     #%patch1 -p1
52     #%patch2 -p1
53    
54    
55     %build
56    
57     find . \( -name "*.orig" -o -name "*~" -o -name .gitignore \) -print0 | \
58     xargs -0 rm -f
59     find . -type f -print0 | xargs -0 chmod -x
60    
61    
62     %install
63     rm -rf $RPM_BUILD_ROOT
64    
65     install -d -m755 $RPM_BUILD_ROOT%{_datadir}/%{name}
66     cp -a * $RPM_BUILD_ROOT%{_datadir}/%{name}
67    
68    
69     pushd $RPM_BUILD_ROOT%{_datadir}/%{name}
70     rm -rf doc/ INSTALL LICENSE config/config.php.example
71     rm -rf tools/
72     find locale -name "*.po" -print0 | xargs -0 rm -f
73     popd
74    
75    
76     install -d -m755 $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
77    
78     mv $RPM_BUILD_ROOT%{_datadir}/%{name}/config/* \
79     $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
80     rmdir $RPM_BUILD_ROOT%{_datadir}/%{name}/config
81    
82     UPS=$(echo %{_datadir}/%{name} | sed -e 's,^/,,' -e 's,[^/]*,..,g')
83     ln -s $UPS%{_sysconfdir}/%{name} \
84     $RPM_BUILD_ROOT%{_datadir}/%{name}/config
85    
86     cat <<EOF >%{name}.conf
87     #
88     # %{summary}
89     #
90    
91     Alias /%{name} %{_datadir}/%{name}/htdocs
92     Alias /ldapadmin %{_datadir}/%{name}/htdocs
93    
94     <Directory %{_datadir}/%{name}/htdocs>
95     <IfModule mod_authz_core.c>
96     # Apache 2.4
97     Require local
98     </IfModule>
99     <IfModule !mod_authz_core.c>
100     # Apache 2.2
101     Order Deny,Allow
102     Deny from all
103     Allow from 127.0.0.1
104     Allow from ::1
105     </IfModule>
106     </Directory>
107    
108     EOF
109    
110     install -d $RPM_BUILD_ROOT%{_sysconfdir}/httpd/conf.d
111     install -m644 %{name}.conf $RPM_BUILD_ROOT%{_sysconfdir}/httpd/conf.d
112    
113    
114     %clean
115     rm -rf $RPM_BUILD_ROOT
116    
117    
118     %post
119     if [ $1 -eq 1 ]; then
120     set @@@ `dd bs=128 count=1 </dev/urandom 2>/dev/null | md5sum`
121     sed -i "/session\['blowfish'\] = null;/ {
122     s/^[^\$]*\\\$/\$/
123     s/null;/'$2'; # Autogenerated for `uname -n`/
124     }" %{_sysconfdir}/%{name}/config.php
125     fi
126    
127    
128     %files
129     %defattr(-,root,root,-)
130     %config %dir %{_sysconfdir}/%{name}
131     %attr(640,root,apache) %config(noreplace) %{_sysconfdir}/%{name}/*.php
132     %config(noreplace) %{_sysconfdir}/httpd/conf.d/*.conf
133     %{_datadir}/%{name}
134     %doc INSTALL.md LICENSE config/config.php.example
135    
136    
137     %changelog
138 brianr 1.4 * Mon Oct 04 2021 Brian Read <brianr@bjsystems.co.uk> 1.2.6-4.sme
139     - Remove deps on php74 and add in AutoReqProv [SME: 11699 ]
140    
141 jcrisp 1.3 * Thu Sep 30 2021 John Crisp <jcrisp@safeandsoundit.co.uk> - 1.2.6-3.sme
142     - Update php versions to php74 [SME: 11700]
143    
144 jcrisp 1.2 * Wed Sep 29 2021 John Crisp <jcrisp@safeandsoundit.co.uk> - 1.2.6-2.sme
145     - Fix the bug number for consistency
146     - Set requires php to 7.3
147    
148     * Tue Sep 28 2021 John Crisp <jcrisp@safeandsoundit.co.uk> - 1.2.6-1.sme
149     - Import for Koozali SME v10 [SME: 11700]
150 jcrisp 1.1
151     * Thu Nov 15 2018 John Crisp <jcrisp@safeandsoundit.co.uk> - 1.2.3.11.sme
152     - Imported as -10 to match current contrib
153     - fix missing source.tar.gz
154    
155     * Sun Jul 16 2017 Dmitry Butskoy <Dmitry@Butskoy.name> - 1.2.3-10
156     - Fix CVE-2017-11107 (#1471112)
157    
158     * Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.3-9
159     - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
160    
161     * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.3-8
162     - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
163    
164     * Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.3-7
165     - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
166    
167     * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.3-6
168     - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
169    
170     * Tue Nov 12 2013 Dmitry Butskoy <Dmitry@Butskoy.name> - 1.2.3-5
171     - Fix compatibility patch for php >= 5.5 (#974928)
172    
173     * Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.3-4
174     - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
175    
176     * Tue Jun 18 2013 Dmitry Butskoy <Dmitry@Butskoy.name> - 1.2.3-3
177     - Add compatibility patch for php >= 5.5
178    
179     * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.3-2
180     - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
181    
182     * Wed Oct 31 2012 Dmitry Butskoy <Dmitry@Butskoy.name> - 1.2.3-1
183     - update to 1.2.3
184     - fix apache config file (#871457)
185    
186     * Tue Sep 18 2012 Dmitry Butskoy <Dmitry@Butskoy.name> - 1.2.2-3.gitbbedf1
187     - update to latest git source (CVE-2012-1114, CVE-2012-1115, #799873)
188    
189     * Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.2-2
190     - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
191    
192     * Thu Feb 2 2012 Dmitry Butskoy <Dmitry@Butskoy.name> - 1.2.2-1
193     - update to 1.2.2
194     - fix CVE-2012-0834 (#786821, patch from upstream)
195    
196     * Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.1.1-3.20111006git
197     - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
198    
199     * Tue Oct 25 2011 Dmitry Butskoy <Dmitry@Butskoy.name> - 1.2.1.1-2.20111006git
200     - update to the latest git #cddf783 to fix security issues
201     (XSS and code injection vulnerabilities, #748538)
202    
203     * Fri Jul 22 2011 Dmitry Butskoy <Dmitry@Butskoy.name> - 1.2.1.1-1
204     - update to 1.2.1.1
205    
206     * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.0.5-3
207     - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
208    
209     * Thu Sep 23 2010 Dmitry Butskoy <Dmitry@Butskoy.name> - 1.2.0.5-2
210     - add patches from Patrick Monnerat <pm@datasphere.ch>:
211     * fix typo (close comment) in config file (#628067)
212     * avoid php-5.3 deprecation errors (#628061)
213     * fix add of parent class attributes (#628060)
214    
215     * Mon Mar 29 2010 Dmitry Butskoy <Dmitry@Butskoy.name> - 1.2.0.5-1
216     - update to 1.2.0.5
217    
218     * Fri Nov 20 2009 Dmitry Butskoy <Dmitry@Butskoy.name> - 1.2.0.4-1
219     - update to 1.2.0.4
220     - allow local IPv6 address by default as well (#539272)
221    
222     * Wed Sep 16 2009 Dmitry Butskoy <Dmitry@Butskoy.name> - 1.2.0.3-1
223     - Upgrade to 1.2.0.3 (#523477)
224    
225     * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0.7-2
226     - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
227    
228     * Thu Apr 9 2009 Dmitry Butskoy <Dmitry@Butskoy.name> - 1.1.0.7-1
229     - update to 1.1.0.7
230    
231     * Fri Sep 26 2008 Dmitry Butskoy <Dmitry@Butskoy.name> - 1.1.0.5-2
232     - update config patch
233    
234     * Wed Feb 13 2008 Dmitry Butskoy <Dmitry@Butskoy.name> - 1.1.0.5-1
235     - upgrade to 1.1.0.5
236    
237     * Fri Aug 17 2007 Dmitry Butskoy <Dmitry@Butskoy.name>
238     - Change License tag to GPLv2+
239     (Note: most files do not specify any license information at all,
240     which could lead just to "GPL+", but some lib/ files specify
241     "GPLv2 or any later" explicitly, hence GPLv2+ wins).
242    
243     * Tue Sep 19 2006 Dmitry Butskoy <Dmitry@Butskoy.name> - 1.0.1-1
244     - upgrade to 1.0.1
245     - drop namingcontexts patch, no more needed for php >= 5.0.6
246    
247     * Fri Sep 1 2006 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.9.8.3-2
248     - rebuild for FC6
249    
250     * Mon May 15 2006 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.9.8.3-1
251     - update to 0.9.8.3
252    
253     * Tue Mar 14 2006 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.9.8.2-1
254     - update to 0.9.8.2
255    
256     * Thu Mar 2 2006 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.9.8.1-1
257     - upgrade to 0.9.8.1
258     - remove unneeded tools dir *.po files in locale dir
259    
260     * Fri Nov 18 2005 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.9.7.2-2
261     - update upstream's tarball (was changed without version increment)
262     - don't treat VERSION as doc file (#173513)
263    
264     * Tue Nov 15 2005 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.9.7.2-1
265     - update to 0.9.7.2
266    
267     * Tue Nov 1 2005 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.9.7.1-1
268     - upgrade to 0.9.7.1
269     - adapt patches and spec to new upstream layout.
270     - don't strip debug anymore -- all seems to work fast enough now.
271    
272     * Tue Sep 27 2005 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.9.7-2
273     - patch cleanups.
274     - accepted for Fedora Extras devel
275     (review by Aurelien Bompard <gauret@free.fr>)
276    
277     * Mon Sep 26 2005 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.9.7-1
278     - upgrade to final 0.9.7
279     - strip debug stuff completely. It gives essential speedup of work.
280     - initial install allow connects from localhost only (security reasons).
281    
282     * Tue Sep 20 2005 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.9.7-0.3.rc3
283     - upgrade to 0.9.7-rc3
284     - add post script to generate blowfish secret on initial installations.
285    
286     * Thu Sep 15 2005 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.9.7-0.2.rc2
287     - upgrade to 0.9.7-rc2, cvs snapshot no more needed.
288    
289     * Tue Sep 13 2005 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.9.7-0.1.20050912
290     - initial release. CVS snapshot is one week later than 0.9.7-rc1 release.
291     - add namingcontexts patch and config patch
292    

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed