1 |
jcrisp |
1.1 |
|
2 |
|
|
Name: phpldapadmin |
3 |
|
|
Summary: Web-based tool for managing LDAP servers |
4 |
|
|
Version: 1.2.3 |
5 |
jcrisp |
1.2 |
Release: 11%{?dist} |
6 |
jcrisp |
1.1 |
Group: Applications/Internet |
7 |
|
|
License: GPLv2+ |
8 |
|
|
URL: http://phpldapadmin.sourceforge.net |
9 |
|
|
|
10 |
|
|
Source: http://dl.sourceforge.net/sourceforge/phpldapadmin/phpldapadmin-%{version}.tgz |
11 |
|
|
|
12 |
|
|
Patch0: phpldapadmin-1.2.3-config.patch |
13 |
|
|
Patch1: phpldapadmin-1.2.3-php5_5.patch |
14 |
|
|
Patch2: phpldapadmin-1.2.3-entry_chooser.patch |
15 |
|
|
|
16 |
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) |
17 |
|
|
BuildArch: noarch |
18 |
|
|
Requires: webserver, php >= 5.0.6, php-ldap |
19 |
|
|
|
20 |
|
|
|
21 |
|
|
%description |
22 |
|
|
PhpLDAPadmin is a web-based LDAP client. |
23 |
|
|
It provides easy, anywhere-accessible, multi-language administration |
24 |
|
|
for your LDAP server. Its hierarchical tree-viewer and advanced search |
25 |
|
|
functionality make it intuitive to browse and administer your LDAP directory. |
26 |
|
|
|
27 |
|
|
Since it is a web application, this LDAP browser works on many platforms, |
28 |
|
|
making your LDAP server easily manageable from any location. |
29 |
|
|
|
30 |
|
|
PhpLDAPadmin is the perfect LDAP browser for the LDAP professional |
31 |
|
|
and novice alike. Its user base consists mostly of LDAP administration |
32 |
|
|
professionals. |
33 |
|
|
|
34 |
|
|
Edit %{_sysconfdir}/%{name}/config.php to change default (localhost) LDAP server |
35 |
|
|
location and other things. Edit %{_sysconfdir}/httpd/conf.d/%{name}.conf to allow |
36 |
|
|
access by remote web-clients. |
37 |
|
|
|
38 |
|
|
|
39 |
|
|
%prep |
40 |
|
|
%setup -q -n %{name}-%{version} |
41 |
|
|
|
42 |
|
|
cp config/config.php.example config/config.php |
43 |
|
|
|
44 |
|
|
%patch0 -p1 |
45 |
|
|
%patch1 -p1 |
46 |
|
|
%patch2 -p1 |
47 |
|
|
|
48 |
|
|
|
49 |
|
|
%build |
50 |
|
|
|
51 |
|
|
find . \( -name "*.orig" -o -name "*~" -o -name .gitignore \) -print0 | \ |
52 |
|
|
xargs -0 rm -f |
53 |
|
|
find . -type f -print0 | xargs -0 chmod -x |
54 |
|
|
|
55 |
|
|
|
56 |
|
|
%install |
57 |
|
|
rm -rf $RPM_BUILD_ROOT |
58 |
|
|
|
59 |
|
|
install -d -m755 $RPM_BUILD_ROOT%{_datadir}/%{name} |
60 |
|
|
cp -a * $RPM_BUILD_ROOT%{_datadir}/%{name} |
61 |
|
|
|
62 |
|
|
|
63 |
|
|
pushd $RPM_BUILD_ROOT%{_datadir}/%{name} |
64 |
|
|
rm -rf doc/ INSTALL LICENSE config/config.php.example |
65 |
|
|
rm -rf tools/ |
66 |
|
|
find locale -name "*.po" -print0 | xargs -0 rm -f |
67 |
|
|
popd |
68 |
|
|
|
69 |
|
|
|
70 |
|
|
install -d -m755 $RPM_BUILD_ROOT%{_sysconfdir}/%{name} |
71 |
|
|
|
72 |
|
|
mv $RPM_BUILD_ROOT%{_datadir}/%{name}/config/* \ |
73 |
|
|
$RPM_BUILD_ROOT%{_sysconfdir}/%{name} |
74 |
|
|
rmdir $RPM_BUILD_ROOT%{_datadir}/%{name}/config |
75 |
|
|
|
76 |
|
|
UPS=$(echo %{_datadir}/%{name} | sed -e 's,^/,,' -e 's,[^/]*,..,g') |
77 |
|
|
ln -s $UPS%{_sysconfdir}/%{name} \ |
78 |
|
|
$RPM_BUILD_ROOT%{_datadir}/%{name}/config |
79 |
|
|
|
80 |
|
|
cat <<EOF >%{name}.conf |
81 |
|
|
# |
82 |
|
|
# %{summary} |
83 |
|
|
# |
84 |
|
|
|
85 |
|
|
Alias /%{name} %{_datadir}/%{name}/htdocs |
86 |
|
|
Alias /ldapadmin %{_datadir}/%{name}/htdocs |
87 |
|
|
|
88 |
|
|
<Directory %{_datadir}/%{name}/htdocs> |
89 |
|
|
<IfModule mod_authz_core.c> |
90 |
|
|
# Apache 2.4 |
91 |
|
|
Require local |
92 |
|
|
</IfModule> |
93 |
|
|
<IfModule !mod_authz_core.c> |
94 |
|
|
# Apache 2.2 |
95 |
|
|
Order Deny,Allow |
96 |
|
|
Deny from all |
97 |
|
|
Allow from 127.0.0.1 |
98 |
|
|
Allow from ::1 |
99 |
|
|
</IfModule> |
100 |
|
|
</Directory> |
101 |
|
|
|
102 |
|
|
EOF |
103 |
|
|
|
104 |
|
|
install -d $RPM_BUILD_ROOT%{_sysconfdir}/httpd/conf.d |
105 |
|
|
install -m644 %{name}.conf $RPM_BUILD_ROOT%{_sysconfdir}/httpd/conf.d |
106 |
|
|
|
107 |
|
|
|
108 |
|
|
%clean |
109 |
|
|
rm -rf $RPM_BUILD_ROOT |
110 |
|
|
|
111 |
|
|
|
112 |
|
|
%post |
113 |
|
|
if [ $1 -eq 1 ]; then |
114 |
|
|
set @@@ `dd bs=128 count=1 </dev/urandom 2>/dev/null | md5sum` |
115 |
|
|
sed -i "/session\['blowfish'\] = null;/ { |
116 |
|
|
s/^[^\$]*\\\$/\$/ |
117 |
|
|
s/null;/'$2'; # Autogenerated for `uname -n`/ |
118 |
|
|
}" %{_sysconfdir}/%{name}/config.php |
119 |
|
|
fi |
120 |
|
|
|
121 |
|
|
|
122 |
|
|
%files |
123 |
|
|
%defattr(-,root,root,-) |
124 |
|
|
%config %dir %{_sysconfdir}/%{name} |
125 |
|
|
%attr(640,root,apache) %config(noreplace) %{_sysconfdir}/%{name}/*.php |
126 |
|
|
%config(noreplace) %{_sysconfdir}/httpd/conf.d/*.conf |
127 |
|
|
%{_datadir}/%{name} |
128 |
|
|
%doc INSTALL LICENSE config/config.php.example |
129 |
|
|
|
130 |
|
|
|
131 |
|
|
%changelog |
132 |
jcrisp |
1.2 |
* Thu Nov 15 2018 John Crisp <jcrisp@safeandsoundit.co.uk> - 1.2.3.11.sme |
133 |
|
|
- Imported as -10 to match current contrib |
134 |
|
|
- fix missing source.tar.gz |
135 |
|
|
|
136 |
jcrisp |
1.1 |
* Sun Jul 16 2017 Dmitry Butskoy <Dmitry@Butskoy.name> - 1.2.3-10 |
137 |
|
|
- Fix CVE-2017-11107 (#1471112) |
138 |
|
|
|
139 |
|
|
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.3-9 |
140 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild |
141 |
|
|
|
142 |
|
|
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.3-8 |
143 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild |
144 |
|
|
|
145 |
|
|
* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.3-7 |
146 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild |
147 |
|
|
|
148 |
|
|
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.3-6 |
149 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild |
150 |
|
|
|
151 |
|
|
* Tue Nov 12 2013 Dmitry Butskoy <Dmitry@Butskoy.name> - 1.2.3-5 |
152 |
|
|
- Fix compatibility patch for php >= 5.5 (#974928) |
153 |
|
|
|
154 |
|
|
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.3-4 |
155 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild |
156 |
|
|
|
157 |
|
|
* Tue Jun 18 2013 Dmitry Butskoy <Dmitry@Butskoy.name> - 1.2.3-3 |
158 |
|
|
- Add compatibility patch for php >= 5.5 |
159 |
|
|
|
160 |
|
|
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.3-2 |
161 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild |
162 |
|
|
|
163 |
|
|
* Wed Oct 31 2012 Dmitry Butskoy <Dmitry@Butskoy.name> - 1.2.3-1 |
164 |
|
|
- update to 1.2.3 |
165 |
|
|
- fix apache config file (#871457) |
166 |
|
|
|
167 |
|
|
* Tue Sep 18 2012 Dmitry Butskoy <Dmitry@Butskoy.name> - 1.2.2-3.gitbbedf1 |
168 |
|
|
- update to latest git source (CVE-2012-1114, CVE-2012-1115, #799873) |
169 |
|
|
|
170 |
|
|
* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.2-2 |
171 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild |
172 |
|
|
|
173 |
|
|
* Thu Feb 2 2012 Dmitry Butskoy <Dmitry@Butskoy.name> - 1.2.2-1 |
174 |
|
|
- update to 1.2.2 |
175 |
|
|
- fix CVE-2012-0834 (#786821, patch from upstream) |
176 |
|
|
|
177 |
|
|
* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.1.1-3.20111006git |
178 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild |
179 |
|
|
|
180 |
|
|
* Tue Oct 25 2011 Dmitry Butskoy <Dmitry@Butskoy.name> - 1.2.1.1-2.20111006git |
181 |
|
|
- update to the latest git #cddf783 to fix security issues |
182 |
|
|
(XSS and code injection vulnerabilities, #748538) |
183 |
|
|
|
184 |
|
|
* Fri Jul 22 2011 Dmitry Butskoy <Dmitry@Butskoy.name> - 1.2.1.1-1 |
185 |
|
|
- update to 1.2.1.1 |
186 |
|
|
|
187 |
|
|
* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.0.5-3 |
188 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild |
189 |
|
|
|
190 |
|
|
* Thu Sep 23 2010 Dmitry Butskoy <Dmitry@Butskoy.name> - 1.2.0.5-2 |
191 |
|
|
- add patches from Patrick Monnerat <pm@datasphere.ch>: |
192 |
|
|
* fix typo (close comment) in config file (#628067) |
193 |
|
|
* avoid php-5.3 deprecation errors (#628061) |
194 |
|
|
* fix add of parent class attributes (#628060) |
195 |
|
|
|
196 |
|
|
* Mon Mar 29 2010 Dmitry Butskoy <Dmitry@Butskoy.name> - 1.2.0.5-1 |
197 |
|
|
- update to 1.2.0.5 |
198 |
|
|
|
199 |
|
|
* Fri Nov 20 2009 Dmitry Butskoy <Dmitry@Butskoy.name> - 1.2.0.4-1 |
200 |
|
|
- update to 1.2.0.4 |
201 |
|
|
- allow local IPv6 address by default as well (#539272) |
202 |
|
|
|
203 |
|
|
* Wed Sep 16 2009 Dmitry Butskoy <Dmitry@Butskoy.name> - 1.2.0.3-1 |
204 |
|
|
- Upgrade to 1.2.0.3 (#523477) |
205 |
|
|
|
206 |
|
|
* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0.7-2 |
207 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild |
208 |
|
|
|
209 |
|
|
* Thu Apr 9 2009 Dmitry Butskoy <Dmitry@Butskoy.name> - 1.1.0.7-1 |
210 |
|
|
- update to 1.1.0.7 |
211 |
|
|
|
212 |
|
|
* Fri Sep 26 2008 Dmitry Butskoy <Dmitry@Butskoy.name> - 1.1.0.5-2 |
213 |
|
|
- update config patch |
214 |
|
|
|
215 |
|
|
* Wed Feb 13 2008 Dmitry Butskoy <Dmitry@Butskoy.name> - 1.1.0.5-1 |
216 |
|
|
- upgrade to 1.1.0.5 |
217 |
|
|
|
218 |
|
|
* Fri Aug 17 2007 Dmitry Butskoy <Dmitry@Butskoy.name> |
219 |
|
|
- Change License tag to GPLv2+ |
220 |
|
|
(Note: most files do not specify any license information at all, |
221 |
|
|
which could lead just to "GPL+", but some lib/ files specify |
222 |
|
|
"GPLv2 or any later" explicitly, hence GPLv2+ wins). |
223 |
|
|
|
224 |
|
|
* Tue Sep 19 2006 Dmitry Butskoy <Dmitry@Butskoy.name> - 1.0.1-1 |
225 |
|
|
- upgrade to 1.0.1 |
226 |
|
|
- drop namingcontexts patch, no more needed for php >= 5.0.6 |
227 |
|
|
|
228 |
|
|
* Fri Sep 1 2006 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.9.8.3-2 |
229 |
|
|
- rebuild for FC6 |
230 |
|
|
|
231 |
|
|
* Mon May 15 2006 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.9.8.3-1 |
232 |
|
|
- update to 0.9.8.3 |
233 |
|
|
|
234 |
|
|
* Tue Mar 14 2006 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.9.8.2-1 |
235 |
|
|
- update to 0.9.8.2 |
236 |
|
|
|
237 |
|
|
* Thu Mar 2 2006 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.9.8.1-1 |
238 |
|
|
- upgrade to 0.9.8.1 |
239 |
|
|
- remove unneeded tools dir *.po files in locale dir |
240 |
|
|
|
241 |
|
|
* Fri Nov 18 2005 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.9.7.2-2 |
242 |
|
|
- update upstream's tarball (was changed without version increment) |
243 |
|
|
- don't treat VERSION as doc file (#173513) |
244 |
|
|
|
245 |
|
|
* Tue Nov 15 2005 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.9.7.2-1 |
246 |
|
|
- update to 0.9.7.2 |
247 |
|
|
|
248 |
|
|
* Tue Nov 1 2005 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.9.7.1-1 |
249 |
|
|
- upgrade to 0.9.7.1 |
250 |
|
|
- adapt patches and spec to new upstream layout. |
251 |
|
|
- don't strip debug anymore -- all seems to work fast enough now. |
252 |
|
|
|
253 |
|
|
* Tue Sep 27 2005 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.9.7-2 |
254 |
|
|
- patch cleanups. |
255 |
|
|
- accepted for Fedora Extras devel |
256 |
|
|
(review by Aurelien Bompard <gauret@free.fr>) |
257 |
|
|
|
258 |
|
|
* Mon Sep 26 2005 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.9.7-1 |
259 |
|
|
- upgrade to final 0.9.7 |
260 |
|
|
- strip debug stuff completely. It gives essential speedup of work. |
261 |
|
|
- initial install allow connects from localhost only (security reasons). |
262 |
|
|
|
263 |
|
|
* Tue Sep 20 2005 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.9.7-0.3.rc3 |
264 |
|
|
- upgrade to 0.9.7-rc3 |
265 |
|
|
- add post script to generate blowfish secret on initial installations. |
266 |
|
|
|
267 |
|
|
* Thu Sep 15 2005 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.9.7-0.2.rc2 |
268 |
|
|
- upgrade to 0.9.7-rc2, cvs snapshot no more needed. |
269 |
|
|
|
270 |
|
|
* Tue Sep 13 2005 Dmitry Butskoy <Dmitry@Butskoy.name> - 0.9.7-0.1.20050912 |
271 |
|
|
- initial release. CVS snapshot is one week later than 0.9.7-rc1 release. |
272 |
|
|
- add namingcontexts patch and config patch |
273 |
|
|
|