1 |
unnilennium |
1.1 |
%define name phpvirtualbox |
2 |
|
|
%define version 4.3.0 |
3 |
|
|
%define release 8 |
4 |
|
|
%define rpmver 4.3.0 |
5 |
|
|
Summary: smserver rpm to install phpvirtualbox |
6 |
|
|
Name: %{name} |
7 |
|
|
Version: %{version} |
8 |
|
|
Release: %{release}%{?dist} |
9 |
|
|
Source: %{name}-%{version}.tar.gz |
10 |
|
|
Patch0: phpvirtualbox-remove-webauth.patch |
11 |
|
|
License: GNU GPL version 2 |
12 |
|
|
URL: http://mirror.de-labrusse.fr |
13 |
|
|
Group: SMEserver/addon |
14 |
|
|
BuildRoot: %{_tmppath}/%{name}-buildroot |
15 |
|
|
Prefix: %{_prefix} |
16 |
|
|
BuildArchitectures: noarch |
17 |
|
|
BuildRequires: e-smith-devtools |
18 |
|
|
Requires: e-smith-release >= 8.0 |
19 |
|
|
AutoReqProv: no |
20 |
|
|
|
21 |
|
|
%description |
22 |
|
|
smserver rpm to install phpvirtualbox |
23 |
|
|
|
24 |
|
|
%changelog |
25 |
|
|
* Mon Dec 30 2013 JP Pialasse <tests@pialasse.com> 4.3.0-8.sme |
26 |
|
|
- prepare rpm to import into buildsys |
27 |
|
|
|
28 |
|
|
* Fri Dec 13 2013 stephane de labrusse <stephdl@de-labrusse.fr> 4.3.7 |
29 |
|
|
- remove the web authentication for the buildin phpvirtualbox authentication |
30 |
|
|
|
31 |
|
|
* Tue Nov 05 2013 stephane de labrusse <stephdl@de-labrusse.fr> 4.3.6 |
32 |
|
|
- change name to match the phpvirtualbox version |
33 |
|
|
* Sat Oct 26 2013 stephane de labrusse <stephdl@de-labrusse.fr> 4.3.5 |
34 |
|
|
- add webauth to setting and "sme admin" as "phpvirtualbox admin" |
35 |
|
|
* Wed Oct 23 2013 stephane de labrusse <stephdl@de-labrusse.fr> 4.3.4 |
36 |
|
|
- Minor adjustment settings |
37 |
|
|
* Sat Oct 19 2013 stephane de labrusse <stephdl@de-labrusse.fr> 4.3.3 |
38 |
|
|
- Initial release |
39 |
|
|
|
40 |
|
|
%prep |
41 |
|
|
%setup |
42 |
|
|
%patch0 -p1 |
43 |
|
|
%build |
44 |
|
|
|
45 |
|
|
%install |
46 |
|
|
rm -rf $RPM_BUILD_ROOT |
47 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
48 |
|
|
rm -f %{name}-%{version}-filelist |
49 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
50 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
51 |
|
|
|
52 |
|
|
%clean |
53 |
|
|
cd .. |
54 |
|
|
rm -rf %{name}-%{version} |
55 |
|
|
|
56 |
|
|
%pre |
57 |
|
|
if [ $1 = 2 ] ; then |
58 |
|
|
/bin/cp /opt/phpvirtualbox/config.php /opt/phpvirtualbox/config.php-your-backup-`date +%Y-%m-%d-%H-%M` |
59 |
|
|
fi |
60 |
|
|
%preun |
61 |
|
|
|
62 |
|
|
%post |
63 |
|
|
|
64 |
|
|
|
65 |
|
|
|
66 |
|
|
%postun |
67 |
|
|
#uninstall |
68 |
|
|
|
69 |
|
|
%files -f %{name}-%{version}-filelist |
70 |
|
|
%defattr(-,root,root) |
71 |
|
|
|