/[smecontribs]/rpms/plague/contribs7/plague.spec
ViewVC logotype

Annotation of /rpms/plague/contribs7/plague.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.2 - (hide annotations) (download)
Wed Apr 2 15:03:56 2008 UTC (16 years, 6 months ago) by slords
Branch: MAIN
Changes since 1.1: +4 -0 lines
Add Id, Authority, Name

1 slords 1.2 # $Id$
2     # Authority: slords
3     # Name: Shad L. Lords
4    
5 slords 1.1 BuildArch: noarch
6    
7     Summary: Distributed build system for RPMs
8     Name: plague
9     Version: 0.4.4.1
10     Release: 10%{?dist}
11     License: GPL
12     Group: Development/Tools
13     Source: http://fedoraproject.org/projects/plague/releases/%{name}-%{version}.tar.bz2
14     URL: http://www.fedoraproject.org/wiki/Projects/Plague
15     BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
16     Requires: createrepo >= 0.4.3
17     Requires: %{name}-common = %{version}-%{release}
18     Requires(post): /sbin/chkconfig
19     Requires(post): /sbin/service
20     Requires(preun): /sbin/chkconfig
21     Requires(preun): /sbin/service
22    
23     Patch0: plague-0.4-daemonize.patch
24     Patch1: plague-0.4-py25.patch
25     Patch2: plague-0.4.4.1-authed.patch
26     Patch3: plague-0.4.4.1-srpm-umask.patch
27     Patch4: plague-0.4.4.1-etc.patch
28     Patch5: plague-0.4.4.1-pause.patch
29     Patch6: plague-0.4.4.1-racecondition.patch
30     Patch7: plague-0.4.4.1-preperrormsg.patch
31     Patch8: plague-0.4.4.1-kill.patch
32     #Patch9: plague-0.4.4.1-mock-0.8.patch
33     Patch10: plague-0.4.4.1-update-builders.patch
34     Patch11: plague-0.4.4.1-filedownloader.patch
35     Patch12: plague-0.4.4.1-faster-downloads.patch
36     Patch13: plague-0.4.4.1-buildsys-fixes.patch
37     Patch14: plague-0.4.4.1-repolock.patch
38     Patch15: plague-0.4.4.1-repoadd.patch
39     Patch100: plague-0.4.4.1-pushscript-extras.patch
40    
41    
42     %description
43     The Plague build system is a client/server distributed build system for
44     building RPM packages. This package provides the plague server.
45    
46    
47     %package common
48     Summary: Common resources for the Plague build system
49     Group: Development/Tools
50     Requires: pyOpenSSL
51    
52     %description common
53     This package includes the common Python module that all Plague services require.
54    
55    
56     %package builder
57     Summary: Builder daemon for Plague builder slaves
58     Group: Development/Tools
59     Requires: %{name}-common = %{version}-%{release}
60     Requires: yum >= 2.2.1, mock < 0.8
61     Requires(post): /sbin/chkconfig
62     Requires(post): /sbin/service
63     Requires(preun): /sbin/chkconfig
64     Requires(preun): /sbin/service
65     Requires(pre): /usr/sbin/useradd
66    
67     %description builder
68     The Plague builder does the actual RPM package building on slave machines.
69    
70     %package client
71     Summary: Package queueing client for the Plague build system
72     Group: Development/Tools
73     Requires: %{name}-common = %{version}-%{release}
74    
75     %description client
76     Client program for enqueueing package builds and interrogating the build system.
77    
78    
79     %package utils
80     Summary: Utility programs for the Plague build system
81     Group: Development/Tools
82     Requires: %{name}-common = %{version}-%{release}
83    
84     %description utils
85     This package includes user utilities for the Plague build system, including
86     the interface to the build server.
87    
88    
89     %prep
90     %setup -q
91     %patch0 -p0 -b .umask
92     %patch1 -p1 -b .py25
93     %patch2 -p1 -b .authed
94     %patch3 -p1 -b .srpm-umask
95     %patch4 -p1 -b .etc
96     %patch5 -p1 -b .pause
97     %patch6 -p1 -b .racecondition
98     %patch7 -p1 -b .preperrormsg
99     %patch8 -p1 -b .kill
100     #patch9 -p1 -b .mock8
101     %patch10 -p1 -b .update-builders
102     %patch11 -p1 -b .filedownloader
103     %patch12 -p1 -b .faster-downloads
104     %patch13 -p1 -b .buildsys-fixes
105     %patch14 -p1 -b .repolock
106     %patch15 -p1 -b .repoadd
107     %patch100 -p1 -b .pushscript-extras
108    
109    
110     %build
111     make
112    
113    
114     %install
115     rm -rf $RPM_BUILD_ROOT
116     make DESTDIR=$RPM_BUILD_ROOT install
117     install -D -m 0644 etc/plague-builder.config $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/%{name}-builder
118     install -D -m 0755 etc/plague-builder.init $RPM_BUILD_ROOT%{_initrddir}/%{name}-builder
119     install -D -m 0644 etc/plague-server.config $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/%{name}-server
120     install -D -m 0755 etc/plague-server.init $RPM_BUILD_ROOT%{_initrddir}/%{name}-server
121     mkdir -p $RPM_BUILD_ROOT/srv/plague_builder
122    
123    
124     %clean
125     rm -rf $RPM_BUILD_ROOT
126    
127    
128     %post
129     /sbin/chkconfig --add plague-server
130     /sbin/service plague-server condrestart >> /dev/null || :
131    
132     %preun
133     if [ $1 = 0 ]; then
134     /sbin/service plague-server stop &> /dev/null
135     /sbin/chkconfig --del plague-server
136     fi
137    
138     %pre builder
139     /usr/sbin/useradd -G mock -s /sbin/nologin -M -r -d /srv/plague_builder plague-builder 2>/dev/null || :
140    
141     %post builder
142     /sbin/chkconfig --add plague-builder
143     /sbin/service plague-builder condrestart >> /dev/null || :
144    
145     %preun builder
146     if [ $1 = 0 ]; then
147     /sbin/service plague-builder stop &> /dev/null
148     /sbin/chkconfig --del plague-builder
149     fi
150    
151     %files
152     %defattr(-, root, root)
153     %{_bindir}/%{name}-server
154     %dir %{_datadir}/%{name}/server
155     %{_datadir}/%{name}/server/*.py*
156     %dir %{_sysconfdir}/%{name}/server
157     %dir %{_sysconfdir}/%{name}/server/certs
158     %config(noreplace) %{_sysconfdir}/sysconfig/%{name}-server
159     %{_initrddir}/%{name}-server
160    
161     %files common
162     %defattr(-, root, root)
163     %doc README ChangeLog
164     %dir %{_sysconfdir}/%{name}
165     %dir %{_datadir}/%{name}
166     %dir /usr/lib/python?.?/site-packages/%{name}
167     /usr/lib/python?.?/site-packages/%{name}/*.py*
168    
169     %files builder
170     %defattr(-, root, root)
171     %{_bindir}/%{name}-builder
172     %dir %{_datadir}/%{name}/builder
173     %{_datadir}/%{name}/builder/*.py*
174     %dir %{_sysconfdir}/%{name}/builder
175     %dir %{_sysconfdir}/%{name}/builder/certs
176     %config(noreplace) %{_sysconfdir}/sysconfig/%{name}-builder
177     %{_initrddir}/%{name}-builder
178     %attr(0755, plague-builder, plague-builder) /srv/plague_builder
179    
180     %files client
181     %defattr(-, root, root)
182     %{_bindir}/%{name}-client
183    
184     %files utils
185     %defattr(-, root, root)
186     %{_bindir}/%{name}-user-manager.py*
187     %{_bindir}/%{name}-certhelper.py*
188    
189    
190     %changelog
191     * Fri Jan 18 2008 Michael Schwendt <mschwendt@users.sf.net> - 0.4.4.1-10.el4
192     - Patch add_to_repo stage.
193    
194     * Wed Jan 9 2008 Michael Schwendt <mschwendt@users.sf.net> - 0.4.4.1-9.el4
195     - Updated etc/ patch.
196     - Disable mock 0.8 patch since EPEL4 includes mock 0.7.
197    
198     * Sat Jan 5 2008 Michael Schwendt <mschwendt@users.sf.net> - 0.4.4.1-8.el5
199     - Add patches: repolock, filedownloader, faster downloads
200     - Merged post-0.4.4.1 patches from buildsys.fedoraproject.org server
201     - Merge the jobs db cleanup (in this form it is specific to Extras/EPEL
202     buildsys and disables the "finish" command)
203    
204     * Wed Dec 26 2007 Michael Schwendt <mschwendt@users.sf.net> - 0.4.4.1-7.el5
205     - Fix update_builders command for non-admin users.
206    
207     * Wed Nov 14 2007 Michael Schwendt <mschwendt@users.sf.net> - 0.4.4.1-6.el5
208     - Add patches for bug-fixes and mock 0.8 support.
209    
210     * Tue Sep 18 2007 Michael Schwendt <mschwendt@users.sf.net> - 0.4.4.1-5
211     - Add dirs /etc/plague and /usr/share/plague to plague-common
212     since "plague-builder" and "plague" use them (#233904).
213    
214     * Fri Dec 15 2006 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.4.4.1-4
215     - Small fix for a change in python 2.5's xmlrpc library. The patch has been
216     upstreamed.
217    
218     * Thu Dec 14 2006 Jason L Tibbitts III <tibbs@math.uh.edu> - 0.4.4.1-3
219     - Rebuild for new Python
220    
221     * Thu Sep 14 2006 Dennis Gilmore <dennis@ausil.us> 0.4.4.0-2
222     - add patch for bad umask setting
223    
224     * Mon Mar 13 2006 Dan Williams <dcbw@redhat.com> 0.4.4.1-1
225     - Update to 0.4.4.1
226     - Fix createrepo dep to >= 0.4.3 (#rh170531)
227    
228     * Sun Mar 12 2006 Dan Williams <dcbw@redhat.com> 0.4.4-1
229     - Update to 0.4.4 release
230     - Don't use pyOpenSSL's sendall() call, but simulate it to achieve
231     timeouts, better error handling, and more efficient CPU usage
232     - Fix up initscripts and lifecycle management
233     - Implement a TERM handler in server & builder for clean shutdown
234     - Ensure jobs don't hang around on builders if they get left there for
235     some reason (ie, server didn't unlock repo for the job)
236     - Make Additional Package Arches really work (kmod support)
237     - Own /usr/lib/python?.?/site-packages/plague (#rh172794#)
238     - Require createrepo >= 4.3 (#rh170531#)
239    
240     * Tue Jan 24 2006 Dan Williams <dcbw@redhat.com> 0.4.3-6
241     - Increase build server builder thread sleep time to work around SSL issues
242     - Spawn mock in a new process group, and when killing jobs kill the entire
243     process group. Hopefully fix orphaned rpmbuild processes on job kill
244    
245     * Mon Jan 23 2006 Dan Williams <dcbw@redhat.com> 0.4.3-5
246     - Restore builder connection timeout
247    
248     * Mon Jan 23 2006 Dan Williams <dcbw@redhat.com> 0.4.3-4
249     - Revert SSL fixes from last build
250    
251     * Sun Jan 22 2006 Dan Williams <dcbw@redhat.com> 0.4.3-3
252     - Don't traceback when killing jobs on builders
253     - Work around SSL hanging issues
254    
255     * Tue Nov 29 2005 Dan Williams <dcbw@redhat.com> 0.4.3-2
256     - Move README and ChangeLog to -common package
257     - Traceback/debug functionality added in server, depends on
258     threadframe module from elsewhere. Disabled by default.
259    
260     * Thu Nov 24 2005 Dan Williams <dcbw@redhat.com> 0.4.3-1
261     - Add socket timeouts for fileserver and xmlrpc bits
262    
263     * Fri Nov 18 2005 Dan Williams <dcbw@redhat.com> 0.4.2-7
264     - Suspend builders on hard errors such as running out of disk space
265     - Retry downloads from server/builder 5 times, not 3
266     - Log retried downloads on the server
267     - Add socket timeouts to downloads to work around hanging issues
268     when downloading from the builder (the downloading/done issue)
269    
270     * Tue Nov 15 2005 Dan Williams <dcbw@redhat.com> 0.4.2-5
271     - Log kill requests on the server
272    
273     * Mon Nov 14 2005 Dan Williams <dcbw@redhat.com> 0.4.2-4
274     - In the builder, close files we open before exec-ing the
275     child process. Fixes massive file descriptor leaks.
276    
277     * Sun Nov 13 2005 Dan Williams <dcbw@redhat.com> 0.4.2-3
278     - Hopefully fix builds not moving past downloading/done
279     - Immediately kill jobs in the 'waiting' state when requested
280     - Utilize pthread_sigmask python module, if present, on Python
281     2.3 and earlier to work around signal blocking issues in
282     Python
283    
284     * Tue Nov 1 2005 Dan Williams <dcbw@redhat.com> 0.4.2-2
285     - Make builders retry downloads from the server up to 3 times
286    
287     * Tue Nov 1 2005 Dan Williams <dcbw@redhat.com> 0.4.2-1
288     - Fix job download from the builders
289     - Fix RPM copy to the repository on the server
290    
291     * Mon Oct 31 2005 Dan Williams <dcbw@redhat.com> 0.4.1-1
292     - Fail jobs on restart if we can't access the original SRPM
293     - For the server, honor config file location passed in on
294     the command line (Jeff Sheltren)
295     - Catch another mock failure case (Alexandr Kanevskiy)
296    
297     * Tue Oct 25 2005 Dan Williams <dcbw@redhat.com> 0.4-6
298     - Retry downloads from builders up to 3 times before failing
299     the job
300    
301     * Tue Oct 25 2005 Dan Williams <dcbw@redhat.com> 0.4-5
302     - Add a MySQL database backend (Jeff Sheltren)
303     - Trap repo copy errors rather than doing a traceback
304     - On the builder, deal correctly with jobs in 'downloaded' state
305     that have been killed
306    
307     * Wed Oct 19 2005 Dan Williams <dcbw@redhat.com> 0.4-4
308     - Really fix client's "allow_uploads" problem
309    
310     * Wed Oct 19 2005 Dan Williams <dcbw@redhat.com> 0.4-3
311     - Fix errors in client's 'job detail' function
312     - Ignore missing "allow_uploads" option in client config file
313     - Fix server when the Additional Package Arches section is missing
314     from a target config file
315     - Make server more robust against random builder SSL issues
316    
317     * Mon Oct 17 2005 Dan Williams <dcbw@redhat.com> 0.4-2
318     - Increase field size of 'username' and 'status' fields when
319     we initially create them on the server. Server ops will
320     need to increase manually or blow away their jobdb.
321    
322     * Sun Oct 16 2005 Dan Williams <dcbw@redhat.com> 0.4-1
323     - Version 0.4
324     o Server:
325     - Per-target config files, new format
326     - Support PostgreSQL as a database backend
327    
328     o Builder:
329     - Multiple concurrent builds with one builder process
330     - Better tracking of mock child processes
331     - Autodetect supported architectures and number of
332     concurrent build processes
333     - Per-target config files, new format
334    
335     o Client:
336     - Ability to upload packages to server
337    
338     o Utilities:
339     - New distro-rebuild.py utility
340     - Fixes for certhelper.py
341    
342     * Tue Aug 23 2005 Dan Williams <dcbw@redhat.com> 0.3.4-1
343     - Version 0.3.4
344     o Make repo scripts actually work
345     o Don't traceback when cleaning up job files if we have none
346    
347     * Mon Aug 19 2005 Dan Williams <dcbw@redhat.com> 0.3.3-1
348     - Version 0.3.3
349     o Add repo script support
350     o Fix double-slashes in log URL (Ignacio Vazquez-Abrams)
351     o Clear out old job info when requeueing jobs
352    
353     * Mon Aug 15 2005 Dan Williams <dcbw@redhat.com> 0.3.2-3
354     - Clear out old job info when requeueing jobs
355    
356     * Mon Aug 15 2005 Dan Williams <dcbw@redhat.com> 0.3.2-2
357     - Append %{?dist} to Releases to get correct precedence on FC3, FC4, and Rawhide
358    
359     * Mon Aug 15 2005 Dan Williams <dcbw@redhat.com> 0.3.2-1
360     - Version 0.3.2
361     o Fix errors in enqueue and enqueue_srpm return values
362     o Implement client/server API versioning
363    
364     * Thu Aug 11 2005 Dan Williams <dcbw@redhat.com> 0.3.1-1
365     - Version 0.3.1
366     o Clean up web interface error handling, catches more errors
367     o Clean up builder code, hopefully deal with block mock processes waiting
368     to write to stderr
369     o Use HTTP GET rather than POST for web forms, more back/forward/reload
370     friendly (Ville Skyttä)
371    
372     * Mon Aug 8 2005 Dan Williams <dcbw@redhat.com> 0.3-1
373     - Version 0.3
374    
375     * Sat Jul 16 2005 Dan Williams <dcbw@redhat.com>
376     - Bump version to 0.2
377     - Grab python files from /usr/lib, not %{_libdir} until the
378     multiarch issues get worked out
379    
380     * Sun Jun 26 2005 Dan Williams <dcbw@redhat.com>
381     - first version/packaging

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed