/[smecontribs]/rpms/plague/contribs7/plague.spec
ViewVC logotype

Annotation of /rpms/plague/contribs7/plague.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.3 - (hide annotations) (download)
Mon Sep 8 14:04:49 2008 UTC (15 years, 9 months ago) by slords
Branch: MAIN
CVS Tags: plague-0_4_5_4-1_el4_sme_1
Changes since 1.2: +66 -74 lines
Import of plague-0.4.5.4-1.el4.sme.1.src.rpm

1 slords 1.1 BuildArch: noarch
2    
3     Summary: Distributed build system for RPMs
4     Name: plague
5 slords 1.3 Version: 0.4.5.4
6     Release: 1%{?dist}.1
7     License: GPLv2+
8 slords 1.1 Group: Development/Tools
9 slords 1.3 #Source: http://fedoraproject.org/projects/plague/releases/%{name}-%{version}.tar.bz2
10     Source: %{name}-%{version}.tar.bz2
11     Patch0: plague-0.4.5.4-pushscript-extras.patch
12 slords 1.1 URL: http://www.fedoraproject.org/wiki/Projects/Plague
13     BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
14 slords 1.3 BuildRequires: python
15     Requires: createrepo >= 0.4.7
16     # get the version of the sqlite api thats available to us
17     %if 0%{?rhel}
18     Requires: python-sqlite
19     %else
20     Requires: python-sqlite2
21     %endif
22    
23 slords 1.1 Requires: %{name}-common = %{version}-%{release}
24     Requires(post): /sbin/chkconfig
25     Requires(post): /sbin/service
26     Requires(preun): /sbin/chkconfig
27     Requires(preun): /sbin/service
28    
29    
30     %description
31     The Plague build system is a client/server distributed build system for
32     building RPM packages. This package provides the plague server.
33    
34    
35     %package common
36     Summary: Common resources for the Plague build system
37     Group: Development/Tools
38     Requires: pyOpenSSL
39    
40     %description common
41 slords 1.3 This package includes the common Python module that all Plague services
42     require.
43 slords 1.1
44    
45     %package builder
46     Summary: Builder daemon for Plague builder slaves
47     Group: Development/Tools
48     Requires: %{name}-common = %{version}-%{release}
49 slords 1.3 Requires: yum >= 2.2.1
50     Requires: mock >= 0.8
51 slords 1.1 Requires(post): /sbin/chkconfig
52     Requires(post): /sbin/service
53     Requires(preun): /sbin/chkconfig
54     Requires(preun): /sbin/service
55     Requires(pre): /usr/sbin/useradd
56    
57     %description builder
58     The Plague builder does the actual RPM package building on slave machines.
59    
60     %package client
61     Summary: Package queueing client for the Plague build system
62     Group: Development/Tools
63     Requires: %{name}-common = %{version}-%{release}
64    
65     %description client
66 slords 1.3 Client program for enqueueing package builds and interrogating the build
67     system.
68 slords 1.1
69    
70     %package utils
71     Summary: Utility programs for the Plague build system
72     Group: Development/Tools
73     Requires: %{name}-common = %{version}-%{release}
74 slords 1.3 Requires: %{name} = %{version}-%{release}
75 slords 1.1
76     %description utils
77     This package includes user utilities for the Plague build system, including
78     the interface to the build server.
79    
80    
81     %prep
82     %setup -q
83 slords 1.3 %patch0 -p1 -b .extras
84     find www -name \*.extras | xargs rm
85 slords 1.1
86    
87     %build
88     make
89    
90    
91     %install
92     rm -rf $RPM_BUILD_ROOT
93 slords 1.3 make DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p" install
94     chmod +x $RPM_BUILD_ROOT%{_bindir}/*
95     install -p -D -m 0644 etc/plague-builder.config $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/%{name}-builder
96     install -p -D -m 0755 etc/plague-builder.init $RPM_BUILD_ROOT%{_initrddir}/%{name}-builder
97     install -p -D -m 0644 etc/plague-server.config $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/%{name}-server
98     install -p -D -m 0755 etc/plague-server.init $RPM_BUILD_ROOT%{_initrddir}/%{name}-server
99     mkdir -p $RPM_BUILD_ROOT/var/lib/plague/builder
100 slords 1.1
101    
102     %clean
103     rm -rf $RPM_BUILD_ROOT
104    
105    
106     %post
107     /sbin/chkconfig --add plague-server
108     /sbin/service plague-server condrestart >> /dev/null || :
109    
110     %preun
111     if [ $1 = 0 ]; then
112     /sbin/service plague-server stop &> /dev/null
113     /sbin/chkconfig --del plague-server
114     fi
115    
116     %pre builder
117 slords 1.3 /usr/sbin/useradd -G mock -s /sbin/nologin -M -r -d /var/lib/plague/builder plague-builder 2>/dev/null || :
118 slords 1.1
119     %post builder
120     /sbin/chkconfig --add plague-builder
121     /sbin/service plague-builder condrestart >> /dev/null || :
122    
123     %preun builder
124     if [ $1 = 0 ]; then
125     /sbin/service plague-builder stop &> /dev/null
126     /sbin/chkconfig --del plague-builder
127     fi
128    
129     %files
130     %defattr(-, root, root)
131     %{_bindir}/%{name}-server
132     %dir %{_datadir}/%{name}/server
133     %{_datadir}/%{name}/server/*.py*
134     %dir %{_sysconfdir}/%{name}/server
135     %dir %{_sysconfdir}/%{name}/server/certs
136     %config(noreplace) %{_sysconfdir}/sysconfig/%{name}-server
137     %{_initrddir}/%{name}-server
138 slords 1.3 %doc www
139 slords 1.1
140     %files common
141     %defattr(-, root, root)
142     %doc README ChangeLog
143     %dir %{_sysconfdir}/%{name}
144     %dir %{_datadir}/%{name}
145     %dir /usr/lib/python?.?/site-packages/%{name}
146     /usr/lib/python?.?/site-packages/%{name}/*.py*
147    
148     %files builder
149     %defattr(-, root, root)
150     %{_bindir}/%{name}-builder
151     %dir %{_datadir}/%{name}/builder
152     %{_datadir}/%{name}/builder/*.py*
153     %dir %{_sysconfdir}/%{name}/builder
154     %dir %{_sysconfdir}/%{name}/builder/certs
155     %config(noreplace) %{_sysconfdir}/sysconfig/%{name}-builder
156     %{_initrddir}/%{name}-builder
157 slords 1.3 %dir /var/lib/plague
158     %attr(0755, plague-builder, plague-builder) /var/lib/plague/builder
159 slords 1.1
160     %files client
161     %defattr(-, root, root)
162     %{_bindir}/%{name}-client
163    
164     %files utils
165     %defattr(-, root, root)
166 slords 1.3 %{_bindir}/%{name}-user-manager
167     %{_bindir}/%{name}-certhelper
168 slords 1.1
169    
170     %changelog
171 slords 1.3 * Sun Sep 7 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.4.5.4-1.extras
172     - update to 0.4.5.4 and update pushscript-extras patch
173 slords 1.1
174 slords 1.3 * Sun Sep 7 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.4.5.3-2.extras
175     - add the optional pushscript-extras patch
176     - fix mod_user in plague-user-manager for sqlite2/3
177    
178     * Fri Sep 5 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.4.5.3-1
179     - update to 0.4.5.3 for sqlite2 compatibility fixes for Fedora
180     - merge fedora pkg spec changes
181     - include the www tree as server pkg docs
182    
183     * Thu Sep 04 2008 Dennis Gilmore <dennis@ausil.us> - 0.4.5.2-1
184     - fix bug in find option to plague-user-manager
185    
186     * Wed Sep 03 2008 Dennis Gilmore <dennis@ausil.us> - 0.4.5.1-1
187     - update to 0.4.5.1 applying Michael schwendt's logging and mock patches
188     - using pysqlite2 on fedora and python-sqlite on RHEL
189     - requires mock > 0.8
190     - requires createrepo >= 0.4.7
191    
192     * Wed Sep 3 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.4.5-2
193     - add the patches from 0.4.5-0.4 (sqlite3, mock08, logtail)
194     - merge more spec changes
195 slords 1.1
196 slords 1.3 * Tue Sep 02 2008 Dennis Gilmore <dennis@ausil.us> - 0.4.5-1
197     - update to 0.4.5 lots of fixes
198 slords 1.1
199 slords 1.3 * Thu May 22 2008 Seth Vidal <skvidal at fedoraproject.org> - 0.4.4.1-6
200     - licensing tag fix
201 slords 1.1
202 slords 1.3 * Tue Sep 18 2007 Michael Schwendt <mschwendt@fedoraproject.org> - 0.4.4.1-5
203 slords 1.1 - Add dirs /etc/plague and /usr/share/plague to plague-common
204     since "plague-builder" and "plague" use them (#233904).
205    
206     * Fri Dec 15 2006 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.4.4.1-4
207     - Small fix for a change in python 2.5's xmlrpc library. The patch has been
208     upstreamed.
209    
210     * Thu Dec 14 2006 Jason L Tibbitts III <tibbs@math.uh.edu> - 0.4.4.1-3
211     - Rebuild for new Python
212    
213     * Thu Sep 14 2006 Dennis Gilmore <dennis@ausil.us> 0.4.4.0-2
214     - add patch for bad umask setting
215    
216     * Mon Mar 13 2006 Dan Williams <dcbw@redhat.com> 0.4.4.1-1
217     - Update to 0.4.4.1
218     - Fix createrepo dep to >= 0.4.3 (#rh170531)
219    
220     * Sun Mar 12 2006 Dan Williams <dcbw@redhat.com> 0.4.4-1
221     - Update to 0.4.4 release
222     - Don't use pyOpenSSL's sendall() call, but simulate it to achieve
223     timeouts, better error handling, and more efficient CPU usage
224     - Fix up initscripts and lifecycle management
225     - Implement a TERM handler in server & builder for clean shutdown
226     - Ensure jobs don't hang around on builders if they get left there for
227     some reason (ie, server didn't unlock repo for the job)
228     - Make Additional Package Arches really work (kmod support)
229     - Own /usr/lib/python?.?/site-packages/plague (#rh172794#)
230     - Require createrepo >= 4.3 (#rh170531#)
231    
232     * Tue Jan 24 2006 Dan Williams <dcbw@redhat.com> 0.4.3-6
233     - Increase build server builder thread sleep time to work around SSL issues
234     - Spawn mock in a new process group, and when killing jobs kill the entire
235     process group. Hopefully fix orphaned rpmbuild processes on job kill
236    
237     * Mon Jan 23 2006 Dan Williams <dcbw@redhat.com> 0.4.3-5
238     - Restore builder connection timeout
239    
240     * Mon Jan 23 2006 Dan Williams <dcbw@redhat.com> 0.4.3-4
241     - Revert SSL fixes from last build
242    
243     * Sun Jan 22 2006 Dan Williams <dcbw@redhat.com> 0.4.3-3
244     - Don't traceback when killing jobs on builders
245     - Work around SSL hanging issues
246    
247     * Tue Nov 29 2005 Dan Williams <dcbw@redhat.com> 0.4.3-2
248     - Move README and ChangeLog to -common package
249     - Traceback/debug functionality added in server, depends on
250     threadframe module from elsewhere. Disabled by default.
251    
252     * Thu Nov 24 2005 Dan Williams <dcbw@redhat.com> 0.4.3-1
253     - Add socket timeouts for fileserver and xmlrpc bits
254    
255     * Fri Nov 18 2005 Dan Williams <dcbw@redhat.com> 0.4.2-7
256     - Suspend builders on hard errors such as running out of disk space
257     - Retry downloads from server/builder 5 times, not 3
258     - Log retried downloads on the server
259     - Add socket timeouts to downloads to work around hanging issues
260     when downloading from the builder (the downloading/done issue)
261    
262     * Tue Nov 15 2005 Dan Williams <dcbw@redhat.com> 0.4.2-5
263     - Log kill requests on the server
264    
265     * Mon Nov 14 2005 Dan Williams <dcbw@redhat.com> 0.4.2-4
266     - In the builder, close files we open before exec-ing the
267     child process. Fixes massive file descriptor leaks.
268    
269     * Sun Nov 13 2005 Dan Williams <dcbw@redhat.com> 0.4.2-3
270     - Hopefully fix builds not moving past downloading/done
271     - Immediately kill jobs in the 'waiting' state when requested
272     - Utilize pthread_sigmask python module, if present, on Python
273     2.3 and earlier to work around signal blocking issues in
274     Python
275    
276     * Tue Nov 1 2005 Dan Williams <dcbw@redhat.com> 0.4.2-2
277     - Make builders retry downloads from the server up to 3 times
278    
279     * Tue Nov 1 2005 Dan Williams <dcbw@redhat.com> 0.4.2-1
280     - Fix job download from the builders
281     - Fix RPM copy to the repository on the server
282    
283     * Mon Oct 31 2005 Dan Williams <dcbw@redhat.com> 0.4.1-1
284     - Fail jobs on restart if we can't access the original SRPM
285     - For the server, honor config file location passed in on
286     the command line (Jeff Sheltren)
287     - Catch another mock failure case (Alexandr Kanevskiy)
288    
289     * Tue Oct 25 2005 Dan Williams <dcbw@redhat.com> 0.4-6
290     - Retry downloads from builders up to 3 times before failing
291     the job
292    
293     * Tue Oct 25 2005 Dan Williams <dcbw@redhat.com> 0.4-5
294     - Add a MySQL database backend (Jeff Sheltren)
295     - Trap repo copy errors rather than doing a traceback
296     - On the builder, deal correctly with jobs in 'downloaded' state
297     that have been killed
298    
299     * Wed Oct 19 2005 Dan Williams <dcbw@redhat.com> 0.4-4
300     - Really fix client's "allow_uploads" problem
301    
302     * Wed Oct 19 2005 Dan Williams <dcbw@redhat.com> 0.4-3
303     - Fix errors in client's 'job detail' function
304     - Ignore missing "allow_uploads" option in client config file
305     - Fix server when the Additional Package Arches section is missing
306     from a target config file
307     - Make server more robust against random builder SSL issues
308    
309     * Mon Oct 17 2005 Dan Williams <dcbw@redhat.com> 0.4-2
310     - Increase field size of 'username' and 'status' fields when
311     we initially create them on the server. Server ops will
312     need to increase manually or blow away their jobdb.
313    
314     * Sun Oct 16 2005 Dan Williams <dcbw@redhat.com> 0.4-1
315     - Version 0.4
316     o Server:
317     - Per-target config files, new format
318     - Support PostgreSQL as a database backend
319    
320     o Builder:
321     - Multiple concurrent builds with one builder process
322     - Better tracking of mock child processes
323     - Autodetect supported architectures and number of
324     concurrent build processes
325     - Per-target config files, new format
326    
327     o Client:
328     - Ability to upload packages to server
329    
330     o Utilities:
331     - New distro-rebuild.py utility
332     - Fixes for certhelper.py
333    
334     * Tue Aug 23 2005 Dan Williams <dcbw@redhat.com> 0.3.4-1
335     - Version 0.3.4
336     o Make repo scripts actually work
337     o Don't traceback when cleaning up job files if we have none
338    
339     * Mon Aug 19 2005 Dan Williams <dcbw@redhat.com> 0.3.3-1
340     - Version 0.3.3
341     o Add repo script support
342     o Fix double-slashes in log URL (Ignacio Vazquez-Abrams)
343     o Clear out old job info when requeueing jobs
344    
345     * Mon Aug 15 2005 Dan Williams <dcbw@redhat.com> 0.3.2-3
346     - Clear out old job info when requeueing jobs
347    
348     * Mon Aug 15 2005 Dan Williams <dcbw@redhat.com> 0.3.2-2
349     - Append %{?dist} to Releases to get correct precedence on FC3, FC4, and Rawhide
350    
351     * Mon Aug 15 2005 Dan Williams <dcbw@redhat.com> 0.3.2-1
352     - Version 0.3.2
353     o Fix errors in enqueue and enqueue_srpm return values
354     o Implement client/server API versioning
355    
356     * Thu Aug 11 2005 Dan Williams <dcbw@redhat.com> 0.3.1-1
357     - Version 0.3.1
358     o Clean up web interface error handling, catches more errors
359     o Clean up builder code, hopefully deal with block mock processes waiting
360     to write to stderr
361     o Use HTTP GET rather than POST for web forms, more back/forward/reload
362     friendly (Ville Skyttä)
363    
364     * Mon Aug 8 2005 Dan Williams <dcbw@redhat.com> 0.3-1
365     - Version 0.3
366    
367     * Sat Jul 16 2005 Dan Williams <dcbw@redhat.com>
368     - Bump version to 0.2
369 slords 1.3 - Grab python files from /usr/lib, not %%{_libdir} until the
370 slords 1.1 multiarch issues get worked out
371    
372     * Sun Jun 26 2005 Dan Williams <dcbw@redhat.com>
373     - first version/packaging

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed