1 |
# $Id: plague.spec,v 1.7 2008/11/25 16:20:15 slords Exp $ |
2 |
# Authority: slords |
3 |
# Name: Shad L. Lords |
4 |
|
5 |
BuildArch: noarch |
6 |
|
7 |
Summary: Distributed build system for RPMs |
8 |
Name: plague |
9 |
Version: 0.4.5.6 |
10 |
Release: 1%{?dist}.1 |
11 |
License: GPLv2+ |
12 |
Group: Development/Tools |
13 |
#Source: http://fedoraproject.org/projects/plague/releases/%{name}-%{version}.tar.bz2 |
14 |
Source: %{name}-%{version}.tar.bz2 |
15 |
Patch0: plague-0.4.5.4-pushscript-extras.patch |
16 |
URL: http://www.fedoraproject.org/wiki/Projects/Plague |
17 |
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) |
18 |
BuildRequires: python |
19 |
Requires: createrepo >= 0.4.7 |
20 |
# get the version of the sqlite api thats available to us |
21 |
%if 0%{?rhel} |
22 |
Requires: python-sqlite |
23 |
%else |
24 |
Requires: python-sqlite2 |
25 |
%endif |
26 |
|
27 |
Requires: %{name}-common = %{version}-%{release} |
28 |
Requires(post): /sbin/chkconfig |
29 |
Requires(post): /sbin/service |
30 |
Requires(preun): /sbin/chkconfig |
31 |
Requires(preun): /sbin/service |
32 |
|
33 |
|
34 |
%description |
35 |
The Plague build system is a client/server distributed build system for |
36 |
building RPM packages. This package provides the plague server. |
37 |
|
38 |
|
39 |
%package common |
40 |
Summary: Common resources for the Plague build system |
41 |
Group: Development/Tools |
42 |
Requires: pyOpenSSL |
43 |
|
44 |
%description common |
45 |
This package includes the common Python module that all Plague services |
46 |
require. |
47 |
|
48 |
|
49 |
%package builder |
50 |
Summary: Builder daemon for Plague builder slaves |
51 |
Group: Development/Tools |
52 |
Requires: %{name}-common = %{version}-%{release} |
53 |
Requires: yum >= 2.2.1 |
54 |
Requires: mock >= 0.8 |
55 |
Requires(post): /sbin/chkconfig |
56 |
Requires(post): /sbin/service |
57 |
Requires(preun): /sbin/chkconfig |
58 |
Requires(preun): /sbin/service |
59 |
Requires(pre): /usr/sbin/useradd |
60 |
|
61 |
%description builder |
62 |
The Plague builder does the actual RPM package building on slave machines. |
63 |
|
64 |
%package client |
65 |
Summary: Package queueing client for the Plague build system |
66 |
Group: Development/Tools |
67 |
Requires: %{name}-common = %{version}-%{release} |
68 |
|
69 |
%description client |
70 |
Client program for enqueueing package builds and interrogating the build |
71 |
system. |
72 |
|
73 |
|
74 |
%package utils |
75 |
Summary: Utility programs for the Plague build system |
76 |
Group: Development/Tools |
77 |
Requires: %{name}-common = %{version}-%{release} |
78 |
Requires: %{name} = %{version}-%{release} |
79 |
|
80 |
%description utils |
81 |
This package includes user utilities for the Plague build system, including |
82 |
the interface to the build server. |
83 |
|
84 |
|
85 |
%prep |
86 |
%setup -q |
87 |
%patch0 -p1 |
88 |
|
89 |
|
90 |
%build |
91 |
make |
92 |
|
93 |
|
94 |
%install |
95 |
rm -rf $RPM_BUILD_ROOT |
96 |
make DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p" install |
97 |
chmod +x $RPM_BUILD_ROOT%{_bindir}/* |
98 |
install -p -D -m 0644 etc/plague-builder.config $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/%{name}-builder |
99 |
install -p -D -m 0755 etc/plague-builder.init $RPM_BUILD_ROOT%{_initrddir}/%{name}-builder |
100 |
install -p -D -m 0644 etc/plague-server.config $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/%{name}-server |
101 |
install -p -D -m 0755 etc/plague-server.init $RPM_BUILD_ROOT%{_initrddir}/%{name}-server |
102 |
mkdir -p $RPM_BUILD_ROOT/var/lib/plague/builder |
103 |
|
104 |
|
105 |
%clean |
106 |
rm -rf $RPM_BUILD_ROOT |
107 |
|
108 |
|
109 |
%post |
110 |
/sbin/chkconfig --add plague-server |
111 |
/sbin/service plague-server condrestart >> /dev/null || : |
112 |
|
113 |
%preun |
114 |
if [ $1 = 0 ]; then |
115 |
/sbin/service plague-server stop &> /dev/null |
116 |
/sbin/chkconfig --del plague-server |
117 |
fi |
118 |
|
119 |
%pre builder |
120 |
/usr/sbin/useradd -G mock -s /sbin/nologin -M -r -d /var/lib/plague/builder plague-builder 2>/dev/null || : |
121 |
|
122 |
%post builder |
123 |
/sbin/chkconfig --add plague-builder |
124 |
/sbin/service plague-builder condrestart >> /dev/null || : |
125 |
|
126 |
%preun builder |
127 |
if [ $1 = 0 ]; then |
128 |
/sbin/service plague-builder stop &> /dev/null |
129 |
/sbin/chkconfig --del plague-builder |
130 |
fi |
131 |
|
132 |
%files |
133 |
%defattr(-, root, root) |
134 |
%{_bindir}/%{name}-server |
135 |
%dir %{_datadir}/%{name}/server |
136 |
%{_datadir}/%{name}/server/*.py* |
137 |
%dir %{_sysconfdir}/%{name}/server |
138 |
%dir %{_sysconfdir}/%{name}/server/certs |
139 |
%config(noreplace) %{_sysconfdir}/sysconfig/%{name}-server |
140 |
%{_initrddir}/%{name}-server |
141 |
%doc www |
142 |
|
143 |
%files common |
144 |
%defattr(-, root, root) |
145 |
%doc README ChangeLog |
146 |
%dir %{_sysconfdir}/%{name} |
147 |
%dir %{_datadir}/%{name} |
148 |
%dir /usr/lib/python?.?/site-packages/%{name} |
149 |
/usr/lib/python?.?/site-packages/%{name}/*.py* |
150 |
|
151 |
%files builder |
152 |
%defattr(-, root, root) |
153 |
%{_bindir}/%{name}-builder |
154 |
%dir %{_datadir}/%{name}/builder |
155 |
%{_datadir}/%{name}/builder/*.py* |
156 |
%dir %{_sysconfdir}/%{name}/builder |
157 |
%dir %{_sysconfdir}/%{name}/builder/certs |
158 |
%config(noreplace) %{_sysconfdir}/sysconfig/%{name}-builder |
159 |
%{_initrddir}/%{name}-builder |
160 |
%dir /var/lib/plague |
161 |
%attr(0755, plague-builder, plague-builder) /var/lib/plague/builder |
162 |
|
163 |
%files client |
164 |
%defattr(-, root, root) |
165 |
%{_bindir}/%{name}-client |
166 |
|
167 |
%files utils |
168 |
%defattr(-, root, root) |
169 |
%{_bindir}/%{name}-user-manager |
170 |
%{_bindir}/%{name}-certhelper |
171 |
|
172 |
|
173 |
%changelog |
174 |
* Sun Oct 5 2008 Shad L. Lords <slords@mail.com> - 0.4.5.6-1.1 |
175 |
- add the optional pushscript-extras patch |
176 |
|
177 |
* Sun Sep 21 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.4.5.6-1 |
178 |
- update to 0.4.5.6 |
179 |
|
180 |
* Sat Sep 20 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.4.5.5-2 |
181 |
- add fix for sqlite's limited ALTER TABLE |
182 |
|
183 |
* Mon Sep 8 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.4.5.5-1 |
184 |
- update to 0.4.5.5 |
185 |
|
186 |
* Sun Sep 07 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.4.5.4-1 |
187 |
- update to 0.4.5.4 to make it work with MySQL 5 |
188 |
|
189 |
* Sun Sep 7 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.4.5.3-2 |
190 |
- fix mod_user in plague-user-manager for sqlite2/3 |
191 |
|
192 |
* Fri Sep 5 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.4.5.3-1 |
193 |
- update to 0.4.5.3 for sqlite2 compatibility fixes for Fedora |
194 |
- merge fedora pkg spec changes |
195 |
- include the www tree as server pkg docs |
196 |
|
197 |
* Thu Sep 04 2008 Dennis Gilmore <dennis@ausil.us> - 0.4.5.2-1 |
198 |
- fix bug in find option to plague-user-manager |
199 |
|
200 |
* Wed Sep 03 2008 Dennis Gilmore <dennis@ausil.us> - 0.4.5.1-1 |
201 |
- update to 0.4.5.1 applying Michael schwendt's logging and mock patches |
202 |
- using pysqlite2 on fedora and python-sqlite on RHEL |
203 |
- requires mock > 0.8 |
204 |
- requires createrepo >= 0.4.7 |
205 |
|
206 |
* Wed Sep 3 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.4.5-2 |
207 |
- add the patches from 0.4.5-0.4 (sqlite3, mock08, logtail) |
208 |
- merge more spec changes |
209 |
|
210 |
* Tue Sep 02 2008 Dennis Gilmore <dennis@ausil.us> - 0.4.5-1 |
211 |
- update to 0.4.5 lots of fixes |
212 |
|
213 |
* Thu May 22 2008 Seth Vidal <skvidal at fedoraproject.org> - 0.4.4.1-6 |
214 |
- licensing tag fix |
215 |
|
216 |
* Tue Sep 18 2007 Michael Schwendt <mschwendt@fedoraproject.org> - 0.4.4.1-5 |
217 |
- Add dirs /etc/plague and /usr/share/plague to plague-common |
218 |
since "plague-builder" and "plague" use them (#233904). |
219 |
|
220 |
* Fri Dec 15 2006 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.4.4.1-4 |
221 |
- Small fix for a change in python 2.5's xmlrpc library. The patch has been |
222 |
upstreamed. |
223 |
|
224 |
* Thu Dec 14 2006 Jason L Tibbitts III <tibbs@math.uh.edu> - 0.4.4.1-3 |
225 |
- Rebuild for new Python |
226 |
|
227 |
* Thu Sep 14 2006 Dennis Gilmore <dennis@ausil.us> 0.4.4.0-2 |
228 |
- add patch for bad umask setting |
229 |
|
230 |
* Mon Mar 13 2006 Dan Williams <dcbw@redhat.com> 0.4.4.1-1 |
231 |
- Update to 0.4.4.1 |
232 |
- Fix createrepo dep to >= 0.4.3 (#rh170531) |
233 |
|
234 |
* Sun Mar 12 2006 Dan Williams <dcbw@redhat.com> 0.4.4-1 |
235 |
- Update to 0.4.4 release |
236 |
- Don't use pyOpenSSL's sendall() call, but simulate it to achieve |
237 |
timeouts, better error handling, and more efficient CPU usage |
238 |
- Fix up initscripts and lifecycle management |
239 |
- Implement a TERM handler in server & builder for clean shutdown |
240 |
- Ensure jobs don't hang around on builders if they get left there for |
241 |
some reason (ie, server didn't unlock repo for the job) |
242 |
- Make Additional Package Arches really work (kmod support) |
243 |
- Own /usr/lib/python?.?/site-packages/plague (#rh172794#) |
244 |
- Require createrepo >= 4.3 (#rh170531#) |
245 |
|
246 |
* Tue Jan 24 2006 Dan Williams <dcbw@redhat.com> 0.4.3-6 |
247 |
- Increase build server builder thread sleep time to work around SSL issues |
248 |
- Spawn mock in a new process group, and when killing jobs kill the entire |
249 |
process group. Hopefully fix orphaned rpmbuild processes on job kill |
250 |
|
251 |
* Mon Jan 23 2006 Dan Williams <dcbw@redhat.com> 0.4.3-5 |
252 |
- Restore builder connection timeout |
253 |
|
254 |
* Mon Jan 23 2006 Dan Williams <dcbw@redhat.com> 0.4.3-4 |
255 |
- Revert SSL fixes from last build |
256 |
|
257 |
* Sun Jan 22 2006 Dan Williams <dcbw@redhat.com> 0.4.3-3 |
258 |
- Don't traceback when killing jobs on builders |
259 |
- Work around SSL hanging issues |
260 |
|
261 |
* Tue Nov 29 2005 Dan Williams <dcbw@redhat.com> 0.4.3-2 |
262 |
- Move README and ChangeLog to -common package |
263 |
- Traceback/debug functionality added in server, depends on |
264 |
threadframe module from elsewhere. Disabled by default. |
265 |
|
266 |
* Thu Nov 24 2005 Dan Williams <dcbw@redhat.com> 0.4.3-1 |
267 |
- Add socket timeouts for fileserver and xmlrpc bits |
268 |
|
269 |
* Fri Nov 18 2005 Dan Williams <dcbw@redhat.com> 0.4.2-7 |
270 |
- Suspend builders on hard errors such as running out of disk space |
271 |
- Retry downloads from server/builder 5 times, not 3 |
272 |
- Log retried downloads on the server |
273 |
- Add socket timeouts to downloads to work around hanging issues |
274 |
when downloading from the builder (the downloading/done issue) |
275 |
|
276 |
* Tue Nov 15 2005 Dan Williams <dcbw@redhat.com> 0.4.2-5 |
277 |
- Log kill requests on the server |
278 |
|
279 |
* Mon Nov 14 2005 Dan Williams <dcbw@redhat.com> 0.4.2-4 |
280 |
- In the builder, close files we open before exec-ing the |
281 |
child process. Fixes massive file descriptor leaks. |
282 |
|
283 |
* Sun Nov 13 2005 Dan Williams <dcbw@redhat.com> 0.4.2-3 |
284 |
- Hopefully fix builds not moving past downloading/done |
285 |
- Immediately kill jobs in the 'waiting' state when requested |
286 |
- Utilize pthread_sigmask python module, if present, on Python |
287 |
2.3 and earlier to work around signal blocking issues in |
288 |
Python |
289 |
|
290 |
* Tue Nov 1 2005 Dan Williams <dcbw@redhat.com> 0.4.2-2 |
291 |
- Make builders retry downloads from the server up to 3 times |
292 |
|
293 |
* Tue Nov 1 2005 Dan Williams <dcbw@redhat.com> 0.4.2-1 |
294 |
- Fix job download from the builders |
295 |
- Fix RPM copy to the repository on the server |
296 |
|
297 |
* Mon Oct 31 2005 Dan Williams <dcbw@redhat.com> 0.4.1-1 |
298 |
- Fail jobs on restart if we can't access the original SRPM |
299 |
- For the server, honor config file location passed in on |
300 |
the command line (Jeff Sheltren) |
301 |
- Catch another mock failure case (Alexandr Kanevskiy) |
302 |
|
303 |
* Tue Oct 25 2005 Dan Williams <dcbw@redhat.com> 0.4-6 |
304 |
- Retry downloads from builders up to 3 times before failing |
305 |
the job |
306 |
|
307 |
* Tue Oct 25 2005 Dan Williams <dcbw@redhat.com> 0.4-5 |
308 |
- Add a MySQL database backend (Jeff Sheltren) |
309 |
- Trap repo copy errors rather than doing a traceback |
310 |
- On the builder, deal correctly with jobs in 'downloaded' state |
311 |
that have been killed |
312 |
|
313 |
* Wed Oct 19 2005 Dan Williams <dcbw@redhat.com> 0.4-4 |
314 |
- Really fix client's "allow_uploads" problem |
315 |
|
316 |
* Wed Oct 19 2005 Dan Williams <dcbw@redhat.com> 0.4-3 |
317 |
- Fix errors in client's 'job detail' function |
318 |
- Ignore missing "allow_uploads" option in client config file |
319 |
- Fix server when the Additional Package Arches section is missing |
320 |
from a target config file |
321 |
- Make server more robust against random builder SSL issues |
322 |
|
323 |
* Mon Oct 17 2005 Dan Williams <dcbw@redhat.com> 0.4-2 |
324 |
- Increase field size of 'username' and 'status' fields when |
325 |
we initially create them on the server. Server ops will |
326 |
need to increase manually or blow away their jobdb. |
327 |
|
328 |
* Sun Oct 16 2005 Dan Williams <dcbw@redhat.com> 0.4-1 |
329 |
- Version 0.4 |
330 |
o Server: |
331 |
- Per-target config files, new format |
332 |
- Support PostgreSQL as a database backend |
333 |
|
334 |
o Builder: |
335 |
- Multiple concurrent builds with one builder process |
336 |
- Better tracking of mock child processes |
337 |
- Autodetect supported architectures and number of |
338 |
concurrent build processes |
339 |
- Per-target config files, new format |
340 |
|
341 |
o Client: |
342 |
- Ability to upload packages to server |
343 |
|
344 |
o Utilities: |
345 |
- New distro-rebuild.py utility |
346 |
- Fixes for certhelper.py |
347 |
|
348 |
* Tue Aug 23 2005 Dan Williams <dcbw@redhat.com> 0.3.4-1 |
349 |
- Version 0.3.4 |
350 |
o Make repo scripts actually work |
351 |
o Don't traceback when cleaning up job files if we have none |
352 |
|
353 |
* Mon Aug 19 2005 Dan Williams <dcbw@redhat.com> 0.3.3-1 |
354 |
- Version 0.3.3 |
355 |
o Add repo script support |
356 |
o Fix double-slashes in log URL (Ignacio Vazquez-Abrams) |
357 |
o Clear out old job info when requeueing jobs |
358 |
|
359 |
* Mon Aug 15 2005 Dan Williams <dcbw@redhat.com> 0.3.2-3 |
360 |
- Clear out old job info when requeueing jobs |
361 |
|
362 |
* Mon Aug 15 2005 Dan Williams <dcbw@redhat.com> 0.3.2-2 |
363 |
- Append %{?dist} to Releases to get correct precedence on FC3, FC4, and Rawhide |
364 |
|
365 |
* Mon Aug 15 2005 Dan Williams <dcbw@redhat.com> 0.3.2-1 |
366 |
- Version 0.3.2 |
367 |
o Fix errors in enqueue and enqueue_srpm return values |
368 |
o Implement client/server API versioning |
369 |
|
370 |
* Thu Aug 11 2005 Dan Williams <dcbw@redhat.com> 0.3.1-1 |
371 |
- Version 0.3.1 |
372 |
o Clean up web interface error handling, catches more errors |
373 |
o Clean up builder code, hopefully deal with block mock processes waiting |
374 |
to write to stderr |
375 |
o Use HTTP GET rather than POST for web forms, more back/forward/reload |
376 |
friendly (Ville Skyttä) |
377 |
|
378 |
* Mon Aug 8 2005 Dan Williams <dcbw@redhat.com> 0.3-1 |
379 |
- Version 0.3 |
380 |
|
381 |
* Sat Jul 16 2005 Dan Williams <dcbw@redhat.com> |
382 |
- Bump version to 0.2 |
383 |
- Grab python files from /usr/lib, not %%{_libdir} until the |
384 |
multiarch issues get worked out |
385 |
|
386 |
* Sun Jun 26 2005 Dan Williams <dcbw@redhat.com> |
387 |
- first version/packaging |