1 |
slords |
1.1 |
BuildArch: noarch |
2 |
|
|
|
3 |
|
|
Summary: Distributed build system for RPMs |
4 |
|
|
Name: plague |
5 |
slords |
1.4 |
Version: 0.4.5.3 |
6 |
|
|
Release: 1%{?dist} |
7 |
|
|
License: GPLv2+ |
8 |
slords |
1.1 |
Group: Development/Tools |
9 |
slords |
1.4 |
#Source: http://fedoraproject.org/projects/plague/releases/%{name}-%{version}.tar.bz2 |
10 |
|
|
Source: %{name}-%{version}.tar.bz2 |
11 |
slords |
1.1 |
URL: http://www.fedoraproject.org/wiki/Projects/Plague |
12 |
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) |
13 |
slords |
1.4 |
BuildRequires: python |
14 |
|
|
Requires: createrepo >= 0.4.7 |
15 |
|
|
# get the version of the sqlite api thats available to us |
16 |
|
|
%if 0%{?rhel} |
17 |
|
|
Requires: python-sqlite |
18 |
|
|
%else |
19 |
|
|
Requires: python-sqlite2 |
20 |
|
|
%endif |
21 |
|
|
|
22 |
slords |
1.1 |
Requires: %{name}-common = %{version}-%{release} |
23 |
|
|
Requires(post): /sbin/chkconfig |
24 |
|
|
Requires(post): /sbin/service |
25 |
|
|
Requires(preun): /sbin/chkconfig |
26 |
|
|
Requires(preun): /sbin/service |
27 |
|
|
|
28 |
|
|
|
29 |
|
|
%description |
30 |
|
|
The Plague build system is a client/server distributed build system for |
31 |
|
|
building RPM packages. This package provides the plague server. |
32 |
|
|
|
33 |
|
|
|
34 |
|
|
%package common |
35 |
|
|
Summary: Common resources for the Plague build system |
36 |
|
|
Group: Development/Tools |
37 |
|
|
Requires: pyOpenSSL |
38 |
|
|
|
39 |
|
|
%description common |
40 |
slords |
1.4 |
This package includes the common Python module that all Plague services |
41 |
|
|
require. |
42 |
slords |
1.1 |
|
43 |
|
|
|
44 |
|
|
%package builder |
45 |
|
|
Summary: Builder daemon for Plague builder slaves |
46 |
|
|
Group: Development/Tools |
47 |
|
|
Requires: %{name}-common = %{version}-%{release} |
48 |
slords |
1.4 |
Requires: yum >= 2.2.1 |
49 |
|
|
Requires: mock >= 0.8 |
50 |
slords |
1.1 |
Requires(post): /sbin/chkconfig |
51 |
|
|
Requires(post): /sbin/service |
52 |
|
|
Requires(preun): /sbin/chkconfig |
53 |
|
|
Requires(preun): /sbin/service |
54 |
|
|
Requires(pre): /usr/sbin/useradd |
55 |
|
|
|
56 |
|
|
%description builder |
57 |
|
|
The Plague builder does the actual RPM package building on slave machines. |
58 |
|
|
|
59 |
|
|
%package client |
60 |
|
|
Summary: Package queueing client for the Plague build system |
61 |
|
|
Group: Development/Tools |
62 |
|
|
Requires: %{name}-common = %{version}-%{release} |
63 |
|
|
|
64 |
|
|
%description client |
65 |
slords |
1.4 |
Client program for enqueueing package builds and interrogating the build |
66 |
|
|
system. |
67 |
slords |
1.1 |
|
68 |
|
|
|
69 |
|
|
%package utils |
70 |
|
|
Summary: Utility programs for the Plague build system |
71 |
|
|
Group: Development/Tools |
72 |
|
|
Requires: %{name}-common = %{version}-%{release} |
73 |
slords |
1.4 |
Requires: %{name} = %{version}-%{release} |
74 |
slords |
1.1 |
|
75 |
|
|
%description utils |
76 |
|
|
This package includes user utilities for the Plague build system, including |
77 |
|
|
the interface to the build server. |
78 |
|
|
|
79 |
|
|
|
80 |
|
|
%prep |
81 |
|
|
%setup -q |
82 |
|
|
|
83 |
|
|
|
84 |
|
|
%build |
85 |
|
|
make |
86 |
|
|
|
87 |
|
|
|
88 |
|
|
%install |
89 |
|
|
rm -rf $RPM_BUILD_ROOT |
90 |
slords |
1.4 |
make DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p" install |
91 |
|
|
chmod +x $RPM_BUILD_ROOT%{_bindir}/* |
92 |
|
|
install -p -D -m 0644 etc/plague-builder.config $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/%{name}-builder |
93 |
|
|
install -p -D -m 0755 etc/plague-builder.init $RPM_BUILD_ROOT%{_initrddir}/%{name}-builder |
94 |
|
|
install -p -D -m 0644 etc/plague-server.config $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/%{name}-server |
95 |
|
|
install -p -D -m 0755 etc/plague-server.init $RPM_BUILD_ROOT%{_initrddir}/%{name}-server |
96 |
|
|
mkdir -p $RPM_BUILD_ROOT/var/lib/plague/builder |
97 |
slords |
1.1 |
|
98 |
|
|
|
99 |
|
|
%clean |
100 |
|
|
rm -rf $RPM_BUILD_ROOT |
101 |
|
|
|
102 |
|
|
|
103 |
|
|
%post |
104 |
|
|
/sbin/chkconfig --add plague-server |
105 |
|
|
/sbin/service plague-server condrestart >> /dev/null || : |
106 |
|
|
|
107 |
|
|
%preun |
108 |
|
|
if [ $1 = 0 ]; then |
109 |
|
|
/sbin/service plague-server stop &> /dev/null |
110 |
|
|
/sbin/chkconfig --del plague-server |
111 |
|
|
fi |
112 |
|
|
|
113 |
|
|
%pre builder |
114 |
slords |
1.4 |
/usr/sbin/useradd -G mock -s /sbin/nologin -M -r -d /var/lib/plague/builder plague-builder 2>/dev/null || : |
115 |
slords |
1.1 |
|
116 |
|
|
%post builder |
117 |
|
|
/sbin/chkconfig --add plague-builder |
118 |
|
|
/sbin/service plague-builder condrestart >> /dev/null || : |
119 |
|
|
|
120 |
|
|
%preun builder |
121 |
|
|
if [ $1 = 0 ]; then |
122 |
|
|
/sbin/service plague-builder stop &> /dev/null |
123 |
|
|
/sbin/chkconfig --del plague-builder |
124 |
|
|
fi |
125 |
|
|
|
126 |
|
|
%files |
127 |
|
|
%defattr(-, root, root) |
128 |
|
|
%{_bindir}/%{name}-server |
129 |
|
|
%dir %{_datadir}/%{name}/server |
130 |
|
|
%{_datadir}/%{name}/server/*.py* |
131 |
|
|
%dir %{_sysconfdir}/%{name}/server |
132 |
|
|
%dir %{_sysconfdir}/%{name}/server/certs |
133 |
|
|
%config(noreplace) %{_sysconfdir}/sysconfig/%{name}-server |
134 |
|
|
%{_initrddir}/%{name}-server |
135 |
slords |
1.4 |
%doc www |
136 |
slords |
1.1 |
|
137 |
|
|
%files common |
138 |
|
|
%defattr(-, root, root) |
139 |
|
|
%doc README ChangeLog |
140 |
|
|
%dir %{_sysconfdir}/%{name} |
141 |
|
|
%dir %{_datadir}/%{name} |
142 |
|
|
%dir /usr/lib/python?.?/site-packages/%{name} |
143 |
|
|
/usr/lib/python?.?/site-packages/%{name}/*.py* |
144 |
|
|
|
145 |
|
|
%files builder |
146 |
|
|
%defattr(-, root, root) |
147 |
|
|
%{_bindir}/%{name}-builder |
148 |
|
|
%dir %{_datadir}/%{name}/builder |
149 |
|
|
%{_datadir}/%{name}/builder/*.py* |
150 |
|
|
%dir %{_sysconfdir}/%{name}/builder |
151 |
|
|
%dir %{_sysconfdir}/%{name}/builder/certs |
152 |
|
|
%config(noreplace) %{_sysconfdir}/sysconfig/%{name}-builder |
153 |
|
|
%{_initrddir}/%{name}-builder |
154 |
slords |
1.4 |
%dir /var/lib/plague |
155 |
|
|
%attr(0755, plague-builder, plague-builder) /var/lib/plague/builder |
156 |
slords |
1.1 |
|
157 |
|
|
%files client |
158 |
|
|
%defattr(-, root, root) |
159 |
|
|
%{_bindir}/%{name}-client |
160 |
|
|
|
161 |
|
|
%files utils |
162 |
|
|
%defattr(-, root, root) |
163 |
slords |
1.4 |
%{_bindir}/%{name}-user-manager |
164 |
|
|
%{_bindir}/%{name}-certhelper |
165 |
slords |
1.1 |
|
166 |
|
|
|
167 |
|
|
%changelog |
168 |
slords |
1.4 |
* Fri Sep 5 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.4.5.3-1 |
169 |
|
|
- update to 0.4.5.3 for sqlite2 compatibility fixes for Fedora |
170 |
|
|
- merge fedora pkg spec changes |
171 |
|
|
- include the www tree as server pkg docs |
172 |
|
|
|
173 |
|
|
* Thu Sep 04 2008 Dennis Gilmore <dennis@ausil.us> - 0.4.5.2-1 |
174 |
|
|
- fix bug in find option to plague-user-manager |
175 |
|
|
|
176 |
|
|
* Wed Sep 03 2008 Dennis Gilmore <dennis@ausil.us> - 0.4.5.1-1 |
177 |
|
|
- update to 0.4.5.1 applying Michael schwendt's logging and mock patches |
178 |
|
|
- using pysqlite2 on fedora and python-sqlite on RHEL |
179 |
|
|
- requires mock > 0.8 |
180 |
|
|
- requires createrepo >= 0.4.7 |
181 |
|
|
|
182 |
|
|
* Wed Sep 3 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.4.5-2 |
183 |
|
|
- add the patches from 0.4.5-0.4 (sqlite3, mock08, logtail) |
184 |
|
|
- merge more spec changes |
185 |
slords |
1.1 |
|
186 |
slords |
1.4 |
* Tue Sep 02 2008 Dennis Gilmore <dennis@ausil.us> - 0.4.5-1 |
187 |
|
|
- update to 0.4.5 lots of fixes |
188 |
slords |
1.1 |
|
189 |
slords |
1.4 |
* Thu May 22 2008 Seth Vidal <skvidal at fedoraproject.org> - 0.4.4.1-6 |
190 |
|
|
- licensing tag fix |
191 |
slords |
1.1 |
|
192 |
slords |
1.4 |
* Tue Sep 18 2007 Michael Schwendt <mschwendt@fedoraproject.org> - 0.4.4.1-5 |
193 |
slords |
1.1 |
- Add dirs /etc/plague and /usr/share/plague to plague-common |
194 |
|
|
since "plague-builder" and "plague" use them (#233904). |
195 |
|
|
|
196 |
|
|
* Fri Dec 15 2006 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.4.4.1-4 |
197 |
|
|
- Small fix for a change in python 2.5's xmlrpc library. The patch has been |
198 |
|
|
upstreamed. |
199 |
|
|
|
200 |
|
|
* Thu Dec 14 2006 Jason L Tibbitts III <tibbs@math.uh.edu> - 0.4.4.1-3 |
201 |
|
|
- Rebuild for new Python |
202 |
|
|
|
203 |
|
|
* Thu Sep 14 2006 Dennis Gilmore <dennis@ausil.us> 0.4.4.0-2 |
204 |
|
|
- add patch for bad umask setting |
205 |
|
|
|
206 |
|
|
* Mon Mar 13 2006 Dan Williams <dcbw@redhat.com> 0.4.4.1-1 |
207 |
|
|
- Update to 0.4.4.1 |
208 |
|
|
- Fix createrepo dep to >= 0.4.3 (#rh170531) |
209 |
|
|
|
210 |
|
|
* Sun Mar 12 2006 Dan Williams <dcbw@redhat.com> 0.4.4-1 |
211 |
|
|
- Update to 0.4.4 release |
212 |
|
|
- Don't use pyOpenSSL's sendall() call, but simulate it to achieve |
213 |
|
|
timeouts, better error handling, and more efficient CPU usage |
214 |
|
|
- Fix up initscripts and lifecycle management |
215 |
|
|
- Implement a TERM handler in server & builder for clean shutdown |
216 |
|
|
- Ensure jobs don't hang around on builders if they get left there for |
217 |
|
|
some reason (ie, server didn't unlock repo for the job) |
218 |
|
|
- Make Additional Package Arches really work (kmod support) |
219 |
|
|
- Own /usr/lib/python?.?/site-packages/plague (#rh172794#) |
220 |
|
|
- Require createrepo >= 4.3 (#rh170531#) |
221 |
|
|
|
222 |
|
|
* Tue Jan 24 2006 Dan Williams <dcbw@redhat.com> 0.4.3-6 |
223 |
|
|
- Increase build server builder thread sleep time to work around SSL issues |
224 |
|
|
- Spawn mock in a new process group, and when killing jobs kill the entire |
225 |
|
|
process group. Hopefully fix orphaned rpmbuild processes on job kill |
226 |
|
|
|
227 |
|
|
* Mon Jan 23 2006 Dan Williams <dcbw@redhat.com> 0.4.3-5 |
228 |
|
|
- Restore builder connection timeout |
229 |
|
|
|
230 |
|
|
* Mon Jan 23 2006 Dan Williams <dcbw@redhat.com> 0.4.3-4 |
231 |
|
|
- Revert SSL fixes from last build |
232 |
|
|
|
233 |
|
|
* Sun Jan 22 2006 Dan Williams <dcbw@redhat.com> 0.4.3-3 |
234 |
|
|
- Don't traceback when killing jobs on builders |
235 |
|
|
- Work around SSL hanging issues |
236 |
|
|
|
237 |
|
|
* Tue Nov 29 2005 Dan Williams <dcbw@redhat.com> 0.4.3-2 |
238 |
|
|
- Move README and ChangeLog to -common package |
239 |
|
|
- Traceback/debug functionality added in server, depends on |
240 |
|
|
threadframe module from elsewhere. Disabled by default. |
241 |
|
|
|
242 |
|
|
* Thu Nov 24 2005 Dan Williams <dcbw@redhat.com> 0.4.3-1 |
243 |
|
|
- Add socket timeouts for fileserver and xmlrpc bits |
244 |
|
|
|
245 |
|
|
* Fri Nov 18 2005 Dan Williams <dcbw@redhat.com> 0.4.2-7 |
246 |
|
|
- Suspend builders on hard errors such as running out of disk space |
247 |
|
|
- Retry downloads from server/builder 5 times, not 3 |
248 |
|
|
- Log retried downloads on the server |
249 |
|
|
- Add socket timeouts to downloads to work around hanging issues |
250 |
|
|
when downloading from the builder (the downloading/done issue) |
251 |
|
|
|
252 |
|
|
* Tue Nov 15 2005 Dan Williams <dcbw@redhat.com> 0.4.2-5 |
253 |
|
|
- Log kill requests on the server |
254 |
|
|
|
255 |
|
|
* Mon Nov 14 2005 Dan Williams <dcbw@redhat.com> 0.4.2-4 |
256 |
|
|
- In the builder, close files we open before exec-ing the |
257 |
|
|
child process. Fixes massive file descriptor leaks. |
258 |
|
|
|
259 |
|
|
* Sun Nov 13 2005 Dan Williams <dcbw@redhat.com> 0.4.2-3 |
260 |
|
|
- Hopefully fix builds not moving past downloading/done |
261 |
|
|
- Immediately kill jobs in the 'waiting' state when requested |
262 |
|
|
- Utilize pthread_sigmask python module, if present, on Python |
263 |
|
|
2.3 and earlier to work around signal blocking issues in |
264 |
|
|
Python |
265 |
|
|
|
266 |
|
|
* Tue Nov 1 2005 Dan Williams <dcbw@redhat.com> 0.4.2-2 |
267 |
|
|
- Make builders retry downloads from the server up to 3 times |
268 |
|
|
|
269 |
|
|
* Tue Nov 1 2005 Dan Williams <dcbw@redhat.com> 0.4.2-1 |
270 |
|
|
- Fix job download from the builders |
271 |
|
|
- Fix RPM copy to the repository on the server |
272 |
|
|
|
273 |
|
|
* Mon Oct 31 2005 Dan Williams <dcbw@redhat.com> 0.4.1-1 |
274 |
|
|
- Fail jobs on restart if we can't access the original SRPM |
275 |
|
|
- For the server, honor config file location passed in on |
276 |
|
|
the command line (Jeff Sheltren) |
277 |
|
|
- Catch another mock failure case (Alexandr Kanevskiy) |
278 |
|
|
|
279 |
|
|
* Tue Oct 25 2005 Dan Williams <dcbw@redhat.com> 0.4-6 |
280 |
|
|
- Retry downloads from builders up to 3 times before failing |
281 |
|
|
the job |
282 |
|
|
|
283 |
|
|
* Tue Oct 25 2005 Dan Williams <dcbw@redhat.com> 0.4-5 |
284 |
|
|
- Add a MySQL database backend (Jeff Sheltren) |
285 |
|
|
- Trap repo copy errors rather than doing a traceback |
286 |
|
|
- On the builder, deal correctly with jobs in 'downloaded' state |
287 |
|
|
that have been killed |
288 |
|
|
|
289 |
|
|
* Wed Oct 19 2005 Dan Williams <dcbw@redhat.com> 0.4-4 |
290 |
|
|
- Really fix client's "allow_uploads" problem |
291 |
|
|
|
292 |
|
|
* Wed Oct 19 2005 Dan Williams <dcbw@redhat.com> 0.4-3 |
293 |
|
|
- Fix errors in client's 'job detail' function |
294 |
|
|
- Ignore missing "allow_uploads" option in client config file |
295 |
|
|
- Fix server when the Additional Package Arches section is missing |
296 |
|
|
from a target config file |
297 |
|
|
- Make server more robust against random builder SSL issues |
298 |
|
|
|
299 |
|
|
* Mon Oct 17 2005 Dan Williams <dcbw@redhat.com> 0.4-2 |
300 |
|
|
- Increase field size of 'username' and 'status' fields when |
301 |
|
|
we initially create them on the server. Server ops will |
302 |
|
|
need to increase manually or blow away their jobdb. |
303 |
|
|
|
304 |
|
|
* Sun Oct 16 2005 Dan Williams <dcbw@redhat.com> 0.4-1 |
305 |
|
|
- Version 0.4 |
306 |
|
|
o Server: |
307 |
|
|
- Per-target config files, new format |
308 |
|
|
- Support PostgreSQL as a database backend |
309 |
|
|
|
310 |
|
|
o Builder: |
311 |
|
|
- Multiple concurrent builds with one builder process |
312 |
|
|
- Better tracking of mock child processes |
313 |
|
|
- Autodetect supported architectures and number of |
314 |
|
|
concurrent build processes |
315 |
|
|
- Per-target config files, new format |
316 |
|
|
|
317 |
|
|
o Client: |
318 |
|
|
- Ability to upload packages to server |
319 |
|
|
|
320 |
|
|
o Utilities: |
321 |
|
|
- New distro-rebuild.py utility |
322 |
|
|
- Fixes for certhelper.py |
323 |
|
|
|
324 |
|
|
* Tue Aug 23 2005 Dan Williams <dcbw@redhat.com> 0.3.4-1 |
325 |
|
|
- Version 0.3.4 |
326 |
|
|
o Make repo scripts actually work |
327 |
|
|
o Don't traceback when cleaning up job files if we have none |
328 |
|
|
|
329 |
|
|
* Mon Aug 19 2005 Dan Williams <dcbw@redhat.com> 0.3.3-1 |
330 |
|
|
- Version 0.3.3 |
331 |
|
|
o Add repo script support |
332 |
|
|
o Fix double-slashes in log URL (Ignacio Vazquez-Abrams) |
333 |
|
|
o Clear out old job info when requeueing jobs |
334 |
|
|
|
335 |
|
|
* Mon Aug 15 2005 Dan Williams <dcbw@redhat.com> 0.3.2-3 |
336 |
|
|
- Clear out old job info when requeueing jobs |
337 |
|
|
|
338 |
|
|
* Mon Aug 15 2005 Dan Williams <dcbw@redhat.com> 0.3.2-2 |
339 |
|
|
- Append %{?dist} to Releases to get correct precedence on FC3, FC4, and Rawhide |
340 |
|
|
|
341 |
|
|
* Mon Aug 15 2005 Dan Williams <dcbw@redhat.com> 0.3.2-1 |
342 |
|
|
- Version 0.3.2 |
343 |
|
|
o Fix errors in enqueue and enqueue_srpm return values |
344 |
|
|
o Implement client/server API versioning |
345 |
|
|
|
346 |
|
|
* Thu Aug 11 2005 Dan Williams <dcbw@redhat.com> 0.3.1-1 |
347 |
|
|
- Version 0.3.1 |
348 |
|
|
o Clean up web interface error handling, catches more errors |
349 |
|
|
o Clean up builder code, hopefully deal with block mock processes waiting |
350 |
|
|
to write to stderr |
351 |
|
|
o Use HTTP GET rather than POST for web forms, more back/forward/reload |
352 |
|
|
friendly (Ville Skyttä) |
353 |
|
|
|
354 |
|
|
* Mon Aug 8 2005 Dan Williams <dcbw@redhat.com> 0.3-1 |
355 |
|
|
- Version 0.3 |
356 |
|
|
|
357 |
|
|
* Sat Jul 16 2005 Dan Williams <dcbw@redhat.com> |
358 |
|
|
- Bump version to 0.2 |
359 |
slords |
1.4 |
- Grab python files from /usr/lib, not %%{_libdir} until the |
360 |
slords |
1.1 |
multiarch issues get worked out |
361 |
|
|
|
362 |
|
|
* Sun Jun 26 2005 Dan Williams <dcbw@redhat.com> |
363 |
|
|
- first version/packaging |